News article

Due to the complexity of supporting multiple client libraries, the Gentoo MySQL maintainers have decided to drop dependencies on the server installation where it is not absolutely necessary.

This will mean that packages might not automatically install the server as a dependency since it does not have to exist on the local machine.

To ensure uninterrupted service, verify that the server package, such as dev-db/mariadb, dev-db/mysql, etc, is included in the world file where it is in operation. This can be accomplished by running emerge with the --noreplace option. Eg.: emerge --noreplace dev-db/mariadb

Applies to

  • virtual/mysql