app-admin / passwordsafe

Password manager with wxGTK based frontend

Official package sites : https://github.com/pwsafe/pwsafe/ · https://pwsafe.org/ ·

v1.18.2 :: 0 :: gentoo

Modified
License
Artistic-2
Keywords
~amd64 ~arm64 ~x86
USE flags
qr test xml yubikey

v1.17.0 :: 0 :: gentoo

Modified
License
Artistic-2
Keywords
amd64 ~arm64 ~x86
USE flags
qr test xml yubikey

General

qr
Enable QR code password display
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)
xml
Enable XML import support
yubikey
Enable support for Yubikey

dev-libs / xerces-c : Validating XML parser written in a portable subset of C++

media-gfx / qrencode : C library for encoding data in a QR Code symbol

net-misc / curl : A Client that groks URLs

sys-apps / util-linux : Various useful Linux utilities

sys-auth / ykpers : Library and tool for personalization of Yubico's YubiKey

x11-base / xorg-proto : X.Org combined protocol headers

x11-libs / libXt : X.Org X Toolkit Intrinsics library

x11-libs / libXtst : X.Org Xlib-based client API for the XTEST & RECORD extensions library

x11-libs / wxGTK : GTK version of wxWidgets, a cross-platform C++ GUI toolkit

dev-libs / xerces-c : Validating XML parser written in a portable subset of C++

media-gfx / qrencode : C library for encoding data in a QR Code symbol

net-misc / curl : A Client that groks URLs

sys-apps / util-linux : Various useful Linux utilities

sys-auth / ykpers : Library and tool for personalization of Yubico's YubiKey

x11-libs / libXt : X.Org X Toolkit Intrinsics library

x11-libs / libXtst : X.Org Xlib-based client API for the XTEST & RECORD extensions library

x11-libs / wxGTK : GTK version of wxWidgets, a cross-platform C++ GUI toolkit

app-misc / pwsafe : A Password Safe compatible command-line password manager

914185
app-admin/passwordsafe-1.17.0 fails tests (PYTHON-3.12-SYSTEM): because of a stack-buffer-overflow
924382
app-admin/passwordsafe-1.17.0 - does not respect make opts
Repository mirror & CI · gentoo
Merge updates from master
Martin Dummer · gentoo
app-admin/passwordsafe: add 1.18.2
Bug: https://bugs.gentoo.org/914185 Closes: https://bugs.gentoo.org/917426 Closes: https://bugs.gentoo.org/917427 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/35058 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Martin Dummer · gentoo
app-admin/passwordsafe: drop 1.15.0, 1.16.0
Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
app-admin/passwordsafe: Stabilize 1.17.0 amd64, #920584
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-admin/passwordsafe: Stabilize 1.16.0 amd64, #908747
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Martin Dummer · gentoo
app-admin/passwordsafe: add 1.17.0
Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/31383 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-admin/passwordsafe: Keyword 1.16.0 arm64, #907127
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Joonas Niilola · gentoo
app-admin/passwordsafe: fix UnusedInherits on 1.16.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Joonas Niilola · gentoo
app-admin/passwordsafe: include "no -std=gnu++11" patch from 1.15.0
Closes: https://bugs.gentoo.org/906667 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Joonas Niilola · gentoo
app-admin/passwordsafe: remove old cruft from the ebuild
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Peter Levine · gentoo
app-admin/passwordsafe: fix building against gtest-1.13
dev-cpp/gtest-1.13.0 now requires building with c++14 or higher, and '-std=gnu++11' has been removed upstream. Closes: https://bugs.gentoo.org/895140 Closes: https://github.com/gentoo/gentoo/pull/30483 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Martin Dummer · gentoo
app-admin/passwordsafe: add 1.16.0
Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/29030 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
app-admin/passwordsafe: drop 1.13.0, 1.14.0-r1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
app-admin/passwordsafe: amd64 stable wrt bug #866608
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-admin/passwordsafe: fix build with GCC 12
Closes: https://bugs.gentoo.org/854144 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Martin Dummer · gentoo
app-admin/passwordsafe: version bump to 1.15.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/25734 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
app-admin/passwordsafe: amd64 stable wrt bug #834612
Package-Manager: Portage-3.0.30, Repoman-3.0.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Martin Dummer · gentoo
app-admin/passwordsafe: remove old
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/22968 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Martin Dummer · gentoo
app-admin/passwordsafe: fix icon, EAPI=8
fix icon installation path and handling, move to EAPI 8 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Martin Dummer · gentoo
app-admin/passwordsafe: version bump to 1.14.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/22593 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-admin/passwordsafe: Stabilize 1.13.0 amd64, #788694
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
app-admin/passwordsafe: remove libressl support
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Martin Dummer · gentoo
app-admin/passwordsafe: version bump to 1.13
new version passwordsafe-1.13 drop USE libressl Closes: https://bugs.gentoo.org/774180 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/19795 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-admin/passwordsafe: Keyword 1.12.0-r1 x86, #765001
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-admin/passwordsafe: Stabilize 1.12.0-r1 amd64, #761846
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Joonas Niilola · gentoo
app-admin/passwordsafe: remove old
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Martin Dummer · gentoo
app-admin/passwordsafe: fix icon filename in desktop file
Fix filename in the passwordsafe.desktop description file, so that the icon appears in the menu. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/18572 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Joonas Niilola · gentoo
app-admin/passwordsafe: remove old versions
Closes: https://bugs.gentoo.org/744355 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Martin Dummer · gentoo
app-admin/passwordsafe: version bump to 1.12.0
new version, compiles with clang-11 Bug: https://bugs.gentoo.org/744355 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/18330 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
David Seifert · gentoo
app-admin/passwordsafe: Inherit optfeature.eclass
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Martin Dummer · gentoo
app-admin/passwordsafe: version bump to 1.11.0
EAPI 7, move to cmake.eclass, add proxy-maintainer Closes: https://bugs.gentoo.org/686486 Closes: https://bugs.gentoo.org/696598 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/17024 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Hendrik v. Raven · gentoo
app-admin/passwordsafe: drop old 1.07_beta
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Hendrik v. Raven <hendrik@consetetur.de> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Hendrik v. Raven · gentoo
app-admin/passwordsafe: version bump to 1.08_beta
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Hendrik v. Raven <hendrik@consetetur.de> Closes: https://github.com/gentoo/gentoo/pull/11895 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Hendrik v. Raven · gentoo
app-admin/passwordsafe: drop old.
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Hendrik v. Raven <hendrik@consetetur.de> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Hendrik v. Raven · gentoo
app-admin/passwordsafe: version bump.
Closes: https://bugs.gentoo.org/677500 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Hendrik v. Raven <hendrik@consetetur.de> Closes: https://github.com/gentoo/gentoo/pull/11018 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Hendrik v. Raven · gentoo
app-admin/passwordsafe: correct install locations
xml and help files have been moved to /usr/share/passwordsafe. Package-Manager: Portage-2.3.49, Repoman-2.3.10 Closes: https://github.com/gentoo/gentoo/pull/9679
Repository mirror & CI · gentoo
Merge updates from master
Hendrik v. Raven · gentoo
app-admin/passwordsafe: force system gtest
this has been changed in the latest release to download gtest. I missed this change when bumping to the latest release. Closes: https://bugs.gentoo.org/664200 Closes: https://github.com/gentoo/gentoo/pull/9660 Package-Manager: Portage-2.3.38, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Hendrik v. Raven · gentoo
app-admin/passwordsafe: drop old.
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Hendrik v. Raven · gentoo
app-admin/passwordsafe: version bump to 1.06_beta.
Closes: https://bugs.gentoo.org/663662 Package-Manager: Portage-2.3.38, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9593
Hendrik v. Raven · gentoo
app-admin/passwordsafe: switch to gtk3 frontend.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Hendrik v. Raven · gentoo
app-admin/passwordsafe: version bump.
Add QR code support. Reported-by: Hans F. Nordhaug <hansfn@gmail.com> Closes: https://bugs.gentoo.org/644640 Closes: https://github.com/gentoo/gentoo/pull/6869 Package-Manager: Portage-2.3.19, Repoman-2.3.6
David Seifert · gentoo
app-admin/passwordsafe: [QA] Add cmake-utils_src_prepare
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Michael Palimaka · gentoo
app-admin/passwordsafe: remove 1.01_beta
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Manuel Rüger · gentoo
app-admin/passwordsafe: Add missing dependency on app-arch/zip
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Manuel Rüger · gentoo
app-admin/passwordsafe: Remove old
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Manuel Rüger · gentoo
app-admin/passwordsafe: Version bump to 1.02.1_beta
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Manuel Rüger · gentoo
app-admin/passwordsafe: Remove old
Package-Manager: portage-2.3.3
Manuel Rüger · gentoo
app-admin/passwordsafe: Version bump to 1.01beta
Package-Manager: portage-2.3.3
Manuel Rüger · gentoo
app-admin/passwordsafe: Remove old
Package-Manager: portage-2.3.1
Manuel Rüger · gentoo
app-admin/passwordsafe: Version bump to 1.0_beta
Package-Manager: portage-2.3.1
Manuel Rüger · gentoo
app-admin/passwordsafe: Version bump to 0.99_beta
Package-Manager: portage-2.2.28
Ian Delaney · gentoo
Merge remote-tracking branch 'remotes/sbraz/syncthing'
Pull Request: https://github.com/gentoo/gentoo/pull/990
Manuel Rüger · gentoo
app-admin/passwordsafe: Remove use default for minimal
Package-Manager: portage-2.2.27
Manuel Rüger · gentoo
app-admin/passwordsafe: Initial version
Gentoo-Bug: #453458 Package-Manager: portage-2.2.27