app-backup / borgbackup

Deduplicating backup program with compression and authenticated encryption

Official package sites : https://borgbackup.readthedocs.io/ ·

v9999 :: 0 :: gentoo

Modified
License
BSD
USE flags
libressl

v1.1.14 :: 0 :: gentoo

Modified
License
BSD
Keywords
~amd64 ~ppc64 ~x86
USE flags
libressl

v1.1.13 :: 0 :: gentoo

Modified
License
BSD
Keywords
amd64 x86 ~ppc64
USE flags
libressl

v1.1.11-r2 :: 0 :: gentoo

Modified
License
BSD
Keywords
amd64 x86
USE flags
libressl

General

libressl
Use dev-libs/libressl instead of dev-libs/openssl when applicable (see also the ssl useflag)

python_targets

python3_6
Build with Python 3.6
python3_7
Build with Python 3.7
python3_8
Build with Python 3.8

app-arch / lz4 : Extremely Fast Compression algorithm

dev-libs / libressl : Free version of the SSL/TLS protocol forked from OpenSSL

dev-libs / openssl : full-strength general purpose cryptography library (including SSL and TLS)

dev-python / cython : A Python to C compiler

dev-python / llfuse : Python bindings for the low-level FUSE API

dev-python / setuptools_scm : Manage versions by scm tags via setuptools

virtual / acl : Virtual for acl support (sys/acl.h)

app-arch / lz4 : Extremely Fast Compression algorithm

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-libs / libressl : Free version of the SSL/TLS protocol forked from OpenSSL

dev-libs / openssl : full-strength general purpose cryptography library (including SSL and TLS)

dev-python / llfuse : Python bindings for the low-level FUSE API

virtual / acl : Virtual for acl support (sys/acl.h)

app-backup / borgmatic : Automatically create, prune and verify backups with borgbackup

app-backup / borgweb : Browser-based user interface for BorgBackup

702240
app-backup/borgbackup-1.1.10-r1: borg serve fails with MemoryError
709886
app-backup/borgbackup-1.1.10-r1 - QA notice - DISTUTILS_USE_SETUPTOOLS value is probably incorrect
732838
app-backup/borgbackup fails to link with LLD because of /usr/lib in the link command line
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.1.14
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
app-backup/borgbackup: x86 stable (bug #736738)
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
app-backup/borgbackup: amd64 stable wrt bug #736738
Package-Manager: Portage-2.3.103, Repoman-2.3.23 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sergei Trofimovich · gentoo
app-backup/borgbackup: keyworded 1.1.13 for ppc64
keyworded wrt bug #723778 Package-Manager: Portage-2.3.101, Repoman-2.3.22 RepoMan-Options: --include-arches="ppc64" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
app-backup/borgbackup: remove pyzmq dependency for -9999
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Florian Schmaus · gentoo
app-backup/borgbackup: remove unnecessary pyzmq dependency
The dev-python/pyzmq dependency was added with https://github.com/gentoo/gentoo/pull/5240, borgbackup actually required pyzmq, with 55e0c43c ("add zeromq dependency"), but that was only a brief period the case and the requirement got removed again with d0bed00e ("remove pyzmq package requirement, not used yet"). However this dependency was *never* required in a released version. Closes: https://bugs.gentoo.org/728208 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Florian Schmaus <flo@geekplace.eu> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Piotr Karbowski · gentoo
app-backup/borgbackup: drop 1.1.10-r1.
Closes: https://bugs.gentoo.org/713820 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Piotr Karbowski · gentoo
app-backup/borgbackup: 1.1.13 version bump; py38 support.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
app-backup/borgbackup: remove older version
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
app-backup/borgbackup: x86 stable wrt bug #713822
Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Piotr Karbowski · gentoo
app-backup/borgbackup-1.1.11-r2: amd64 stable (bug 713822)
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
app-backup/borgbackup: fall back on bundled msgpack, bug #713820
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
app-backup/borgbackup: use system msgpack
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.1.11
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Clean PYTHON_COMPAT of obsolete impls
Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Piotr Karbowski · gentoo
app-backup/borgbackup-1.1.10-r1: python 3.7 target added.
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Piotr Karbowski · gentoo
app-backup/borgbackup: drop old.
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
app-backup/borgbackup: amd64 stable wrt bug #699402
Package-Manager: Portage-2.3.76, Repoman-2.3.16 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
app-backup/borgbackup: x86 stable wrt bug #699402
Package-Manager: Portage-2.3.76, Repoman-2.3.16 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Piotr Karbowski · gentoo
app-backup/borgbackup: 1.1.10-r1, 9999: man pages added.
Closes: https://bugs.gentoo.org/639722 Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Piotr Karbowski · gentoo
app-backup/borgbackup-9999: build time dependency on dev-python/pkgconfig.
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
app-backup/borgbackup: x86 stable (bug #689218)
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Agostino Sarubbo · gentoo
app-backup/borgbackup: amd64 stable wrt bug #689218
Signed-off-by: Agostino Sarubbo <ago@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
Repository mirror & CI · gentoo
Merge updates from master
Piotr Karbowski · gentoo
app-backup/borgbackup: 1.1.8: fixed msgpack version dependency.
This is the same fix that has been applied to 1.1.9, as reported on bug 683012. Bug: https://bugs.gentoo.org/683012 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.1.10
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Piotr Karbowski · gentoo
app-backup/borgbackup: 1.1.9: fixed msgpack version dependency
Currently borgbackup does not support msgpack other than 0.5.6, with version checking hardcoded internally. The msgpack >=0.6 is supposed to be supported in borgbackup-1.2 that is yet to be released. Closes: https://bugs.gentoo.org/683012 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Patrick Lauer · gentoo
app-backup/borgbackup: Restrict msgpack version
Otherwise it'll refuse to run. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
app-backup/borgbackup: remove older versions
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Anthony G. Basile · gentoo
app-backup/borgbackup: depend on virtual/acl, bug #609428
Thanks Aljoscha Vollmerhaus <gentoobugzilla@aljoscha.vollmerhaus.net> Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
app-backup/borgbackup: 1.1.8 stable on amd64 and x86
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.1.9
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.1.8
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
app-backup/borgbackup: remove older versions
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.1.7
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
app-backup/borgbackup: amd64 stable wrt bug #660326
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
app-backup/borgbackup: x86 stable (bug #660326)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.1.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.1.5
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Matthew Thode · gentoo
app-backup/borgbackup: fixing setup.py sed
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Matthew Thode · gentoo
app-backup/borgbackup: allow the use of the msgpack rename w/ fast stable
Package-Manager: Portage-2.3.19, Repoman-2.3.6 RepoMan-Options: --force
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.1.4
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Anthony G. Basile · gentoo
app-backup/borgbackup: remove vulnerable versions, bug #639102
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Anthony G. Basile · gentoo
app-backup/borgbackup: stable on amd64, bug #639102
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.1.3
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Anthony G. Basile · gentoo
app-backup/borgbackup: remove older versions
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Anthony G. Basile · gentoo
app-backup/borgbackup: version 1.1.1 stable on amd64
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.1.2
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.1.1
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.1.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Rainer Hihn · gentoo
app-backup/borgbackup: Added dev-python/pyzmq to RPDEPEND
Closes: https://github.com/gentoo/gentoo/pull/5240
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.0.11
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Manuel Rüger · gentoo
app-backup/borgbackup: Add python3_6
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Anthony G. Basile · gentoo
app-backup/borgbackup: remove older versions
Package-Manager: portage-2.3.3
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.0.10
Package-Manager: portage-2.3.3
Agostino Sarubbo · gentoo
app-backup/borgbackup: amd64 stable wrt bug #607060
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Tobias Klausmann · gentoo
app-backup/borgbackup-1.0.7-r0: stable on amd64
Gentoo-Bug: 595796
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.0.9
Package-Manager: portage-2.3.0
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.0.8
Package-Manager: portage-2.3.0
Pacho Ramos · gentoo
app-backup/borgbackup: Support python 3.5
Package-Manager: portage-2.3.1
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.0.7, remove older
Package-Manager: portage-2.2.28
Anthony G. Basile · gentoo
app-backup/borgbackup: remove older unstable versions
Package-Manager: portage-2.2.28
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.0.6
Package-Manager: portage-2.2.28
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.0.3
Package-Manager: portage-2.2.26
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.0.2
Package-Manager: portage-2.2.26
Anthony G. Basile · gentoo
app-backup/borgbackup: fix file conflict with app-office/borg, bug #580402
Package-Manager: portage-2.2.26
Anthony G. Basile · gentoo
app-backup/borgbackup: remove older version
Package-Manager: portage-2.2.26
Anthony G. Basile · gentoo
app-backup/borgbackup: version bump to 1.0.1
Package-Manager: portage-2.2.26
Anthony G. Basile · gentoo
app-backup/borgbackup: fix openssl and libressl slots
Package-Manager: portage-2.2.26
Anthony G. Basile · gentoo
app-backup/borgbackup: initial commit
Borg is a fork of attic. Attic may be dead upstream while borg is currently actively being maintained. Package-Manager: portage-2.2.26