app-crypt / johntheripper-jumbo

fast password cracker

Official package sites : http://www.openwall.com/john/ ·

v9999 :: 0 :: gentoo

Modified
License
GPL-2
USE flags
custom-cflags kerberos mpi opencl openmp pcap

v1.8.0 :: 0 :: gentoo

Modified
License
GPL-2
Keywords
~alpha ~amd64 ~amd64-linux ~arm ~hppa ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-linux
USE flags
custom-cflags kerberos mpi opencl openmp pcap

General

custom-cflags
Build with user-specified CFLAGS (unsupported)
kerberos
Add kerberos support
mpi
Add MPI (Message Passing Interface) layer to the apps that support it
opencl
Missing description
openmp
Build support for the OpenMP (support parallel computing), requires >=sys-devel/gcc-4.2 built with USE="openmp"
pcap
Missing description

app-arch / bzip2 : A high-quality data compressor used extensively by Gentoo Linux

dev-libs / gmp : Library for arbitrary-precision arithmetic on different type of numbers

dev-libs / openssl : full-strength general purpose cryptography library (including SSL and TLS)

net-libs / libpcap : A system-independent library for user-level network packet capture

sys-libs / zlib : Standard (de)compression library

virtual / krb5 : Virtual for Kerberos V implementation

virtual / mpi : Virtual for Message Passing Interface (MPI) v2.0 implementation

virtual / opencl : Virtual for OpenCL implementations

app-arch / bzip2 : A high-quality data compressor used extensively by Gentoo Linux

app-crypt / johntheripper : fast password cracker

dev-libs / gmp : Library for arbitrary-precision arithmetic on different type of numbers

dev-libs / openssl : full-strength general purpose cryptography library (including SSL and TLS)

net-libs / libpcap : A system-independent library for user-level network packet capture

sys-libs / zlib : Standard (de)compression library

virtual / krb5 : Virtual for Kerberos V implementation

virtual / mpi : Virtual for Message Passing Interface (MPI) v2.0 implementation

virtual / opencl : Virtual for OpenCL implementations

app-crypt / johntheripper : fast password cracker

net-analyzer / metasploit : Advanced framework for developing, testing, and using vulnerability exploit code

net-wireless / wepattack : WLAN tool for breaking 802.11 WEP keys

674656
app-crypt/johntheripper-jumbo-1.8.0 configure: error: JtR requires libssl being installed
Repository mirror & CI · gentoo
Merge updates from master
Rick Farina · gentoo
app-crypt/johntheripper-jumbo: fix bug #673414
also don't install opencl kernels in a dir john doesn't read them in Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Rick Farina · gentoo
app-crypt/johntheripper-jumbo: split jtr and jumbo
jumbo "patch" has taken on a life of it's own and is now vastly too different than jtr to keep a sane unified ebuild Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>