app-emacs / compat

Compatibility libraries for Emacs

Official package sites : https://git.sr.ht/~pkal/compat/ · https://github.com/emacs-compat/compat/ ·

v29.1.4.4 :: 0 :: gentoo

Modified
License
GPL-3+
Keywords
amd64 arm64 ppc64 x86 ~arm ~riscv

app-editors / emacs : The extensible, customizable, self-documenting real-time display editor

app-emacs / cape : Completion At Point Extensions

app-emacs / citeproc-el : CSL 1.0.2 Citation Processor for Emacs

app-emacs / consult : Consulting complete-read for GNU Emacs

app-emacs / corfu : Completion Overlay Region FUnction

app-emacs / doom-modeline : Fancy and fast mode-line for Emacs inspired by minimalism design

app-emacs / ebib : BibTeX database manager for Emacs

app-emacs / emacs-eat : Emulate A Terminal, in a region, in a buffer and in Eshell

app-emacs / embark : Conveniently act on minibuffer completions inside GNU Emacs

app-emacs / ghub : Minuscule client library for the Git forge APIs

app-emacs / git-modes : Emacs major modes for editing Git configuration files

app-emacs / hl-todo : Highlight TODO and similar keywords in comments and strings

app-emacs / indent-bars : Fast, configurable indentation guide-bars for Emacs

app-emacs / jinx : Enchanted Spell Checker for GNU Emacs

app-emacs / marginalia : Marginalia in the minibuffer

app-emacs / no-littering : ELisp library that helps keeping Emacs configuration directory clean

app-emacs / org-modern : Modern style for your GNU Emacs Org buffers

app-emacs / osm : OpenStreetMap tile-based viewer for GNU Emacs

app-emacs / package-lint : Linting library for Emacs Lisp package metadata

app-emacs / speed-type : Practice touch and speed typing

app-emacs / tempel : Templates with in-buffer field editing for GNU Emacs

app-emacs / transient : Transient commands abstraction for GNU Emacs

app-emacs / vertico : Vertical interactive completion

app-emacs / with-editor : Use the Emacsclient as the $EDITOR of child processes

Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: drop old 29.1.4.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-emacs/compat: Stabilize 29.1.4.4 ppc64, #921203
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-emacs/compat: Stabilize 29.1.4.4 ALLARCHES, #919919
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: bump to 29.1.4.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: drop old 29.1.4.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-emacs/compat: Stabilize 29.1.4.2 ALLARCHES, #913498
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: drop old 29.1.4.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Maciej Barć · gentoo
app-emacs/compat: drop old 29.1.3.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: bump to 29.1.4.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-emacs/compat: Stabilize 29.1.4.1 arm64, #909101
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jakov Smolić · gentoo
app-emacs/compat: Keyword 29.1.4.1 riscv, #906291
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: drop old 29.1.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Maciej Barć · gentoo
app-emacs/compat: drop old 28.1.2.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-emacs/compat: Stabilize 29.1.4.1 ALLARCHES, #905191
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-emacs/compat: Stabilize 29.1.4.0 amd64, #903682
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: bump to 29.1.4.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matthew Smith · gentoo
app-emacs/*: drop redundant NEED_EMACS
Not needed after elisp-common.eclass changed the default to 25.3 (the oldest currently in tree). Signed-off-by: Matthew Smith <matthew@gentoo.org> [Whitespace: removed double empty lines] Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-emacs/compat: Stabilize 29.1.3.3 ALLARCHES, #900983
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: drop old 29.1.3.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Maciej Barć · gentoo
app-emacs/compat: drop old 29.1.3.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: bump to 29.1.4.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Maciej Barć · gentoo
app-emacs/compat: drop old 28.1.1.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: bump to 29.1.3.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-emacs/compat: Stabilize 29.1.1.0 ALLARCHES, #893860
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: bump to 29.1.3.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Maciej Barć · gentoo
app-emacs/compat: drop old 29.1.3.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Maciej Barć · gentoo
app-emacs/compat: drop old 29.1.3.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: bump to 29.1.3.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs: H -> COMMIT
Bug: https://github.com/pkgcore/pkgcheck/issues/536 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: drop old 29.1.1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Maciej Barć · gentoo
app-emacs/compat: drop old 29.1.2.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Maciej Barć · gentoo
app-emacs/compat: bump to 29.1.3.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: bump to 29.1.3.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: bump to 29.1.2.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-emacs/compat: Stabilize 28.1.2.2 ALLARCHES, #891021
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: drop old 29.1.0.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Maciej Barć · gentoo
app-emacs/compat: bump to 29.1.1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: drop old 28.1.2.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Maciej Barć · gentoo
app-emacs/compat: bump to 29.1.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: bump to 29.1.0.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-emacs/compat: Stabilize 28.1.1.3 x86, #889586
Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
app-emacs/compat: Stabilize 28.1.1.3 amd64, #889586
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-emacs/compat: Keyword 28.1.2.2 arm64, #877195
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
app-emacs/compat: Keyword 28.1.2.2 arm, #877195
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
app-emacs/compat: Keyword 28.1.2.2 ppc64, #877195
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: drop old 28.1.2.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Maciej Barć · gentoo
app-emacs/compat: bump to 28.1.2.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: bump to 28.1.2.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matthew Smith · gentoo
app-emacs/compat: drop 28.1.1.1-r1
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Matthew Smith · gentoo
app-emacs/compat: add 28.1.2.0
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ulrich Müller · gentoo
app-emacs/compat: Don't die when the installed Emacs doesn't support tests
There's no perfect solution here, but we don't want to override the user's choice of Emacs' USE flags just for running tests. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Ulrich Müller · gentoo
app-emacs/compat: Drop BDEPEND on emacs[json]
Bug: https://bugs.gentoo.org/853322#c11 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: add missing die to avoid false-positive
Bug: https://bugs.gentoo.org/853322 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Maciej Barć · gentoo
app-emacs/compat: check for native JSON parsing support
Closes: https://bugs.gentoo.org/853322 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: add emacs[json] required for tests
Closes: https://bugs.gentoo.org/853322 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/compat: bump to 28.1.1.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matthew Smith · gentoo
app-emacs/compat: don't run deleted tests
Also, build and install info documentation. Signed-off-by: Matthew Smith <matthew@gentoo.org> Closes: https://bugs.gentoo.org/848066
Repository mirror & CI · gentoo
Merge updates from master
Matthew Smith · gentoo
app-emacs/compat: new package, add 28.1.1.1
Required for app-emacs/consult. Signed-off-by: Matthew Smith <matthew@gentoo.org>