app-emacs / elpy

Emacs Python Development Environment

Official package sites : https://github.com/jorgenschaefer/elpy/ ·

v1.35.0_p20220627-r1 :: 0 :: gentoo

Modified
License
GPL-3+
Keywords
~amd64 ~x86
USE flags
doc test

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_single_target

python3_10
Build for Python 3.10 only
python3_11
Build for Python 3.11 only
python3_12
Build for Python 3.12 only

app-editors / emacs : The extensible, customizable, self-documenting real-time display editor

app-emacs / company-mode : In-buffer completion front-end

app-emacs / highlight-indentation : Minor modes to highlight indentation guides in Emacs

app-emacs / pyvenv : Python virtual environment interface for Emacs

app-emacs / s : The long lost Emacs string manipulation library

app-emacs / yasnippet : Yet another snippet extension for Emacs

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-python / flake8 : A wrapper around PyFlakes, pep8 & mccabe

Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/elpy: enable py3.12 compat
Closes: https://bugs.gentoo.org/929303 Closes: https://bugs.gentoo.org/885897 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/elpy: drop old 1.35.0_p20220321
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matthew Smith · gentoo
app-emacs/*: drop redundant NEED_EMACS
Not needed after elisp-common.eclass changed the default to 25.3 (the oldest currently in tree). Signed-off-by: Matthew Smith <matthew@gentoo.org> [Whitespace: removed double empty lines] Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/elpy: enable python 3.11
Closes: https://bugs.gentoo.org/896532 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs: H -> COMMIT
Bug: https://github.com/pkgcore/pkgcheck/issues/536 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
David Seifert · gentoo
*/*: remove py3.8 from PYTHON_COMPAT
Signed-off-by: David Seifert <soap@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/elpy: bump to 1.35.0_p20220627
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/elpy: remove python-exec hack
fixed in 3adbe305677 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Maciej Barć · gentoo
app-emacs/elpy: new package; add version 1.35.0_p20220321
2022.03.21 snapshot Signed-off-by: Maciej Barć <xgqt@gentoo.org>