app-emulation / docker-compose

Multi-container orchestration for Docker

Official package sites : https://github.com/docker/compose ·

v1.24.1 :: 0 :: gentoo

Modified
License
Apache-2.0
Keywords
~amd64
USE flags
test

v1.24.0 :: 0 :: gentoo

Modified
License
Apache-2.0
Keywords
amd64
USE flags
test

General

test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

python2_7
Build with Python 2.7
python3_6
Build with Python 3.6

dev-python / PySocks : SOCKS client module

dev-python / backports-ssl-match-hostname : Backport of the ssl.match_hostname function

dev-python / cached-property : A cached-property for decorating methods in classes

dev-python / docker-py : Python client for Docker

dev-python / dockerpty : Python library to use the pseudo-tty of a docker container

dev-python / docopt : Pythonic argument parser, that will make you smile

dev-python / enum34 : Python 3.4 Enum backported

dev-python / ipaddress : IPv4/IPv6 manipulation library, backport of the ipaddress module

dev-python / jsonschema : An implementation of JSON-Schema validation for Python

dev-python / mock : Rolling backport of unittest.mock for all Pythons

dev-python / paramiko : SSH2 protocol library

dev-python / pytest : Simple powerful testing with Python

dev-python / pyyaml : YAML parser and emitter for Python

dev-python / requests : HTTP library for human beings

dev-python / setuptools : Collection of extensions to Distutils

dev-python / six : Python 2 and 3 compatibility library

dev-python / texttable : Module for creating simple ASCII tables

dev-python / websocket-client : WebSocket client for python with hybi13 support

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / PySocks : SOCKS client module

dev-python / backports-ssl-match-hostname : Backport of the ssl.match_hostname function

dev-python / cached-property : A cached-property for decorating methods in classes

dev-python / docker-py : Python client for Docker

dev-python / dockerpty : Python library to use the pseudo-tty of a docker container

dev-python / docopt : Pythonic argument parser, that will make you smile

dev-python / enum34 : Python 3.4 Enum backported

dev-python / ipaddress : IPv4/IPv6 manipulation library, backport of the ipaddress module

dev-python / jsonschema : An implementation of JSON-Schema validation for Python

dev-python / paramiko : SSH2 protocol library

dev-python / pyyaml : YAML parser and emitter for Python

dev-python / requests : HTTP library for human beings

dev-python / setuptools : Collection of extensions to Distutils

dev-python / six : Python 2 and 3 compatibility library

dev-python / texttable : Module for creating simple ASCII tables

dev-python / websocket-client : WebSocket client for python with hybi13 support

Repository mirror & CI · gentoo
Merge updates from master
Sebastian Pipping · gentoo
app-emulation/docker-compose: Remove old
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.67, Repoman-2.3.12
Sebastian Pipping · gentoo
app-emulation/docker-compose: Tests need pyyaml <5.1
Closes: https://bugs.gentoo.org/687460 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.67, Repoman-2.3.12
Sebastian Pipping · gentoo
app-emulation/docker-compose: Tests need pytest <4
Closes: https://bugs.gentoo.org/688688 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.67, Repoman-2.3.12
Repository mirror & CI · gentoo
Merge updates from master
Sebastian Pipping · gentoo
app-emulation/docker-compose: 1.24.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.67, Repoman-2.3.12
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
app-emulation/docker-compose: amd64 stable wrt bug #687190
Signed-off-by: Agostino Sarubbo <ago@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Sebastian Pipping · gentoo
app-emulation/docker-compose: 1.24.0
Closes: https://bugs.gentoo.org/682148 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.65, Repoman-2.3.12
Sebastian Pipping · gentoo
app-emulation/docker-compose: Fix dependencies
This unblocks system-wide updates of e.g. - dev-python/jsonschema-3.0.1 - dev-python/pyyaml-5.1 - dev-python/texttable-1.6.1 Closes: https://bugs.gentoo.org/681002 Bug: https://bugs.gentoo.org/679968 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.65, Repoman-2.3.12
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
app-emulation/docker-compose: ammend requests boundary in setup.py
Closes: https://bugs.gentoo.org/679968 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
app-emulation/docker-compose: mark stable
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Mikle Kolyada · gentoo
app-emulation/docker-compose: Drop lower bpundary for requests
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
app-emulation/docker-compose: Drop old
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
app-emulation/docker-compose: Version bump (v1.23.2)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Manuel Rüger · gentoo
app-emulation/docker-compose: Drop colorama dependency
Only required on windows platforms Signed-off-by: Manuel Rüger <mrueg@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Sebastian Pipping · gentoo
app-emulation/docker-compose: 1.23.1
1.23.0 is too broken to keep, hence the rename. Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Sebastian Pipping · gentoo
app-emulation/docker-compose: 1.23.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Sebastian Pipping · gentoo
app-emulation/docker-compose: Drop generic upper version boundaries
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Sebastian Pipping · gentoo
app-emulation/docker-compose: 1.22.0
Closes: https://bugs.gentoo.org/661882 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Manuel Rüger · gentoo
app-emulation/docker-compose: Fix dependency on docker-py
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Manuel Rüger · gentoo
app-emulation/docker-compose: Stabilize on amd64
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.21.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 3.21.0
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.20.1
Closes: https://bugs.gentoo.org/651090 Package-Manager: Portage-2.3.27, Repoman-2.3.9
Aaron Bauman · gentoo
app-emulation/docker-compose: amd64 stable
Bug: https://bugs.gentoo.org/644614 Package-Manager: Portage-2.3.26, Repoman-2.3.7
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.19.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.18.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.18.0_rc2
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.18.0_rc1
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.12, Repoman-2.3.4
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.17.1
Package-Manager: Portage-2.3.12, Repoman-2.3.4
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.17.0
Package-Manager: Portage-2.3.12, Repoman-2.3.4
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Manuel Rüger · gentoo
app-emulation/docker-compose: Fix dependency on texttable
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.16.1
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.15.0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.14.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Manuel Rüger · gentoo
app-emulation/docker-compose: Add python3_6
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.13.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.12.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Manuel Rüger · gentoo
app-emulation/docker-compose: Add support for python3_5
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.11.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: portage-2.3.3
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.11.1
Package-Manager: portage-2.3.3
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.11.0
Package-Manager: portage-2.3.3
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.10.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.10.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.10.0_rc2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.10.0_rc1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Manuel Rüger · gentoo
app-emulation/docker-compose: Fix dependencies
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Manuel Rüger · gentoo
app-emulation/docker-compose: Add new snapshot supporting compose version 3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: portage-2.3.2
Manuel Rüger · gentoo
app-emulation/docker-compose: Remove old
Package-Manager: portage-2.3.2
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.9.0
Package-Manager: portage-2.3.2
Manuel Rüger · gentoo
app-emulation/docker-compose: Version bump to 1.9.0_rc4
Gentoo-Bug: 599312 Package-Manager: portage-2.3.0
Alex Brandt · gentoo
app-emulation/docker-compose: remove version 1.8.0_rc2
Package-Manager: portage-2.3.2
Alex Brandt · gentoo
app-emulation/docker-compose: add version 1.9.0_rc1
Package-Manager: portage-2.3.2
Alex Brandt · gentoo
app-emulation/docker-compose: remove version 1.8.0_rc1
Package-Manager: portage-2.3.1
Alex Brandt · gentoo
app-emulation/docker-compose: add version 1.8.1
Package-Manager: portage-2.3.1
Alex Brandt · gentoo
app-emulation/docker-compose: remove version 1.7.1
Package-Manager: portage-2.3.0
Alex Brandt · gentoo
app-emulation/docker-compose: add version 1.8.0
Package-Manager: portage-2.3.0
Alex Brandt · gentoo
app-emulation/docker-compose: remove version 1.7.0
Package-Manager: portage-2.3.0
Alex Brandt · gentoo
app-emulation/docker-compose: add version 1.8.0_rc2
Package-Manager: portage-2.3.0
Alex Brandt · gentoo
app-emulation/docker-compose: remove version 1.7.0_rc1
Package-Manager: portage-2.3.0
Alex Brandt · gentoo
app-emulation/docker-compose: add version 1.8.0_rc1
Package-Manager: portage-2.3.0
Alex Brandt · gentoo
app-emulation/docker-compose: remove version 1.6.2
Package-Manager: portage-2.3.0_rc1
Alex Brandt · gentoo
app-emulation/docker-compose: remove version 1.5.2
Package-Manager: portage-2.3.0_rc1
Alex Brandt · gentoo
app-emulation/docker-compose: add version 1.7.1
Package-Manager: portage-2.3.0_rc1
Zac Medico · gentoo
app-emulation/docker-compose: version bump to 1.7.0
Package-Manager: portage-2.2.28
Alex Brandt · gentoo
app-emulation/docker-compose: remove version 1.5.1
Package-Manager: portage-2.2.28
Alex Brandt · gentoo
app-emulation/docker-compose: add version 1.7.0_rc1
Package-Manager: portage-2.2.28
Alex Brandt · gentoo
app-emulation/docker-compose: remove version 1.4.0
Package-Manager: portage-2.2.28
Alex Brandt · gentoo
app-emulation/docker-compose: add version 1.6.2
Package-Manager: portage-2.2.28
Alex Brandt · gentoo
app-emulation/docker-compose: remove version 1.2.0-r1
Package-Manager: portage-2.2.26
Alex Brandt · gentoo
app-emulation/docker-compose: add version 1.5.2
Package-Manager: portage-2.2.26
Alex Brandt · gentoo
app-emulation/docker-compose: move enum34 dependence
The dev-python/enum34 dependence was in the incorrect set of dependencies. I read the setup.py incorrectly and placed it in testing dependences rather than common. This fixes bug #566754. Package-Manager: portage-2.2.26
Alex Brandt · gentoo
app-emulation/docker-compose: add version 1.5.1
Fixes bug #560596. Package-Manager: portage-2.2.25
Justin Lecher · gentoo
Fix Malformed Id header on line: 3
Convert Header to Id Signed-off-by: Justin Lecher <jlec@gentoo.org>
Alex Brandt · gentoo
app-emulation/docker-compose: add version 1.4.0
Package-Manager: portage-2.2.20.1
Robin H. Johnson · gentoo
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed