app-emulation / fs-uae-launcher

PyQt5-based launcher for FS-UAE

Official package sites : https://fs-uae.net/ ·

v3.0.0 :: 0 :: gentoo

Modified
License
GPL-2
Keywords
~amd64
USE flags
lha

General

lha
Enable LHA archive support

python_single_target

python3_5
Build for Python 3.5 only
python3_6
Build for Python 3.6 only
python3_7
Build for Python 3.7 only

python_targets

python3_5
Build with Python 3.5
python3_6
Build with Python 3.6
python3_7
Build with Python 3.7

sys-devel / gettext : GNU locale utilities

app-emulation / fs-uae : Integrates the most accurate Amiga emulation code available from WinUAE

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / PyQt5 : Python bindings for the Qt framework

dev-python / pyopengl : Python OpenGL bindings

dev-python / python-lhafile : LHA archive support for Python

dev-python / requests : HTTP library for human beings

631346
[seden overlay] app-emulation/fs-uae-launcher - ImportError: No module named 'six.moves'
676112
[seden overlay] app-emulation/fs-uae-launcher-2.9.7 - fs-uae-launcher: AttributeError: type object 'Callable' has no attribute '_abc_registry'
Repository mirror & CI · gentoo
Merge updates from master
James Le Cuirot · gentoo
app-emulation/fs-uae-launcher: Drop old 2.8.3-r1
Package-Manager: Portage-2.3.69, Repoman-2.3.13 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
James Le Cuirot · gentoo
app-emulation/fs-uae-launcher: Version bump to 3.0.0
Package-Manager: Portage-2.3.69, Repoman-2.3.13 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
James Le Cuirot · gentoo
app-emulation/fs-uae-launcher: Patch around crash under KDE Plasma
This issue affects PyQt5 in general but I don't know the proper solution and it's easy to patch around. Closes: https://bugs.gentoo.org/684948 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
James Le Cuirot · gentoo
app-emulation/fs-uae-launcher: Add required PyQt5 USE flags
Closes: https://bugs.gentoo.org/684946 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
James Le Cuirot · gentoo
app-emulation/fs-uae-launcher: New package for launching fs-uae
Closes: https://bugs.gentoo.org/403913 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>