app-emulation / rkt

rkt is an App Container runtime for Linux

Official package sites : https://github.com/coreos/rkt ·

rkt is the next-generation container manager for Linux clusters. Designed for security, simplicity, and composability within modern cluster architectures, rkt discovers, verifies, fetches, and executes application containers with pluggable isolation. rkt can run the same container with varying degrees of protection, from lightweight, OS-level namespace and capabilities isolation to heavier, VM-level hardware virtualization.

v1.30.0 :: 0 :: gentoo

Modified
License
Apache-2.0
Keywords
~amd64
USE flags
actool doc examples systemd

v1.29.0 :: 0 :: gentoo

Modified
License
Apache-2.0
Keywords
~amd64
USE flags
actool doc examples systemd

General

actool
Missing description
doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
examples
Install examples, usually source code
rkt_stage1_coreos
Missing description
rkt_stage1_fly
Missing description
rkt_stage1_host
Missing description
rkt_stage1_kvm
Missing description
rkt_stage1_kvm_lkvm
Missing description
rkt_stage1_kvm_qemu
Missing description
rkt_stage1_src
Missing description
systemd
Enable use of systemd-specific libraries and features like socket activation or session tracking

app-arch / cpio : A file archival tool which can also read and write tar files

app-crypt / trousers : An open-source TCG Software Stack (TSS) v1.1 implementation

app-portage / elt-patches : Collection of patches for libtool.eclass

dev-lang / go : A concurrent garbage collected and typesafe programming language

dev-perl / Capture-Tiny : Capture STDOUT and STDERR from Perl, XS or external programs

sys-apps / attr : Extended attributes tools

sys-apps / util-linux : Various useful Linux utilities

sys-devel / autoconf : Used to create autoconfiguration files

sys-devel / automake : Used to generate Makefile.in from Makefile.am

sys-devel / libtool : A shared library tool for developers

sys-fs / squashfs-tools : tools to create and extract Squashfs filesystems

sys-libs / libcap : POSIX 1003.1e capabilities

sys-libs / zlib : Standard (de)compression library

virtual / pkgconfig : Virtual for the pkg-config implementation

x11-libs / pixman : Low-level pixel manipulation routines

app-shells / bash : The standard GNU Bourne again shell

sys-apps / systemd : System and service manager for Linux

622330
app-emulation/rkt-1.26.0 : make: *** [stage1/.../build-usr.mk:162: /var/tmp/portage/app-emulation/rkt-1.26.0/work/rkt-1.26.0/build-rkt-1.26.0/stamps/__stage1_usr_from_coreos_build_usr_mkfor_usr_from_coreos_mk_mkbase.stamp] Error 1
634746
app-emulation/rkt-1.28.1 will not build with USE examples: dodoc error: /usr/bin/install: cannot stat 'examples': No such file or directory
645400
app-emulation/rkt-1.29.0: parse-util.c:26:10: fatal error: xlocale.h: No such file or directory
671558
app-emulation/rkt-1.30.0 - builtin-run.c:412:28: error: ‘%s’ directive output may be truncated writing up to 4095 bytes into a region of size 4091 [-Werror=format-truncation=]
672062
app-emulation/rkt-1.30.0 with USE=rkt_stage1_kvm_qemu is missing static-libs DEPENDs for a several packages
679182
app-emulation/rkt-1.30.0 : failed to initialize build cache at /.../go-build: mkdir /.../cache: permission denied
Repository mirror & CI · gentoo
Merge updates from master
Robin Hallabro · gentoo
app-emulation/rkt: Bump version to 1.30.0
Closes: https://bugs.gentoo.org/671046 Closes: https://github.com/gentoo/gentoo/pull/10436 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Robin Hallabro <robin@hallabro.nu> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Zac Medico · gentoo
app-emulation/rkt: remove old version 1.28.1
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Zac Medico · gentoo
app-emulation/rkt: new linux headers lkvm fix (bug 635274)
Closes: https://bugs.gentoo.org/635274 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Zac Medico · gentoo
app-emulation/rkt: fix to compile with glibc-2.25 (bug 580330)
Thanks to Dennis Schridde <devurandom@gmx.net> for the lkvm patch instructions. Bug: https://bugs.gentoo.org/580330 Bug: https://bugs.gentoo.org/627564 Package-Manager: Portage-2.3.12, Repoman-2.3.3
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.29.0
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Zac Medico · gentoo
app-emulation/rkt: remove old version 1.27.0
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.28.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Zac Medico · gentoo
app-emulation/rkt: remove old versions
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Zac Medico · gentoo
app-emulation/rkt: fix REQUIRED_USE to comply with GLEP 73
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.27.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.26.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Zac Medico · gentoo
app-emulation/rkt: remove old versions
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.25.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.24.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Zac Medico · gentoo
app-emulation/rkt: remove old versions
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.23.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.22.0
Package-Manager: portage-2.3.3
Zac Medico · gentoo
app-emulation/rkt: remove old versions
Package-Manager: portage-2.3.3
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.21.0
Package-Manager: portage-2.3.3
Zac Medico · gentoo
app-emulation/rkt: remove old versions
Package-Manager: portage-2.3.2
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.20.0
Package-Manager: portage-2.3.2
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.19.0
Package-Manager: portage-2.3.2
Zac Medico · gentoo
app-emulation/rkt: adjust qemu deps for bug 600042
Package-Manager: portage-2.3.2
Zac Medico · gentoo
app-emulation/rkt: use emake V=3
Package-Manager: portage-2.3.2
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.18.0
Package-Manager: portage-2.3.2
Zac Medico · gentoo
app-emulation/rkt: remove old versions
Package-Manager: portage-2.3.2
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.17.0
Package-Manager: portage-2.3.2
Zac Medico · gentoo
app-emulation/rkt: avoid sd-journal.h include for bug 595874
Package-Manager: portage-2.3.1
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.16.0
Package-Manager: portage-2.3.1
Zac Medico · gentoo
app-emulation/rkt: remove old versions
Package-Manager: portage-2.3.1
Kai-Chieh Ku · gentoo
app-emulation/rkt: install bash-completion
Package-Manager: portage-2.3.0
Zac Medico · gentoo
app-emulation/rkt: rename rkt_stage1_kvm to rkt_stage1_kvm_lkvm
Package-Manager: portage-2.3.1
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.15.0
Package-Manager: portage-2.3.1
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.14.0
Package-Manager: portage-2.3.0
Zac Medico · gentoo
app-emulation/rkt: fix 1.12.0 to not require git, bug 591314
Package-Manager: portage-2.3.0
Zac Medico · gentoo
app-emulation/rkt: remove old version 1.10.1
Package-Manager: portage-2.3.0
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.12.0
Package-Manager: portage-2.3.0
Zac Medico · gentoo
app-emulation/rkt: reduce DESCRIPTION lenght
Package-Manager: portage-2.3.0
Zac Medico · gentoo
app-emulation/rkt: drop 9999 ebuild
Package-Manager: portage-2.3.0
Zac Medico · gentoo
app-emulation/rkt: remove old versions
Package-Manager: portage-2.3.0
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.11.0
Package-Manager: portage-2.3.0
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.10.1 (fixes bug 585208)
This includes the patch from https://github.com/coreos/rkt/pull/2868 and --enable-sdjournal=no is passed to econf when USE=systemd is not enabled. Package-Manager: portage-2.3.0
Zac Medico · gentoo
app-emulation/rkt: remove old version 1.4.0
Package-Manager: portage-2.3.0_rc1
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.7.0
Package-Manager: portage-2.3.0_rc1
Zac Medico · gentoo
app-emulation/rkt: remove old versions
Package-Manager: portage-2.3.0_rc1
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.6.0
Package-Manager: portage-2.3.0_rc1
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.4.0
Package-Manager: portage-2.2.28
Zac Medico · gentoo
app-emulation/rkt: remove old versions
Package-Manager: portage-2.2.28
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.3.0
Package-Manager: portage-2.2.28
Ian Delaney · gentoo
Merge remote-tracking branch 'remotes/sbraz/syncthing'
Pull Request: https://github.com/gentoo/gentoo/pull/990
Zac Medico · gentoo
app-emulation/rkt: update 9999 ebuild
Package-Manager: portage-2.2.27
Zac Medico · gentoo
app-emulation/rkt: fix makefile dependencies to work in src_test
Package-Manager: portage-2.2.27
Zac Medico · gentoo
app-emulation/rkt: use forward-vars for get_lkvm_sources makefile target
Package-Manager: portage-2.2.27
Zac Medico · gentoo
app-emulation/rkt: fix kvm when coreos stage1 is disabled, + makefile tweaks
Package-Manager: portage-2.2.27
Zac Medico · gentoo
app-emulation/rkt: fix rkt_stage1_host RDEPEND conditional
Package-Manager: portage-2.2.27
Zac Medico · gentoo
app-emulation/rkt: support rkt_stage1_host
Package-Manager: portage-2.2.27
Patrick Lauer · gentoo
app-emulation/rkt: Whitespace
Package-Manager: portage-2.2.27
Zac Medico · gentoo
app-emulation/rkt: add rkt_stage1_kvm support
Package-Manager: portage-2.2.27
Zac Medico · gentoo
app-emulation/rkt: use ${PXE_SYSTEMD_VERSION} more
Package-Manager: portage-2.2.27
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.1.0
Package-Manager: portage-2.2.27
Zac Medico · gentoo
app-emulation/rkt: add app-crypt/trousers dependency for bug 575472
Package-Manager: portage-2.2.27
Zac Medico · gentoo
app-emulation/rkt: version bump to 1.0.0
Package-Manager: portage-2.2.27
Alex Brandt · gentoo
app-emulation/rkt: add version 0.8.0 and 9999
Provided by Stefan Junker (listed as maintainer) This commit does add a USE flag, rkt_stage1_src, to the selinux package.use.mask. This is required due to the systemd integration with selinux and rkt's dependence on systemd with this USE flag enabled. Package-Manager: portage-2.2.20.1