app-text / languagetool

A proof-reading tool for many languages

Official package sites : https://www.languagetool.org/ ·

v5.4 :: 0 :: gentoo

Modified
License
LGPL-2.1
Keywords
~amd64 ~x86

dev-java / java-config : Java environment configuration query tool

dev-java / commons-cli : A Java library for working with the command line arguments and options

dev-java / commons-collections : Extends the JCF classes with new interfaces, implementations and utilities

dev-java / commons-io : Utility classes, stream implementations, file filters, and much more

dev-java / commons-lang : Commons components to manipulate core java classes

dev-java / commons-logging : An ultra-thin bridge between different Java logging libraries

dev-java / hamcrest-core : Core library of matchers for building test expressions

dev-java / java-config : Java environment configuration query tool

dev-java / jcommander : Command line parsing framework for Java

dev-java / jna : Java Native Access

dev-java / slf4j-api : The slf4j API

virtual / jre : Virtual for Java Runtime Environment (JRE)

app-vim / languagetool : grammar checker for various languages

817398
app-text/languagetool: start-stop-daemon does not start; forgotten "--" for arguments
839528
app-text/languagetool: multiple bundled java packages
Repository mirror & CI · gentoo
Merge updates from master
Volkmar W. Pogatzki · gentoo
app-text/languagetool: Remove obsolete versions
Closes: https://bugs.gentoo.org/833310 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/24191 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Patrice Clement · gentoo
app-text/languagetool: add missing param.
Closes: https://bugs.gentoo.org/817353 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Patrice Clement · gentoo
app-text/languagetool: version bump.
Closes: https://bugs.gentoo.org/803332 Closes: https://github.com/gentoo/gentoo/pull/22532 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
app-text/languagetool: use BDEPEND for app-arch/unzip
Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Tim Harder · gentoo
app-text/languagetool: version bump to 4.6
Closes: https://bugs.gentoo.org/688878 Closes: https://bugs.gentoo.org/688942 Closes: https://bugs.gentoo.org/689200 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Tim Harder · gentoo
app-text/languagetool: remove old
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Tim Harder · gentoo
app-text/languagetool: version bump to 4.5
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Michael Mair-Keimberger · gentoo
app-text/languagetool: use HTTPS.
Closes: https://github.com/gentoo/gentoo/pull/7336
James Le Cuirot · gentoo
app-text/languagetool: Drop broken and unnecessary 3.5-r2 (#629468)
This "fixed" a non-existent bug and didn't actually work for anybody. Package-Manager: Portage-2.3.8, Repoman-2.3.2
Patrice Clement · gentoo
app-text/languagetool: define DEPEND variable.
Gentoo-Bug: https://bugs.gentoo.org/628948 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
James Le Cuirot · gentoo
app-text/languagetool: Remove old 3.4 and 3.5
Package-Manager: portage-2.3.2
James Le Cuirot · gentoo
app-text/languagetool: Bump guava SLOT, use Gentoo Java scripts
guava:20 is needed so that Java 7 can be dropped from Gentoo. Using our Java scripts makes the ebuild cleaner, avoids symlinks, and ensures that the correct JVM is chosen at runtime. There are still many external libraries being bundled and we don't have the time to package them all right now but I have bumped jackson and friends to a newer version than is bundled here so that can be used and I've also introduced commons-collections:4. I noticed that jna:0 was used before, which is version 3, but it's actually version 4 that's bundled so I've amended that dependency. This was given the +1 by Radhermit. Package-Manager: portage-2.3.2
Tim Harder · gentoo
app-text/languagetool: version bump to 3.5
Tim Harder · gentoo
app-text/languagetool: update worthless header
Tim Harder · gentoo
app-text/languagetool: initial import