dev-java / jts-core

JTS Topology Suite for Java

Official package sites : https://tsusiatsoftware.net/jts/main.html ·

v1.14 :: 0 :: gentoo

Modified
License
LGPL-2.1+
Keywords
~amd64 ~x86
USE flags
doc source test

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
source
Zip the sources and install them
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

elibc

FreeBSD
ELIBC setting for systems that use the FreeBSD C library

app-arch / unzip : unzipper for pkzip-compressed files

app-arch / zip : Info ZIP (encryption support)

dev-java / java-config : Java environment configuration query tool

dev-java / junit : Simple framework to write repeatable tests

virtual / jdk : Virtual for Java Development Kit (JDK)

app-arch / zip : Info ZIP (encryption support)

dev-java / java-config : Java environment configuration query tool

virtual / jre : Virtual for Java Runtime Environment (JRE)

Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Michael Mair-Keimberger · gentoo
dev-java/jts-core: use HTTPS
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
James Le Cuirot · gentoo
dev-java/jts-core: New package, required by h2
h2 is currently in java-overlay. Apparently several other things require this too. Package-Manager: portage-2.2.28