dev-libs / libtracefs

Linux kernel trace file system library

Official package sites : https://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git/ ·

v1.7.0 :: 0 :: gentoo

Modified
License
LGPL-2.1
Keywords
amd64 arm arm64 ppc ppc64 x86 ~alpha ~loong ~riscv

v1.6.4-r1 :: 0 :: gentoo

Modified
License
LGPL-2.1
Keywords
~amd64 ~arm64 ~riscv ~x86
USE flags
doc

v1.6.3-r2 :: 0 :: gentoo

Modified
License
LGPL-2.1
Keywords
~amd64 ~arm64 ~riscv ~x86
USE flags
doc

v1.6.1-r2 :: 0 :: gentoo

Modified
License
LGPL-2.1
Keywords
amd64 ~arm64 ~x86
USE flags
doc

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally

dev-libs / libtraceevent : Linux kernel trace event library

dev-libs / libtraceevent : Linux kernel trace event library

dev-libs / libtracecmd : Linux kernel tracecmd library

dev-util / kernelshark : Graphical reader for trace-cmd output

dev-util / perf : Userland tools for Linux Performance Counters

dev-util / trace-cmd : User-space front-end for Ftrace

sys-block / ndctl : Helper tools and libraries for managing non-volatile memory on Linux

Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-libs/libtracefs: Stabilize 1.7.0 arm64, #916522
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jakov Smolić · gentoo
dev-libs/libtracefs: Stabilize 1.7.0 arm, #916522
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-libs/libtracefs: Stabilize 1.7.0 ppc, #916522
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
dev-libs/libtracefs: Stabilize 1.7.0 ppc64, #916522
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
dev-libs/libtracefs: Stabilize 1.7.0 x86, #916522
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
dev-libs/libtracefs: Stabilize 1.7.0 amd64, #916522
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Yixun Lan · gentoo
dev-libs/libtracefs: fix wrong doc path
Closes: https://bugs.gentoo.org/865751 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matoro Mahri · gentoo
dev-libs/libtracefs: Keyword 1.7.0 alpha, #922878
Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-libs/libtracefs: sys-devel/bison -> app-alternatives/yacc
All of these will be using app-alternatives/yacc anyway as they're not unsetting YACC or LEX, so make the dep reflect reality. (Included both YACC and LEX out of conservatism.) Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
dev-libs/libtracefs: sys-devel/flex -> app-alternatives/lex
All of these will be using app-alternatives/lex anyway as they're not unsetting YACC or LEX, so make the dep reflect reality. (Included both YACC and LEX out of conservatism.) Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
WANG Xuerui · gentoo
dev-libs/libtracefs: keyword 1.7.0 for ~loong
Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-libs/libtracefs: Keyword 1.7.0 ppc64, #909735
Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
dev-libs/libtracefs: Keyword 1.7.0 ppc, #909735
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-libs/libtracefs: Keyword 1.7.0 arm, #909735
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-libs/libtracefs: add 1.7.0
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Yixun Lan · gentoo
dev-libs/libtracefs: correct version of trace-cmd blocker
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Yixun Lan · gentoo
dev-libs/libtracefs: add 1.6.4
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-libs/libtracefs: add blocker for old versions of dev-util/trace-cmd
Closes: https://bugs.gentoo.org/852746 Bug: https://bugs.gentoo.org/890597 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Yixun Lan · gentoo
dev-libs/libtracefs: drop 1.3.1, 1.4.2, 1.5.0
cleanup old after stabilization, wrt #889634 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-libs/libtracefs: Stabilize 1.6.1 amd64, #889634
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Yixun Lan · gentoo
dev-libs/libtracefs: Keyword 1.6.3 riscv, #887821
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Yixun Lan · gentoo
dev-libs/libtracefs: Version bump 1.6.3
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Yixun Lan · gentoo
dev-libs/libtracefs: add 1.6.1
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Yixun Lan · gentoo
dev-libs/libtracefs: add 1.5.0
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
brahmajit das · gentoo
dev-libs/libtracefs: add 1.4.2
Version bump and test fix. This is related to bug 855893. The issues on that bug is fixed upsteam, hence updating the package is another fix. Closes: https://bugs.gentoo.org/855893 Signed-off-by: brahmajit das <listout@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/26890 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
brahmajit das · gentoo
dev-libs/libtracefs: Fix wrong target install-doc and source-highlight dependency
The make target install-doc is wrong and install_doc should be used in this package's case. gnu source-highlight is needed for source highlighting by asciidoc Closes: https://bugs.gentoo.org/865465 Closes: https://bugs.gentoo.org/865469 Signed-off-by: brahmajit das <listout@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/26913 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
brahmajit das · gentoo
dev-libs/libtracefs: Fix pthread_mutex_t unknown type on musl
On musl it is necessary to include pthread header else the compiler cannot identify pthread_mutex_t as a known type Closes: https://bugs.gentoo.org/855893 Signed-off-by: brahmajit das <listout@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/26882 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-libs/libtracefs: Keyword 1.3.1 arm64, #861347
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Christian Schmidt · gentoo
dev-libs/libtracefs: New package, add 1.3.1
Signed-off-by: Christian Schmidt <gentoo@digadd.de> Bug: https://bugs.gentoo.org/824982 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>