dev-libs / ocl-icd

Alternative to vendor specific OpenCL ICD loaders

Official package sites : https://github.com/OCL-dev/ocl-icd ·

v2.3.1 :: 0 :: gentoo (Masked by set 6257)

Modified
License
BSD-2
Keywords
~amd64 ~ppc64 ~x86
USE flags
khronos-headers

v2.3.0 :: 0 :: gentoo (Masked by set 6257)

Modified
License
BSD-2
Keywords
amd64 x86 ~ppc64
USE flags
khronos-headers

General

khronos-headers
Install Khronos OpenCL headers.

abi_mips

n32
64-bit (32-bit pointer) libraries
n64
64-bit libraries
o32
32-bit libraries

abi_s390

32
32-bit (s390) libraries
64
64-bit (s390x) libraries

abi_x86

32
32-bit (x86) libraries
64
64-bit (amd64) libraries
x32
x32 ABI libraries

dev-util / opencl-headers : Unified C language headers for the OpenCL API

dev-libs / opencl-icd-loader : Official Khronos OpenCL ICD Loader

dev-util / opencl-headers : Unified C language headers for the OpenCL API

dev-libs / opencl-icd-loader : Official Khronos OpenCL ICD Loader

virtual / opencl : Virtual for OpenCL API

643102
dev-libs/ocl-icd does not seem to provide libOpenCL.so
733018
dev-libs/ocl-icd fails to compile
736860
dev-libs/ocl-icd-2.3.1 uses automake in maintainer-mode

6257
Michał Górny
Unpredictable build failures reported. No revdeps left. dev-libs/opencl-icd-loader is a good replacement. Removal on 2022-12-23. Bug #733018.
  • dev-libs/ocl-icd
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-libs/ocl-icd: keyword 2.3.0 for ~ppc64
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-libs/ocl-icd: Keyword 2.3.1 ppc64, #860288
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Yiyang Wu · gentoo
dev-libs/ocl-icd: change the vendors dir when use prefix
Closes: https://github.com/gentoo/gentoo/pull/25785 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
James Le Cuirot · gentoo
dev-libs/ocl-icd: Add ruby31 to 2.3.1
Closes: https://bugs.gentoo.org/836589 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
dev-libs/ocl-icd: drop 2.2.12-r4
Invoking maintainer time-out. Closes: https://bugs.gentoo.org/834446 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Patrick Lauer · gentoo
dev-libs/ocl-icd: Bump to 2.3.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-libs/ocl-icd: x86 stable wrt bug #810847
Package-Manager: Portage-3.0.20, Repoman-3.0.3 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
dev-libs/ocl-icd: amd64 stable wrt bug #810847
Package-Manager: Portage-3.0.20, Repoman-3.0.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Patrick Lauer · gentoo
dev-libs/ocl-icd: Fix dependencies
Closes: https://bugs.gentoo.org/798444 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
James Le Cuirot · gentoo
dev-libs/ocl-icd: Drop old and broken 2.2.14
Closes: https://bugs.gentoo.org/789558 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
James Le Cuirot · gentoo
dev-libs/ocl-icd: Version bump to 2.3.0
This is compatible with the new OpenCL headers. Closes: https://bugs.gentoo.org/789558 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
James Le Cuirot · gentoo
dev-libs/ocl-icd: Pin opencl-headers on 2.2.12 to compatible version
We need to ensure this version isn't removed. Closes: https://bugs.gentoo.org/789558 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Peter Levine · gentoo
dev-libs/ocl-icd: Add support for dev-lang/ruby:3.0
Having tested ruby26, ruby27, and ruby30 with the command the build uses to generate files (i.e., ${RUBY} "${S}"/icd_generator.rb --mode database --database "${S}"/ocl_interface.yaml) and diffed the results, all generated files are exactly the same. Closes: https://bugs.gentoo.org/704056 Closes: https://bugs.gentoo.org/766261 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Peter Levine <plevine457@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20156 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Peter Levine · gentoo
dev-libs/ocl-icd: Fix ruby BDEP selection
The Makefile sets RUBY=ruby. The active ruby interpreter set via eselect may not correspond to one that satisfies ${RUBY_DEPS}. Test for the existence of a versioned ruby from among USE_RUBY, moving from right to left, and pass it to emake. Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Peter Levine · gentoo
dev-libs/ocl-icd: Remove ruby24 from USE_RUBY
dev-lang/ruby:2.4 is no longer in the gentoo tree. Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Patrick Lauer · gentoo
dev-libs/ocl-icd: Bump to 2.2.14
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-libs/ocl-icd: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
dev-libs/ocl-icd: x86 stable (bug #721674)
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-libs/ocl-icd: amd64 stable wrt bug #721674
Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="amd64" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
dev-libs/ocl-icd: do not block x11-drivers/nvidia-drivers
There are now versions of the latter in the tree which do not depend on eselect-opencl. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
dev-libs/ocl-icd: use dev-util/opencl-headers instead of bundled ones
Builds just fine against these, which is not surprising given both sets are official Khronos Group OpenCL 2.2 headers - the only difference being the bundled ones are legacy and the separately packaged ones are unified. Furthermore, without having to worry about file collisions in /usr/include/CL, it will become possible for packages depending on unified headers (e.g. dev-libs/intel-neo, which too uses a bundled copy for now) to use dev-util/opencl-headers regardless of which ICD loader provides the library. Last but not least, one bundling less to worry about! Note that this change makes USE=khronos-headers redundant, that said we keep it in IUSE - at least for now anyway - so that ebuilds explicitly requesting this USE flag needn't be modified. No revbump because the first commit introducing -r3 has at the time of me writing this not had been pushed to Gentoo servers yet. Committed directly due to prolonged absence of the maintainer. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Marek Szuba · gentoo
dev-libs/ocl-icd: install directly into /usr
This leaves x11-drivers/nvidia-drivers as the only OpenCL implementation still requiring eselect-opencl. Committed directly due to prolonged absence of the maintainer. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
dev-libs/ocl-icd: block dev-libs/opencl-icd-loader
Now, because we depend on app-eselect/eselect-opencl and opencl-icd-loader blocks it. In the future, to avoid file collisions on $libdir/libOpenCL.so* Committed directly due to prolonged absence of the maintainer. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sergei Trofimovich · gentoo
dev-libs/ocl-icd: tweak for gcc-10, bug #706098
Reported-by: Anthony Parsons Closes: https://bugs.gentoo.org/706098 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Alexey Shvetsov · gentoo
dev-libs/ocl-icd: works with ruby27
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-libs/ocl-icd: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Guilherme Amadio · gentoo
dev-libs/ocl-icd: fix ${D} vs ${ED} for prefix
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Alexey Shvetsov · gentoo
dev-libs/ocl-icd: Version bump drop old ruby, add new one
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
dev-libs/ocl-icd: x86 stable (bug #668900)
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-libs/ocl-icd: amd64 stable wrt bug #668900
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Jan Vesely · gentoo
dev-libs/ocl-icd-2.2.12: Install headers and drop ocl-icd.icd
Add useflag to install khronos CL headers. Don't install ocl-icd.icd to /etc/. v2: Don't try to move docs. It's not necessary. v3: Fixup ruby depend Signed-off-by: Jan Vesely <jano.vesely@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10122 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-libs/ocl-icd: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Matt Turner · gentoo
dev-libs/ocl-icd: Version bump to 2.2.12
Closes: https://bugs.gentoo.org/637964 Closes: https://bugs.gentoo.org/646122 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Agostino Sarubbo · gentoo
dev-libs/ocl-icd: x86 stable wrt bug #621594
Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
dev-libs/ocl-icd: amd64 stable wrt bug #621594
Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Patrick Lauer · gentoo
dev-libs/ocl-icd: Bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Patrick Lauer · gentoo
dev-libs/ocl-icd: Whitespace
Package-Manager: portage-2.2.28
Abheek Ghosh · gentoo
dev-libs/ocl-icd: fix dev-lang/ruby dependency
ocl-icd requires dev-ruby/rubygems to build. version 2.2.3 and 2.2.8 fixed. Gentoo-Bug: https://bugs.gentoo.org/577266 Closes: https://github.com/gentoo/gentoo/pull/1038
Patrick Lauer · gentoo
dev-libs/ocl-icd: Bump #575020
Package-Manager: portage-2.2.27
Robin H. Johnson · gentoo
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed