dev-lua / readline

A simple interface to the readline and history libraries

Official package sites : https://pjb.com.au/comp/lua/readline.html ·

v3.1 :: 0 :: gentoo

Modified
License
MIT
Keywords
amd64 x86 ~arm ~arm64

lua_targets

lua5-1
Build with Lua 5.1
lua5-3
Build with Lua 5.3
lua5-4
Build with Lua 5.4
luajit
Build with LuaJIT

dev-lua / luaposix : Bindings for POSIX APIs

sys-libs / readline : Another cute console display library

dev-lua / luaposix : Bindings for POSIX APIs

sys-libs / readline : Another cute console display library

net-im / prosody : Prosody is a modern XMPP communication server

Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
dev-lua/readline: drop 3.0-r1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Conrad Kostecki · gentoo
dev-lua/readline: x86 stable
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Conrad Kostecki · gentoo
dev-lua/readline: amd64 stable
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
dev-lua/readline: add 3.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
dev-lua/readline: x86 stable
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Conrad Kostecki · gentoo
dev-lua/readline: amd64 stable
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-lua/readline: misc fixups
- BDEPEND on virtual/pkgconfig as we call it in the ebuild - := on sys-libs/readline as it exposes a subslot for its ABI and we link against it - Add missing || dies - Don't use ${EROOT} (forbidden in src_test), instead use ${ESYSROOT} which should have what we need installed there. Closes: https://github.com/gentoo/gentoo/pull/24676 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
dev-lua/readline: initial import
This is a needed dep for upcoming prosody-0.12 release. Signed-off-by: Conrad Kostecki <conikost@gentoo.org>