dev-ml / ppx_optcomp

Optional compilation for OCaml

Official package sites : https://github.com/janestreet/ppx_optcomp ·

v0.9.0-r3 :: 0/0.9.0 :: gentoo

Modified
License
Apache-2.0
Keywords
~amd64 ~ppc ~x86

dev-lang / ocaml : Type-inferring functional programming language descended from the ML family

dev-ml / jbuilder : A composable build system for OCaml

dev-ml / ocaml-migrate-parsetree : Convert OCaml parsetrees between different major versions

dev-ml / opam : A source-based package manager for OCaml

dev-ml / ppx_core : Standard library for ppx rewriters

dev-ml / stdio : Standard IO Library for OCaml

dev-lang / ocaml : Type-inferring functional programming language descended from the ML family

dev-ml / ocaml-migrate-parsetree : Convert OCaml parsetrees between different major versions

dev-ml / ppx_core : Standard library for ppx rewriters

dev-ml / stdio : Standard IO Library for OCaml

dev-ml / ocaml-conduit : Dereference URIs into communication channels for Async or Lwt

dev-ml / ppx_driver : Feature-full driver for OCaml AST transformers

dev-ml / ppx_here : Expands [%here] into its location

dev-ml / ppx_sexp_conv : Support Library for type-driven code generators

Thomas Deutschmann · gentoo
dev-ml/ppx_optcomp: x86 keyworded (bug #627836)
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Alexis Ballier · gentoo
dev-ml/ppx_optcomp: Revbump to fix missing transitive := dep on stdio.
Closes: https://bugs.gentoo.org/636518 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Sergei Trofimovich · gentoo
dev-ml/ppx_optcomp: keyworded 0.9.0-r2 for ppc, bug #627836
Package-Manager: Portage-2.3.8, Repoman-2.3.3 RepoMan-Options: --include-arches="ppc"
Alexis Ballier · gentoo
dev-ml/ppx_optcomp: convert to opam.eclass
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Alexis Ballier · gentoo
dev-ml/ppx_optcomp: add missing dev-ml/ocaml-migrate-parsetree:= dep
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Alexis Ballier · gentoo
dev-ml/ppx_optcomp: revbump for propagating previous fix
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Alexis Ballier · gentoo
dev-ml/ppx_optcomp: add missing dev-lang/ocaml:= dep, bug #615768
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Alexis Ballier · gentoo
dev-ml/ppx_optcomp: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Alexis Ballier · gentoo
dev-ml/ppx_optcomp: remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Alexis Ballier · gentoo
dev-ml/ppx_optcomp: fix build with ocaml 4.04
Package-Manager: portage-2.3.2
Alexis Ballier · gentoo
dev-ml/ppx_optcomp: fix build with ocaml 4.03
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Alexis Ballier · gentoo
dev-ml/ppx_optcomp: bump to 113.33.00
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Alexis Ballier · gentoo
dev-ml/ppx_optcomp: use proper install method.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Alexis Ballier · gentoo
dev-ml/ppx_optcomp: initial import; ebuild by me
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>