dev-ml / ppx_tools

Tools for authors of ppx rewriters

Official package sites : https://github.com/alainfrisch/ppx_tools ·

v6.3 :: 0/6.3 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86
USE flags
ocamlopt

v6.2 :: 0/6.2 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86
USE flags
ocamlopt

General

ocamlopt
Enable ocamlopt support (ocaml native code compiler) -- Produces faster programs (Warning: you have to disable/enable it at a global scale)

dev-lang / ocaml : Programming language supporting functional, imperative & object-oriented styles

dev-lang / ocaml : Programming language supporting functional, imperative & object-oriented styles

dev-ml / ppx_deriving : Type-driven code generation for OCaml

795243
dev-ml/ppx_tools-6.3 - Error: Program cppo not found in the tree or in PATH
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-ml/ppx_tools: require < OCaml 4.12 for older ppx_tools
Bug: https://bugs.gentoo.org/795039 Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
dev-ml/ppx_tools: add 6.3
Closes: https://bugs.gentoo.org/795039 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
dev-ml/ppx_tools: drop old
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-ml/ppx_tools: ppc64 keyworded (bug #748576)
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-ml/ppx_tools: Keyword 6.2 ppc, #748576
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mark Wright · gentoo
dev-ml/ppx_tools: Bump to 6.2
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Miroslav Šulc · gentoo
dev-ml/ppx_tools: bumped to 5.3.4.08.0 + eapi7
Bug: https://bugs.gentoo.org/708696 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Miroslav Šulc · gentoo
dev-ml/ppx_tools: doesn't compile with ocaml-4.09
Bug: https://bugs.gentoo.org/708696 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Thomas Deutschmann · gentoo
dev-ml/ppx_tools: x86 keyworded (bug #611014)
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Alexis Ballier · gentoo
dev-ml/ppx_tools: remove 5.1.4.06.0, moved to overlay
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Alexis Ballier · gentoo
dev-ml/ppx_tools: bump to 5.1.4.06.0
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Alexis Ballier · gentoo
dev-ml/ppx_tools: add ocamlopt useflag, bug #624170
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Alexis Ballier · gentoo
dev-ml/ppx_tools: forward ~arm to the masked version too
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Alexis Ballier · gentoo
dev-ml/ppx_tools: keyword ~arm64
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Markus Meier · gentoo
dev-ml/ppx_tools: add ~arm, bug #611014
Package-Manager: Portage-2.3.5, Repoman-2.3.2 RepoMan-Options: --include-arches="arm"
Michael Weber · gentoo
dev-ml/ppx_tools: add ~ppc (bug 527318).
Package-Manager: Portage-2.3.5, Repoman-2.3.2 RepoMan-Options: --include-arches="ppc"
Alexis Ballier · gentoo
dev-ml/ppx_tools: Add version for ocaml 4.05
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Alexis Ballier · gentoo
dev-ml/ppx_tools: remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Alexis Ballier · gentoo
dev-ml/ppx_tools: backport upstream fixes for ocaml 4.04
Package-Manager: portage-2.3.2
Alexis Ballier · gentoo
dev-ml/ppx_tools: bump to 5.0 and remove 4.03 version
Package-Manager: portage-2.3.0_rc1
Alexis Ballier · gentoo
dev-ml/ppx_tools: bump to new upstream releases, changing versionning scheme to match ocaml
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Alexis Ballier · gentoo
dev-ml/ppx_tools: bump a snapshot that works with ocaml 4.03
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Alexis Ballier · gentoo
dev-ml/ppx_tools: bump to 0.99.3. This version comes from a fork but opam (official ocaml PM) uses this, and eliom needs it.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Alexis Ballier · gentoo
dev-ml/ppx_tools: initial import; ebuild by me
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>