dev-python / PythonQt

A dynamic Python binding for the Qt framework

Official package sites : https://mevislab.github.io/pythonqt ·

PythonQt is a dynamic Python binding for the Qt framework. It offers an easy way to embed the Python scripting language into your C++ Qt applications. The focus of PythonQt is on embedding Python into an existing C++ application, not on writing the whole application completely in Python.

v9999 :: 0 :: gentoo

Modified
License
LGPL-2.1
USE flags
debug doc examples extensions test

v3.2-r1 :: 0 :: gentoo

Modified
License
LGPL-2.1
Keywords
~amd64 ~x86
USE flags
debug doc examples extensions test

General

debug
Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
examples
Install examples, usually source code
extensions
Install extensions
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_single_target

python3_6
Build for Python 3.6 only
python3_7
Build for Python 3.7 only

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-qt / designer : WYSIWYG tool for designing and building graphical user interfaces with QtWidgets

dev-qt / qtcore : Cross-platform application development framework

dev-qt / qtdeclarative : The QML and Quick modules for the Qt5 framework

dev-qt / qtgui : The GUI module and platform plugins for the Qt5 framework

dev-qt / qtmultimedia : Multimedia (audio, video, radio, camera) library for the Qt5 framework

dev-qt / qtnetwork : Network abstraction library for the Qt5 framework

dev-qt / qtopengl : OpenGL support library for the Qt5 framework (deprecated)

dev-qt / qtprintsupport : Printing support library for the Qt5 framework

dev-qt / qtsql : SQL abstraction library for the Qt5 framework

dev-qt / qtsvg : SVG rendering library for the Qt5 framework

dev-qt / qttest : Unit testing library for the Qt5 framework

dev-qt / qtwidgets : Set of components for creating classic desktop-style UIs for the Qt5 framework

dev-qt / qtxml : Implementation of SAX and DOM for the Qt5 framework

dev-qt / qtxmlpatterns : XPath, XQuery, XSLT, and XML Schema validation library for the Qt5 framework

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-qt / designer : WYSIWYG tool for designing and building graphical user interfaces with QtWidgets

dev-qt / qtcore : Cross-platform application development framework

dev-qt / qtdeclarative : The QML and Quick modules for the Qt5 framework

dev-qt / qtgui : The GUI module and platform plugins for the Qt5 framework

dev-qt / qtmultimedia : Multimedia (audio, video, radio, camera) library for the Qt5 framework

dev-qt / qtnetwork : Network abstraction library for the Qt5 framework

dev-qt / qtopengl : OpenGL support library for the Qt5 framework (deprecated)

dev-qt / qtprintsupport : Printing support library for the Qt5 framework

dev-qt / qtsql : SQL abstraction library for the Qt5 framework

dev-qt / qtsvg : SVG rendering library for the Qt5 framework

dev-qt / qtwidgets : Set of components for creating classic desktop-style UIs for the Qt5 framework

dev-qt / qtxml : Implementation of SAX and DOM for the Qt5 framework

dev-qt / qtxmlpatterns : XPath, XQuery, XSLT, and XML Schema validation library for the Qt5 framework

app-admin / calamares : Distribution-independent installer framework

Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-python/PythonQt: Drop 3.2 (r0)
Dropping another dev-qt/qtwebkit:5 revdep. Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-python/PythonQt: Fix BDEPEND/DEPEND
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-python/PythonQt: Minor ebuild style++
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Vladimir Pavljuchenkov (SpiderX) · gentoo
dev-python/PythonQt: update live ebuild
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Vladimir Pavljuchenkov (SpiderX) · gentoo
dev-python/PythonQt: python3_7, EAPI 7, fix revdep, tests
1. add github reference in metadata 2. move to EAPI 7 3. add python3_7 4. add tests 5. add missed app-arch/unzip 6. don't build tests and examples 7. remove webkit USE flag Closes: https://bugs.gentoo.org/708700 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Closes: https://github.com/gentoo/gentoo/pull/14680 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/PythonQt: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Clean PYTHON_COMPAT of obsolete impls
Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Pacho Ramos · gentoo
dev-python/PythonQt: Support python3.6
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-python/PythonQt: Drop 3.1 and 3.1-r1
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Vladimir Pavljuchenkov (SpiderX) · gentoo
dev-python/PythonQt: version bump to 3.2.
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Vladimir Pavljuchenkov (SpiderX) · gentoo
dev-python/PythonQt: prevent using with Qt greater then 5.7
1. Added Python 3.6 to PYTHON_COMPAT. 2. Restricted Qt dependencies to 5.7 (wrt #634544) Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6610
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Vladimir Pavljuchenko (SpiderX) · gentoo
dev-python/PythonQt: new ebuild
PythonQt is a dynamic Python binding for the Qt framework. It offers an easy way to embed the Python scripting language into your C++ Qt applications. The focus of PythonQt is on embedding Python into an existing C++ application, not on writing the whole application completely in Python. Base for ebuild from https://github.com/SpiderX/portage-overlay/tree/master/dev-python/PythonQt Gentoo-Bug: https://bugs.gentoo.org/214331 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2634 Signed-off-by: David Seifert <soap@gentoo.org>