dev-python / asdf

Python library for the Advanced Scientific Data Format

Official package sites : https://asdf.readthedocs.io/en/latest/ ·

ASDF (Advanced Scientific Data Format) is a proposed next generation interchange format for scientific data. ASDF aims to exist in the same middle ground that made FITS so successful, by being a hybrid text and binary format: containing human editable metadata for interchange, and raw binary data that is fast to load and use. Unlike FITS, the metadata is highly structured and is designed up-front for extensibility.

v1.2.1 :: 0 :: gentoo

Modified
License
BSD
Keywords
~amd64 ~amd64-linux ~x86 ~x86-fbsd ~x86-linux
USE flags
doc test

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

python2_7
Build with Python 2.7
python3_5
Build with Python 3.5
python3_6
Build with Python 3.6

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / astropy-helpers : Helpers for Astropy and Affiliated packages

dev-python / jsonschema : An implementation of JSON-Schema validation for Python

dev-python / numpy : Fast array and numerical python library

dev-python / pytest : Simple powerful testing with Python

dev-python / pyyaml : YAML parser and emitter for Python

dev-python / setuptools : Collection of extensions to Distutils

dev-python / six : Python 2 and 3 compatibility library

dev-python / sphinx : Python documentation generator

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / jsonschema : An implementation of JSON-Schema validation for Python

dev-python / numpy : Fast array and numerical python library

dev-python / pyyaml : YAML parser and emitter for Python

dev-python / six : Python 2 and 3 compatibility library

dev-python / gwcs : Python for managing the World Coordinate System

638712
dev-python/asdf-1.2.1 : [TEST] error: The test command requires the astropy package to be installed and importable.
667180
dev-python/asdf-1.2.1 : sandbox issue
Repository mirror & CI · gentoo
Merge updates from master
Michael Mair-Keimberger · gentoo
dev-python/asdf: use HTTPS
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Pacho Ramos · gentoo
dev-python/asdf: Support python 3.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Sébastien Fabbro · gentoo
dev-python/asdf: initial import
Package-Manager: portage-2.3.3