dev-python / confuse

Confuse is a configuration library for Python that uses YAML

Official package sites : https://github.com/beetbox/confuse ·

Confuse is a configuration library for Python that uses YAML. It takes care of defaults, overrides, type checking, command-line integration, human-readable errors, and standard OS-specific locations.

v1.4.0 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~x86
USE flags
doc test

v1.0.0 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~x86
USE flags
doc test

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

pypy3
Build with PyPy3
python3_7
Build with Python 3.7
python3_8
Build with Python 3.8
python3_9
Build with Python 3.9

dev-python / pyyaml : YAML parser and emitter for Python

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / pypy3 : A fast, compliant alternative implementation of the Python (3.7) language

dev-python / pyyaml : YAML parser and emitter for Python

Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove obsolete values from PYTHON_COMPAT
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
David Roman · gentoo
dev-python/confuse: verbump to 1.4.0
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18388 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Clean PYTHON_COMPAT of obsolete impls
Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Bernardo Meurer · gentoo
dev-python/confuse: new package (1.0.0)
Confuse is a configuration library for Python that uses YAML. Closes: https://bugs.gentoo.org/693178 Closes: https://github.com/gentoo/gentoo/pull/12828 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Bernardo Meurer <bernardo@standard.ai> Signed-off-by: David Seifert <soap@gentoo.org>