dev-python / flask-appconfig

Configures Flask applications in a canonical way

Official package sites : https://github.com/mbr/flask-appconfig ·

v0.11.1-r1 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~x86
USE flags
doc test

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

pypy
Build with PyPy
pypy3
Build with PyPy3
python2_7
Build with Python 2.7
python3_5
Build with Python 3.5
python3_6
Build with Python 3.6
python3_7
Build with Python 3.7

dev-python / alabaster : A configurable sidebar-enabled Sphinx theme

dev-python / click : A Python package for creating beautiful command line interfaces

dev-python / flask : A microframework based on Werkzeug, Jinja2 and good intentions

dev-python / pytest : Simple powerful testing with Python

dev-python / setuptools : Collection of extensions to Distutils

dev-python / six : Python 2 and 3 compatibility library

dev-python / sphinx : Python documentation generator

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / click : A Python package for creating beautiful command line interfaces

dev-python / flask : A microframework based on Werkzeug, Jinja2 and good intentions

dev-python / six : Python 2 and 3 compatibility library

virtual / pypy : A virtual for PyPy Python implementation

virtual / pypy3 : A virtual for PyPy3 Python implementation

dev-python / flask-bootstrap : An extension that includes Bootstrap in your project, without boilerplate code

Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Louis Sautier · gentoo
dev-python/flask-appconfig: add Python 3.7 support, missing doc dep
Also make tests verbose. Signed-off-by: Louis Sautier <sbraz@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Louis Sautier · gentoo
dev-python/flask-appconfig: remove old
Closes: https://bugs.gentoo.org/589548 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Louis Sautier · gentoo
dev-python/flask-appconfig: Add Python 3.6, PyPy{,3}
Also remove useless depend on pytest-runner. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Louis Sautier · gentoo
dev-python/flask-appconfig: stop installing scripts to prevent collision
The console script called 'flask' causes a collision with dev-python/flask-0.11. Upstream already removed the console_scripts entry point: https://github.com/mbr/flask-appconfig/commit/42b1fe09dbd19cb7c48dfce7f505d7db7e6dd0be Gentoo-Bug: https://bugs.gentoo.org/589548 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/1948 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Louis Sautier · gentoo
dev-python/flask-appconfig: new package, dependency of flask-bootstrap, vn. 0.11.1
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1353 Signed-off-by: Ian Delaney <idella4@gentoo.org>