dev-python / html5-parser

Fast C based HTML 5 parsing for python

Official package sites : https://github.com/kovidgoyal/html5-parser/ ·

v0.4.9 :: 0 :: gentoo

Modified
License
Apache-2.0
Keywords
amd64 x86 ~arm

python_targets

python3_6
Build with Python 3.6
python3_7
Build with Python 3.7
python3_8
Build with Python 3.8

dev-libs / libxml2 : XML C parser and toolkit

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-libs / libxml2 : XML C parser and toolkit

dev-python / chardet : Universal encoding detector

dev-python / lxml : A Pythonic binding for the libxml2 and libxslt libraries

app-text / calibre : Ebook management application

Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/html5-parser: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Zac Medico · gentoo
dev-python/html5-parser: Remove old versions
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Zac Medico · gentoo
dev-python/html5-parser: Stabilize 0.4.9 for bug 705088
Needed for compat with latest stable dev-python/beautifulsoup. Bug: https://bugs.gentoo.org/705088#c3 Bug: https://bugs.gentoo.org/705090 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Zac Medico · gentoo
dev-python/html5-parser: Bump to version 0.4.9
Reported-by: rayslava@gmail.com Closes: https://bugs.gentoo.org/705090 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Clean PYTHON_COMPAT of obsolete impls
Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Zamarin Arthur · gentoo
dev-python/html5-parser: add Python3.7 support
Closes: https://github.com/gentoo/gentoo/pull/11872 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
James Le Cuirot · gentoo
dev-python/html5-parser: Version bump to 0.4.5, EAPI 7
Fixes cross-compiling by using the correct pkg-config. Signed-off-by: James Le Cuirot <chewi@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Aaron Bauman · gentoo
dev-python/html5-parser: amd64 stable
Bug: https://bugs.gentoo.org/642796 Package-Manager: Portage-2.3.26, Repoman-2.3.7
Thomas Deutschmann · gentoo
dev-python/html5-parser: x86 stable (bug #642796)
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Zac Medico · gentoo
dev-python/html5-parser: use src_prepare
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Zac Medico · gentoo
dev-python/html5-parser: disable soup test
Closes: https://bugs.gentoo.org/647066 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Zac Medico · gentoo
dev-python/html5-parser: new package
Package-Manager: Portage-2.3.10, Repoman-2.3.3