dev-python / jira

Python library for interacting with the JIRA REST API

Official package sites : https://jira.readthedocs.io/en/latest/ ·

Python library for interacting with JIRA via REST APIs.

v1.0.14-r1 :: 0 :: gentoo

Modified
License
BSD-2
Keywords
~amd64
USE flags
filemagic jirashell kerberos oauth

v1.0.14 :: 0 :: gentoo

Modified
License
BSD-2
Keywords
~amd64
USE flags
filemagic ipython oauth

v1.0.10-r1 :: 0 :: gentoo

Modified
License
BSD-2
Keywords
~amd64
USE flags
filemagic ipython oauth

v1.0.10 :: 0 :: gentoo

Modified
License
BSD-2
Keywords
~amd64
USE flags
filemagic ipython oauth

v1.0.5 :: 0 :: gentoo

Modified
License
BSD
Keywords
~amd64
USE flags
filemagic ipython oauth

General

filemagic
Missing description
ipython
Missing description
jirashell
Missing description
kerberos
Add kerberos support
oauth
Missing description

python_targets

python2_7
Build with Python 2.7
python3_5
Build with Python 3.5
python3_6
Build with Python 3.6

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / pbr : Inject some useful and sensible default behaviors into setuptools

dev-python / pytest-runner : Adds support for tests during installation of setup.py files

dev-python / setuptools : Collection of extensions to Distutils

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / defusedxml : XML bomb protection for Python stdlib modules, an xml serialiser

dev-python / filemagic : A Python API for libmagic, the library behind the Unix file command

dev-python / ipython : Advanced interactive shell for Python

dev-python / pycrypto : Python Cryptography Toolkit

dev-python / pycryptodome : A self-contained cryptographic library for Python

dev-python / requests : HTTP library for human beings

dev-python / requests-kerberos : A Kerberos authentication handler for python-requests

dev-python / requests-oauthlib : This project provides first-class OAuth library support for Requests

dev-python / requests-toolbelt : A utility belt for advanced users of python-requests

dev-python / setuptools : Collection of extensions to Distutils

dev-python / six : Python 2 and 3 compatibility library

dev-python / tlslite : TLS Lite is a free python library that implements SSL 3.0 and TLS 1.0/1.1

Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Denis Dupeyron · gentoo
dev-python/jira: fixed bug 655854, added kerberos authentication
Brian Dolbec · gentoo
dev-python/jira: Version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Austin English · gentoo
dev-python/jira: allow dev-python/pycryptodome as well as dev-python/pycrypto, Bug #611568
Gentoo-Bug: https://bugs.gentoo.org/611568 Gentoo-Bug: https://bugs.gentoo.org/611596 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Denis Dupeyron · gentoo
dev-python/jira: add dev-python/requests-toolbelt to RDEPEND in 1.0.10 (bug #599988)
Denis Dupeyron · gentoo
dev-python/jira: fix dependencies for 1.0.10
Zac Medico · gentoo
dev-python/jira: Add python3.6 to PYTHON_COMPAT
Also drop the tlslite dependency since that dependency was eliminated in version 1.0.7: https://github.com/pycontribs/jira/commit/1ab6709ea83f08ee0d2793331baf95c2d8b4fb3b Package-Manager: Portage-2.3.5, Repoman-2.3.2
Zac Medico · gentoo
dev-python/jira: version bump to 1.0.10
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Zac Medico · gentoo
dev-python/jira: Add python3_5 to PYTHON_COMPAT
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Mike Gilbert · gentoo
dev-python/jira: restore python3.4
Package-Manager: Portage-2.3.3_p12, Repoman-2.3.1_p5
Mike Gilbert · gentoo
dev-python/tlslite: drop python3.4
Michał Górny · gentoo
global: Drop dead implementations from PYTHON_COMPAT
Austin English · gentoo
dev-python/jira: add dev-python/jira-1.0.5
Package-Manager: portage-2.2.26