dev-python / josepy

JOSE protocol implementation in Python

Official package sites : https://github.com/certbot/josepy ·

JOSE protocol implementation in Python using cryptography Originally developed as part of the ACME protocol implementation.

v1.4.0 :: 0 :: gentoo

Modified
License
Apache-2.0
Keywords
~amd64 ~arm ~arm64 ~ppc64 ~x86
USE flags
test

v1.3.0 :: 0 :: gentoo

Modified
License
Apache-2.0
Keywords
amd64 x86 ~arm ~arm64 ~ppc64

General

test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

pypy3
Build with PyPy3
python3_6
Build with Python 3.6
python3_7
Build with Python 3.7
python3_8
Build with Python 3.8
python3_9
Build with Python 3.9

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / cryptography : Library providing cryptographic recipes and primitives

dev-python / pyopenssl : Python interface to the OpenSSL library

dev-python / setuptools : Collection of extensions to Distutils

dev-python / six : Python 2 and 3 compatibility library

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / cryptography : Library providing cryptographic recipes and primitives

dev-python / pyopenssl : Python interface to the OpenSSL library

dev-python / pypy3 : A fast, compliant alternative implementation of the Python (3.7) language

dev-python / setuptools : Collection of extensions to Distutils

dev-python / six : Python 2 and 3 compatibility library

app-crypt / acme : An implementation of the ACME protocol

app-crypt / certbot : Let's encrypt client to automate deployment of X.509 certificates

Repository mirror & CI · gentoo
Merge updates from master
Louis Sautier · gentoo
dev-python/josepy: bump to 1.4.0, add tests and Py3.9+PyPy3 support
Also: * Fix deps. * Remove blocker on acme 0.20.0 (removed from the tree more than 2 years ago). * Update HOMEPAGE. * EAPI=7. Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/josepy: Remove py2.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matthew Thode · gentoo
dev-python/josepy: cleanup
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Matthew Thode · gentoo
dev-python/josepy: 1.3.0 stable amd64 and x86
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matthew Thode · gentoo
dev-python/josepy: 1.1.0 cleanup
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Matthew Thode · gentoo
dev-python/josepy: 1.3.0 bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/josepy: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Clean PYTHON_COMPAT of obsolete impls
Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Lucius Q. User · gentoo
dev-python/josepy: Add support for python 3.8
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Sasha Finkelstein <finka1242@outlook.com> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matthew Thode · gentoo
dev-python/josepy: 1.2.0 stable amd64 and x86 with cleanup
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matthew Thode · gentoo
dev-python/josepy: 1.2.0 bump
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matthew Thode · gentoo
dev-python/josepy: add py37 to 1.1.0
Bug: https://bugs.gentoo.org/685330 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrius Štikonas · gentoo
app-crypt/certbot: add ~arm64 keywords to certbot and dependencies.
Signed-off-by: Andrius Štikonas <andrius@stikonas.eu> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matthew Thode · gentoo
dev-python/josepy: 1.1.0 stable amd64 and x86
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Matthew Thode · gentoo
dev-python/josepy: 1.1.0 bup
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Matthew Thode · gentoo
dev-python/josepy: stable amd64 and x86 for acme
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Mike Frysinger · gentoo
dev-python/josepy: block all old versions of acme
Since these both install /usr/bin/jws, making the blocker conditional upon the python versions doesn't make sense, so always block it. This also fixes upgrades when older acme was built against different python versions (and thus the blocker wouldn't activate).
Matthew Thode · gentoo
dev-python/josepy: move blocker to rdep
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Matthew Thode · gentoo
dev-python/josepy: block on earlier versions of acme
Closes: https://bugs.gentoo.org/642954 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Matthew Thode · gentoo
dev-python/josepy: adding for certbot/acme
Package-Manager: Portage-2.3.14, Repoman-2.3.6