dev-python / parso

a python parser that supports error recovery and round-trip parsing

Official package sites : https://github.com/davidhalter/parso · https://pypi.org/project/parso/ ·

v0.5.2 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86
USE flags
doc test

v0.5.1-r1 :: 0 :: gentoo

Modified
License
MIT
Keywords
amd64 arm64 ppc64 x86 ~arm ~ppc
USE flags
doc test

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

pypy3
Build with PyPy3
python2_7
Build with Python 2.7
python3_6
Build with Python 3.6
python3_7
Build with Python 3.7
python3_8
Build with Python 3.8

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / pypy3 : A fast, compliant alternative implementation of the Python (3.6) language

dev-python / jedi : Autocompletion library for Python

Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Clean PYTHON_COMPAT of obsolete impls
Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/parso: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Michał Górny · gentoo
dev-python/parso: Stabilize 0.5.1-r1 ALLARCHES
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Michał Górny · gentoo
dev-python/parso: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
dev-python/parso: arm64 stable
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.80, Repoman-2.3.19
Repository mirror & CI · gentoo
Merge updates from master
Patrick McLean · gentoo
dev-python/parso-0.5.1-r1: revbump, port to new helpers, py38, pypy{,3}
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
dev-python/parso: amd64 stable
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.80, Repoman-2.3.19
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
dev-python/parso: fix QA warning about tests
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/parso: Bump to 0.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Tim Harder · gentoo
dev-python/parso: remove old
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Tim Harder · gentoo
dev-python/parso: version bump to 0.5.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/parso: Tested on py3.7
Michał Górny · gentoo
dev-python/parso: Bump to 0.3.1
Thomas Deutschmann · gentoo
dev-python/parso: x86 stable (bug #596714)
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Michael Mair-Keimberger · gentoo
update pypi HOMEPAGE to avoid redirection
Closes: https://github.com/gentoo/gentoo/pull/8080
Mike Gilbert · gentoo
Replace pypi.python.org with pypi.org in HOMEPAGE
Bug: https://bugs.gentoo.org/653540
Markus Meier · gentoo
dev-python/parso: add ~arm, bug #604532
Package-Manager: Portage-2.3.24, Repoman-2.3.6 RepoMan-Options: --include-arches="arm"
Matt Turner · gentoo
dev-python/parso-0.1.1: added ~ppc, bug 604532
Sergei Trofimovich · gentoo
dev-python/parso: stable 0.1.1 for ppc64, bug #596714
Package-Manager: Portage-2.3.24, Repoman-2.3.6 RepoMan-Options: --include-arches="ppc64"
Tim Harder · gentoo
dev-python/parso: initial import, required by latest version of jedi