dev-python / pyicu

Python bindings for dev-libs/icu

Official package sites : https://github.com/ovalhub/pyicu ·

v2.3.1 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~x86
USE flags
test

v2.3 :: 0 :: gentoo

Modified
License
MIT
Keywords
amd64 x86
USE flags
test

v2.0.2 :: 0 :: gentoo

Modified
License
MIT
Keywords
amd64 x86
USE flags
test

General

test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

python2_7
Build with Python 2.7
python3_5
Build with Python 3.5
python3_6
Build with Python 3.6
python3_7
Build with Python 3.7

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-libs / icu : International Components for Unicode

dev-python / pytest : Simple powerful testing with Python

dev-python / six : Python 2 and 3 compatibility library

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-libs / icu : International Components for Unicode

app-misc / gramps : Genealogical Research and Analysis Management Programming System

Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-python/pyicu: amd64 stable wrt bug #686866
Signed-off-by: Agostino Sarubbo <ago@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
dev-python/pyicu: x86 stable (bug #686866)
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
dev-python/pyicu: bump to 2.3.1
Includes backported upstream workaround for python2.7 test failure. Bug: https://bugs.gentoo.org/644226 Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
dev-python/pyicu: remove old
Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Marek Szuba · gentoo
dev-python/pyicu: bump to 2.3
This is the first version of PyICU to support ICU-64 Closes: https://bugs.gentoo.org/682064 Closes: https://bugs.gentoo.org/682200 Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
dev-python/pyicu: trigger a rebuild upon dev-libs/icu update
Closes: https://bugs.gentoo.org/show_bug.cgi?id=676624 Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Marek Szuba · gentoo
dev-python/pyicu: remove old
Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
dev-python/pyicu: bump to 2.2
Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
dev-python/pyicu: bump to 2.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
dev-python/pyicu: bump 2.0.3 to EAPI 7
Package-Manager: Portage-2.3.40, Repoman-2.3.9
David Seifert · gentoo
dev-python/pyicu: Force C++11
Closes: https://bugs.gentoo.org/651748 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Marek Szuba · gentoo
dev-python/pyicu: remove old
Package-Manager: Portage-2.3.39, Repoman-2.3.9
Marek Szuba · gentoo
dev-python/pyicu: bump to 2.0.3
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jason Zaman · gentoo
dev-python/pyicu: amd64 stable
Gentoo-bug: 646892 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Thomas Deutschmann · gentoo
dev-python/pyicu: x86 stable (bug #646892)
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Marek Szuba · gentoo
dev-python/pyicu-2.0.2: skip tests on python2
test_Script/testSurrogatePairs fails on UCS-4 builds of python2_7, which is what Gentoo (and most Linux distributions) use. Upstream has been aware of the issue since November 2017 but has not fixed it yet. Gentoo-Bug: https://bugs.gentoo.org/644226 Upstream-Bug: https://github.com/ovalhub/pyicu/issues/61 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Marek Szuba · gentoo
dev-python/pyicu: remove old
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Marek Szuba · gentoo
dev-python/pyicu-1.9.5: add upper limit on dev-libs/icu version
Support for 59.1 was only added in 1.9.7, for 60.1 - in 1.9.8. Closes: https://bugs.gentoo.org/644806 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Marek Szuba · gentoo
dev-python/pyicu: bump to 2.0.2
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Marek Szuba · gentoo
dev-python/pyicu: bump to 1.9.8
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Marek Szuba · gentoo
dev-python/pyicu: remove old
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Marek Szuba · gentoo
dev-python/pyicu: bump to 1.9.7
Among other things, this version allows building with >=dev-libs/icu-59 and GCC <6 Gentoo-Bug: 618934 Package-Manager: Portage-2.3.5, Repoman-2.3.1
Manuel Rüger · gentoo
dev-python/pyicu: Add python3_6
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Marek Szuba · gentoo
dev-python/pyicu-1.9.6: remove USE=doc
Starting with this release PyICU no longer provides auto-generated API documentation. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Marek Szuba · gentoo
dev-python/pyicu: version bump to 1.9.6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Agostino Sarubbo · gentoo
dev-python/pyicu: x86 stable wrt bug #597924
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Marek Szuba · gentoo
dev-python/pyicu: mark 1.9.5 stable on amd64
Gentoo-Bug: 597924 Package-Manager: portage-2.3.0
Marek Szuba · gentoo
dev-python/pyicu: remove old
Package-Manager: portage-2.3.2
Marek Szuba · gentoo
dev-python/pyicu: bump to 1.9.5
Package-Manager: portage-2.3.2
Marek Szuba · gentoo
dev-python/pyicu: version bump to 1.9.4.
Includes backported icu-58.1 support from master. Gentoo-Bug: 599102 Package-Manager: portage-2.3.2
Michał Górny · gentoo
global: Drop dead implementations from PYTHON_COMPAT
Marek Szuba · gentoo
dev-python/pyicu: add ~x86 keyword
Many thanks to Dracwyrm <j.scruggs@gmail.com> for having run the tests. Package-Manager: portage-2.3.1
Marek Szuba · gentoo
dev-python/pyicu: fix generation of API documentation
PyICU API documentation is generated using epydoc, which cannot process python3 binary modules. It is therefore necessary to force the use of python_targets_python2_7 if USE=doc is enabled. Package-Manager: portage-2.3.1
Marek Szuba · gentoo
dev-python/pyicu: use HTML_DOCS instead of deprecated dohtml
Package-Manager: portage-2.3.0
Marek Szuba · gentoo
dev-python/pyicu: new package
Python bindings for dev-libs/icu. Ebuild based heavily on the one for version 1.9.2 from the jmbsvicetto overlay. Package-Manager: portage-2.3.0