dev-python / python-lsp-server

Python Language Server for the Language Server Protocol

Official package sites : https://github.com/python-lsp/python-lsp-server ·

v1.2.3 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~arm64 ~x86
USE flags
all-plugins test

v1.2.2 :: 0 :: gentoo

Modified
License
MIT
Keywords
amd64 x86 ~arm64
USE flags
all-plugins test

General

all-plugins
Pull in all optional plugins
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

python3_8
Build with Python 3.8
python3_9
Build with Python 3.9

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / autopep8 : Automatically formats Python code to conform to the PEP 8 style guide

dev-python / flake8 : A wrapper around PyFlakes, pep8 & mccabe

dev-python / jedi : Autocompletion library for Python

dev-python / mccabe : flake8 plugin: McCabe complexity checker

dev-python / pluggy : plugin and hook calling mechanisms for python

dev-python / pycodestyle : Python style guide checker (fka pep8)

dev-python / pydocstyle : Python docstring style checker

dev-python / pyflakes : Passive checker for Python programs

dev-python / pylint : Python code static checker

dev-python / python-lsp-jsonrpc : JSON RPC 2.0 server library

dev-python / rope : Python refactoring library

dev-python / setuptools : Collection of extensions to Distutils

dev-python / yapf : A formatter for Python files

dev-python / pyls-spyder : Spyder extensions for the python language server

dev-python / python-lsp-black : Black plugin for the Python LSP Server

Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/python-lsp-server: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-python/python-lsp-server: Stabilize 1.2.2 ALLARCHES, #815994
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/python-lsp-server: add version 1.2.3
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/python-lsp-server: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-python/python-lsp-server: amd64/x86 stable (ALLARCHES policy) wrt bug #811651
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/python-lsp-server: drop version 1.0.1
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/python-lsp-server: add version 1.2.2
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-python/python-lsp-server: Stabilize 1.1.0-r1 ALLARCHES, #806403
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/python-lsp-server: remove version 1.2.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/python-lsp-server: add version 1.2.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/python-lsp-server: add version 1.2.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/python-lsp-server: introduce all-plugins USE flag
Spyder requires all optional plugins for pylsp to be installed. Previously we handled this in the spyder ebuild. However, different versions of pylsp can be (in)compatible with different versions of these plugins. Which means that we run into problems with spyder if the version dependecny information for version X is recorded in the spyder ebuild, but version Y of pylsp is installed. The obvious solution is to record these dependencies in the pylsp ebuild instead, however to not pull in *everything* unconditionally we also introduce the USE flag. Package-Manager: Portage-3.0.20, Repoman-3.0.3 RepoMan-Options: --force Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/python-lsp-server: add version 1.1.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-python/python-lsp-server: Stabilize 1.0.1 x86, #795924
Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
dev-python/python-lsp-server: Stabilize 1.0.1 amd64, #795924
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/python-lsp-server: fix the tests (again)
See https://github.com/python-lsp/python-lsp-server/pull/9 Closes: https://bugs.gentoo.org/791166 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/python-lsp-server: add spyder fork of python-language-server
Bug: https://bugs.gentoo.org/783618 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>