dev-python / spark-parser

An Early-Algorithm Context-free grammar Parser

Official package sites : https://github.com/rocky/python-spark/ · https://pypi.org/project/spark_parser/ ·

SPARK stands for Scanning, Parsing, and Rewriting Kit. It uses Jay Early’s algorithm for parsing context free grammars, and comes with some generic Abstract Syntax Tree routines. There is also a prototype scanner which does its job by combining Python regular expressions.

v1.8.5 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~x86
USE flags
test

v1.6.1 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~x86
USE flags
test

v1.6.0 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~x86
USE flags
test

v1.5.1-r1 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~x86
USE flags
test

General

test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

pypy
Build with PyPy
python2_7
Build with Python 2.7
python3_5
Build with Python 3.5
python3_6
Build with Python 3.6

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / mock : Rolling backport of unittest.mock for all Pythons

dev-python / nose : Unittest extension with automatic test suite discovery and easy test authoring

dev-python / setuptools : Collection of extensions to Distutils

virtual / pypy : A virtual for PyPy Python implementation

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

virtual / pypy : A virtual for PyPy Python implementation

dev-python / uncompyle6 : Python cross-version byte-code deparser

651886
dev-python/spark-parser should depend on dev-python/click - uncompyle6: pkg_resources.DistributionNotFound: The 'click' distribution was not found and is required by spark-parser
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Michael Mair-Keimberger · gentoo
update pypi HOMEPAGE to avoid redirection
Closes: https://github.com/gentoo/gentoo/pull/8080
Mike Gilbert · gentoo
Replace pypi.python.org with pypi.org in HOMEPAGE
Bug: https://bugs.gentoo.org/653540
Brian Dolbec · gentoo
dev-python/spark-parser: Version bump
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Brian Dolbec · gentoo
dev-python/spark-parser: Version bump
Package-Manager: Portage-2.3.6_p2, Repoman-2.3.2_p70
Michał Górny · gentoo
dev-python/spark-parser: Clean old versions up
Brian Dolbec · gentoo
dev-python/spark-parser: Version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Brian Dolbec · gentoo
dev-python/spark-parser: Add latest dep version for uncompyle6
Package-Manager: portage-2.3.2
Denis Dupeyron · gentoo
dev-python/spark-parser-1.5.1: sed in python_prepare_all is no longer needed for tests
Denis Dupeyron · gentoo
dev-python/spark-parser: bump to 1.5.1 at dolsen's request
Package-Manager: portage-2.3.2
Brian Dolbec · gentoo
dev-python/spark-parser: Fix setup.py unconditional test only dep bug 599638
Package-Manager: portage-2.3.2_p3
Brian Dolbec · gentoo
dev-python/spark-parser: New package, dep of new dev-python/uncompyle6 pkg
Package-Manager: portage-2.3.1_p8