dev-python / spyder

The Scientific Python Development Environment

Official package sites : https://github.com/spyder-ide/spyder/ · https://pypi.org/project/spyder/ · https://www.spyder-ide.org/ ·

Spyder is a powerful scientific environment written in Python, for Python,and designed by and for scientists, engineers and data analysts. It features a unique combination of the advanced editing, analysis, debugging and profiling functionality of a comprehensive development tool with the data exploration, interactive execution, deep inspection and beautiful visualization capabilities of an analysis package. Furthermore, Spyder offers built-in integration with many popular scientific libraries, including NumPy, SciPy, Pandas, IPython, QtConsole, Matplotlib, SymPy, and more, and can be extended further with full plugin support.

v5.1.5-r1 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~x86
USE flags
doc test

v5.0.5-r1 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~x86
USE flags
doc test

v4.2.5-r2 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64 ~x86
USE flags
doc test

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

python3_8
Build with Python 3.8
python3_9
Build with Python 3.9

dev-util / desktop-file-utils : Command line utilities to work with desktop menu entries

x11-misc / shared-mime-info : The Shared MIME-info Database specification

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / QtPy : Abstraction layer on top of PyQt5 and PySide2 and additional custom QWidgets

dev-python / atomicwrites : Atomic file writes

dev-python / chardet : Universal encoding detector

dev-python / cloudpickle : Extended pickling support for Python objects

dev-python / diff-match-patch : Diff, match and patch algorithms for plain text

dev-python / intervaltree : Editable interval tree data structure for Python 2 and 3

dev-python / ipython : Advanced interactive shell for Python

dev-python / jsonschema : An implementation of JSON-Schema validation for Python

dev-python / keyring : Provides access to the system keyring service

dev-python / nbconvert : Converting Jupyter Notebooks

dev-python / numpydoc : Sphinx extension to support docstrings in Numpy format

dev-python / pexpect : Python module for spawning child apps and responding to expected patterns

dev-python / pickleshare : A small 'shelve' like datastore with concurrency support

dev-python / psutil : Retrieve information on running processes and system utilization

dev-python / pygments : Pygments is a syntax highlighting package written in Python

dev-python / pylint : Python code static checker

dev-python / pyls-spyder : Spyder extensions for the python language server

dev-python / python-lsp-black : Black plugin for the Python LSP Server

dev-python / pyxdg : A Python module to deal with freedesktop.org specifications

dev-python / pyzmq : Lightweight and super-fast messaging library built on top of the ZeroMQ library

dev-python / qdarkstyle : A dark style sheet for QtWidgets application

dev-python / qstylizer : Stylesheet Generator for PyQt5/PySide2

dev-python / qtawesome : Enables iconic fonts such as Font Awesome in PyQt

dev-python / qtconsole : Qt-based console for Jupyter with support for rich media output

dev-python / setuptools : Collection of extensions to Distutils

dev-python / sphinx : Python documentation generator

dev-python / spyder-kernels : Kernels used by spyder on its ipython console

dev-python / textdistance : Compute distance between the two texts

dev-python / three-merge : Simple Python library to perform a 3-way merge between strings

dev-python / watchdog : Python API and shell utilities to monitor file system events

dev-util / cookiecutter : Command-line utility to create projects from cookiecutters (project templates)

sci-libs / rtree : R-Tree spatial index for Python GIS

dev-python / spyder-line-profiler : Plugin to run the python line profiler from within the spyder editor

dev-python / spyder-memory-profiler : Plugin to run the python memory_profiler from within the spyder editor

dev-python / spyder-notebook : Jupyter notebook integration with Spyder

dev-python / spyder-terminal : Run system terminals inside Spyder

dev-python / spyder-unittest : Plugin for Spyder to run tests and view the results

dev-python / spyder-vim : Plugin for Spyder to enable Vim keybindings

791313
portage thinks dev-python/spyder does not exist
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: drop dep on <pytest-6.0
Closes: https://bugs.gentoo.org/816132 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: sed out indirect dependency on pylint
The incompatibility with pylint>2.10 is in python-lsp and not in spyder Closes: https://bugs.gentoo.org/815160 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: drop version 5.1.4
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: add version 5.1.5
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: drop version 5.1.3
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: add version 5.1.4
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: drop version 5.1.2
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: add version 5.1.3
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: drop version 5.1.1
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: add version 5.1.2
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: remove version 5.1.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: add version 5.1.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: add version 5.1.0
No keywords until https://github.com/spyder-ide/spyder/issues/16117 is resolved. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: do not depend on parso,jedi,pylsp
spyder does not use these directly, instead it imports pyls-spyder, which imports pylsp, which imports jedi, which imports parso. We remove the indirect dependencies here so we don't have to touch this ebuilds if e.g. pylsp becomes (in)compatible with a certain version of jedi. Instead we record this infomration in the downstream ebuilds where it belongs. This requires some sed magic to make sure spyder's dependency checks don't complain. This is intended to once and for all fix Bug 743466 and prevent the repeating issue of bugs such as Bug 803269 Closes: https://bugs.gentoo.org/803269 Bug: https://bugs.gentoo.org/743466 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: allow parso 0.7.1
Otherwise we get stuck in a dependency conflict with python_targets_python3_10 Closes: https://bugs.gentoo.org/743466 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: remove version 5.0.4
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: add version 5.0.5
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: switch pyls --> python-lsp-server
We are running into a dependency mess with pyls because it hasn't been updated for over 6 months. We can no longer wait for upstream to make the switch to their own fork of the project (though I still expect this soonish) Bug: https://bugs.gentoo.org/783618 Bug: https://bugs.gentoo.org/783615 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: drop version 5.0.3
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: add version 5.0.4
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: fix dep on rtree
Closes: https://bugs.gentoo.org/791316 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: add missing dep on rtree
temporary workaround allows use of older rtree versions until 3dprint project gives the OK to bump rtree to the correct version. Bug: https://bugs.gentoo.org/791316 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: remove reference to eslect-QtPy
This eselect modules is being last-rited, USE flags is the new way to toggle between pyside2/pyqt5 in dev-python/QtPy-1.9.0-r4. Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: cleanup old
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: drop 5.0.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: add version 5.0.3
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: add py3.9
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: drop 4.2.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: add 5.0.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Andreas Sturmlechner · gentoo
dev-python/spyder: Drop superfluous optfeature header
Fix indendation. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: remove 4.2.4
has a very annoying bug: custom layouts not working at all Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: version bump 4.2.5
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Joonas Niilola · gentoo
dev-python/spyder: drop 4.2.1
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Joonas Niilola · gentoo
Revert "dev-python/spyder: drop 4.2.0, 4.2.1"
This reverts commit b08df34fdcf01c8610373c52a8e77ac1b2e07990. Stable request, #722830 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Joonas Niilola · gentoo
dev-python/spyder: drop 4.2.0, 4.2.1
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: version bump 4.2.4
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: version bump 4.2.3
Yes, the exact dependencies on parso and jedi are still required Also added a note about the false positive warning shown in the pkg_postinst phase And a note on that spyder currently only works with PyQt5, and a matching dependency on PyQt5 and PyQtWebEngine Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: version bump 4.2.1
Closes: https://bugs.gentoo.org/755242 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/18724 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Joonas Niilola · gentoo
dev-python/spyder: false-positive with DISTUTILS_USE_SETUPTOOLS
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Joonas Niilola · gentoo
dev-python/spyder: DISTUTILS_USE_SETUPTOOLS=no
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Joonas Niilola · gentoo
dev-python/spyder: update eutils.eclass to optfeature.eclass
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: cleanup old
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: version bump 4.2.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/spyder: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
Move {sci-libs → dev-python}/scipy
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Joonas Niilola · gentoo
dev-python/spyder: fix indentation on 4.1.5
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
David Seifert · gentoo
dev-python/spyder: Inherit optfeature.eclass
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: version bump 4.1.5
latest stable release Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/17148 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/spyder: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: version bump
Closes: https://bugs.gentoo.org/722508 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/spyder: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: version bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: clean up old
Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/15313 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: version bump 4.1.2
Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Joonas Niilola · gentoo
dev-python/spyder: add missing die
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: clean up
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/15170 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: use sed instead of patch
trying to patch file with DOS EOL the patch got converted to UNIX EOL somehwere along the road and is not working Bug: https://bugs.gentoo.org/715148 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Joonas Niilola · gentoo
dev-python/spyder: revbump due to changed RDEPEND
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: allow newer parso versions
Closes: https://bugs.gentoo.org/715148 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/15149 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: version bump 4.1.1
Bug: https://bugs.gentoo.org/714760 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/15012 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrey Grozin · gentoo
dev-python/spyder: add version restrictions from dependencies.py
Closes: https://bugs.gentoo.org/show_bug.cgi?id=711024 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
dev-python/spyder: Clean up spyder-3.x.x versions
Bug: https://bugs.gentoo.org/709866 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Joonas Niilola · gentoo
dev-python/spyder: add symlink to spyder
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: Clean up 4.0.0_beta versions
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Andrew Ammerlaan · gentoo
dev-python/spyder: Version bump 4.0.1
Bug: https://bugs.gentoo.org/702458 Bug: https://bugs.gentoo.org/702768 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Clean PYTHON_COMPAT of obsolete impls
Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/spyder: Remove redundant version
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Michał Górny · gentoo
dev-python/spyder: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-python/spyder: avoid direct dependency on dev-python/PyQt5
That's why QtPy exists in the first place. It also fixes bug 689064. Closes: https://bugs.gentoo.org/689064 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-python/spyder: Drop py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrey Grozin · gentoo
dev-python/spyder: 4.0.0_beta1: depend on >=dev-python/jedi-0.11.0
Closes: https://bugs.gentoo.org/666655 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Andrey Grozin · gentoo
dev-python/spyder: bump to 4.0.0_beta1
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Andrey Grozin · gentoo
gentoo/dev-python/spyder: bump to 3.3.1
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Andrey Grozin · gentoo
dev-python/spyder: bump to 3.3.0
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Michael Mair-Keimberger · gentoo
dev-python/spyder: use HTTPS
Closes: https://github.com/gentoo/gentoo/pull/8165
Andrey Grozin · gentoo
dev-python/spyder: bump to 3.2.8 and support QtWebengine
Suggested-by: holgersson@posteo.de Package-Manager: Portage-2.3.19, Repoman-2.3.6
Mike Gilbert · gentoo
Replace pypi.python.org with pypi.org in HOMEPAGE
Bug: https://bugs.gentoo.org/653540
Michał Górny · gentoo
dev-python/spyder: Clean old up
Andrey Grozin · gentoo
dev-python/spyder: bump to 3.2.4
Closes: https://bugs.gentoo.org/637288 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Andrey Grozin · gentoo
dev-python/spyder: add a missing dependency
Bug: https://bugs.gentoo.org/613396 Package-Manager: Portage-2.3.6, Repoman-2.3.3
Andrey Grozin · gentoo
dev-python/spyder: cleaning old
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Andrey Grozin · gentoo
dev-python/spyder: bump to 3.2.3
Thanks to Roberto Castagnola <roberto.castagnola@gmail.com> Bug: https://bugs.gentoo.org/613396 Package-Manager: Portage-2.3.6, Repoman-2.3.3
Andreas Sturmlechner · gentoo
dev-python/spyder: Drop old
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Andreas Sturmlechner · gentoo
dev-python/spyder: Drop dev-python/{PyQt4,pyside} options
Gentoo-bug: 620822, 610100 Package-Manager: Portage-2.3.7, Repoman-2.3.3
Andreas Sturmlechner · gentoo
dev-python/spyder: Drop old
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Michał Górny · gentoo
dev-python/spyder: Clean old versions up
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Andrey Grozin · gentoo
dev-python/spyder: install spyder2 and spyder3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Andrey Grozin · gentoo
dev-python/spyder: bump to 3.0.2
Bug: 602242 Package-Manager: portage-2.3.3
Michał Górny · gentoo
global: Drop dead implementations from PYTHON_COMPAT
Andrey Grozin · gentoo
dev-python/spyder: bump to 2.3.9
Bug: 586340 Package-Manager: portage-2.3.0_rc1
Andrey Grozin · gentoo
dev-python/spyder: inherit eutils in spyder-2.3.8.ebuild
Package-Manager: portage-2.2.27
Patrice Clement · gentoo
dev-python/spyder: Following EAPI 6 bump, convert patch to p1 format.
With the EAPI 6, patches must be p1 compliant. So let's make Portage happy and comply with the new rule. Package-Manager: portage-2.2.26
Patrice Clement · gentoo
dev-python/spyder: Make use of variables wherever possible.
Package-Manager: portage-2.2.26
Patrice Clement · gentoo
dev-python/spyder: Fix Copyright year.
Package-Manager: portage-2.2.26
Patrice Clement · gentoo
Merge github#881: dev-python/spyder: Version bump.
Pull-Request: https://github.com/gentoo/gentoo/pull/881 Reporter: T. Malfatti <malfatti@gmx.com> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
T. Malfatti · gentoo
dev-python/spyder: Add spyder-2.3.8 ebuild
Justin Lecher · gentoo
Enable https for all google URIs
Signed-off-by: Justin Lecher <jlec@gentoo.org>
Robin H. Johnson · gentoo
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed