dev-python / xdis

Python cross-version byte-code disassembler and marshal routines

Official package sites : https://github.com/rocky/python-xdis/ · https://pypi.org/project/xdis/ ·

This Python module allows you to disassemble bytecode from different versions of Python than you are running on. It can marshal load Python bytecodes from different versions of Python. The command-line routine pydisasm will show disassembly output using Python 3.5 disassembly conventions

v3.6.0 :: 0 :: gentoo

Modified
License
GPL-2
Keywords
~amd64 ~x86
USE flags
test

v3.3.1 :: 0 :: gentoo

Modified
License
GPL-2
Keywords
~amd64 ~x86
USE flags
test

General

test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

pypy
Build with PyPy
python2_7
Build with Python 2.7
python3_5
Build with Python 3.5
python3_6
Build with Python 3.6

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / mock : Rolling backport of unittest.mock for all Pythons

dev-python / nose : Unittest extension with automatic test suite discovery and easy test authoring

dev-python / pytest : Simple powerful testing with Python

dev-python / setuptools : Collection of extensions to Distutils

virtual / pypy : A virtual for PyPy Python implementation

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / click : A Python package for creating beautiful command line interfaces

dev-python / six : Python 2 and 3 compatibility library

virtual / pypy : A virtual for PyPy Python implementation

dev-python / uncompyle6 : Python cross-version byte-code deparser

637372
dev-python/xdis-3.6.0 : [TEST] E AssertionError: version 2.7.14 is not in magic.magics.keys: [ 3.000+3 , 3.000+2 , 3.000+1 , 3.000+7 , 3.000+6 , 3.000+5 , 3.000+4 , 2.7.1b3Jython , 3.000+9 , 3.000+8 , 3.1a0+ , 3.7.0alpha0 , 3.000 ,
643694
dev-python/uncompyle6: depends on old version of dev-python/xdis
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Michael Mair-Keimberger · gentoo
update pypi HOMEPAGE to avoid redirection
Closes: https://github.com/gentoo/gentoo/pull/8080
Mike Gilbert · gentoo
Replace pypi.python.org with pypi.org in HOMEPAGE
Bug: https://bugs.gentoo.org/653540
Michał Górny · gentoo
dev-python/xdis: Clean old up
Brian Dolbec · gentoo
dev-python/xdis: Version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Brian Dolbec · gentoo
dev-python/xdis: Fix bug 596510 xdis-3.3.1
Apply xdis-3.3.0-remove-pytest-runner-dep.patch as it is not required for install nor for tests. Package-Manager: Portage-2.3.6, Repoman-2.3.3
Brian Dolbec · gentoo
dev-python/xdis: Version bump
Package-Manager: Portage-2.3.6_p2, Repoman-2.3.2_p70
Brian Dolbec · gentoo
dev-python/xdis: Version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30
Brian Dolbec · gentoo
dev-python/xdis: Version bump, remove older versions not compatible with python-3.5.3
Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Brian Dolbec · gentoo
dev-python/xdis: Version bump, license change
Package-Manager: Portage-2.3.3_p7, Repoman-2.3.1
Brian Dolbec · gentoo
dev-python/xdis: Version bump
Package-Manager: portage-2.3.2_p3
Brian Dolbec · gentoo
dev-python/xdis: Fix setup.py unconditional test dep bug 596510
Fix metadata.py pypi id Package-Manager: portage-2.3.2_p3
Michał Górny · gentoo
global: Drop dead implementations from PYTHON_COMPAT
Brian Dolbec · gentoo
dev-python/xdis: New package, dep of dev-python/uncompyle6
Package-Manager: portage-2.3.1_p8