dev-qt / qt-creator

Lightweight IDE for C++/QML development centering around Qt

Official package sites : https://www.qt.io/product/development-tools ·

v9999 :: 0 :: gentoo

Modified
License
GPL-3
USE flags
clang designer doc help qmldesigner serialterminal svg test tracing webengine

v12.0.2 :: 0 :: gentoo

Modified
License
GPL-3
Keywords
amd64
USE flags
clang designer doc help qmldesigner serialterminal svg test tracing webengine

v12.0.1 :: 0 :: gentoo

Modified
License
GPL-3
Keywords
amd64
USE flags
clang designer doc help qmldesigner serialterminal svg test tracing webengine

General

clang
Build clang-based plugins for C/C++ development (code model, formatting, static analysis)
designer
Enable designer for QtWidgets-based UIs
designer
Enable designer for QtWidgets-based UIs
doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
help
Enable the integrated dev-qt/qt-docs viewer (also needed for examples)
qmldesigner
Build QmlDesigner and related plugins (Insight, StudioWelcome)
serialterminal
Build the serial terminal plugin
svg
Add support for SVG (Scalable Vector Graphics)
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)
tracing
Build plugins requiring tracing capabilities (CtfVisualizer, PerfProfiler, QmlProfiler)
webengine
Use dev-qt/qtwebengine with the help USE rather than bundled litehtml

llvm_slot

15
Use LLVM 15.
16
Use LLVM 16.
17
Use LLVM 17.
18
Use LLVM 18.

app-arch / zstd : zstd fast compression library

dev-cpp / yaml-cpp : YAML parser and emitter in C++

dev-libs / elfutils : Libraries/utilities to handle ELF objects (drop in replacement for libelf)

dev-qt / qt5compat : Qt module containing the unsupported Qt 5 APIs

dev-qt / qtbase : Cross-platform application development framework

dev-qt / qtdeclarative : Qt Declarative (Quick 2)

dev-qt / qtquick3d : Qt module and API for defining 3D content in Qt QuickTools

dev-qt / qtserialport : Serial port abstraction library for the Qt6 framework

dev-qt / qtshadertools : Qt APIs and Tools for Graphics Pipelines

dev-qt / qtsvg : SVG rendering library for the Qt6 framework

dev-qt / qttools : Qt Tools Collection

dev-qt / qtwebengine : Library for rendering dynamic web content in Qt6 C++ and QML applications

sys-devel / clang : C language family frontend for LLVM

app-arch / zstd : zstd fast compression library

dev-cpp / yaml-cpp : YAML parser and emitter in C++

dev-libs / elfutils : Libraries/utilities to handle ELF objects (drop in replacement for libelf)

dev-qt / qt5compat : Qt module containing the unsupported Qt 5 APIs

dev-qt / qtbase : Cross-platform application development framework

dev-qt / qtdeclarative : Qt Declarative (Quick 2)

dev-qt / qtimageformats : Additional format plugins for the Qt image I/O system

dev-qt / qtquick3d : Qt module and API for defining 3D content in Qt QuickTools

dev-qt / qtquicktimeline : Qt module for keyframe-based timeline construction

dev-qt / qtserialport : Serial port abstraction library for the Qt6 framework

dev-qt / qtshadertools : Qt APIs and Tools for Graphics Pipelines

dev-qt / qtsvg : SVG rendering library for the Qt6 framework

dev-qt / qttools : Qt Tools Collection

dev-qt / qtwebengine : Library for rendering dynamic web content in Qt6 C++ and QML applications

sys-devel / clang : C language family frontend for LLVM

586252
sys-apps/portage: confusing USE=bindist slot conflict triggered by dev-qt/qt-creator dependency on dev-libs/botan[-bindist]
915870
dev-qt/qt-creator-11.0.3 fails tests (segfault)
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qt-creator: Stabilize 12.0.2 amd64, #925703
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: disable designer by default in live
This been set by default in the old ebuilds and opted to leave it like that but, with Qt6 and the non-split qttools where designer is off by default, this been annoying for users. Default designer on qttools when most users don't need it does not seem like the right move -- and believe users that actually want this will know to set it themselves (perhaps even globally). Not that I'm either a qt-creator nor designer user (just maintaining regardless), so opinions from actual users for defaults are welcome. (live-only to avoid long rebuilds, will propagate in next version) Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: use := to match upcoming llvm-r1 changes
Currently ommited in the llvm-r1 example, but that's being changed and >=llvm-18.1.0_rc3 will use $(ver_cut 1-2) as subslot. No need for a revbump (slot 18 is still masked either way). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: sync 12.0.2 with live for llvm-r1
Done together with the Qt6.6.2 bump which is going to trigger a rebuild either way. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qt-creator: migrate live to llvm-r1, allow slot 18
Tested with 18.1.0_rc2 at same time, seems to be fine so may as well do this now. Will migrate 12.0.2 when add Qt6.6.2 given that will trigger a rebuild either way. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: add 12.0.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
Move {dev-util → dev-build}/cmake
Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/34792 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
Move {dev-util → dev-build}/meson
Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/34790 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Michał Górny · gentoo
Move {dev-util → dev-debug}/valgrind
Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/34786 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qt-creator: Stabilize 12.0.1 amd64, #921646
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: drop 12.0.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: add 12.0.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qt-creator: drop 11.0.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: add 12.0.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: re-add cvs to live readme
Didn't mean to push that bit, it is now disabled by default in qt-creator-12, but it is not *gone*. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: update live
Not much to update, but next release is close and checking state. Tests pass except tst_utils_deviceshell which is failing in upstream's CI as well (unless QTC_USE_QPROCESS=false). The change causing this is not included in 12.0.0rc1 though, so not going to worry about it. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: set llvm_check_deps
Forgot, albeit typically not an issue unless someone has an extra llvm slot without clang. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: drop 11.0.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: add 11.0.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: adjust Android support deps in README
I find dev-util/android-sdk-update-manager just confusing unless *really* want to set this up for system-wide availability. Qt Creator has a button to handle everything and open the sdk manager. Feel it is better to remove than suggest it (not to mention that the package is mostly unmaintained in Gentoo and not planning to pick it up). On the other hand, jdk is required and it is simpler to use system's (can be finnicky but is typically is autodetected). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: remove qt653 patch from live
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qt-creator: fix build with yaml-cpp-0.8
Closes: https://bugs.gentoo.org/914732 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: drop 8.0.2
With llvm-17.0.1 being released, keeping a -14 ebuild around is a stretch and would be surprised if someone still relied on this old ebuild. So let's just drop it now. This loses keywords for arm and x86. As noted in bug #905166, currently no intention to restore these unless someone actually wants and requests it. Closes: https://bugs.gentoo.org/905166 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qt-creator: add live ebuild
Mostly the same as 11.0.2 bare no longer any unexpected test failures, minor adjustments due to newer litehtml, and allowing clang-17. May still be more that need changes but will give it a closer look on release unless something comes up first. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qt-creator: add 11.0.2
Not going to list every changes given this ebuild is from scratch. There are a few ebuilds for this going around, but they about all have (IMO) overcustomization, with a lot of USE to juggle for both users and maintainers (some handled through sed'ing cmake files) -- all while plugins can still be disabled at runtime either way. So this is now mostly limited to options that introduce an extra dependency (e.g. clang). "Some" of the longest to build plugins do have dependencies, so this still allows to cut down build time a decent amount (not that this is a short build still). Other small notes: * Default IUSEs match what Qt Creator enables by default at runtime (albeit default USE=-tracing could be interesting for faster builds). * Left gumbo unbundling out for now given ultimate goal is to unbundle litehtml instead (which itself uses gumbo), but currently it requires a large patch for 0.8 support (likewise to unbundle on qttools). wrt bug #905166, delaying cleanup given restoring keywords is non-trivial and users may need time to adjust for Qt5->Qt6, but can be dropped anytime anyway if llvm:14 cleanup is happening (do not consider this a blocker). Bug: https://bugs.gentoo.org/905166 Closes: https://bugs.gentoo.org/835042 Closes: https://bugs.gentoo.org/905417 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Peter Levine · gentoo
dev-qt/qt-creator: call xdg_pkg_postinst
xdg_pkg_postinst needs to be explicitly called since we define our own pkg_postinst. Closes: https://bugs.gentoo.org/879887 Signed-off-by: Peter Levine <plevine457@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28149 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Peter Levine · gentoo
dev-qt/qt-creator: fix unnecessary dependence on dev-cpp/yaml-cpp
Including the clangtools plugin's CMakeLists.txt causes an unconditional dependence on dev-cpp/yaml-cpp, whether or not the plugin is enabled. Removing 'add_subdirectory(clangtools)' from the parent directory's CMakeLists.txt when the clangtools USE flag is disabled resolves it. Bug: https://bugs.gentoo.org/878753 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: drop 8.0.1
Signed-off-by: Peter Levine <plevine457@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28047 Signed-off-by: Sam James <sam@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: add 8.0.2
Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: fix pkgconfig bdep
virtual/pkgconfig should be included as a build dependency if building without qtwebengine support. Also, such a dep should be explicitly searched for by cmake with the 'find_package' command. Closes: https://bugs.gentoo.org/878753 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Peter Levine · gentoo
dev-qt/qt-creator: drop 6.0.0 and 9999
6.0.0 is shadowed by 8.0.1 and 9999 requires QT6. Closes: https://github.com/gentoo/gentoo/pull/26675 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: add 8.0.1
Switched from the qmake to cmake buildsystem. Added support for the Coco code coverage tool. The 'git' USE flag now also builds the gitlab plugin. The 'wayland' flag was added to enforce built-with-use dependency. 'imageviewer' flag is added for conditional dependence on dev-qt/qtsvg. clangd functionality now depends on >=clang-14.*. Bug: https://bugs.gentoo.org/828071 Bug: https://bugs.gentoo.org/846947 Closes: https://bugs.gentoo.org/876169 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: drop old 4.15.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: bump to 6.0.0
Closes: https://bugs.gentoo.org/807580 Closes: https://bugs.gentoo.org/801922 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: enable a couple more USE flags by default
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: add USE flag to disable the qmake project manager
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: various test fixes
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: clangcodemodel plugin requires USE=lsp
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: merge qmldesigner and qmljs USE flags
And also put qmlpreview and qmlprojectmanager behind the new flag Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: always build clangsupport and sqlite internal libs
The CppEditor plugin, which is pretty fundamental, depends on them. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: drop RDEPEND on build tools
They are used as development tools in this context, and the user/developer may want to use different versions from those available via portage. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: add USE 'conan' and 'docker'
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: add 'meson' USE flag
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: add 'incredibuild' USE flag
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: allow clang 13
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: require syntax-highlighting >= 5.87
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: clang{refactoring,pchmanager} are completely gone
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: USE=android requires lsp
Closes: https://bugs.gentoo.org/802372 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Kritzmensch · gentoo
dev-qt/qt-creator: add 'baremetal' as a required dep for 'mcu'
Bug: https://bugs.gentoo.org/802372 Closes: https://github.com/gentoo/gentoo/pull/23019 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: remove half-broken 4.12.3-r1
Bug: https://bugs.gentoo.org/757756 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Hans Fredrik Nordhaug · gentoo
dev-qt/qt-creator: add 4.15.1
Closes: https://bugs.gentoo.org/721720 Closes: https://bugs.gentoo.org/750527 Closes: https://github.com/gentoo/gentoo/pull/21278 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans Fredrik Nordhaug <hansfn@gmail.com> Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: sync KEYWORDS
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: add hr translation
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: require clang 11 or 12
Upstream recommends 11 or later Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Hans Fredrik Nordhaug · gentoo
dev-qt/qt-creator: adjust sed
https://github.com/gentoo/gentoo/pull/21278 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Hans Fredrik Nordhaug · gentoo
dev-qt/qt-creator: drop obsolete patch
https://github.com/gentoo/gentoo/pull/21278 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Hans Fredrik Nordhaug · gentoo
dev-qt/qt-creator: drop obsolete dep on dev-libs/libclangformat-ide
https://github.com/gentoo/gentoo/pull/21278 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qt-creator: sys-devel/gdb[client] is gone
It's now always on. Fixes: 2aa76f92308d2b745bf47b9ca94937f125301691 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qt-creator: Drop 4.8.2, destabilising package
This also leaves dev-util/qbs without any stable revdep so could be cleaned up. Bug: https://bugs.gentoo.org/720240 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-qt/qt-creator: Remove redundant ver (LLVM 8)
Bug: https://bugs.gentoo.org/720240 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qt-creator: arm keyworded (bug #729580)
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: we need cmake >= 3.14
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: disable clangpchmanager and clangrefactoring
Upstream considers them "too unstable even for experimental status" https://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=8dff37f0d3ebcae0aa4f4839165fb70fa9cd965c Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: add USE=qmljs
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: skip building two more support libs if not used
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: yaml-cpp is required only with USE=clang
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: drop ios and winrt USE flags
These two plugins cannot effectively be used on linux Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: stop enabling USE=webengine by default
QtWebEngine is a very large dependency and the built-in backends (litehtml and QTextBrowser) are normally enough. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: the qbs plugin no longer links to libqbscore
https://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=6913947986a1aebeb9eba6212ef270c31de28af8 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: restore the autotools plugin
Not sure why it was dropped in the 4.10.0_rc1 version bump Bug: https://bugs.gentoo.org/721720 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: Qt 5.14 is now required
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: re-introduce bazaar USE flag
Handle it like clearcase and perforce. Amends commit 045077ec0296e1508b28da617c6fab978620714d, which ended up always *enabling* the plugin instead of disabling it. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jason A. Donenfeld · gentoo
dev-qt/qt-creator: bump to 4.12.3
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Jason A. Donenfeld · gentoo
dev-qt/qt-creator: rollback change to apply Peter's work
This reverts commit b5b9383e897b618372ae474fedb68517738a0d04. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jason A. Donenfeld · gentoo
dev-qt/qt-creator: build with clang 10 and bump to 4.12.3
Closes: https://bugs.gentoo.org/723644 Closes: https://bugs.gentoo.org/722306 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: Drop qt-creator-4.12.0
Buggy ebuild and superseded by 4.12.2. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: Remove sys-devel/clang:8 dependency
Prepare for eventual removal of sys-devel/clang:8 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: Add bdeps
pkgconfig, qdoc, and binaries from linguist-tools need to execute at build time. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: rm fixups
Don't use -f. If it fails, we likely want to know. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: Build against dev-libs/libclangformat-ide
Build against a patched libclangFormat in the correct slot for a fully functional clangformat plugin. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: Pass the correct clang stot
Add llvm_check_deps to check for the right clang slot. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: Add dev-qt/qtquicktimeline to rdeps
qmldesigner and studiowelcome both have qmls which import QtQuick.Timeline. If not available at runtime, stderr prints 'module "QtQuick.Timeline" is not installed"'. When installed, all is well and studiowelcome, if enabled, shows a nice animated splash. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: Bump qt-creator-4.12.2
Bug: https://bugs.gentoo.org/700142 Closes: https://github.com/gentoo/gentoo/pull/15711 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: Unbundle yaml-cpp
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: Unbundle KSyntaxHighlighting
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Peter Levine · gentoo
dev-qt/qt-creator: Support clang-10
Builds and runs without issue using patch from https://codereview.qt-project.org/c/qt-creator/qt-creator/+/299377 Closes: https://bugs.gentoo.org/720240 Closes: https://bugs.gentoo.org/711788 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jason A. Donenfeld · gentoo
dev-qt/qt-creator: bump to 4.12.0
Closes: https://bugs.gentoo.org/704540 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-qt/qt-creator: remove bazaar references
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: remove 4.10.0_rc1
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: add mcu and webassembly plugins in 9999
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: fix USE=python
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: add 4.10.1
Closes: https://bugs.gentoo.org/695274 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/qt-creator: add plugins/fix build for 9999
New plugins Boot2Qt [1] and Chrome Trace Format Visualizer [2]. 1. https://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=5942b824 2. https://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=7fec4182 Reported-by: Manuel Nickschas <sputnick@quassel-irc.org> Closes: https://github.com/gentoo/gentoo/pull/13036 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: add 4.10.0_rc1
Closes: https://bugs.gentoo.org/683390 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: in 4.8.2, restrict botan dep due to bug 689346
Closes: https://bugs.gentoo.org/689346 Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: botan dep was dropped in 4.9 and later
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: remove old
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qt-creator: stabilize 4.8.2 on amd64
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: add 4.8.2
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: fix qbs dependency
Closes: https://bugs.gentoo.org/685444 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qt-creator: Demand new qml USEdep from qtxmlpatterns
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qt-creator: Add dev-qt/qtxmlpatterns alternative test DEPEND
In Qt 5.12, xmllistmodel moved from qtdeclarative[xml] into qtxmlpatterns. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: several test fixes
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: in 4.6.2, restrict qbs dep to ~1.11.1
Closes: https://bugs.gentoo.org/661644 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: add 4.8.0
* new plugins: cppcheck, LSP client, silver searcher, serial terminal * make help plugin (and its qthelp dependency) optional * unify all clang-based plugins under USE=clang * enable clang and designer USE flags by default * disable updateinfo plugin Closes: https://bugs.gentoo.org/661646 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: stabilize 4.6.2 on amd64
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Davide Pesavento · gentoo
dev-qt/qt-creator: remove old
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Davide Pesavento · gentoo
dev-qt/qt-creator: add 4.6.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Davide Pesavento · gentoo
dev-qt/qt-creator: raise clang dependency
http://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=319daa2612dcdd205e271cf2b4b5bf4532fad163 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Davide Pesavento · gentoo
dev-qt/qt-creator: fix build with USE=-clangcodemodel
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Davide Pesavento · gentoo
dev-qt/qt-creator: remove 4.6.0_rc1
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Davide Pesavento · gentoo
dev-qt/qt-creator: in 4.5.2, pin qbs dep to =1.10.1*
Closes: https://bugs.gentoo.org/655784 Package-Manager: Portage-2.3.38, Repoman-2.3.9
Jimi Huotari · gentoo
dev-qt/qt-creator: Fix sed in src_prepare()
We disable unreliable tests by using sed magic, and one of the files (and directories) related to this was renamed from 'timeline' to 'tracing'. http://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=734611131dc20283b118353130bdd5e16ce0aeaf Closes: https://github.com/gentoo/gentoo/pull/8454 Package-Manager: Portage-2.3.38, Repoman-2.3.9
Asgeir Bjarni Ingvarsson · gentoo
dev-qt/qt-creator: version bump to 4.6.1
Closes: https://bugs.gentoo.org/651960 Closes: https://github.com/gentoo/gentoo/pull/8257 Package-Manager: Portage-2.3.38, Repoman-2.3.9
Davide Pesavento · gentoo
dev-qt/qt-creator: remove old
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Davide Pesavento · gentoo
dev-qt/qt-creator: stabilize 4.5.2 on amd64
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Davide Pesavento · gentoo
dev-qt/qt-creator: fix sed
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Davide Pesavento · gentoo
dev-qt/qt-creator: raise qt deps in live ebuild
See https://codereview.qt-project.org/223368 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Davide Pesavento · gentoo
dev-qt/qt-creator: bump to 4.6.0_rc1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Davide Pesavento · gentoo
dev-qt/qt-creator: add 4.5.2
Closes: https://bugs.gentoo.org/650510 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jason A. Donenfeld · gentoo
dev-qt/qt-creator: add unkeyworded beta
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jason A. Donenfeld · gentoo
dev-qt/qt-creator: version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Davide Pesavento · gentoo
dev-qt/qt-creator: remove 4.3.1
x86 is demoted to ~arch Package-Manager: Portage-2.3.20, Repoman-2.3.6
Davide Pesavento · gentoo
dev-qt/qt-creator: stabilize 4.4.1 on amd64
Bug: https://bugs.gentoo.org/644948 Package-Manager: Portage-2.3.20, Repoman-2.3.6
Ulrich Müller · gentoo
dev-qt/qt-creator: Migrate from LINGUAS to L10N.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Davide Pesavento · gentoo
dev-qt/qt-creator: restrict max clang version
Closes: https://bugs.gentoo.org/631194 Package-Manager: Portage-2.3.11, Repoman-2.3.3
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump
Closes: https://bugs.gentoo.org/630870 Package-Manager: Portage-2.3.11, Repoman-2.3.3
Davide Pesavento · gentoo
dev-qt/qt-creator: remove old
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Davide Pesavento · gentoo
dev-qt/qt-creator: stabilize 4.3.1 on amd64 and x86
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Davide Pesavento · gentoo
dev-qt/qt-creator: drop insecure git:// repo URI
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Davide Pesavento · gentoo
dev-qt/qt-creator: raise qbs dep
Gentoo-Bug: 625640 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Davide Pesavento · gentoo
dev-qt/qt-creator: remove old
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Michael Palimaka · gentoo
dev-qt/qt-creator: use HTTPS
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Davide Pesavento · gentoo
dev-qt/qt-creator: remove old
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Davide Pesavento · gentoo
dev-qt/qt-creator: fix bug 617728
Gentoo-Bug: 617728 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump
Also fixed bug 616876. Package-Manager: Portage-2.3.6, Repoman-2.3.2
Davide Pesavento · gentoo
dev-qt/qt-creator: sync live ebuild
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Davide Pesavento · gentoo
dev-qt/qt-creator: fix path to some clang headers
Gentoo-Bug: 614872 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Davide Pesavento · gentoo
dev-qt/qt-creator: gdb is a runtime dep only
Also move all PDEPENDs to RDEPEND, there's no reason they have to be in PDEPEND. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Davide Pesavento · gentoo
dev-qt/qt-creator: use llvm.eclass
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Davide Pesavento · gentoo
dev-qt/qt-creator: query llvm-config instead of hardcoding the path
Fixes build against clang-4.0 Gentoo-Bug: 612634 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Davide Pesavento · gentoo
dev-qt/qt-creator: remove old
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Davide Pesavento · gentoo
dev-qt/qt-creator: restrict dep on qbs
Build fails against the newly released qbs-1.7.0 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump
Gentoo-Bug: 592148 Gentoo-Bug: 596178 Package-Manager: portage-2.3.2
Davide Pesavento · gentoo
dev-qt/qt-creator: restrict dep on qbs to avoid build failures
Gentoo-Bug: 594256 Package-Manager: portage-2.3.2
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump
Package-Manager: portage-2.3.0
Davide Pesavento · gentoo
dev-qt/qt-creator: update build requirements for 9999
http://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=7812390b0bdb31aec113fef317e4e83c4f822872 Package-Manager: portage-2.3.0
Davide Pesavento · gentoo
dev-qt/qt-creator: remove ancient versions (finally)
Package-Manager: portage-2.3.0_rc1
Michael Palimaka · gentoo
dev-qt/qt-creator: amd64/x86 stable
Gentoo-bug: 581878 Package-Manager: portage-2.3.0_rc1
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump
Package-Manager: portage-2.3.0_rc1
Davide Pesavento · gentoo
dev-qt/qt-creator: raise qbs dependency
Package-Manager: portage-2.3.0_rc1
Davide Pesavento · gentoo
dev-qt/qt-creator: remove old
Package-Manager: portage-2.3.0_rc1
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump
Package-Manager: portage-2.3.0_rc1
Davide Pesavento · gentoo
dev-qt/qt-creator: add live ebuild
Package-Manager: portage-2.2.28
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump
Package-Manager: portage-2.2.28
Davide Pesavento · gentoo
dev-qt/qt-creator: allow newer versions of clang
Package-Manager: portage-2.2.28
Davide Pesavento · gentoo
dev-qt/qt-creator: drop old version that won't be stabilized
Package-Manager: portage-2.2.28
Davide Pesavento · gentoo
dev-qt/qt-creator: block dev-util/qbs for now
This is only temporary until we can unbundle it again. Gentoo-Bug: 580880 Package-Manager: portage-2.2.28
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump
Package-Manager: portage-2.2.28
Davide Pesavento · gentoo
dev-qt/qt-creator: restrict clang dep to 3.6.x only
Later versions don't work correctly. Package-Manager: portage-2.2.28
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump
Package-Manager: portage-2.2.28
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump, EAPI=6
Package-Manager: portage-2.2.26
Davide Pesavento · gentoo
dev-qt/qt-creator: promote 3.4.2 to stable on amd64
Gentoo-Bug: 562834 Package-Manager: portage-2.2.23
Davide Pesavento · gentoo
dev-qt/qt-creator: apply patches
Package-Manager: portage-2.2.23
Davide Pesavento · gentoo
dev-qt/qt-creator: remove old
Package-Manager: portage-2.2.23
Davide Pesavento · gentoo
dev-qt/qt-creator: bump to 3.5.1
Fixed also bug 560398 and 563312 Package-Manager: portage-2.2.23
Davide Pesavento · gentoo
dev-qt/qt-creator: raise clang dependency
Gentoo-Bug: 560398 Package-Manager: portage-2.2.20.1
Davide Pesavento · gentoo
dev-qt/qt-creator: fix bug 560394
USE=bindist on botan disables ECDSA support, but ECDSA is required by QtCreator's internal SSH implementation since version 3.5.0. Package-Manager: portage-2.2.20.1
Davide Pesavento · gentoo
dev-qt/qt-creator: version bump
Package-Manager: portage-2.2.20.1
Robin H. Johnson · gentoo
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed