dev-qt / qtwebengine

Library for rendering dynamic web content in Qt6 C++ and QML applications

Official package sites : https://www.qt.io/ ·

v6.9999 :: 6/6.9999 :: gentoo

Modified
License
|| ( GPL-2 GPL-3 LGPL-3 ) FDL-1.3
USE flags
alsa bindist custom-cflags designer geolocation jumbo-build kerberos opengl pdfium pulseaudio qml screencast system-icu test vaapi vulkan widgets

v6.7.9999 :: 6/6.7.9999 :: gentoo

Modified
License
|| ( GPL-2 GPL-3 LGPL-3 ) FDL-1.3
USE flags
alsa bindist custom-cflags designer geolocation jumbo-build kerberos opengl pdfium pulseaudio qml screencast system-icu test vaapi vulkan widgets

v6.6.9999 :: 6/6.6.9999 :: gentoo

Modified
License
|| ( GPL-2 GPL-3 LGPL-3 ) FDL-1.3
USE flags
alsa bindist custom-cflags designer geolocation jumbo-build kerberos opengl pdfium pulseaudio qml screencast system-icu test vaapi vulkan widgets

v6.6.2 :: 6/6.6.2 :: gentoo

Modified
License
|| ( GPL-2 GPL-3 LGPL-3 ) FDL-1.3
Keywords
amd64 ~arm64
USE flags
alsa bindist custom-cflags designer geolocation jumbo-build kerberos opengl pdfium pulseaudio qml screencast system-icu test vaapi vulkan widgets

v5.15.12_p20240122 :: 5/5.15 :: gentoo

Modified
License
|| ( GPL-2 GPL-3 LGPL-3 ) FDL-1.3
Keywords
amd64 arm64 ~arm ~ppc64 ~x86
USE flags
alsa bindist debug designer geolocation jumbo-build kerberos pulseaudio screencast system-icu test widgets

General

alsa
Add support for media-libs/alsa-lib (Advanced Linux Sound Architecture)
alsa
Add support for media-libs/alsa-lib (Advanced Linux Sound Architecture)
bindist
Flag to enable or disable options for prebuilt (GRP) packages (eg. due to licensing issues)
custom-cflags
Build with user-specified CFLAGS (unsupported)
debug
Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
designer
Install the QWebEngineView plugin used to add widgets in dev-qt/designer forms that display web pages.
geolocation
Enable physical position determination
jumbo-build
Combine source files to speed up build process.
kerberos
Add kerberos support
opengl
Add support for OpenGL (3D graphics)
pdfium
Build the QtPdf module based on chromium's PDFium library
pulseaudio
Add sound server support via media-libs/libpulse (may be PulseAudio or PipeWire)
qml
Build QML/QtQuick bindings and imports
screencast
Enable support for remote desktop and screen cast using PipeWire
system-icu
Use the system-wide dev-libs/icu instead of bundled.
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)
vaapi
Enable Video Acceleration API for hardware decoding
vulkan
Add support for 3D graphics and computing via the Vulkan cross-platform API
widgets
Enable QtWidgets support
widgets
Enable QtWidgets support

app-arch / snappy : A high-speed compression/decompression library by Google

app-text / poppler : PDF rendering library based on the xpdf-3.0 code base

dev-libs / expat : Stream-oriented XML parser library

dev-libs / glib : The GLib library of C routines

dev-libs / icu : International Components for Unicode

dev-libs / libevent : Library to execute a function when a specific event occurs on a file descriptor

dev-libs / libxml2 : XML C parser and toolkit

dev-libs / libxslt : XSLT libraries and tools

dev-libs / nspr : Netscape Portable Runtime

dev-libs / nss : Mozilla's Network Security Services library that implements PKI support

dev-libs / re2 : An efficient, principled regular expression library

dev-qt / designer : WYSIWYG tool for designing and building graphical user interfaces with QtWidgets

dev-qt / qtbase : Cross-platform application development framework

dev-qt / qtcore : Cross-platform application development framework

dev-qt / qtdeclarative : Qt Declarative (Quick 2)

dev-qt / qtgui : The GUI module and platform plugins for the Qt5 framework

dev-qt / qtnetwork : Network abstraction library for the Qt5 framework

dev-qt / qtpositioning : Physical position determination library for the Qt6 framework

dev-qt / qtprintsupport : Printing support library for the Qt5 framework

dev-qt / qttest : Unit testing library for the Qt5 framework

dev-qt / qttools : Qt Tools Collection

dev-qt / qtwebchannel : Qt WebChannel

dev-qt / qtwidgets : Set of components for creating classic desktop-style UIs for the Qt5 framework

dev-util / vulkan-headers : Vulkan Header files and API registry

media-libs / alsa-lib : Advanced Linux Sound Architecture Library

media-libs / fontconfig : A library for configuring and customizing font access

media-libs / freetype : High-quality and portable font engine

media-libs / harfbuzz : An OpenType text shaping engine

media-libs / lcms : A lightweight, speed optimized color management engine

media-libs / libepoxy : Library for handling OpenGL function pointer management

media-libs / libglvnd : The GL Vendor-Neutral Dispatch library

media-libs / libjpeg-turbo : MMX, SSE, and SSE2 SIMD accelerated JPEG library

media-libs / libpng : Portable Network Graphics library

media-libs / libpulse : Libraries for PulseAudio clients

media-libs / libva : Video Acceleration (VA) API for Linux

media-libs / libvpx : WebM VP8 and VP9 Codec SDK

media-libs / libwebp : A lossy image compression format

media-libs / mesa : OpenGL-like graphic library for Linux

media-libs / openjpeg : Open-source JPEG 2000 library

media-libs / opus : Open codec for interactive speech and music transmission over the Internet

media-libs / tiff : Tag Image File Format (TIFF) library

media-video / pipewire : Multimedia processing graphs

net-print / cups : The Common Unix Printing System

sys-apps / dbus : A message bus system, a simple way for applications to talk to each other

sys-apps / pciutils : Various utilities dealing with the PCI bus

sys-libs / zlib : Standard (de)compression library

virtual / krb5 : Virtual for Kerberos V implementation

virtual / libudev : Virtual for libudev providers

x11-base / xorg-proto : X.Org combined protocol headers

x11-libs / libX11 : X.Org X11 library

x11-libs / libXScrnSaver : X.Org XScrnSaver library

x11-libs / libXcomposite : X.Org Xcomposite library

x11-libs / libXcursor : X.Org Xcursor library

x11-libs / libXdamage : X.Org Xdamage library

x11-libs / libXext : X.Org Xext library

x11-libs / libXfixes : X.Org Xfixes library

x11-libs / libXi : X.Org Xi library

x11-libs / libXrandr : X.Org Xrandr library

x11-libs / libXrender : X.Org Xrender library

x11-libs / libXtst : X.Org Xlib-based client API for the XTEST & RECORD extensions library

x11-libs / libdrm : X.Org libdrm library

x11-libs / libxcb : X C-language Bindings library

x11-libs / libxkbcommon : Keymap handling library for toolkits and window systems

x11-libs / libxkbfile : X.Org xkbfile library

x11-libs / libxshmfence : Shared memory fences using futexes

app-arch / snappy : A high-speed compression/decompression library by Google

dev-libs / expat : Stream-oriented XML parser library

dev-libs / glib : The GLib library of C routines

dev-libs / icu : International Components for Unicode

dev-libs / libevent : Library to execute a function when a specific event occurs on a file descriptor

dev-libs / libxml2 : XML C parser and toolkit

dev-libs / libxslt : XSLT libraries and tools

dev-libs / nspr : Netscape Portable Runtime

dev-libs / nss : Mozilla's Network Security Services library that implements PKI support

dev-libs / re2 : An efficient, principled regular expression library

dev-qt / designer : WYSIWYG tool for designing and building graphical user interfaces with QtWidgets

dev-qt / qtbase : Cross-platform application development framework

dev-qt / qtcore : Cross-platform application development framework

dev-qt / qtdeclarative : Qt Declarative (Quick 2)

dev-qt / qtgui : The GUI module and platform plugins for the Qt5 framework

dev-qt / qtnetwork : Network abstraction library for the Qt5 framework

dev-qt / qtpositioning : Physical position determination library for the Qt6 framework

dev-qt / qtprintsupport : Printing support library for the Qt5 framework

dev-qt / qttools : Qt Tools Collection

dev-qt / qtwebchannel : Qt WebChannel

dev-qt / qtwidgets : Set of components for creating classic desktop-style UIs for the Qt5 framework

media-libs / alsa-lib : Advanced Linux Sound Architecture Library

media-libs / fontconfig : A library for configuring and customizing font access

media-libs / freetype : High-quality and portable font engine

media-libs / harfbuzz : An OpenType text shaping engine

media-libs / lcms : A lightweight, speed optimized color management engine

media-libs / libjpeg-turbo : MMX, SSE, and SSE2 SIMD accelerated JPEG library

media-libs / libpng : Portable Network Graphics library

media-libs / libpulse : Libraries for PulseAudio clients

media-libs / libva : Video Acceleration (VA) API for Linux

media-libs / libvpx : WebM VP8 and VP9 Codec SDK

media-libs / libwebp : A lossy image compression format

media-libs / mesa : OpenGL-like graphic library for Linux

media-libs / openjpeg : Open-source JPEG 2000 library

media-libs / opus : Open codec for interactive speech and music transmission over the Internet

media-libs / tiff : Tag Image File Format (TIFF) library

media-video / pipewire : Multimedia processing graphs

sys-apps / dbus : A message bus system, a simple way for applications to talk to each other

sys-apps / pciutils : Various utilities dealing with the PCI bus

sys-libs / zlib : Standard (de)compression library

virtual / krb5 : Virtual for Kerberos V implementation

virtual / libudev : Virtual for libudev providers

x11-libs / libX11 : X.Org X11 library

x11-libs / libXScrnSaver : X.Org XScrnSaver library

x11-libs / libXcomposite : X.Org Xcomposite library

x11-libs / libXcursor : X.Org Xcursor library

x11-libs / libXdamage : X.Org Xdamage library

x11-libs / libXext : X.Org Xext library

x11-libs / libXfixes : X.Org Xfixes library

x11-libs / libXi : X.Org Xi library

x11-libs / libXrandr : X.Org Xrandr library

x11-libs / libXrender : X.Org Xrender library

x11-libs / libXtst : X.Org Xlib-based client API for the XTEST & RECORD extensions library

x11-libs / libdrm : X.Org libdrm library

x11-libs / libxcb : X C-language Bindings library

x11-libs / libxkbcommon : Keymap handling library for toolkits and window systems

x11-libs / libxkbfile : X.Org xkbfile library

app-admin / calamares : Distribution-independent installer framework

app-editors / ghostwriter : Cross-platform, aesthetic, distraction-free markdown editor

app-i18n / fcitx-chinese-addons : Addons related to Chinese, including IME previous bundled inside fcitx4.

app-i18n / fcitx-libpinyin : Chinese LibPinyin input methods for Fcitx

app-misc / recoll : Personal full text search package

app-office / kmymoney : Personal finance manager based on KDE Frameworks

app-office / libalkimia : Library with common classes and functionality used by KDE finance applications

app-office / merkuro : Calendar application using Akonadi

app-office / skrooge : Personal finances manager, aiming at being simple and intuitive

app-office / texmaker : Powerful LaTeX-IDE

app-text / bibletime : Qt Bible-study application using the SWORD library

app-text / cb2bib : Tool for extracting unformatted bibliographic references

app-text / kbibtex : BibTeX editor to edit bibliographies used with LaTeX

app-text / kchmviewer : Feature rich chm file viewer, based on Qt

app-text / sigil : Multi-platform WYSIWYG ebook editor for ePub format

app-text / zeal : Offline documentation browser inspired by Dash

dev-python / PyQt6 : Python bindings for the Qt framework

dev-python / PyQt6-WebEngine : Python bindings for QtWebEngine

dev-python / PyQtWebEngine : Python bindings for QtWebEngine

dev-python / pyside2 : Python bindings for the Qt framework

dev-python / pyside6 : Python bindings for the Qt framework

dev-qt / qt-creator : Lightweight IDE for C++/QML development centering around Qt

dev-qt / qtwebview : Module for displaying web content in a QML application using the Qt6 framework

dev-util / kdevelop : Integrated Development Environment, supporting KF5/Qt, C/C++ and much more

games-util / lgogdownloader : Unofficial GOG.com downloader for Linux

kde-apps / akregator : News feed aggregator

kde-apps / cantor : Interface for doing mathematics and scientific computing

kde-apps / grantlee-editor : Utilities and tools to manage themes in KDE PIM applications

kde-apps / k3b : Full-featured burning and ripping application based on KDE Frameworks

kde-apps / kaccounts-providers : KDE accounts providers

kde-apps / kalgebra : MathML-based 2D and 3D graph calculator by KDE

kde-apps / kdepim-runtime : Runtime plugin collection to extend the functionality of KDE PIM

kde-apps / khelpcenter : Application to read documentation for KDE Plasma, Applications, Utilities

kde-apps / kimagemapeditor : Generator of HTML image maps

kde-apps / kmail : Email client, supporting POP3 and IMAP mailboxes

kde-apps / konqueror : Web browser and file manager based on KDE Frameworks

kde-apps / kontact : Container application to unify several major PIM applications within one

kde-apps / ktp-text-ui : KDE Telepathy text chat window

kde-apps / libksieve : Common PIM libraries

kde-apps / marble : Virtual Globe and World Atlas to learn more about Earth

kde-apps / messagelib : Libraries for messaging functions

kde-apps / parley : Vocabulary trainer to help you memorize things

kde-misc / tellico : Collection manager based on KDE Frameworks

kde-plasma / kdeplasma-addons : Extra Plasma applets and engines

kde-plasma / libksysguard : Task management and system monitoring library

kde-plasma / plasma-nm : KDE Plasma applet for NetworkManager

media-gfx / digikam : Digital photo management application

media-gfx / freecad : QT based Computer Aided Design application

media-gfx / luminance-hdr : Graphical user interface that provides a workflow for HDR imaging

media-sound / musescore : WYSIWYG Music Score Typesetter

media-sound / supercollider : Environment and programming language for real time audio synthesis

media-sound / teamspeak-client : A client software for quality voice communication via the internet

media-video / jellyfin-media-player : Jellyfin Desktop Client based on Plex Media Player

net-analyzer / nmapsi : Qt frontend to nmap

net-im / psi : Qt XMPP client

net-im / whatsie : Qt Based WhatsApp Client

net-irc / kvirc : Advanced IRC Client

net-irc / quassel : Qt/KDE IRC client supporting a remote daemon for 24/7 connectivity

net-libs / signon-ui : Online accounts signon UI

net-misc / fatrat : Qt5-based download/upload manager

net-misc / nextcloud-client : Desktop Syncing Client for Nextcloud

net-misc / seafile-client : Seafile desktop client

net-news / rssguard : Simple (yet powerful) news feed reader

net-p2p / ktorrent : Powerful BitTorrent client based on KDE Frameworks

sci-astronomy / stellarium : 3D photo-realistic skies in real time

sci-electronics / eagle : Autodesk EAGLE schematic and printed circuit board (PCB) layout editor

sci-geosciences / gpsbabel : GPS waypoints, tracks and routes converter

sci-geosciences / merkaartor : Qt based map editor for the openstreetmap.org project

sci-geosciences / qmapshack : GPS mapping utility

sci-mathematics / rkward : IDE for the R-project

sci-mathematics / yacas : General purpose computer algebra system

sci-physics / root : C++ data analysis framework and interpreter from CERN

sci-visualization / paraview : Powerful scientific data visualization application

www-client / falkon : Cross-platform web browser using QtWebEngine

www-client / otter : Project aiming to recreate classic Opera (12.x) UI using Qt5

595574
dev-qt/qtwebengine checks GCC version based on what dev-qt/qtcore was built with
636242
dev-qt/qtwebengine-5.9.2 fails to build (arm): Project ERROR: GN build error!
652172
dev-qt/qtwebengine:5 CC, CXX, CFLAGS, CXXFLAGS, LDFLAGS not respected for most of the build
678332
>=dev-qt/qtwebengine-5.12 fails to build when <dev-qt/qtwebengine-5.12 is already installed
681832
dev-qt/qtwebengine-5.12.2: fails to link/install libQt5WebEngineCore.so with not enough memory/disk-space @preserved-rebuild loop
688218
dev-qt/qtwebengine-5.12.3 fails to build with clang: missing ../../3rdparty/chromium/chrome/android/profiles/afdo.prof
703978
dev-qt/qtwebengine-5.14.0 - ld: .../work/qtwebengine-everywhere-src-5.14.0/src/core/release/obj/third_party/openh264/openh264_common_yasm/dct.o: warning: relocation in read-only section `.text'
713900
dev-qt/qtwebengine: GN run error: ERROR at the command-line "--args":1:1671: Undefined identifier (arm_version=n)
714932
dev-qt/qtwebengine-5.14.1 with USE=-widgets: Project ERROR: Unknown module(s) in QT_PRIVATE: quickwidgets
719696
dev-qt/qtwebengine: gen/third_party/blink/public/mojom/fetch/fetch_api_request.mojom-blink.h:323:3: internal compiler error: Segmentation fault
749417
dev-qt/qtwebengine-5.15.1 - SyntaxError: Unexpected token = at exports.runInThisContext (vm.js:54:16) at Module._compile (module.js:375:25) at Object.Module._extensions..js (module.js:406:10) at Module.load (module.js:345:32) at Function.Module._load[...]
761457
dev-qt/qtwebengine-5.15.2 failed (configure phase) Unknown feature object private_tests in expression 'features.private_tests'
774717
dev-qt/qtwebengine-5.15.2 without X11 dependencies
813249
dev-qt/qtwebengine-5.15.2_p20210824-r1 - error: unknown argument: '-mpreferred-stack-boundary=5' with clang-12
815430
dev-qt/qtwebengine-5.15.2_p20210824-r1: Build fails due to ambiguous function call
822204
dev-qt/qtwebengine-5.15.2_p20211019: fails to build on arm (//skia/BUILD.gn:799:11: Undefined identifier. configs -= [ "//build/config/compiler:compiler_arm_fpu" ])
828497
dev-qt/qtwebengine-5.15.2_p20211019 - .../src/3rdparty/chromium/third_party/skia/include/core/SkImageInfo.h:105:6: error: #error "SK_*32_SHIFT values must correspond to BGRA or RGBA byte order"
830409
dev-qt/qtwebengine-5.15.2_p20211216: error: redefinition of ‘struct WTF::CrossThreadCopier<rtc::scoped_refptr<U> >’
830661
dev-qt/qtwebengine-5.15.2_p20211216: fails pre-emerge checks when distcc or large host is used because of too high RAM requirements
832949
dev-qt/qtwebengine fails install when symlink in root path
856403
dev-qt/qtwebengine-5.15.5_p20220618 ignores MAKEOPTS (when resuming with FEATURE="keepwork")
875641
dev-qt/qtwebengine: update has_version test for sys-devel/clang[default-libcxx]
876520
dev-qt/qtwebengine: needs patch to build on musl with Clang (QtWebEngineCore module will not be built. A suitable version >= 2.27 of libc required to build QtWebEngine could not be found.)
876999
dev-qt/qtwebengine-5.15.5_p20220618 - clang-15: error: unknown argument: -mpreferred-stack-boundary=5
889042
dev-qt/qtwebengine-5.15.7_p20221122 fails to compile: common-operator.h:599:34: error: call to non-constexpr function v8::internal::compiler::IrOpcode::Value v8::internal::compiler::Node::opcode() const
903573
dev-qt/qtwebengine-5.15.8_p20230313: Fails to build with Clang 16
907286
dev-qt/qtwebengine-5.15.9_p20230505: failed to build anything.
908218
dev-qt/qtwebengine-5.15.9_p20230505: TypeScript compilation failed
909009
dev-qt/qtwebengine: No progress information from parallel build with ninja
909395
dev-qt/qtwebengine-5.15.9_p20230505 crashes in www-client/qutebrowser with status 5 when built with clang 16
911715
dev-qt/qtwebengine-5.15.10_p20230623 and dev-qt/qtwebengine-6.5.2 - ninja: error: Filename too long
913923
dev-qt/qtwebengine-5.15.10_p20230815:5/5.15 fails to compile: FAILED: obj/gpu/command_buffer/service/gles2_sources/program_manager.o
915615
dev-qt/qtwebengine-6.6.0: Fails to build ModuleNotFoundError: No module named 'src.trace_processor'
920555
dev-qt/qtwebengine-6.6.1 when built with gcc -march=armv8-a+pauth bytecode_builtins_list_generator/gen-regexp-special-case build tool crash
922868
dev-qt/qtwebengine-5.15.12_p20240122:5/5.15 compilation hangs/freezes whole system
923500
dev-qt/qtwebengine-5.15.12_p20240122 - build.cc & build.h Errors (LLVM 17)
924108
dev-qt/qtwebengine-6.6.1: build fails on error libworklet.a: error adding symbols: malformed archive
924383
dev-qt/qtwebengine-5.15.12_p20240122 - does not respect make opts
924674
dev-qt/qtwebengine-5.15.12_p20240122 - ERROR: Feature 'webengine-pulseaudio' was enabled, but the pre-condition 'libs.webengine-pulseaudio' failed.
924936
dev-qt/qtwebengine-5.15.12_p20240122 macro-assembler-ppc.cc:1176:58: error: no matching function for call to 'v8::internal::RegExpMacroAssemblerPPC::CheckStackGuardState
925718
[Tracker] dev-qt/qtwebengine:5 removal
925719
<dev-util/kdevelop-24.05 depends on dev-qt/qtwebengine:5
925720
KDE PIM:5 depends on dev-qt/qtwebengine:5
925722
www-client/otter depends on dev-qt/qtwebengine:5
925723
net-irc/quassel[urlpreview] depends on dev-qt/qtwebengine:5
925724
app-admin/calamares-3.3.4 version bump (and port away from Qt5 with dev-qt/qtwebengine:5)
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: fix build with upcoming clang18
Do not want to trigger rebuilds over this, so straight-to-stable with no revbump. Entirely untested for 6.7, not worrying too much until 6.7.0-rc. With some luck Qt may backport this themselves before release. Will move in patchset later if the patch needs to stay. Closes: https://bugs.gentoo.org/925486 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: drop 6.6.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: enable py3.12 in 6.6.2+
Fixes were merged bit at last minute and the bug for it (QTBUG-117979) was updated late, and missed that 6.6.2 fixed py3.12 support. Note that while it still has several references to distutils and an upstream bug (QTBUG-115512), seems none are necessary as it built fine with setuptools[-python_target_python3_12] after double-checking that it did use 3.12. (if reading this wondering why portage asks to rebuild qtwebengine, it's time to start using -U/--changed-use rather than -N/--newuse -- alternatively could've held it back until 6.6.3 but well) Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 6.6.2 amd64, #924651
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: add 6.6.2
Closes: https://bugs.gentoo.org/920758 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: clarify comment for skipped 6.9999 patches
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: drop 5.15.11_p20231120, 5.15.12_p20240112
Bug: https://bugs.gentoo.org/922189 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matoro Mahri · gentoo
dev-qt/qtwebengine: Stabilize 5.15.12_p20240122 arm64, #921565
Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/*: sync keywords in live (qt6)
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Matoro Mahri · gentoo
dev-qt/qtwebengine: Stabilize 5.15.12_p20240122 amd64, #921565
Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: update patchset for 6.6 and 6.7 branches
6.6-8 -> 6.6-9 and 6.7-3 -> 6.7-4 changes: Updated: * gn-bootstrap.patch (updated to not pass -Werror wrt bug #920758) Removed: * samurai.patch (unnecessary with the new app-alternatives/ninja) Meant to do these last time updated patchsets, but forgot to read my notes when worked on that. Doing it now so that it will be in the 6.6.2 release in ~2 days. Bug: https://bugs.gentoo.org/920758 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: update patchset for 6.6 and 6.7 branches
6.6-7 -> 6.6-8 and 6.7-2 -> 6.7-3 changes: Removed: * icu74.patch (upstreamed) Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.12_p20240122
Bug: https://bugs.gentoo.org/921565 Bug: https://bugs.gentoo.org/922189 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
Move {dev-util → dev-build}/gn
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: drop 5.15.12_p20231219
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.12_p20240112
Bug: https://bugs.gentoo.org/921565 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: tentatively work around race condition (qt6)
Unknown if this really helps, depend on if the file was missing or if it was just failing to find where it is with bad include search -- but given it is generated good odds it is the former. Have not actually reproduced myself and it is possible another target also needs to be run, could potentially fail differently if that does not resolve it (forcing -j1 is of course out of the question for this package). Needs a proper investigation/fix, but given this tend to fail very late in the build it is not obvious and ccache likely makes it harder to fail. Does not help that these rules are created through several Qt cmake wrapper functions (the sync headers bits come from qtbase cmake files, not from here). May tentatively try to remove in a somewhat-distant future to see if it is still an issue, and/or when related-sounding fixes occurred in qtbase or qtwebengine. Closes: https://bugs.gentoo.org/915953 Closes: https://bugs.gentoo.org/921680 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
Revert "dev-qt/qtwebengine: sys-devel/flex -> app-alternatives/lex"
This reverts commit b179a17a6695decb63e3bb7c824a9766b69cf7aa. Hadn't noticed this had been done for lex as well. Like bison, this looks for flex directly like bison and does not respect LEX. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: do the install sanity-check from qt5 in qt6 too
The check was removed before I touched these and didn't know it existed. Was fair to think it wouldn't be needed anymore with cmake but it is, e.g. it installs nothing if bison is not found without hard failure. File path is hopefully correct for Qt6, did give it two test builds (one "bad" that's empty, and one full build) just in case. Albeit haven't retried prefix (it's included in QT6_LIBDIR though). The qt6-build eclass does force fatal errors for a few "build nothing" cases, but not qtwebengine's custom ones. Kind of wonder if a similar end result file check should be done for all of dev-qt/* (aka fail if does not install anything but cmake files and docs). May revisit if Qt has more original ways to build nothing not limited to qtwebengine. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
Revert "dev-qt/qtwebengine: sys-devel/bison -> app-alternatives/yacc"
This reverts commit 2e783c9f85e7259aaabc02dbc7175ffb2313f3db. This may not set YACC, but that's because qtwebengine does not respect this variable in the first place and looks for bison directly. This furthermore fails in a horrible way, it installs an empty qtwebengine when bison is not found (should probably improve this to hard fail). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: sys-devel/bison -> app-alternatives/yacc
All of these will be using app-alternatives/yacc anyway as they're not unsetting YACC or LEX, so make the dep reflect reality. (Included both YACC and LEX out of conservatism.) Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
dev-qt/qtwebengine: sys-devel/flex -> app-alternatives/lex
All of these will be using app-alternatives/lex anyway as they're not unsetting YACC or LEX, so make the dep reflect reality. (Included both YACC and LEX out of conservatism.) Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
dev-qt/qtwebengine: dev-util/ninja -> app-alternatives/ninja
All of these will be using app-alternatives/ninja anyway as they're not calling ninja-reference, so make the dep reflect reality. Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: update patchset for 6.6 and 6.7 branches
6.6-5 -> 6.6-6 changes (only used by 6.6.1): Added: * gcc14.patch (imported from gentoo tree, not needed in 6.7) Updated: * cstdint.patch (>=qtwebengine-6.6.1 needs an extra for gcc+musl) 6.6-6 -> 6.6-7 changes (due for 6.6.2 if nothing else comes up): Removed: * libcxx17.patch (backported from 6.7) * libxml2-2.12.patch (upstreamed) 6.7-1 -> 6.7-2 changes (tentative, release is still far away): Updated: * cstdint.patch (>=qtwebengine-6.6.1 needs an extra for gcc+musl) Removed: * libxml2-2.12.patch (upstreamed) Safe changes, and no need for revbumps. For libxml2, Qt did the same changes that we did rather than do like upstream chromium. Meaning we do not need to depend on the newer libxml2 and it works for the old as well. Hopefully more gcc+musl issues don't keep showing up given been using clang+musl for testing musl and would rather not do both on top of gcc+glibc (idea was to pickup most toolchain issues with only two builds). Only know about this because a user mentioned it on IRC. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.12_p20231219
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-qt/qtwebengine: keyword 6.6.1 for ~arm64
Bug: https://bugs.gentoo.org/907080 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: filter -march on arm64 with gcc for now (qt6)
Bit like Qt5's webengine which did not respect it either. Not ideal but given the complexity tend to be lucky if it builds at all. As noted in the comment, please report if this works again so can cleanup (can test with USE=custom-cflags), may get fixed either by >=qtwebengine-6.7 (chromium-118) or a new gcc version depending on where the real issue is, but not planning to pursue this further myself. Closes: https://bugs.gentoo.org/920555 Closes: https://bugs.gentoo.org/920568 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: drop 6.5.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: fix 6.6.x build with gcc14
Closes: https://bugs.gentoo.org/920257 Thanks-to: Sam James <sam@gentoo.org> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 6.6.1 amd64, #920154
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: roughly update size requirements for 6.7
This is chromium 112->118 and is unsurprisingly going up. May be a bit less with USE=-pdfium but margin won't hurt. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: add 6.7.9999
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: drop 6.6.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: update patchset for 6.7 branch
6.6-5 -> 6.7-1 changes: Removed: * musl-no-close.patch (QT's fork now always disables that nonsense) * libcxx17.patch (upstreamed) Plus some rebasing where needed. Still subject to changes given testing is still minimal and have notably not tried 6.7+ with musl yet. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: update live
Adds a system-gbm option but it was already default ON and changes nothing given we do not need to turn it off. This is also still only used with screencast/vaapi, and gn now complaints that the option that Qt's build system passes was unused if disabled (thankfully not fatal). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: add 6.6.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: update patchset for 6.6 live branch
6.6-4 -> 6.6-5 changes: Added: * icu74.patch (imported from filesdir) * libxml2-2.12.patch (imported from filesdir) Imagine may be fixed in 6.6.2, but add just to allow cleaning these up later given 6.6.1 is a stable candidate while others are due to be dropped. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Cleanup vulnerable 5.15.11_p20231102
Bug: https://bugs.gentoo.org/915465 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: skip tst_touchinput (qt6)
Thought hit a 6.6.1 regression while using 6.6.9999 after had rebuilt the qt stack without tests, but turns out qtbase[test] vs [-test] seems to affect this test. Given most people running tests with qtwebengine likely enable for the rest of the qt stack, seems went overlooked. Failure itself is trivial, it is likely the test being performed badly (fake touch and hold text selection event) rather than an actual runtime problem. Let's just skip for now to avoid issues when attempt to keyword this by itself. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: adjust re2 comment (qt6)
Just so use of the word does not get outdated. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: enable v8 for pdfium in live (qt6)
Seeing little reason to lack support or make it optional given need using v8 for webengine either way. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: fix build with >=libxml2-2.12 (qt6)
For convenience, use LIBXML_VERSION rather than has_version so that can include in patchset tarball later if still needed. Formerly meant to fix only in upcoming 6.6.1 (soon) but is a simple and safe fix so let's fix the others too. Closes: https://bugs.gentoo.org/917601 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.11_p20231120, fix build w/ libxml2-2.12
Bug: https://bugs.gentoo.org/917645 Closes: https://bugs.gentoo.org/917601 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: update patchset for 6.6 live branch
In preparation for approaching 6.6.1 release. 6.6-3 -> 6.6-4 changes: Removed: * ffmpeg-binutils-2.41.patch (upstreamed) * libvpx-CVE-2023-5217.patch (upstreamed) Not adding icu74 patch, still waiting to see how it goes upstream (should be hopefully short lived either way). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Paul Zander · gentoo
dev-qt/qtwebengine: fix build with icu74 (qt5)
Apply quick-fix from b7982facbd6d596888e100c11b07fff5599e2203 to qt5 as well. Closes: https://bugs.gentoo.org/917635 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33926 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: fix build with icu74 (qt6)
Just a quick fix, not fixed in either upstreams yet. Have not tried qt5. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: drop 6.5.2-r1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 6.5.3 amd64, #915549
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Apply ppc64 patches after eapply_user
Thanks-to: Marcus Comstedt <marcus@mc.pp.se> Closes: https://bugs.gentoo.org/910218 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: drop 5.15.11_p20231019
Bug: https://bugs.gentoo.org/915465 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: drop 5.15.10_p20230623, 5.15.10_p20230815
Bug: https://bugs.gentoo.org/913050 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.11_p20231102 arm64, #915391
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.11_p20231102 amd64, #915391
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.11_p20231102
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: drop 5.15.11_p20230927
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.11_p20231019
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: update py3.12 comment with bugrefs
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: add 6.6.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: drop 6.6.0_rc
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.11_p20230927
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: update patchset for 6.6 branch
6.6-2 -> 6.6-3 changes: Added: * cstdint.patch (missing includes, imported from ::gentoo files/) * libvpx-CVE-2023-5217.patch (only needed with the new USE=vaapi, otherwise the system's libvpx is used) Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: fix build with gcc13+musl
Primarily been testing musl on a llvm-musl profile, so overlooked this. Does not manifest as an issue if use any of gcc12, clang, or glibc. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/*: drop 6.5.9999
Technically an LTS branch but 6.5.3 is due to be the last "public" release for this branch plus Plasma 6 is based on 6.6, so should have no use for this anymore. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: add 6.5.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: skip test failing with network sandbox in 6.6+
Newly does a dns-over-https test. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: depend on vulkan-headers for vaapi in 6.6+
In QTBUG-115722, Qt opted to disable vaapi autodetection if QT_FEATURE_vulkan is disabled due to missing headers, but can ignore that and just pull the headers (not used without webengine_vulkan). Ideally would just depend on vulkan-headers regardless of vaapi, but it is not used in other parts of qtwebengine (it bundles like 3-4 different copies of vulkan-headers and for some reason wants the system's here). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: add 6.6.0_rc
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: use -g1 rather than -g (qt6)
Turns out -g is still too much, or at least with gcc+bfd. Closes: https://bugs.gentoo.org/914475 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: replace -g3+ for -g unless custom-cflags (qt6)
On second thought let's do this, but keep a warning that mentions USE=custom-cflags given users may not be used to -g* getting replaced and then lacking the symbols they were expecting. Not going to keep disk space / memory usage updated for -g as estimates would likely be all over the place and consider that the warning is sufficient there. Not using a full replace-flags '-g*' -g to allow e.g. a package.env that adds -g0/-g1 at the end to still work while disregaring the warning without implementing extra logic. Note that have not retried -g to be sure it is fine, albeit pretty sure it was fine last time tried. Worst case could replace by -g1, or drop flags-respecting-patches and request debugging symbols to gn instead (selectively forces -g1 even if asked for more). Closes: https://bugs.gentoo.org/914475 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: extend -g warning and increase visibility
If this comes up more often an issue, may opt to transform -g* (other than -g0) for -g without USE=custom-cflags. Albeit do not overly want to give surprises, nor assume when something is going to work or not given the toolchain and other options. Note that this does not affect <qtwebengine-6.5.2-r1 nor qtwebengine:5 because they simply do not respect *FLAGS. Bug: https://bugs.gentoo.org/914475 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Niccolò Belli · gentoo
dev-qt/qtwebengine: fix ppc64 bundled ffmpeg for 5.15
Closes: https://bugs.gentoo.org/904372 Signed-off-by: Niccolò Belli <niccolo.belli@linuxsystems.it> Closes: https://github.com/gentoo/gentoo/pull/32922 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.10_p20230815 amd64, #913051
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: update patchset for 6.6 branch
6.6-1 -> 6.6-2 changes: Removed: * screencast-gio.patch (fix was backported from 6.7) Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 6.5.2-r1 amd64, #914113
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: note that libva is dlopen
Still keep := though, ensures that remain compatible with the library that gets opened. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: drop 6.5.2-r0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: add IUSE=vaapi in 6.6+
wrt [X], it currently auto-uses va_x11.h if ozone x11 is enabled, it *could* be optional (use_vaapi_x11) but it probably makes little sense to introduce IUSE=X unless we can make ozone_x11 optional too. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: add new tiff dependency in 6.6+
Upstream has unbundled by default. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: update patchset for 6.6 branch
6.5-1 -> 6.6-1 changes: Added: * libcxx17.patch (import from 6.5.2 ebuild) * screencast-gio.patch (regression fix backported from 6.7) Updated: * musl-no-execinfo.patch (reduced, mostly fixed upstream) * musl-no-res-ninit.patch (reduced, mostly fixed upstream) Removed (fixed upstream): * musl-lfs64.patch * musl-no-canonicalize.patch * musl-no-temp-retry.patch * musl-no-user-vfp.patch * musl-pthread-stack.patch * musl-stacksize.patch * musl-stdint.patch * musl-systypes.patch * narrowing-cast.patch Still a way to go before release, so may still need updates. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/*: add 6.6.9999
Sraight copies from 6.9999, pending updates as-needed to prepare for 6.6 which is slowly approaching (6.9999 been 6.7 for some time). 6.5.9999 will be leaving soon given 6.5.3 is the last 6.5 release for plebians. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: rename IUSE=pdf to pdfium (qt6)
This is in part a message to future revdeps that having their own USE=pdf will not work too well given it is default on desktop profile and we do not really want to pull webengine by default unless really wanted. Plus gives a way to disable globally for arches where qtwebengine is not keyworded. At worst this will become innacurate if qtpdf changes its backing library. IUSE is still in live-only so should not really disrupt. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: add IUSE=pdf for QtPdf support in live
Nothing seems too special here, so can just enable it. Live-only given IUSE=pdf is a default on desktop profiles and will cause a big unnecessary rebuild (nothing needs QtPdf yet). Note that QtPdf is fairly trivial (and small'ish) after chromium bits are already built either way, and does not hurt as a default. Does require cups at build time (dlopen, left DEPEND-only). May be possible to be optional but would rather no pdf-only IUSE=cups on this big package (may revisit if someone wants this). Would be nicer split (or allow IUSE=-webengine) but, even though the option exists, build system files note that webengine cannot really be disabled and then QtPdf still needs parts of chromium to be built (splitting would cause to rebuild some of the same things twice, but it is not nearly as big as webengine proper). May revisit. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: fix build with >=libcxx-17
May(?) need a revbump given updating to libcxx-17 while built against <17 unpatched could give symbol issues, ...but let's spare having everyone rebuild, esp given by the time llvm:17 is released may have qtwebengine-6.5.3 in the tree to trigger a build. Thanks-to: Violet Purcell <vimproved@inventati.org> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: remove qtbase[X] dep (qt6)
While this currently still requires X11 dependencies, qtbase[X] itself should not be necessary. Sparing the revbump. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/*: replace = by ~ for dev-qt/*:6 deps
Less jarring a little bit shorter. Made sense in Qt5 given it used a ver_cut QT5_PV and could be used to ignore additional components, but with PV it does nothing useful. Plus we still want _rc and _betas to match (_p<date> are where issues start though, if ever needed we could reintroduce QT6_PV, but for now...). Should have done this in the previous style commit. Still keeping :6, do prefer these being everywhere for clarity with Qt slots (and qa-vdb!) even if essentially a no-op here. Plus, even if this does not happen with Qt, two slots having the same version can happen with revisions (e.g. current webkit-gtk). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: refactor qt6 ebuild, various fixes incl. musl
Essentially a rewrite, so only have a not exhaustive summary of changes rather than split commits. Bugs addressed: * respect *FLAGS wrt bug #652172 (fwics should be no issues left) * hopefully fixed musl/libcxx (tested with llvm-musl) wrt bug #876520 (not planning to review Qt5's myself, so no changes on that end) IUSE changes: * enable alsa by default, finding that you have no audio options only after building is not great and alsa is cheap * enable widgets by default, needed by both falkon and qutebrowser * add custom-cflags, if going to use *FLAGS then should strip-flags like chromium's ebuild * add opengl, unfortunately littered in QT_CONFIG(opengl) and need qtbase[opengl=] to avoid ABI/automagic issues * add vulkan, has its own feature so should only need qtbase[vulkan?] * add qml similarly to other packages Misc: * support EXTRA_GN like qtwebengine:5 and chromium (Gentoo-specific) * build dir went from >9GB to ~6.3GB by dropping -g1 * drop estack+extglob, setting extglob is technically not needed for use in bash [[ ]] tests which is-flagq does * drop INCLUDEPATH, tried to sed qmake files but this is using cmake * respect NINJA env var to allow samu (NINJA_PATH was a no-op) * use get_NINJAOPTS for NINJAFLAGS and ignore environment (NINJAOPTS is the var to set for this, while NINJAFLAGS is a private qtwebengine var, ninja does not actually use this directly) * drop icu's bundling check for simplicity (and consistency with other system libraries), bug #630834 prompted adding this but does not seem so fragile anymore (plus iwdevtools would report lib misuse, albeit not headers) * switch to bundled re2 to be spared headaches (see github PR#32281) * optfeature on chrome-binary-plugins for widevine support * cleanup/reduce QT_FEATURE and old comments * fix designer automagic * various dependencies adjustments, wrt re2c that is only needed if we build ninja * do not redefine _FORTIFY_SOURCE (use gentoo's defaults), upstream actually switched to =3 in chromium-118 (albeit only for ChromeOS) and "hopefully" is fine for this older version (tests pass at least) Also moved patches to a tarball (like qt5). It is simple small patches mostly adjusting macros rather than add actual code, but was beginning to add up. Considered reducing RAM requirements a little bit (generally *seems* not so bad), but there is rather bad spikes and I do not think it can be considered safe unless we assume everyone is not using RAM for anything else. Plus usage will likely keep growing with versions. Bug: https://bugs.gentoo.org/652172 Bug: https://bugs.gentoo.org/876520 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.10_p20230815
Bug: https://bugs.gentoo.org/913050 Bug: https://bugs.gentoo.org/913051 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: automate chromium version warning (qt6)
Just an unnecessary disparity between ebuilds to maintain, plus would typically be inaccurate in live ebuilds (albeit check may make live version fail on a whim if format changes, but kept fatal or else issues will be easy to miss on bumps). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: do not install gn (qt6)
qtwebengine handling of gn does not allow to use CBUILD toolchain, and only when cross-compiling it will look for system's. Also does not respect *FLAGS as upstream intentially commented these out because someone did a bug report with overzealous flags (QTBUG-64759). And, unfortunately, qtwebengine's is modified and so dev-util/gn may not work as expected with it (plus will need CMakeLists modifications to be found). Bare that, two possible options would be: 1. dev-qt/qtwebengine-gn or so to BDEPEND on and build cleanly 2. fix the mess that is the modified gen.py, and use BUILD_ variables For now at least skip installing it as it'll just cause conflicts if we want to do this later and is not really useful unless want to do something like BDEPEND="cross? ( dev-qt/qtwebengine )". Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: prefixify widevine search path (qt6)
Allows dropping a workaround in qutebrowser. And yes, wrt -w, the line we are changing literally has "Gentoo" in an upstream comment. Also move qt6-build_src_prepare up given modifying files before patches tend to be messy. No revbump given use case is rather uncommon. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: make pkgcheck happier (qt6)
ebuild needs more real refactoring (will do in a separate revbump), but at least address pkgcheck's warnings in this one wrt src_unpack (which triggers indirect git-r3 usage), not quite sure what the debug check was doing (repeated) there, and (currently) no patchset to unpack so can just drop the whole thing. For patchsets this may be better handled in qt6-build given it is the one inheriting git-r3. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/qtwebengine: various adjustments for tests (qt6)
* use -j1 (similarly to when I tried to use python-xdist on qutebrowser which uses qtwebengine, parallel tests don't seem to work so well here either) * skip tests that need network * skip cert test, not looked too closely but likely missing something or (maybe) expirations are causing issues * export various variables to stop it from using the system's qtwebengine (otherwise fails if not installed) Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/*: streamline style a bit across qt6 ebuilds
Misc minor adjustments / sorting, but more commonly: * use same RDEPEND + DEPEND ordering everywhere, bit of both order is used all across and sometime inverted in Qt5's so let's match skel.ebuild to avoid confusion * use explicit :6 slots, not necessary with =PV but this is more about normalizing usage when multiple slots exist (plus *cough* qa-vdb won't complaint anymore) Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Ionen Wolkens · gentoo
dev-qt/*: import qt6 live ebuilds from ::qt
As-is, no changes in this commit which is mostly the same as the current in-tree ebuilds. Maintaining these in two different repos feels like just a hassle (to me), and would rather have everything in one place so I can change live and release ebuilds simultaneously as needed, plus not have to sync metadata or eclass changes either (plus chiitoo has ::gentoo commit access now). May move packages if I happen to work on them, albeit I have no intention to really touch Qt5 or LXQt (anyone working on these are free to the same if they want, or keep current workflow). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: fix build w/ binutils-2.41
Closes: https://bugs.gentoo.org/911688 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/qtwebengine: drop 6.5.1
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/qtwebengine: update 6.5.2 Chromium security patches version
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/qtwebengine: add 6.5.2
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Denis Pronin · gentoo
dev-qt/qtwebengine: fix compiling with clang-16
clang-16 complains about casting an integer value that exceeds an enumeration capacity in the class base::BitField to not modify chromium code we just cancel warning about this circumstance to prevent it from being converted to an error that fails compilation [sam: Note that this is a bandaid and won't work with Clang 17.] Bug: https://bugs.gentoo.org/903573 Signed-off-by: Denis Pronin <dannftk@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/31869 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: drop 5.15.9_p20230505, 5.15.10_p20230505
Bug: https://bugs.gentoo.org/906857 Bug: https://bugs.gentoo.org/909778 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.10_p20230623 amd64, #909313
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.10_p20230623 arm64, #909313
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.10_p20230623
Bug: https://bugs.gentoo.org/909313 Bug: https://bugs.gentoo.org/909778 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.10_p20230505
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/qtwebengine: drop 6.5.0-r2
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Jimi Huotari · gentoo
dev-qt/qtwebengine: add 6.5.1
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: drop 5.15.9_p20230421
Bug: https://bugs.gentoo.org/906857 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.9_p20230505 arm64, #906883
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.9_p20230505 amd64, #906883
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.9_p20230505, equiv. to upstream 5.15.14
Patched with security patches up to Chromium version: 113.0.5672.64 Bug: https://bugs.gentoo.org/906857 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/qtwebengine: drop 6.4.3
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: cleanup vulnerable 5.15.8_p20230313
Bug: https://bugs.gentoo.org/904290 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: fix qutebrowser's hinting issue (6.5 regression)
Without this, scripts that qutebrowser (or others) inject may semi-randomly fail leading to e.g. keyword hints not working, or users' greasemonkey scripts not being loaded. qutebrowser has opted to not do messy mitigations (at least for now) and a fix here makes more sense. Albeit fix was not merged upstream yet, "hopefully" will make it in 6.5.1 if doesn't miss the window. Given qtwebengine is not used for much in Gentoo beside qutebrowser so far, should be worth the revbump/rebuild. Acked-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: drop 5.15.9_p20230404
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.9_p20230421 arm64, #904373
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.9_p20230421 amd64, #904373
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.9_p20230421
Bug: https://bugs.gentoo.org/904373 Bug: https://bugs.gentoo.org/904290 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/qtwebengine: drop 6.5.0 (0)
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Jimi Huotari · gentoo
dev-qt/qtwebengine: fix build with GCC-13
Also add a dependency on 'media-libs/openjpeg', so that the system package is used. Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/qtwebengine: add 6.5.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: fix build w/ GCC 13
Closes: https://bugs.gentoo.org/904342 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.9_p20230404 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Cleanup vulnerable 5.15.8_p20230112
Bug: https://bugs.gentoo.org/903544 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.8_p20230313 amd64, #903115
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.8_p20230313 arm64, #903115
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.8_p20230313
Bug: https://bugs.gentoo.org/903115 Bug: https://bugs.gentoo.org/903544 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: fix build w/ gcc-13
Bug: https://bugs.gentoo.org/898634 Closes: https://bugs.gentoo.org/889724 Closes: https://bugs.gentoo.org/895196 Closes: https://bugs.gentoo.org/898902 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/qtwebengine: drop 6.4.2
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/qtwebengine: fixup build/no-build detection for 6.4.3
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/qtwebengine: add 6.4.3
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: drop 6.4.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: destabilize 5.15.8_p20230112 for ~x86
Bug: https://bugs.gentoo.org/893234 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: cleanup vulnerable 5.15.7_p20221122
Bug: https://bugs.gentoo.org/888181 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.8_p20230112 x86, #888946
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.8_p20230112 arm64, #888946
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.8_p20230112 amd64, #888946
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: drop 5.15.8_p20230106
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.8_p20230112
Fixes CVE-2022-4437 and CVE-2022-4438. Snapshotted at: Branch: 5.15 Commit: 38e0df6c6e5a1186b68df9b3d6f4cafbb211f2da Submodule qtwebengine-chromium.git: Branch: 87-based Commit: 97a1254923022e66fa75245c3ace64f58112cba6 Patched with security patches up to Chromium version: 98.0.4758.102 Bug: https://bugs.gentoo.org/888946 Bug: https://bugs.gentoo.org/888181 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.8_p20230106
Snapshotted at: Branch: 5.15 Commit: 38e0df6c6e5a1186b68df9b3d6f4cafbb211f2da Submodule qtwebengine-chromium.git: Branch: 87-based Commit: ce9155cc73d8a94f1536b96e841c0aee2ff7d921 Patched with security patches up to Chromium version: 98.0.4758.102 Bug: https://bugs.gentoo.org/888181 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/qtwebengine: add 6.4.2
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: cleanup vulnerable 5.15.5_p20220618
Bug: https://bugs.gentoo.org/866332 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.7_p20221122 arm64, #883677
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.7_p20221122 x86, #883677
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.7_p20221122 amd64, #883677
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: drop 6.3.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 5.15.7_p20221122
Snapshotted at: Branch: 5.15 Commit: 5d89f26414471689a9626515d098104e38bacbda Submodule qtwebengine-chromium.git: Branch: 87-based Commit: 20f20a41961ae1f63cf04a02f743cd2d9892a3b0 Patched with security patches up to Chromium version: 98.0.4758.102 Bug: https://bugs.gentoo.org/866332 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/*: add version 6.4.0
Bug: https://bugs.gentoo.org/838970 Bug: https://bugs.gentoo.org/863224 Bug: https://bugs.gentoo.org/875956 Closes: https://bugs.gentoo.org/862525 Closes: https://bugs.gentoo.org/863395 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/27812 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: fix has_version default-libcxx test for Clang
We moved the flag to sys-devel/clang-common to prepare for proper config file support (which is backported to 15.0.2, although it's going to be better in 16.x). Go for the hack for now, but keep the bug open as we want to switch to the proper link test from the LLVM ebuilds. Bug: https://bugs.gentoo.org/875641 Bug: https://bugs.gentoo.org/875563 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: drop 6.3.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: add 6.3.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Ionen Wolkens · gentoo
dev-qt/qtwebengine: backport :6 favicon display fix
Not worth a revbump rebuild, but is still annoying and wanted to toss it here at least for future builds. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Cleanup vulnerable 5.15.4_p20220526
Bug: https://bugs.gentoo.org/853229 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.5_p20220618 arm64, #853232
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.5_p20220618 x86, #853232
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.5_p20220618 amd64, #853232
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fixup fix for CVE-2022-0796
Thanks-to: Michael <voron1@gmail.com> Thanks-to: Jimi Huotari <chiitoo@gentoo.org> Closes: https://bugs.gentoo.org/853097 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Jimi Huotari · gentoo
dev-qt/qtwebengine: add version 6.3.1
Bug: https://bugs.gentoo.org/838970 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.5_p20220618 version bump
One security fix: CVE-2022-0796: Use after free in Media Snapshotted at: Branch: 5.15 Commit: 1da56888ac5815a68e31d113a8022993a40b9f8f Submodule qtwebengine-chromium.git: Branch: 87-based Commit: ecc2bb74f1f7140fc52650042299be18e826b27b Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Cleanup vulnerable 5.15.3_p20220406
Bug: https://bugs.gentoo.org/847613 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.4_p20220526 arm64, #843353
Signed-off-by: Sam James <sam@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop 5.15.4_p20220505
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-qt/qtwebengine: x86 stable wrt bug #843353
Package-Manager: Portage-3.0.30, Repoman-3.0.3 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Georgy Yakovlev · gentoo
dev-qt/qtwebengine: don't use clang-format on ppc64
Closes: https://bugs.gentoo.org/849458 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.4_p20220526 amd64, #843353
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Re-add KEYWORDS to 5.15.4_p20220526
Bug: https://bugs.gentoo.org/847613 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.4_p20220526 version bump
Various security fixes... Snapshotted at: Branch: 5.15 Commit: 79943b157ef381e5953f34f8e03049f2eecd6eb5 Submodule qtwebengine-chromium.git: Branch: 87-based Commit: 7857ff290ab254a5a1fe2e85e146680448b4d46e Bug: https://bugs.gentoo.org/847613 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.4_p20220505 version bump
No additional security fixes in webengine-chromium over p20220404. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: fix build with GCC 12
Closes: https://bugs.gentoo.org/840326 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-qt/qtwebengine: Prepare for makeopts_jobs default inf change
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Cleanup vulnerable 5.15.2_p20211216
Bug: https://bugs.gentoo.org/836830 Bug: https://bugs.gentoo.org/835761 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Cleanup obsolete and vulnerable 5.15.3_p20220329
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.3_p20220406 x86, #835762
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.3_p20220406 amd64, #835762
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
dev-qt/qtwebengine: Stabilize 5.15.3_p20220406 arm64, #835762
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.3_p20220406 version bump
Fix 5.15.3 version downsedding after 5.15.10 bump No additional security fixes in webengine-chromium over p20220330. ${P}-patchset contains patches to drop catapult as well. Thanks-to: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.3_p20220330 version bump, py3
Patched with security patches up to Chromium version: 98.0.4758.102 plus fixes for CVE-2022-0971, CVE-2022-1096 Patches sourced from ArchLinux: - Enable build with >=python-3 - Fix build with >=ffmpeg-5 - Enable screencast support using pipewire-3 Snapshotted at: Branch: 5.15 Commit: dcdf9656f794e1903163a5533d0a325eb3dce423 Submodule qtwebengine-chromium.git: Branch: 87-based Commit: d13d0924c4e18ecc4b79adf0fec142ee9a9eaa14 Bug: https://bugs.gentoo.org/835761 Closes: https://bugs.gentoo.org/831487 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Miezhiko · gentoo
dev-qt/qtwebengine: fix building with clang 14
Signed-off-by: Miezhiko <Miezhiko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24897 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop 5.15.3_p20220310
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.3_p20220329 snapshot bump
No security fixes since previous snapshot. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.3_p20220310 version bump
Patched with security patches up to Chromium version: 98.0.4758.102 Snapshotted at: Branch: 5.15 Commit: 9e3ad4273df3aeb16687e924c65fe451e4c03ad2 Submodule qtwebengine-chromium.git: Branch: 87-based Commit: 1629f9b8f7f05288f17ed73f2dc328581dffce6a Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: disable CHECKREQS_MEMORY for distcc
It's harder to calculate properly for this case. Bug: https://bugs.gentoo.org/830661 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: add check-reqs for disk space and memory usage
For now, assumes: - RAM/memory: 2GB per job for GCC, 1.5GB per job for Clang - Disk (build): 7GB - Disk (installed): 150MB (Also moves pkg_preinst to the end of the ebuild to reflect phase execution order, as per devmanual.) Closes: https://bugs.gentoo.org/570534 Thanks-to: Ionen Wolkens <ionen@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Cleanup vulnerable 5.15.2_p20211019
Bug: https://bugs.gentoo.org/829161 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2_p20211216 arm64, #829196
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-qt/qtwebengine: x86 stable wrt bug #829196
Package-Manager: Portage-3.0.28, Repoman-3.0.3 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-qt/qtwebengine: amd64 stable wrt bug #829196
Package-Manager: Portage-3.0.28, Repoman-3.0.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop 5.15.2_p20211210
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20211216 snapshot bump
Patched with security patches up to Chromium version: 96.0.4664.110 Snapshotted at: Branch: 5.15 Commit: 1c9785bf7eee038f6f0b8e2d73dcb9588f6d60c1 Submodule qtwebengine-chromium.git: Branch: 87-based Commit: 0ad2814370799a2161057d92231fe3ee00e2fe98 Bug: https://bugs.gentoo.org/829161 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop 5.15.2_p20211207
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20211210 snapshot bump
Patched with security patches up to Chromium version: 96.0.4664.93 Snapshotted at: Branch: 5.15.8 Commit: 6369c52cebd276f03856dd333af727fd8427ac63 Submodule qtwebengine-chromium.git: Branch: 87-based Commit: 2918e073086af29bd3e4176cd2403dffa789fdc0 Bug: https://bugs.gentoo.org/828099 Bug: https://bugs.gentoo.org/829161 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20211207 snapshot bump
Patched with security patches up to Chromium version: 96.0.4664.45 Snapshotted at: Branch: 5.15 Commit: cf53bf7fa434c78d902b78378e55b4c38c095bba Submodule qtwebengine-chromium.git: Branch: 87-based Commit: b3ec1114d8fe670f1e93d6ccb19fd614bcbc398c Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Cleanup vulnerable 5.15.2_p20210824-r1
Bug: https://bugs.gentoo.org/815397 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2_p20211019 arm64, #820893
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Georgy Yakovlev · gentoo
dev-qt/qtwebengine: update SRC_URI with new ppc64le patchset
added struct kernel_stat patch for src/3rdparty/chromium/sandbox/linux/system_headers/linux_stat.h Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-qt/qtwebengine: x86 stable wrt bug #820893
Package-Manager: Portage-3.0.20, Repoman-3.0.3 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2_p20211019 amd64, #820893
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Stephan Hartmann · gentoo
dev-qt/qtwebengine: add jumbo-build patch
Closes: https://bugs.gentoo.org/813957 Thanks-to: Marco Genasci <fedeliallalinea@gmail.com> (enhancing patch) Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop 5.15.2_p20211015 w/o keywords
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20211019 snapshot bump for testing
Snapshotted at: Branch: 5.15 Commit: 03b3df668088d0750af6a59410ee4d0d00ba88ae Submodule qtwebengine-chromium.git: Branch: 87-based Commit: 8c0a9b4459f5200a24ab9e687a3fb32e975382e5 Fixes build on arm64. Bug: https://bugs.gentoo.org/815397 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20211015 snapshot bump w/o keywords
Snapshotted at: Branch: 5.15 Commit: 5f6a292bc53b9adf14c0e45a7de226a56449dbca Submodule qtwebengine-chromium.git: Branch: 87-based Commit: d33026ed7c5f25bd0c7936963021936148015522 - Add missing PYTHON_REQ_USE="xml(+)" - Add pdfium-system-lcms2 patch - Drop obsolete GCC-11 patch - Replace media-libs/{mesa -> libglvnd} in DEPEND - Docu: Add upstream link for version downpatch rationale Bug: https://bugs.gentoo.org/818217 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: add Fedora patch for >= harfbuzz 3
I'd like to add the patches Google used for Chromium but we know this one works and I'd like the tree to be in a working state. Can swap patches later. Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop vulnerable 5.15.2_p20210625
Bug: https://bugs.gentoo.org/810781 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2_p20210824-r1 arm64, #811441
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2_p20210824-r1 amd64, #811441
Signed-off-by: Sam James <sam@gentoo.org>
Davide Pesavento · gentoo
dev-qt/qtwebengine: usex -> qt_use
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix .qmake.conf
Bug: https://bugs.gentoo.org/811441 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-qt/qtwebengine: x86 stable wrt bug #811441
Package-Manager: Portage-3.0.20, Repoman-3.0.3 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix build with GLIBC-2.34
Thanks-to: Nik <nik_cro@abv.bg> Closes: https://bugs.gentoo.org/811312 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Switch from ~QTVER to =QT5_PV* version deps
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Rebase disable-fatal-warnings.patch
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Support EXTRA_GN env var
Thanks-to: Jannik Glückert <jannik.glueckert@gmail.com> Closes: https://bugs.gentoo.org/774186 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20210824 snapshot bump, EAPI-8 bump
Snapshotted at: Branch: 5.15.6 Commit: 2acbba86362ac3a1c2d8c20390dc263875f8f09c Additional cherry-pick from branch 5.15: Fix crash when clicking on a link in PDF Commit: 7f4a6ff45743cecbfe0dd14ef29afd0874a2ed39 Submodule qtwebengine-chromium.git: Branch: 87-based Commit: 9f71911e38c041cedc5291c5e772b7d03ce8b8c Bug: https://bugs.gentoo.org/810781 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Add missing sys-devel/flex BDEPEND
Reported-by: Joonas Niilola <juippis@gentoo.org> Closes: https://bugs.gentoo.org/810463 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20210421 security cleanup
Bug: https://bugs.gentoo.org/800181 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2_p20210625 arm64, #800181
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2_p20210625 amd64, #800181
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-qt/qtwebengine: x86 stable wrt bug #800181
Package-Manager: Portage-3.0.20, Repoman-3.0.2 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop 5.15.2_p20210521
Overshadowed by 5.15.2_p20210625. Bug: https://bugs.gentoo.org/800181 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Add pkg_preinst() disclaimer
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20210625 snapshot bump
Snapshotted at: Branch: 5.15 Commit: 7b9e9c92286aec8102ab221434e785a1def0af87 Submodule qtwebengine-chromium.git: Branch: 87-based Commit: 0b959ee26c9e4098744021d949d0fc67cc0316d8 Closes: https://bugs.gentoo.org/792054 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
James Beddek · gentoo
dev-qt/qtwebengine: fix build with sys-devel/clang[default-libcxx]
Signed-off-by: James Beddek <telans@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/21337 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20210224 security cleanup
Bug: https://bugs.gentoo.org/787950 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2_p20210421 arm64, #787950
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2_p20210421 amd64, #787950
Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2_p20210421 x86, #787950
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20210521 snapshot bump
Snapshotted at: Branch: 5.15 Commit: 2240a3f8ebcd317e11fac446aec14bc004067cd9 Submodule qtwebengine-chromium.git: Branch: 87-based Commit: dc35950b9eed3be05c4dc747720f495148ffe14 QTBUG-91773, ICU-69.1 and (some) GCC-11 fixes are upstream. Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Georgy Yakovlev · gentoo
dev-qt/qtwebengine: dev-util/gn required on ppc64
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop 5.15.2_p20210406
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Backport QTBUG-91773 loadFinished signal fix
Thanks to Arch Linux. See also: https://bugreports.qt.io/browse/QTBUG-91773 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix build with ICU-69.1
Tested-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://bugs.gentoo.org/781236 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Nils Freydank · gentoo
dev-qt/qtwebengine: Move some DEPENDs to BDEPEND
This commit changes two things: 1. Some deps were in DEPEND which are actually CBUILD dependencies, so they're moved into BDEPEND now. 2. DEPEND contained an old gzip dep to a version which is not in the tree anymore. Committer-comment: Fixed DEPEND/BDEPEND, rebased onto 29de6e40, updated git summary accordingly. See also: https://github.com/gentoo/qt/pull/237 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20210406 snapshot bump
Snapshotted at: Branch: 5.15 Commit: 1f3412fa07b524fa7917250ed0cc2661abb9246a Submodule qtwebengine-chromium.git: Branch: 87-based Commit: d13920f28c2f3922e0cf793996ea33d02b81a0a4 Add Fedora patches for GLIBC-2.33 and GCC-11... Bug: https://bugs.gentoo.org/769989 Closes: https://bugs.gentoo.org/768261 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2 security cleanup
Bug: https://bugs.gentoo.org/773040 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Georgy Yakovlev · gentoo
dev-qt/qtwebengine: restore ppc64 keyword for 5.15.2_p20210224
add new patchet, based on chromium-87 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Alec Moskvin · gentoo
dev-qt/qtwebengine: depend on net-libs/nodejs[ssl]
Closes: https://github.com/gentoo/gentoo/pull/20021 Closes: https://bugs.gentoo.org/777405 Signed-off-by: Alec Moskvin <alecm@gmx.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix runtime crash with certain locales
Due to the pain a revbump will cause and only a minority of users affected, the patch is applied in place and we will ask affected users to rebuild. Reported-by: 12101111 <w12101111@outlook.com> Thanks-to: Florian Bruhin <gentoo.org@the-compiler.org> Bug: https://bugs.gentoo.org/757606 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Arfrever Frehtes Taifersar Arahesis · gentoo
dev-qt/qtwebengine: Set correct QT5_BUILD_DIR.
Closes: https://bugs.gentoo.org/775275 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2_p20210224 arm64, #773040
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2_p20210224 amd64, #773040
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
dev-qt/qtwebengine: x86 stable (bug #773040)
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop 5.15.2_p20210205
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20210224 bump
Snapshotted at: Branch: 5.15 Commit: 0b5f110234256eabaa264189d9117069f2a2d144 Submodule qtwebengine-chromium.git: Branch: 87-based Commit: 0eea95b24a9ed61c185adeeb787fb5b62e8f4537 V8-ICU-68 runtime fix: Thanks-to: Stephan Hartmann <sultan@gentoo.org> Bug: https://bugs.gentoo.org/773040 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20210220 bump, no KEYWORDS for now
Snapshotted at: Branch: 5.15 Commit: 0b5f110234256eabaa264189d9117069f2a2d144 Submodule qtwebengine-chromium.git: Branch: 87-based Commit: d77379c520980bea4f53e093c0a130d57155c2ad V8-ICU-68 runtime fix: Thanks-to: Stephan Hartmann <sultan@gentoo.org> Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20210421 bump, fix build with GCC-11
Snapshotted at: Branch: 5.15.4 Commit: 0d4ca9cfb0d6e538172005e1c4b0b3a021b1c18c Submodule qtwebengine-chromium.git: Branch: 87-based Commit: 3f594ea1afb8b18c864715a796ef21099d432a13 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Georgy Yakovlev · gentoo
dev-qt/qtwebengine: drop ~ppc64 keyword from snapshot
needs patches rebased, keywords will be re-added later. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Restore KEYWORDS
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop 5.15.2_p20210126 snapshot
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20210205 snapshot bump
Snapshotted at: Branch: 5.15 Commit: a4fce092cbd877560dd75b38a2e495aaa75f60f3 Submodule qtwebengine-chromium.git: Branch: 87-based Commit: 19c6bab869563fc97a5047eeea6eed7992458af8 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.15.2_p20210126 snapshot bump w/o KEYWORDS
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Security cleanup
Bug: https://bugs.gentoo.org/754852 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2 amd64, #754852
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2 x86, #754852
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.2 arm64, #754852
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix V8 runtime issues with ICU-68
Thanks-to: Stephan Hartmann <sultan@gentoo.org> Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Georgy Yakovlev · gentoo
dev-qt/qtwebengine: prevent git from running in src_prepare on ppc64
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Georgy Yakovlev · gentoo
dev-qt/qtwebengine: refresh ppc64le patch for 5.15.2
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.15.2
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix build with ICU-68
Thanks-to: Lars Wendler <polynomial-c@gentoo.org> Closes: https://bugs.gentoo.org/751997 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
dev-qt/qtwebengine: x86 stable (bug #734600)
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.14.2
Bug: https://bugs.gentoo.org/734600 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.1 amd64, #734600
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-qt/qtwebengine: Stabilize 5.15.1 arm64, #734600
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Stephan Hartmann · gentoo
dev-qt/qtwebengine: add use default for libvpx dependency
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Stephan Hartmann <sultan@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/17752 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.15.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
dev-qt/qtwebengine: fix building with >=bison-3.7
Closes: https://bugs.gentoo.org/740580 Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.15.1
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jimi Huotari · gentoo
dev-qt/qtwebengine: fix build with >=bison-3.7
Backport commit from Qt upstream [1]. 1. https://code.qt.io/cgit/qt/qtwebengine-chromium.git/commit/?h=80-based&id=1a53f599 Reported-by: Toralf Förster <toralf@gentoo.org> Thanks-to: YOSHIOKA Takuma <lo73741824@hard-wi.red> Closes: https://bugs.gentoo.org/734356 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/17171 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.14.1 and vulnerable dev-qt/qtgui
Bug: https://bugs.gentoo.org/719732 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Georgy Yakovlev · gentoo
dev-qt/qtwebengine: add ~ppc64 keyword and patchset
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Acked-by: Andreas Sturmlechner <asturm@gentoo.org> Reviewed-by: Davide Pesavento <pesa@gentoo.org> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.15.0 release
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-qt/qtwebengine: arm64 stable wrt bug #719732
Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="arm64" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-qt/qtwebengine: x86 stable wrt bug #719732
Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="x86" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-qt/qtwebengine: amd64 stable wrt bug #719732
Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="amd64" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Update gcc-10.patch
Additionally includes patch to decoding_state.h. Thanks-to: Jimi Huotari <chiitoo@gentoo.org> Bug: https://bugs.gentoo.org/721876 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix build with GCC-10
Thanks-to: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Lars Wendler · gentoo
dev-qt/qtwebengine: Fixed build with icu-67
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop vulnerable 5.13.2
Effectively dropping package without revdeps back to ~arm. Bug: https://bugs.gentoo.org/713900 Bug: https://bugs.gentoo.org/699328 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Arfrever Frehtes Taifersar Arahesis · gentoo
dev-qt/qtwebengine: Fix using generated headers
Closes: https://bugs.gentoo.org/717122 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.14.2
Closes: https://bugs.gentoo.org/669994 Closes: https://bugs.gentoo.org/710866 Closes: https://bugs.gentoo.org/713722 Closes: https://bugs.gentoo.org/716754 Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Security cleanup Qt 5.13.2 all KEYWORDS except for arm/~arm
Drop all packages ending up without KEYWORDS. Bug: https://bugs.gentoo.org/699328 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-qt/qtwebengine: arm64 stable (bug #699328)
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Detect >=dev-util/ninja-1.10
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.12.3
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-qt/qtwebengine: x86 stable wrt bug #699328
Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-qt/qtwebengine: amd64 stable wrt bug #699328
Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Stephan Hartmann · gentoo
dev-qt/qtwebengine: fix building on x86
Closes: https://bugs.gentoo.org/695446 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Stephan Hartmann <stha09@googlemail.com> Closes: https://github.com/gentoo/gentoo/pull/14598 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: pax_kernel is dead
Closes: https://bugs.gentoo.org/708676 Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Drop arm from 5.12.3
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Mikle Kolyada · gentoo
dev-qt/qtwebengine: arm stable wrt bug #699240
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Jimi Huotari · gentoo
dev-qt/qtwebengine: Re-add USE geolocation
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> (cherry picked from commit 7064af6a1dceefb550fcc9c43ba9ccfbff2c5187) Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Drop 5.14.0
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: 5.14.1 version bump
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt: Drop all KEYWORDS from 5.12.3 except arm, x86
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt: Drop 5.12.5
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.12.3: Use pulseaudio-13 patch from 5.12.5
Tested-by: Douglas Paul <doug-gentoo@bogon.ca> Closes: https://bugs.gentoo.org/705434 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.12.3: Use ICU-65 patch from 5.12.5
Reported-by: Thomas Deutschmann <whissi@gentoo.org> Closes: https://bugs.gentoo.org/705180 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
dev-qt/qtwebengine: arm64 stable (bug #699240)
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.82, Repoman-2.3.20
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.14.0
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-qt/qtwebengine: amd64 stable wrt bug #699240
Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
dev-qt/qtwebengine: arm64 stable (bug #691738)
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.79, Repoman-2.3.18
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.13.2
Closes: https://bugs.gentoo.org/689016 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix build against ICU-65
Tested-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-qt/qtwebengine: amd64 stable wrt bug #691738
Package-Manager: Portage-2.3.76, Repoman-2.3.16 RepoMan-Options: --include-arches="amd64" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop obsolete patch, already upstreamed in 5.12.5
Fix applied in slightly different place, upstream commit 6e2562dd1efff2b96848e8ec166e8c233029d6cc Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.12.4
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix build with >=media-sound/pulseaudio-13.0
Reported-by: Guy <defuebr@gmail.com> Tested-by: josef64 in #gentoo-qt IRC Closes: https://bugs.gentoo.org/694960 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.12.5
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix build with >=linux-headers-5.2
Tested-by: Aaron Bauman <bman@gentoo.org> Closes: https://bugs.gentoo.org/692352 Package-Manager: Portage-2.3.74, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.12.4
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Philipp Ammann · gentoo
*/*: Depend on media-libs/mesa[X(+)]
This changes any package that depends on media-libs/mesa (though not virtual/opengl) to depend on media-libs/mesa[X(+)] instead. Bug: https://bugs.gentoo.org/560096 Signed-off-by: Philipp Ammann <philipp.ammann@posteo.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.11.3
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
dev-qt/qtwebengine: arm64 stable
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.12 RepoMan-Options: --include-arches="arm64"
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-qt/qtwebengine: arm stable wrt bug #685260
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="arm"
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-qt/qtwebengine: x86 stable wrt bug #685260
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="x86"
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-qt/qtwebengine: amd64 stable wrt bug #685260
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
Repository mirror & CI · gentoo
Merge updates from master
Anthony G. Basile · gentoo
dev-qt/qtwebengine: stable on arm
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Michael Palimaka · gentoo
dev-qt/qtwebengine: remove unused dependency
Closes: https://bugs.gentoo.org/610836 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Block broken sys-devel/binutils-2.31.1-r5
Thanks-to: Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com> Closes: https://bugs.gentoo.org/683794 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.12.2
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.12.3
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.12.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.12.2
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.12.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.11.1
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Restrict to <media-libs/libvpx-1.8
Bug: https://bugs.gentoo.org/677612 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-qt/qtwebengine: x86 stable wrt bug #670864
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Mikle Kolyada · gentoo
dev-qt/qtwebengine: amd64 stable wrt bug #670864
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.11.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.9.6
5.11.1 is stable for some time, with 5.11.3 already being prepared. We did not bother to bump 5.9.7 anymore, and there are several sec fixes in these later versions. Depends on app-misc/geoclue:0 to be removed from repo. Does not build against >=OpenSSL-1.1. Does not build against >=ffmpeg-4. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.11.3
Bug: https://bugs.gentoo.org/670864 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Add missing DEPEND
Bug: https://bugs.gentoo.org/669642 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Update paxmark-mksnapshot patches for 5.11.{1,2}
Reported-by: Han <jkmls@outlook.com> Thanks-to: Attila Tóth <atoth@atoth.sote.hu> Thanks-to: Miroslaw Mieszczak <gentoo@mieszczak.com.pl> Closes: https://bugs.gentoo.org/670852 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix x86 build with GCC-8 (again)
Closes: https://bugs.gentoo.org/657124 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Re-drop net-libs/libsrtp DEPEND
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.11.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
dev-qt/qtwebengine: x86 stable (bug #664566)
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-qt/qtwebengine: amd64 stable wrt bug #664566
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop net-libs/libsrtp DEPEND
It is currently not supported to unbundle from chromium source. Package-Manager: Portage-2.3.49, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.9.4
Closes: https://bugs.gentoo.org/609752 Closes: https://bugs.gentoo.org/652508 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
dev-qt/qtwebengine: x86 stable (bug #655664)
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Raise system-icu dependency to >=ICU-60.2
Closes: https://bugs.gentoo.org/660418 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-qt/qtwebengine: amd64 stable wrt bug #655664
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop unused dependency
(Unfortunately) it currently uses chromium's bundled protobuf. Thanks-to: Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com> Bug: https://bugs.gentoo.org/660586 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Restrict to <ffmpeg-4
Closes: https://bugs.gentoo.org/654744 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Drop 5.9.6 (r0)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Disable GPU when using nouveau
Kindly borrowed from opensuse (disable-gpu-when-using-nouveau-boo-1005323.diff). Bug: https://bugs.gentoo.org/609752 Bug: https://bugs.gentoo.org/609752 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Add missing mesa[egl] use dep
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix x86 build with GCC-8
Closes: https://bugs.gentoo.org/657124 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.11.0_rc2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.11.1 (masked)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.9.5
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Arfrever Frehtes Taifersar Arahesis · gentoo
dev-qt/qtwebengine: Add "designer" USE flag
Bug: https://bugs.gentoo.org/652508
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.9.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.11.0_rc (1)
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.11.0_rc2
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix build without dev-qt/qtlocation
Thanks-to: Jimi Huotari <chiitoo@gentoo.org> Tested-by: josef64 (via irc #gentoo-qt) Package-Manager: Portage-2.3.36, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.11.0_beta4
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.11.0_rc
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.7.1
De-stabilising arm. Bug: https://bugs.gentoo.org/642822 Bug: https://bugs.gentoo.org/653986 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt: Add Qt 5.11.0_beta4, masked
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Andreas Sturmlechner · gentoo
dev-qt: 5.9.5 version bump
Package-Manager: Portage-2.3.28, Repoman-2.3.9
kermeat · gentoo
dev-qt/qtwebengine: fix dependencies
skip build if mesa without egl: "khronos development headers appear to be missing (mesa/libegl1-mesa-dev)" Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7683
Michael Palimaka · gentoo
dev-qt: stabilise 5.9.4 for amd64/x86
Bug: https://bugs.gentoo.org/642822 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix build with jpeg-9
Closes: https://bugs.gentoo.org/607424 Closes: https://bugs.gentoo.org/646456 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Michael Palimaka · gentoo
dev-qt: remove 5.9.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Michael Palimaka · gentoo
dev-qt: version bump 5.9.4
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: 5.7.1-r2: Switch off USE=system-icu, fix dep
Fix build and ease dependency resolution with a future stable icu-60.2. Bug: https://bugs.gentoo.org/618648 Package-Manager: Portage-2.3.21, Repoman-2.3.6
Michael Palimaka · gentoo
dev-qt/qtwebengine: dev-libs/libxml2 must be build with USE="icu"
Closes: https://bugs.gentoo.org/644602 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Michael Palimaka · gentoo
dev-qt/qtwebengine: add missing dependency
Closes: https://bugs.gentoo.org/638998 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Michael Palimaka · gentoo
dev-qt/qtwebengine: add missing USE dependency
Closes: https://bugs.gentoo.org/638872 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Michael Palimaka · gentoo
dev-qt: remove 5.9.2
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Magnus Granberg · gentoo
dev-qt/qtwebengine: fix build on pax kernel
Closes: https://bugs.gentoo.org/634220 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Andreas Sturmlechner · gentoo
dev-qt/qtwebengine: Fix build with >=ICU-60
Closes: https://bugs.gentoo.org/639220 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Michael Palimaka · gentoo
dev-qt/qtwebengine: add missing dependency
Closes: https://bugs.gentoo.org/639026 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Michael Palimaka · gentoo
dev-qt: version bump 5.9.3
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Andreas Sturmlechner · gentoo
dev-qt: Drop Qt 5.6.2, de-stabilise hppa
Closes: https://github.com/gentoo/gentoo/pull/6077 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Michael Palimaka · gentoo
dev-qt/qtwebengine: add missing dependency
Closes: https://bugs.gentoo.org/633750 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Michael Palimaka · gentoo
dev-qt: version bump 5.9.2
Bug: https://bugs.gentoo.org/625258 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Chí-Thanh Christopher Nguyễn · gentoo
dev-qt/qtwebengine: keyword ~arm
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Sergey Alirzaev · gentoo
dev-qt/qtwebengine: := dep on app-arch/snappy
libsnappy.so.1.1.5: cannot open shared object file: No such file or directory Closes: https://github.com/gentoo/gentoo/pull/5115
Agostino Sarubbo · gentoo
dev-qt/qtwebengine: x86 stable wrt bug #620334
Package-Manager: Portage-2.3.6, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
dev-qt/qtwebengine: amd64 stable wrt bug #620334
Package-Manager: Portage-2.3.6, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Alexis Ballier · gentoo
dev-qt/qtwebengine: keyword ~arm64
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Michael Palimaka · gentoo
dev-qt/qtwebengine: die if nothing is built
Gentoo-bug: 601472 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Arfrever Frehtes Taifersar Arahesis · gentoo
dev-qt/qtwebengine: allow NINJAFLAGS to be overridden
Gentoo-bug: 592660 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Michael Palimaka · gentoo
dev-qt/qtwebengine: assorted fixes
* Add missing dependencies * Remove unused dependencies * Fix build with GCC 7 * Respect MAKEOPTS * Make build log verbose Gentoo-bug: 590920 Gentoo-bug: 592660 Gentoo-bug: 610830 Gentoo-bug: 610834 Gentoo-bug: 610848 Gentoo-bug: 610860 Gentoo-bug: 617896 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Michael Palimaka · gentoo
dev-qt/qtwebengine: remove 5.7.1-r0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Davide Pesavento · gentoo
dev-qt: drop Qt 5.6.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Jimi Huotari · gentoo
dev-qt/qtwebengine: fix detecting audio backends
The upstream change doesn't really work for us, so we'll make it work with us. http://code.qt.io/cgit/qt/qtwebengine.git/commit/?id=cf7d82a79dff4ea5c53e0908ed5c13ce1f87796d Closes: https://github.com/gentoo/gentoo/pull/3219 Gentoo-Bug: https://bugs.gentoo.org/603498 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Davide Pesavento · gentoo
dev-qt/qtwebengine: fix typo in comment
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Michael Palimaka · gentoo
dev-qt: remove 5.7.0
Package-Manager: portage-2.3.3
Michael Palimaka · gentoo
dev-qt: version bump 5.7.1
Package-Manager: portage-2.3.3
Michael Palimaka · gentoo
dev-qt: stabilise 5.6.2 for amd64/x86
Gentoo-bug: 598780 Package-Manager: portage-2.3.2
Michael Palimaka · gentoo
dev-qt/qtwebengine: ensure build against system icu headers
Gentoo-bug: 601264 Package-Manager: portage-2.3.2
Aric Belsito · gentoo
dev-qt/qtwebengine: Use correct libsrtp slot.
Aric Belsito · gentoo
dev-qt/qtwebengine: Fix on PaX kernels
Gentoo-Bug: 582558 Gentoo-Bug: 579712
Aric Belsito · gentoo
dev-qt/qtwebengine: Add patches.
qtwebengine-5.7.0-fix-system-ffmpeg.patch undefines FF_API_CONVERGENCE_DURATION, which should only be defined when not using the system ffmpeg. This causes segmentation faults at runtime with FFMPEG 3.x qtwebengine-5.7.0-gcc6.patch is adapted from http://code.qt.io/cgit/qt/qtwebengine-chromium.git/commit/?id=cffcf22082879939bbcfa89e88057beda829a0a7 http://code.qt.io/cgit/qt/qtwebengine-chromium.git/commit/?id=ae73e50e7d8c1371ed293c10150646a2719f4598 http://code.qt.io/cgit/qt/qtwebengine.git/commit/?id=c7aeb3b03ecce75c40d3f53352e8b7b3a4d6d050 http://code.qt.io/cgit/qt/qtwebengine.git/commit/?id=d6c8a2cf8fa374e6d1c0a578391b57112c047fa4 qtwebengine-5.7.0-icu58.patch is adapted from www-client/chromium/files/chromium-icu-58.patch qtwebengine-5.7.0-undef-madv_free.patch is adapted from http://code.qt.io/cgit/qt/qtwebengine-chromium.git/commit/?id=fa8cdb3a32c377b6290d0a92d2522186bcd48293 Gentoo-Bug: 599094
Davide Pesavento · gentoo
dev-qt: Qt 5.6.2 version bump
Package-Manager: portage-2.3.1
Michael Palimaka · gentoo
dev-qt/qtwebengine: relax media-video/ffmpeg dependency for 5.7.0
Package-Manager: portage-2.3.0
Michael Palimaka · gentoo
dev-qt: remove 5.6.0
Package-Manager: portage-2.3.0
Michael Palimaka · gentoo
dev-qt: version bump 5.7.0
Package-Manager: portage-2.3.0
Michael Palimaka · gentoo
dev-qt: stabilise 5.6.1 on amd64/x86
Gentoo-bug: 586180 Package-Manager: portage-2.3.0
Davide Pesavento · gentoo
dev-qt: Qt 5.6.1 version bump
Package-Manager: portage-2.3.0_rc1
Davide Pesavento · gentoo
dev-qt/qtwebengine: add a few missing deps and several slot operators
Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
dev-qt: version bump 5.6.0
Package-Manager: portage-2.2.28