dev-ruby / drb

Distributed object system for Ruby

Official package sites : https://github.com/ruby/drb ·

v2.2.1 :: 0 :: gentoo

Modified
License
BSD-2
Keywords
~alpha ~amd64 ~amd64-linux ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc-macos ~ppc64 ~riscv ~s390 ~sparc ~x64-macos ~x64-solaris ~x86 ~x86-linux
USE flags
doc test

v2.2.0 :: 0 :: gentoo

Modified
License
BSD-2
Keywords
~alpha ~amd64 ~amd64-linux ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc-macos ~ppc64 ~riscv ~s390 ~sparc ~x64-macos ~x64-solaris ~x86 ~x86-linux
USE flags
doc test

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

ruby_targets

ruby31
Build with MRI Ruby 3.1.x
ruby32
Build with MRI Ruby 3.2.x
ruby33
Build with MRI Ruby 3.3.x

dev-lang / ruby : An object-oriented scripting language

virtual / rubygems : Virtual ebuild for rubygems

dev-lang / ruby : An object-oriented scripting language

dev-ruby / ruby2_keywords : Shim library for Module#ruby2_keywords

virtual / rubygems : Virtual ebuild for rubygems

dev-ruby / activesupport : Utility Classes and Extension to the Standard Library

923384
dev-ruby/drb-2.2.0 fails tests: kernel_require.rb:127:in require: cannot load such file core_assertions (LoadError)
Repository mirror & CI · gentoo
Merge updates from master
Hans de Graaff · gentoo
dev-ruby/drb: add 2.2.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Hans de Graaff · gentoo
dev-ruby/drb: enable ruby33
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Hans de Graaff · gentoo
dev-ruby/drb: drop 2.1.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Hans de Graaff · gentoo
dev-ruby/drb: add 2.2.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Hans de Graaff · gentoo
dev-ruby/drb: new package, add 2.1.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>