dev-ruby / ffi-compiler

Ruby FFI Rakefile generator

Official package sites : https://github.com/ffi/ffi/wiki ·

v1.0.1 :: 0 :: gentoo

Modified
License
Apache-2.0
Keywords
~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86
USE flags
doc test

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

ruby_targets

ruby26
Build with MRI Ruby 2.6.x
ruby27
Build with MRI Ruby 2.7.x

dev-lang / ruby : An object-oriented scripting language

virtual / rubygems : Virtual ebuild for rubygems

dev-lang / ruby : An object-oriented scripting language

dev-ruby / ffi : Ruby extension for programmatically loading dynamic libraries

dev-ruby / rake : Make-like scripting in Ruby

virtual / rubygems : Virtual ebuild for rubygems

Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-ruby/ffi-compiler: Keyword 1.0.1 ppc64, #761550
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-ruby/ffi-compiler: Keyword 1.0.1 x86, #761550
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-ruby/ffi-compiler: Keyword 1.0.1 arm64, #761550
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-ruby/ffi-compiler: Keyword 1.0.1 arm, #761550
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Rolf Eike Beer · gentoo
dev-ruby/ffi-compiler: keyworded 1.0.1 for sparc, bug #761550
Package-Manager: Portage-3.0.12, Repoman-3.0.2 RepoMan-Options: --include-arches="sparc" Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Rolf Eike Beer · gentoo
dev-ruby/ffi-compiler: keyworded 1.0.1 for hppa, bug #761550
Package-Manager: Portage-3.0.12, Repoman-3.0.2 RepoMan-Options: --include-arches="hppa" Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Hans de Graaff · gentoo
dev-ruby/ffi-compiler: initial import of 1.0.1
Imported from graaff overlay. Dependency for forthcoming dev-ruby/http-parser. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>