dev-ruby / metasploit-payloads

Compiled binaries for Metasploit's Meterpreter

Official package sites : https://rubygems.org/gems/metasploit-payloads ·

v1.3.53 :: 1.3.53 :: gentoo

Modified
License
BSD
Keywords
~amd64 ~arm ~x86
USE flags
test

General

test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

ruby_targets

ruby24
Build with MRI Ruby 2.4.x

dev-lang / ruby : An object-oriented scripting language

dev-ruby / rake : Make-like scripting in Ruby

virtual / rubygems : Virtual ebuild for rubygems

dev-lang / ruby : An object-oriented scripting language

virtual / rubygems : Virtual ebuild for rubygems

net-analyzer / metasploit : Advanced framework for developing, testing, and using vulnerability exploit code

Repository mirror & CI · gentoo
Merge updates from master
Hans de Graaff · gentoo
dev-ruby/metasploit-payloads: cleanup ruby23-only versions
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Hans de Graaff · gentoo
dev-ruby/metasploit-payloads: cleanup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: bump for metasploit
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: bump and minor cleanup
Package-Manager: portage-2.3.0
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: bump
Package-Manager: portage-2.3.0_rc1
Ian Delaney · gentoo
Merge remote-tracking branch 'remotes/jasom/master'
Pull request: https://github.com/gentoo/gentoo/pull/725
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: version bump for new snapshot
Package-Manager: portage-2.2.27
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: drop ruby19 and fix copyright year
Package-Manager: portage-2.2.27
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: cleanup and bump
Package-Manager: portage-2.2.27
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: bump
Package-Manager: portage-2.2.26
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: version bump for msf live
Package-Manager: portage-2.2.26
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: re-add 1.0.15 for new snapshot
Package-Manager: portage-2.2.23
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: version bump
Package-Manager: portage-2.2.23
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: remove get_libdir in global scope to avoid possible metadata variance
Package-Manager: portage-2.2.23
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: add || die to the cat
Package-Manager: portage-2.2.23
Manuel Rüger · gentoo
dev-ruby/metasploit-payloads: Fix header
Package-Manager: portage-2.2.23
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: add support for ruby22
Package-Manager: portage-2.2.22
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: import version bump from pentoo
Package-Manager: portage-2.2.22
Hans de Graaff · gentoo
dev-ruby/metasploit-payloads: ruby22
Package-Manager: portage-2.2.20.1
Justin Lecher · gentoo
Fix Malformed Id header on line: 3
Convert Header to Id Signed-off-by: Justin Lecher <jlec@gentoo.org>
Zero_Chaos · gentoo
dev-ruby/metasploit-payloads: restrict strip, it makes no sense for this package of precompiled binaries and causes collisions
Zero_Chaos · gentoo
net-analyzer/metasploit: add a modern version of metasploit (and a ton of deps for it)