dev-ruby / postgres_ext

Native PostgreSQL data types and querying extensions for ActiveRecord and Arel

Official package sites : https://github.com/dockyard/postgres_ext ·

v3.0.1 :: 3 :: gentoo (Masked by set 3905)

Modified
License
BSD
Keywords
~amd64 ~arm ~x86
USE flags
doc test

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

ruby_targets

ruby24
Build with MRI Ruby 2.4.x

dev-lang / ruby : An object-oriented scripting language

dev-ruby / activerecord : Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM

dev-ruby / arel : Arel is a Relational Algebra for Ruby

dev-ruby / bundler : An easy way to vendor gem dependencies

dev-ruby / pg_array_parser : Simple library to parse PostgreSQL arrays into a array of strings

dev-ruby / rake : Make-like scripting in Ruby

dev-ruby / rdoc : An extended version of the RDoc library from Ruby 1.8

virtual / rubygems : Virtual ebuild for rubygems

dev-lang / ruby : An object-oriented scripting language

dev-ruby / activerecord : Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM

dev-ruby / arel : Arel is a Relational Algebra for Ruby

dev-ruby / pg_array_parser : Simple library to parse PostgreSQL arrays into a array of strings

virtual / rubygems : Virtual ebuild for rubygems

dev-ruby / metasploit_data_models : The database layer for Metasploit

688696
dev-ruby/postgres_ext-3.0.1 : sandbox issue

3905
Hans de Graaff
Old ruby24-only rails version that is no longer supported upstream and has known security issues, including dependencies and slots specific to Rails 4.2. Migrate to Rails 5.2. Masked for removal in 30 days. Metasploit is a reverse dependency on Rails 4.2 Upstream shows no sign of moving to a supported Rails version. Metasploit will most likely be moved to an overlay.
  • dev-ruby/actionmailer:4.2
  • dev-ruby/actionpack-xml_parser:0
  • dev-ruby/actionpack:4.2
  • dev-ruby/actionview:4.2
  • dev-ruby/activejob:4.2
  • dev-ruby/activemodel:4.2
  • dev-ruby/activerecord:4.2
  • dev-ruby/activesupport:4.2
  • dev-ruby/arel:6.0
  • dev-ruby/jquery-rails:3
  • dev-ruby/metasploit-concern
  • dev-ruby/metasploit-credential
  • dev-ruby/metasploit-model
  • dev-ruby/metasploit_data_models
  • dev-ruby/postgres_ext
  • dev-ruby/protected_attributes
  • dev-ruby/rails-dom-testing:1
  • dev-ruby/rails:4.2
  • dev-ruby/railties:4.2
  • dev-ruby/rex-arch
  • dev-ruby/rex-bin_tools
  • dev-ruby/rex-core
  • dev-ruby/rex-encoder
  • dev-ruby/rex-exploitation
  • dev-ruby/rex-java
  • dev-ruby/rex-mime
  • dev-ruby/rex-nop
  • dev-ruby/rex-ole
  • dev-ruby/rex-powershell
  • dev-ruby/rex-random_identifier
  • dev-ruby/rex-registry
  • dev-ruby/rex-rop_builder
  • dev-ruby/rex-socket
  • dev-ruby/rex-sslscan
  • dev-ruby/rex-struct2
  • dev-ruby/rex-text
  • dev-ruby/rex-zip
  • dev-ruby/web-console:0
  • net-analyzer/metasploit
Repository mirror & CI · gentoo
Merge updates from master
Zero_Chaos · gentoo
dev-ruby/postgres_ext: x86
cleanup qa warning Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Hans de Graaff · gentoo
dev-ruby/postgres_ext: cleanup
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Hans de Graaff · gentoo
dev-ruby/postgres_ext: fix dependency on rails, bug 653430
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Hans de Graaff · gentoo
dev-ruby/postgres_ext: add 3.0.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Hans de Graaff · gentoo
dev-ruby/postgres_ext: remove masked version
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Hans de Graaff · gentoo
dev-ruby/postgres_ext: drop x86 for rails 4.2 cleanup
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Hans de Graaff · gentoo
dev-ruby/postgres_ext: drop redundant SRC_URI
Package-Manager: portage-2.3.3
Hans de Graaff · gentoo
dev-ruby/postgres_ext: drop activerecord:4.1, ruby20
Package-Manager: portage-2.3.3
Hans de Graaff · gentoo
dev-ruby/postgres_ext: add 3.0.0
Package-Manager: portage-2.2.28
Hans de Graaff · gentoo
dev-ruby/postgres_ext: add ruby22, fix USE=doc
Package-Manager: portage-2.2.28
Hans de Graaff · gentoo
dev-ruby/postgres_ext: shorten description to avoid warnings
Package-Manager: portage-2.2.28
Hans de Graaff · gentoo
dev-ruby/postgres_ext: drop ruby19
Package-Manager: portage-2.2.28
Hans de Graaff · gentoo
dev-ruby/postgres_ext: drop rails 4.0 dependency in preparation of masking it
Package-Manager: portage-2.2.28
Justin Lecher · gentoo
Fix Malformed Id header on line: 3
Convert Header to Id Signed-off-by: Justin Lecher <jlec@gentoo.org>
Zero_Chaos · gentoo
Revert "net-analyzer/metasploit (and deps): Revert "re-add ~arm keyword""
This reverts commit 8bdbfab2f6bedacee6cb37559ce5cb63aba7a285. Not trying to be rude here, just the easiest way to readd this commit it to revert the revert.
Michał Górny · gentoo
net-analyzer/metasploit (and deps): Revert "re-add ~arm keyword"
This causes issue due to a number of non-keyworded dependencies. Reverts: 3270b7eb07 (net-analyzer/metasploit (and deps): re-add ~arm keyword)
Zero_Chaos · gentoo
net-analyzer/metasploit (and deps): re-add ~arm keyword
Zero_Chaos · gentoo
dev-ruby/postgres_ext: fix to include activerecord:4.0
Zero_Chaos · gentoo
net-analyzer/metasploit: add a modern version of metasploit (and a ton of deps for it)