dev-ruby / rex-rop_builder

Ruby Exploitation(Rex) Library for building ROP chains

Official package sites : https://rubygems.org/gems/rex-rop_builder ·

v0.1.3 :: 0 :: gentoo (Masked by set 3905)

Modified
License
BSD
Keywords
~amd64 ~arm ~x86
USE flags
test

General

test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

ruby_targets

ruby24
Build with MRI Ruby 2.4.x
ruby25
Build with MRI Ruby 2.5.x
ruby26
Build with MRI Ruby 2.6.x

dev-lang / ruby : An object-oriented scripting language

dev-ruby / metasm : cross-architecture assembler, disassembler, linker, and debugger

dev-ruby / rake : Make-like scripting in Ruby

dev-ruby / rex-core : Core libraries required for the Ruby Exploitation(Rex) Suite

dev-ruby / rex-text : Rex library for text generation and manipulation

virtual / rubygems : Virtual ebuild for rubygems

dev-lang / ruby : An object-oriented scripting language

dev-ruby / metasm : cross-architecture assembler, disassembler, linker, and debugger

dev-ruby / rex-core : Core libraries required for the Ruby Exploitation(Rex) Suite

dev-ruby / rex-text : Rex library for text generation and manipulation

virtual / rubygems : Virtual ebuild for rubygems

net-analyzer / metasploit : Advanced framework for developing, testing, and using vulnerability exploit code


3905
Hans de Graaff
Old ruby24-only rails version that is no longer supported upstream and has known security issues, including dependencies and slots specific to Rails 4.2. Migrate to Rails 5.2. Masked for removal in 30 days. Metasploit is a reverse dependency on Rails 4.2 Upstream shows no sign of moving to a supported Rails version. Metasploit will most likely be moved to an overlay.
  • dev-ruby/actionmailer:4.2
  • dev-ruby/actionpack-xml_parser:0
  • dev-ruby/actionpack:4.2
  • dev-ruby/actionview:4.2
  • dev-ruby/activejob:4.2
  • dev-ruby/activemodel:4.2
  • dev-ruby/activerecord:4.2
  • dev-ruby/activesupport:4.2
  • dev-ruby/arel:6.0
  • dev-ruby/jquery-rails:3
  • dev-ruby/metasploit-concern
  • dev-ruby/metasploit-credential
  • dev-ruby/metasploit-model
  • dev-ruby/metasploit_data_models
  • dev-ruby/postgres_ext
  • dev-ruby/protected_attributes
  • dev-ruby/rails-dom-testing:1
  • dev-ruby/rails:4.2
  • dev-ruby/railties:4.2
  • dev-ruby/rex-arch
  • dev-ruby/rex-bin_tools
  • dev-ruby/rex-core
  • dev-ruby/rex-encoder
  • dev-ruby/rex-exploitation
  • dev-ruby/rex-java
  • dev-ruby/rex-mime
  • dev-ruby/rex-nop
  • dev-ruby/rex-ole
  • dev-ruby/rex-powershell
  • dev-ruby/rex-random_identifier
  • dev-ruby/rex-registry
  • dev-ruby/rex-rop_builder
  • dev-ruby/rex-socket
  • dev-ruby/rex-sslscan
  • dev-ruby/rex-struct2
  • dev-ruby/rex-text
  • dev-ruby/rex-zip
  • dev-ruby/web-console:0
  • net-analyzer/metasploit
Repository mirror & CI · gentoo
Merge updates from master
Hans de Graaff · gentoo
dev-ruby/rex-rop_builder: add ruby26
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Hans de Graaff · gentoo
dev-ruby/rex-rop_builder: cleanup
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Hans de Graaff · gentoo
dev-ruby/rex-rop_builder: add 0.1.3
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Zero_Chaos · gentoo
dev-ruby/rex-rop_builder: that is all the metasploit deps, for today
Package-Manager: Portage-2.3.5, Repoman-2.3.2