dev-ruby / xdr

Read/write XDR encoded data structures

Official package sites : https://github.com/stellar/ruby-xdr ·

v3.0.0 :: 3.0.0 :: gentoo

Modified
License
Apache-2.0
Keywords
~amd64 ~arm ~x86
USE flags
doc test

v2.0.0 :: 2.0.0 :: gentoo

Modified
License
Apache-2.0
Keywords
~amd64 ~arm ~x86
USE flags
doc test

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

ruby_targets

ruby24
Build with MRI Ruby 2.4.x
ruby25
Build with MRI Ruby 2.5.x
ruby26
Build with MRI Ruby 2.6.x

dev-lang / ruby : An object-oriented scripting language

dev-ruby / activemodel : Toolkit for building modeling frameworks like Active Record and Active Resource

dev-ruby / activesupport : Utility Classes and Extension to the Standard Library

dev-ruby / rdoc : An extended version of the RDoc library from Ruby 1.8

dev-ruby / rspec : A Behaviour Driven Development (BDD) framework for Ruby

virtual / rubygems : Virtual ebuild for rubygems

dev-lang / ruby : An object-oriented scripting language

dev-ruby / activemodel : Toolkit for building modeling frameworks like Active Record and Active Resource

dev-ruby / activesupport : Utility Classes and Extension to the Standard Library

virtual / rubygems : Virtual ebuild for rubygems

net-analyzer / metasploit : Advanced framework for developing, testing, and using vulnerability exploit code

Repository mirror & CI · gentoo
Merge updates from master
Hans de Graaff · gentoo
dev-ruby/xdr: add ruby26
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Hans de Graaff · gentoo
dev-ruby/xdr: fix FEATURES=test
Add ruby as co-maintainer. Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Zero_Chaos · gentoo
dev-ruby/xdr: metasploit needs 2.0.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Zero_Chaos · gentoo
dev-ruby/xdr: fix ruby vers
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Zero_Chaos · gentoo
dev-ruby/xdr: metasploit dep
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>