dev-util / cutter

A Qt and C++ GUI for radare2 reverse engineering framework

Official package sites : https://www.radare.org ·

v1.9.0 :: 0 :: gentoo

Modified
License
GPL-3
Keywords
~amd64 ~x86
USE flags
jupyter webengine

v1.8.2 :: 0 :: gentoo

Modified
License
GPL-3
Keywords
~amd64 ~x86
USE flags
jupyter webengine

v1.8.0 :: 0 :: gentoo

Modified
License
GPL-3
Keywords
~amd64 ~x86
USE flags
jupyter webengine

v1.7.4 :: 0 :: gentoo

Modified
License
GPL-3
Keywords
~amd64 ~x86
USE flags
jupyter webengine

v1.7 :: 0 :: gentoo

Modified
License
GPL-3
Keywords
~amd64 ~x86
USE flags
jupyter webengine

v1.6 :: 0 :: gentoo

Modified
License
GPL-3
Keywords
~amd64 ~x86
USE flags
jupyter webengine

v1.4 :: 0 :: gentoo

Modified
License
GPL-3
Keywords
~amd64 ~x86
USE flags
jupyter webengine

v1.0 :: 0 :: gentoo

Modified
License
GPL-3
Keywords
~amd64 ~x86

General

jupyter
Add support for jupyter notebook
webengine
Use dev-qt/qtwebengine for in-app jupyter browser

python_single_target

python3_6
Build for Python 3.6 only
python3_7
Build for Python 3.7 only

python_targets

python3_6
Build with Python 3.6
python3_7
Build with Python 3.7

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / jupyter : Jupyter metapackage. Install all the Jupyter components in one go

dev-qt / qtcore : Cross-platform application development framework

dev-qt / qtgui : The GUI module and platform plugins for the Qt5 framework

dev-qt / qtnetwork : Network abstraction library for the Qt5 framework

dev-qt / qtsvg : SVG rendering library for the Qt5 framework

dev-qt / qtwebengine : Library for rendering dynamic web content in Qt5 C++ and QML applications

dev-qt / qtwidgets : Set of components for creating classic desktop-style UIs for the Qt5 framework

dev-util / radare2 : unix-like reverse engineering framework and commandline tools

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / jupyter : Jupyter metapackage. Install all the Jupyter components in one go

dev-qt / qtcore : Cross-platform application development framework

dev-qt / qtgui : The GUI module and platform plugins for the Qt5 framework

dev-qt / qtnetwork : Network abstraction library for the Qt5 framework

dev-qt / qtsvg : SVG rendering library for the Qt5 framework

dev-qt / qtwebengine : Library for rendering dynamic web content in Qt5 C++ and QML applications

dev-qt / qtwidgets : Set of components for creating classic desktop-style UIs for the Qt5 framework

dev-util / radare2 : unix-like reverse engineering framework and commandline tools

664660
dev-util/cutter-1.7 build failure: ‘r_core_task_break’ was not declared in this scope
669528
dev-util/cutter-1.7 : src/Cutter.h:429:83: error: R_IO_READ was not declared in this scope
678570
dev-util/cutter-1.7.4 - src/Cutter.cpp:377:5: error: ‘r_core_hash_load’ was not declared in this scope
Repository mirror & CI · gentoo
Merge updates from master
Tact Yoshida · gentoo
dev-util/cutter: version bump to 1.9.0
Closes: https://bugs.gentoo.org/696680 Signed-off-by: Tact Yoshida <otakuto.gentoo@gmail.com> Package-Manager: Portage-2.3.66, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/13207 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-util/cutter: Add missing PYTHON_REQUIRED_USE
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Azamat H. Hackimov · gentoo
dev-util/cutter: version bump to 1.8.2
dev-util/radare2-3.4.1 changed API which breakes compilation of cutter (#684446). This breakage fixed in 1.8.1. Update EAPI to 7. Closes: https://bugs.gentoo.org/684446 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11988 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Rick Farina · gentoo
dev-util/cutter: bump
roughly seems to work, messages during build claim python support is disabled but it appears to link to python anyway so probably just need to patch the message if anyone cares Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Tact Yoshida · gentoo
dev-util/cutter: version bump to 1.7.4.
Signed-off-by: Tact Yoshida <otakuto.gentoo@gmail.com> Package-Manager: Portage-2.3.52, Repoman-2.3.12 Closes: https://github.com/gentoo/gentoo/pull/10900 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Tact Yoshida · gentoo
dev-util/cutter: version bump to 1.7.
Package-Manager: Portage-2.3.44, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9622
Repository mirror & CI · gentoo
Merge updates from master
Tact Yoshida · gentoo
dev-util/cutter: bump to 1.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9257
Repository mirror & CI · gentoo
Merge updates from master
Tact Yoshida · gentoo
dev-util/cutter: bump to version 1.4
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9141
Takuto Yoshida · gentoo
dev-util/cutter: new package
A Qt and C++ GUI for radare2 reverse engineering framework. Closes: https://github.com/gentoo/gentoo/pull/6472 Package-Manager: Portage-2.3.16, Repoman-2.3.6