dev-util / geany-plugins

A collection of different plugins for Geany

Official package sites : https://plugins.geany.org ·

v1.35 :: 0 :: gentoo

Modified
License
GPL-2
Keywords
~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86
USE flags
ctags debugger enchant git gpg gtk3 gtkspell lua markdown multiterm nls pretty-printer python scope soup

v1.34 :: 0 :: gentoo

Modified
License
GPL-2
Keywords
amd64 arm sparc x86 ~alpha ~ia64 ~ppc ~ppc64
USE flags
ctags debugger enchant git gpg gtk3 gtkspell lua markdown multiterm nls pretty-printer python scope soup

v1.30 :: 0 :: gentoo

Modified
License
GPL-2
Keywords
alpha amd64 arm ia64 ppc ppc64 sparc x86
USE flags
autoclose automark commander ctags debugger defineformat enchant git gpg gtk3 gtkspell lua multiterm nls overview python scope soup

General

autoclose
Enable the autoclose plugin.
automark
Enable the automark plugin
commander
Enable the commander plugin which provides a command panel for rapid access to any action.
ctags
Enable ctags plugin
debugger
Enable the debugger plugin which interfaces with sys-devel/gdb
defineformat
Enable the defineformat plugin.
enchant
Enable spell checking using enchant
git
Enable git (version control system) support
gpg
Enable geanypg plugin which integrates GPG using app-crypt/gpgme
gtk3
Use GTK+3 instead of GTK+2
gtk3
Use GTK+3 instead of GTK+2
gtkspell
Use gtkspell for dictionary support in GeanyVC
lua
Enable Lua scripting support
markdown
Enable the markdown plugin
multiterm
Enable the multiterm plugin
nls
Add Native Language Support (using gettext - GNU locale utilities)
overview
Enable overview plugin
pretty-printer
Enable pretty-printer plugin
python
Add optional support/bindings for the Python language
scope
Enable the scope plugin which is a graphical GDB front-end
soup
Enable updatechecker and geniuspaste plugins which require net-libs/libsoup

python_targets

python2_7
Build with Python 2.7

app-crypt / gpgme : GnuPG Made Easy is a library for making GnuPG easier to use

app-text / discount : A Markdown-to HTML translator written in C

app-text / enchant : Spellchecker wrapping library

app-text / gtkspell : Spell checking widget for GTK

dev-lang / lua : A powerful light-weight programming language designed for extending applications

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-lang / vala : Compiler for the GObject type system

dev-libs / glib : The GLib library of C routines

dev-libs / libgit2 : A linkable library for Git

dev-libs / libxml2 : XML C parser and toolkit

dev-python / pygtk : GTK+2 bindings for Python

dev-util / ctags : Exuberant Ctags creates tags files for code browsing in editors

dev-util / geany : GTK+ based fast and lightweight IDE

net-libs / libsoup : An HTTP library implementation in C

net-libs / webkit-gtk : Open source web browser engine

sys-devel / gettext : GNU locale utilities

virtual / pkgconfig : Virtual for the pkg-config implementation

x11-libs / gtk+ : Gimp ToolKit +

x11-libs / vte : Library providing a virtual terminal emulator widget

app-crypt / gpgme : GnuPG Made Easy is a library for making GnuPG easier to use

app-text / discount : A Markdown-to HTML translator written in C

app-text / enchant : Spellchecker wrapping library

app-text / gtkspell : Spell checking widget for GTK

dev-lang / lua : A powerful light-weight programming language designed for extending applications

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-lang / vala : Compiler for the GObject type system

dev-libs / glib : The GLib library of C routines

dev-libs / libgit2 : A linkable library for Git

dev-libs / libxml2 : XML C parser and toolkit

dev-python / pygtk : GTK+2 bindings for Python

dev-util / ctags : Exuberant Ctags creates tags files for code browsing in editors

dev-util / geany : GTK+ based fast and lightweight IDE

net-libs / libsoup : An HTTP library implementation in C

net-libs / webkit-gtk : Open source web browser engine

sys-devel / gdb : GNU debugger

x11-libs / gtk+ : Gimp ToolKit +

x11-libs / vte : Library providing a virtual terminal emulator widget

638774
dev-util/geany-plugins: match dev-util/geany version / convert remaining GTK+ 2 only plugins
684702
dev-util/geany-1.34.1 and dev-util/geany-plugins-1.34 stablilization
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-util/geany-plugins: arm stable wrt bug #684702
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="arm"
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
dev-util/geany-plugins: x86 stable (bug #684702)
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-util/geany-plugins: amd64 stable wrt bug #684702
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
Chris Mayo · gentoo
dev-util/geany-plugins: version bump to 1.35
Signed-off-by: Chris Mayo <aklhfex@gmail.com> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11864 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Rolf Eike Beer · gentoo
dev-util/geany-plugins: stable 1.34 for sparc, bug #684702
Signed-off-by: Rolf Eike Beer <eike@sf-mail.de> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="sparc" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Lars Wendler · gentoo
dev-util/geany-plugins: Removed old.
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Chris Mayo · gentoo
dev-util/geany-plugins: version bump to 1.34.
markdown and scope plugins now available for GTK+ 3. Closes: https://bugs.gentoo.org/674290 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10654 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Lars Wendler · gentoo
dev-util/geany-plugins: Removed old.
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Lars Wendler · gentoo
dev-util/geany-plugins: Removed old.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Chris Mayo · gentoo
dev-util/geany-plugins: version bump to 1.33
Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7322
Chris Mayo · gentoo
dev-util/geany-plugins: version bump to 1.32 and fix dependencies.
USE flags changed as a result of dependency fixes. - All plugins need GTK+ at compile time and it is not easy to determine which need it at run time, therefore always depend on it. Always build plugins with no other dependencies removing their USE flags - pretty-printer is the only plugin directly using libxml2, put it behind a USE flag Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6262
Lars Wendler · gentoo
dev-util/geany-plugins: Removed old.
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Sergei Trofimovich · gentoo
dev-util/geany-plugins: stable 1.30 for sparc, bug #622002 (thanks to Rolf Eike Beer)
Package-Manager: Portage-2.3.13, Repoman-2.3.4 RepoMan-Options: --include-arches="sparc"
Sergei Trofimovich · gentoo
dev-util/geany-plugins: stable 1.30 for ppc, bug #622002 (thanks to ernsteiswuerfel)
Package-Manager: Portage-2.3.11, Repoman-2.3.3 RepoMan-Options: --include-arches="ppc"
Sergei Trofimovich · gentoo
dev-util/geany-plugins: stable 1.30 for ppc64, bug #622002
Package-Manager: Portage-2.3.11, Repoman-2.3.3 RepoMan-Options: --include-arches="ppc64"
Tobias Klausmann · gentoo
dev-util/geany-plugins-1.30-r0: alpha stable
Gentoo-Bug: 622002
Thomas Deutschmann · gentoo
dev-util/geany-plugins: x86 stable (bug #622002)
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Markus Meier · gentoo
dev-util/geany-plugins: arm stable, bug #622002
Package-Manager: Portage-2.3.6, Repoman-2.3.1 RepoMan-Options: --include-arches="arm"
Sergei Trofimovich · gentoo
dev-util/geany-plugins: ia64 stable, bug #622002
Package-Manager: Portage-2.3.6, Repoman-2.3.3 RepoMan-Options: --include-arches="ia64"
Chris Mayo · gentoo
dev-util/geany-plugins: version bump to 1.31.
New plugin keyrecord with USE flag. Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5141
Tobias Klausmann · gentoo
dev-util/geany-plugins-1.30-r0: amd64 stable
Gentoo-Bug: 622002
Chris Mayo · gentoo
dev-util/geany-plugins: version bump to 1.30.
This commit also simplifies LINGUAS handling. Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/3584
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Lars Wendler · gentoo
dev-util/geany-plugins: Removed old.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Agostino Sarubbo · gentoo
dev-util/geany-plugins: ppc64 stable wrt bug #599264
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="ppc64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Tobias Klausmann · gentoo
dev-util/geany-plugins-1.28-r1: stable on alpha
Gentoo-Bug: 599264
Agostino Sarubbo · gentoo
dev-util/geany-plugins: ia64 stable wrt bug #599264
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="ia64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
dev-util/geany-plugins: ppc stable wrt bug #599264
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="ppc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
dev-util/geany-plugins: sparc stable wrt bug #599264
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="sparc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Markus Meier · gentoo
dev-util/geany-plugins: arm stable, bug #599264
Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="arm"
Pacho Ramos · gentoo
dev-util/geany-plugins: amd64/x86 stable, bug #599264
Package-Manager: portage-2.3.2
Lars Wendler · gentoo
dev-util/geany-plugins: Removed old.
Package-Manager: portage-2.3.2
Pacho Ramos · gentoo
dev-util/geany-plugins: Disable optional webkit support, as it relies on obsolete and vulnerable versions (#584172)
Package-Manager: portage-2.3.2
Lars Wendler · gentoo
dev-util/geany-plugins: Fixed USE-dependency on dev-util/geany
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Lars Wendler · gentoo
dev-util/geany-plugins: Simplified ebuild a bit.
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Chris Mayo · gentoo
dev-util/geany-plugins: Bump to 1.28 and add gtk3 USE flag
configure decides to build for GTK+ 2 or 3 based on installed geany using pkg-config. - Ensure geany and geany-plugins are in step with a gtk3 USE flag (this adds unnecessary work for a user not installing any GTK+ using plugins, but does no harm) - Fix GTK+ dependencies to reflect the SLOT that will be used - Block selection of GTK+ 2 only plugins for gtk3 with REQUIRED_USE - Explicitly enable all plugins - Honour LINGUAS, makes it and nl available - Fix metadata for gtkspell, it is the spellchecker for GeanyVC - geany-1.26 is the minimum since 1.27 - Prune .la files - Move to EAPI6, remove use of autotools-utils and versionator, tidy Gentoo-Bug: https://bugs.gentoo.org/586162 Gentoo-Bug: https://bugs.gentoo.org/566214 Gentoo-Bug: https://bugs.gentoo.org/556840 Closes: https://github.com/gentoo/gentoo/pull/2063 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Agostino Sarubbo · gentoo
dev-util/geany-plugins: ppc stable wrt bug #570902
Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="ppc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
dev-util/geany-plugins: x86 stable wrt bug #570902
Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Tobias Klausmann · gentoo
dev-util/geany-plugins-1.25-r0: add alpha keyword
Gentoo-Bug: 570902 Package-Manager: portage-2.3.0_rc1
Jeroen Roovers · gentoo
dev-util/geany-plugins: Stable for PPC64 (bug #570902).
Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches
Markus Meier · gentoo
dev-util/geany-plugins: arm stable, bug #570902
Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="arm"
Agostino Sarubbo · gentoo
dev-util/geany-plugins: ia64 stable wrt bug #570902
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="ia64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
dev-util/geany-plugins: amd64 stable wrt bug #570902
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Manuel Rüger · gentoo
dev-util/geany-plugins: Version bump
Gentoo-Bug: 566214 Package-Manager: portage-2.2.26
Nathan Phillip Brink · gentoo
dev-util/geany-plugins: Older plugins are incompatible with geany-1.25. Fix lua deps.
Package-Manager: portage-2.2.20
Nathan Phillip Brink · gentoo
dev-util/geany-plugins: Add geany-plugins-1.25 for bug #555330 thanks vityokster, M8R-u38wij.
Package-Manager: portage-2.2.20
Agostino Sarubbo · gentoo
dev-util/geany-plugins: ppc64 stable wrt bug #554880
Package-Manager: portage-2.2.20.1 RepoMan-Options: --include-arches="ppc64"
Mikle Kolyada · gentoo
dev-util/geany-plugins: ia64 stable wrt bug 554880
Package-Manager: portage-2.2.20
Robin H. Johnson · gentoo
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed