dev-util / gnome-builder

An IDE for writing GNOME-based software

Official package sites : https://gitlab.gnome.org/GNOME/gnome-builder · https://wiki.gnome.org/Apps/Builder ·

v43.4 :: 0 :: gentoo

Modified
License
GPL-3+ GPL-2+ LGPL-3+ LGPL-2+ MIT CC-BY-SA-3.0 CC0-1.0
Keywords
~amd64
USE flags
clang d-spy doc flatpak git gtk-doc spell sysprof test webkit

v42.1 :: 0 :: gentoo

Modified
License
GPL-3+ GPL-2+ LGPL-3+ LGPL-2+ MIT CC-BY-SA-3.0 CC0-1.0
Keywords
amd64
USE flags
clang devhelp doc flatpak git glade gtk-doc spell sysprof test webkit

General

clang
Provide integration with sys-devel/clang for best possible C/C++ autocompletion, semantic highlighting, symbol resolving, and diagnostics support
d-spy
Provide D-Bus debugging functionality via dev-util/d-spy
devhelp
Provide API docs browsing and integration via dev-util/devhelp
doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
flatpak
Enable support for flatpak applications using sys-apps/flatpak
git
Provide support for the Git version control system via dev-libs/libgit2-glib (such as setup of Git for New Project, direct cloning for Open Project and changed lines indicators in the editor gutter)
glade
Provide integration with dev-util/glade UI designer for Gtk
gtk-doc
Build and install gtk-doc based developer documentation for dev-util/devhelp, IDE and offline use
spell
Add dictionary support
sysprof
Provide an integrated profiler via dev-util/sysprof
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)
webkit
Add support for the WebKit HTML rendering/layout engine

python_single_target

python3_10
Build for Python 3.10 only
python3_11
Build for Python 3.11 only
python3_8
Build for Python 3.8 only
python3_9
Build for Python 3.9 only

app-text / cmark : CommonMark parsing and rendering library and program in C

app-text / editorconfig-core-c : EditorConfig core library written in C

app-text / enchant : Spellchecker wrapping library

app-text / gspell : Spell check library for GTK+ applications

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-libs / glib : The GLib library of C routines

dev-libs / gobject-introspection : Introspection system for GObject-based libraries

dev-libs / icu : International Components for Unicode

dev-libs / json-glib : Library providing GLib serialization and deserialization for the JSON format

dev-libs / jsonrpc-glib : JSON-RPC library for GLib

dev-libs / libdazzle : Experimental new features for GTK+ and GLib

dev-libs / libgit2 : A linkable library for Git

dev-libs / libgit2-glib : Git library for GLib

dev-libs / libpcre : Perl-compatible regular expression library

dev-libs / libpcre2 : Perl-compatible regular expression library

dev-libs / libpeas : A GObject plugins library

dev-libs / libportal : Flatpak portal library

dev-libs / libxml2 : XML C parser and toolkit

dev-libs / template-glib : Templating library for GLib

dev-python / pygobject : Python bindings for GObject Introspection

dev-util / d-spy : D-spy is a blisteringly fast D-Bus debugger

dev-util / devhelp : An API documentation browser for GNOME

dev-util / glade : A user interface designer for GTK+ and GNOME

dev-util / ostree : Operating system and container binary deployment and upgrades

dev-util / sysprof : System-wide Linux Profiler

dev-util / sysprof-capture : Static library for sysprof capture data generation

gui-libs / gtk : GTK is a multi-platform toolkit for creating graphical user interfaces

gui-libs / gtksourceview : A text widget implementing syntax highlighting and other features

gui-libs / libadwaita : Building blocks for modern adaptive GNOME applications

gui-libs / libhandy : Building blocks for modern adaptive GNOME apps

gui-libs / libpanel : A dock/panel library for GTK 4

gui-libs / vte : Library providing a virtual terminal emulator widget

net-libs / libsoup : HTTP client/server library for GNOME

net-libs / webkit-gtk : Open source web browser engine

sys-apps / flatpak : Linux application sandboxing and distribution framework

sys-devel / clang : C language family frontend for LLVM

x11-libs / gtk+ : Gimp ToolKit +

x11-libs / gtksourceview : A text widget implementing syntax highlighting and other features

x11-libs / pango : Internationalized text layout and rendering library

x11-libs / vte : Library providing a virtual terminal emulator widget

app-text / cmark : CommonMark parsing and rendering library and program in C

app-text / editorconfig-core-c : EditorConfig core library written in C

app-text / enchant : Spellchecker wrapping library

app-text / gspell : Spell check library for GTK+ applications

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-libs / glib : The GLib library of C routines

dev-libs / gobject-introspection : Introspection system for GObject-based libraries

dev-libs / icu : International Components for Unicode

dev-libs / json-glib : Library providing GLib serialization and deserialization for the JSON format

dev-libs / jsonrpc-glib : JSON-RPC library for GLib

dev-libs / libdazzle : Experimental new features for GTK+ and GLib

dev-libs / libgit2 : A linkable library for Git

dev-libs / libgit2-glib : Git library for GLib

dev-libs / libpcre : Perl-compatible regular expression library

dev-libs / libpcre2 : Perl-compatible regular expression library

dev-libs / libpeas : A GObject plugins library

dev-libs / libportal : Flatpak portal library

dev-libs / libxml2 : XML C parser and toolkit

dev-libs / template-glib : Templating library for GLib

dev-python / pygobject : Python bindings for GObject Introspection

dev-util / d-spy : D-spy is a blisteringly fast D-Bus debugger

dev-util / devhelp : An API documentation browser for GNOME

dev-util / glade : A user interface designer for GTK+ and GNOME

dev-util / ostree : Operating system and container binary deployment and upgrades

dev-util / sysprof : System-wide Linux Profiler

dev-util / sysprof-capture : Static library for sysprof capture data generation

gui-libs / gtk : GTK is a multi-platform toolkit for creating graphical user interfaces

gui-libs / gtksourceview : A text widget implementing syntax highlighting and other features

gui-libs / libadwaita : Building blocks for modern adaptive GNOME applications

gui-libs / libhandy : Building blocks for modern adaptive GNOME apps

gui-libs / libpanel : A dock/panel library for GTK 4

gui-libs / vte : Library providing a virtual terminal emulator widget

net-libs / libsoup : HTTP client/server library for GNOME

net-libs / webkit-gtk : Open source web browser engine

sys-apps / flatpak : Linux application sandboxing and distribution framework

sys-devel / clang : C language family frontend for LLVM

x11-libs / gtk+ : Gimp ToolKit +

x11-libs / gtksourceview : A text widget implementing syntax highlighting and other features

x11-libs / pango : Internationalized text layout and rendering library

x11-libs / vte : Library providing a virtual terminal emulator widget

615930
dev-util/gnome-builder: review dependency or information expressing for included project scaffolding templates
788262
dev-util/gnome-builder (wayland native) requires a desktop session with D-Bus. Please set DBUS_SESSION_BUS_ADDRESS.
872707
dev-util/gnome-builder-42.1: Run-time dependency sysprof-ui-4 found: NO (tried pkgconfig and cmake)
884067
dev-util/gnome-builder-43.4 - ../.../ide-config.c: error: declaration shadows a variable in the global scope [-Werror,-Wshadow]
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-util/gnome-builder: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-util/gnome-builder: Version bump to 43.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-util/gnome-builder: Drop x86 keywords
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Guillermo Joandet · gentoo
dev-util/gnome-builder: Version bump to 43.3
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28282 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Guillermo Joandet · gentoo
dev-util/gnome-builder: version bump to 43.2
Closes: https://bugs.gentoo.org/844103 Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-util/gnome-builder: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-util/gnome-builder: Stabilize 42.1 x86, #853958
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-util/gnome-builder: Stabilize 42.1 amd64, #853958
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-util/gnome-builder: Version bump to 42.1
Closes: https://bugs.gentoo.org/829838 Closes: https://bugs.gentoo.org/843224 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: enable py3.10
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-util/gnome-builder: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-util/gnome-builder: Stabilize 3.40.2 amd64, #792327
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-util/gnome-builder: Stabilize 3.40.2 x86, #792327
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-util/gnome-builder: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Matt Turner · gentoo
dev-util/gnome-builder: Version bump to 3.40.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-util/gnome-builder: Version bump to 3.40.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-util/gnome-builder: Raise glib dependency
Closes: https://bugs.gentoo.org/785454 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-util/gnome-builder: Version bump to 3.40.0
Closes: https://bugs.gentoo.org/738932 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
dev-util/gnome-builder: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
dev-util/gnome-builder: x86 stable (bug #774927)
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-util/gnome-builder: Stabilize 3.38.2 amd64, #774927
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: bump to 3.38.2
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove obsolete values from PYTHON_COMPAT
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: bump to 3.38.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: remove old
Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-util/gnome-builder: Stabilize 3.36.1 amd64, #738728
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
dev-util/gnome-builder: x86 stable (bug #738728)
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: add subslot operator dep := for dev-util/glade
Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Mart Raudsepp · gentoo
dev-util/gnome-builder: remove old
Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: add subslot operator dep := for libgit2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: bump to 3.36.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: bump to 3.36.0+patches
Closes: https://bugs.gentoo.org/715662 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: fix compat with libgit2:0/1.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: fix missing build dep for USE=doc
Closes: https://bugs.gentoo.org/720738 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: remove old
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-util/gnome-builder: x86 stable wrt bug #717144
Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-util/gnome-builder: amd64 stable wrt bug #717144
Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: remove old
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-util/gnome-builder: x86 stable wrt bug #717076
Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
dev-util/gnome-builder: amd64 stable wrt bug #717076
Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: fix USE=-git to be honored
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: bump to 3.34.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder-3.32: USE=sysprof requires sysprof-2.pc (subslot 0)
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: Enable py3.8
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: add missing deps for USE=gtk-doc
Closes: https://bugs.gentoo.org/709270 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-util/gnome-builder: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: re-enable spellcheck plugin option
Now that we have enchant:2, the spellcheck plugin can be restored; this time via a USE flag (used to be hard required before). Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: bump to 3.32.4
Closes: https://bugs.gentoo.org/702442 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Clean PYTHON_COMPAT of obsolete impls
Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: remove old
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-util/gnome-builder: x86 stable wrt bug #685254
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="x86"
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
dev-util/gnome-builder: amd64 stable wrt bug #685254
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: remove old
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder-3.24: json-glib[introspection] is required for build
In 3.24 jsonrpc-glib is not a split out separate package, thus the global introspection enabling on gnome-builder affects it as well (not optional). jsonrpc-glib GIR requires json-glib GIR, thus add the missing introspection USE dep on json-glib to ensure successful builds. This is not a problem 3.26 and onwards, as jsonrpc-glib introspection support is controlled by USE flag and there are proper conditional USE deps in place in the external package on json-glib already there. Fixes: https://bugs.gentoo.org/682060 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: bump to 3.30.3
Most of what's in 3.30.3 was already included in our patchset on top of 3.30.2, except some of the gdb integration improvements (and french/spanish translation updates). Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: bump to 3.30.2
Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: add glib-utils build dep
Package-Manager: Portage-2.3.49, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
dev-util/gnome-builder: x86 keyworded (bug #664922)
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
dev-util/gnome-builder: bump to 3.28.4
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Mart Raudsepp · gentoo
dev-util/gnome-builder: remove old
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Aaron Bauman · gentoo
dev-util/gnome-builder: amd64 stable
Bug: https://bugs.gentoo.org/652976 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Thomas Deutschmann · gentoo
dev-util/gnome-builder: x86 stable (bug #652976)
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Mart Raudsepp · gentoo
dev-util/gnome-builder: Move package from gnome-extra/gnome-builder
gnome-builder is an IDE, so move it alongside many other IDEs wrt category. gnome-extra isn't a dumping ground for all slightly gnome related apps, but rather more of a legacy deprecated "stuff didn't fit somewhere else in the past" thing. Package-Manager: Portage-2.3.28, Repoman-2.3.9 RepoMan-Options: --force