dev-util / intel-graphics-compiler

LLVM-based OpenCL compiler targetting Intel Gen graphics hardware

Official package sites : https://github.com/intel/intel-graphics-compiler ·

v1.0.8 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64

v1.0.4 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64

v1.0.3 :: 0 :: gentoo

Modified
License
MIT
Keywords
~amd64

abi_mips

n32
64-bit (32-bit pointer) libraries
n64
64-bit libraries
o32
32-bit libraries

abi_riscv

lp64
64-bit (rv64) soft-float libraries
lp64d
64-bit (rv64) double hard-float libraries

abi_s390

32
32-bit (s390) libraries
64
64-bit (s390x) libraries

abi_x86

32
32-bit (x86) libraries
64
64-bit (amd64) libraries
x32
x32 ABI libraries

dev-libs / opencl-clang : OpenCL-oriented thin wrapper library around clang

dev-util / cmake : Cross platform Make

sys-devel / llvm : Low Level Virtual Machine

sys-devel / make : Standard tool to compile source trees

dev-libs / opencl-clang : OpenCL-oriented thin wrapper library around clang

sys-devel / llvm : Low Level Virtual Machine

dev-libs / intel-neo : Intel Graphics Compute Runtime for OpenCL, for Gen8 (Broadwell) and beyond

687970
dev-util/intel-graphics-compiler - remove -Werror
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
dev-util/intel-graphics-compiler: bump to 1.0.8
Now with proper gcc-9.1 support. Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
dev-util/intel-graphics-compiler: bump to version 1.0.4 and EAPI-7
Moreover, explicitly reject the use of gcc-9+ because they are known to fail. Bug: https://bugs.gentoo.org/685790 Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
dev-util/intel-graphics-compiler: new package
First-order dependency of Intel Graphics Compute Runtime. Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11