dev-util / rosdep

Command-line tool for installing ROS system dependencies

Official package sites : http://wiki.ros.org/rosdep ·

v9999 :: 0 :: gentoo

Modified
License
BSD
USE flags
test

v0.15.0 :: 0 :: gentoo

Modified
License
BSD
Keywords
~amd64 ~arm
USE flags
test

v0.14.0 :: 0 :: gentoo

Modified
License
BSD
Keywords
~amd64 ~arm
USE flags
test

v0.13.0 :: 0 :: gentoo

Modified
License
BSD
Keywords
~amd64 ~arm
USE flags
test

General

test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

pypy
Build with PyPy
pypy3
Build with PyPy3
python2_7
Build with Python 2.7
python3_5
Build with Python 3.5
python3_6
Build with Python 3.6

dev-python / catkin_pkg : Standalone Python library for the catkin package system

dev-python / pyyaml : YAML parser and emitter for Python

dev-python / rosdistro : Tools to work with catkinized rosdistro files

dev-python / rospkg : Standalone Python library for the ROS package system

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-python / catkin_pkg : Standalone Python library for the catkin package system

dev-python / pyyaml : YAML parser and emitter for Python

dev-python / rosdistro : Tools to work with catkinized rosdistro files

dev-python / rospkg : Standalone Python library for the ROS package system

virtual / pypy : A virtual for PyPy Python implementation

virtual / pypy3 : A virtual for PyPy3 Python implementation

dev-ros / roslaunch : Tool for easily launching multiple ROS nodes

dev-ros / roswtf : Tool for diagnosing issues with a running ROS system

619650
dev-util/rosdep unsupported pickle protocol: 4
637072
dev-util/rosdep-0.11.8 : ERROR: test.test_rosdep_debian.test_dpkg_detect
675532
dev-util/rosdep-0.14.0 : [TEST] ERROR: test.test_rosdep_gbpdistro_support.test_get_gbprepo_as_rosdep_data
675628
dev-util/rosdep-0.14.0 : [TEST] ImportError: No module named api.legacy
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Alexis Ballier · gentoo
dev-util/rosdep: bump to 0.15.0
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Alexis Ballier · gentoo
dev-util/rosdep: bump to 0.14.0
Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Alexis Ballier · gentoo
dev-util/rosdep: Remove old
Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Alexis Ballier · gentoo
dev-util/rosdep: bump to 0.13.0; update EAPI
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Alexis Ballier · gentoo
dev-util/rosdep: bump to 0.12.2
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Alexis Ballier · gentoo
dev-util/rosdep: Remove old
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Alexis Ballier · gentoo
dev-util/rosdep: add missing flake8 test dep.
Closes: https://bugs.gentoo.org/647662 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Alexis Ballier · gentoo
dev-util/rosdep: bump to 0.12.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Alexis Ballier · gentoo
dev-util/rosdep: Remove old
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Alexis Ballier · gentoo
dev-util/rosdep: bump to 0.11.8
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Alexis Ballier · gentoo
dev-util/rosdep: bump to 0.11.6
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Alexis Ballier · gentoo
dev-util/rosdep: Add python 3.6 / pypy/3 support
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Alexis Ballier · gentoo
dev-util/rosdep: Add python 3.5 support.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Alexis Ballier · gentoo
dev-util/rosdep: remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Michał Górny · gentoo
global: Drop dead implementations from PYTHON_COMPAT
Justin Lecher · gentoo
Merge branch 'anthonyryan1-github'
* anthonyryan1-github: HTTPS (and canonicalize domain) for github.com
Alexis Ballier · gentoo
dev-util/rosdep: bump to 0.11.5
Package-Manager: portage-2.3.0_rc1
Anthony Ryan · gentoo
HTTPS (and canonicalize domain) for github.com
All links to www.github.com were changed to github.com (preferred by GitHub). During the automated testing of all modified packages the following SRC_URIs were discovered to have changed upstream. Upon closer inspection they were all confirmed to not be regressions. They will all continue to work when served from the mirrors. * dev-python/catkin_pkg-0.2.10 (upstream tarball changed) * dev-python/rosdistro-0.4.4 (upstream tarball changed) * dev-util/rosdep-0.11.4 (upstream tarball changed) * dev-util/wstool-0.1.12 (upstream tarball changed) * dev-util/wstool-0.1.13 (upstream tarball changed) * dev-util/rosdep-0.11.5 (upstream tarball deleted)
Alexis Ballier · gentoo
dev-util/rosdep: remove old.
Package-Manager: portage-2.2.22
Alexis Ballier · gentoo
dev-util/rosdep: dev-python/nose is always needed at build time, not only for tests. Bug #562012 by Randolph Maaßen.
Package-Manager: portage-2.2.22
Alexis Ballier · gentoo
dev-util/rosdep: Bump to 0.11.4.
Package-Manager: portage-2.2.22
Alexis Ballier · gentoo
dev-util/rosdep: initial import. ebuild by me.
Package-Manager: portage-2.2.20.1