dev-util / rosinstall_generator

Generates rosinstall metadata about repositories with ROS packages/stacks

Official package sites : https://wiki.ros.org/rosinstall_generator ·

v9999 :: 0 :: gentoo (Masked by set 6247)

Modified
License
BSD
USE flags
test

v0.1.22-r1 :: 0 :: gentoo (Masked by set 6247)

Modified
License
BSD
Keywords
~amd64 ~arm
USE flags
test

General

test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_targets

python3_8
Build with Python 3.8
python3_9
Build with Python 3.9

dev-python / catkin_pkg : Standalone Python library for the catkin package system

dev-python / nose : Unittest extension with automatic test suite discovery and easy test authoring

dev-python / pyyaml : YAML parser and emitter for Python

dev-python / rosdistro : Tools to work with catkinized rosdistro files

dev-python / rospkg : Standalone Python library for the ROS package system

dev-python / setuptools : Collection of extensions to Distutils

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-python / catkin_pkg : Standalone Python library for the catkin package system

dev-python / pyyaml : YAML parser and emitter for Python

dev-python / rosdistro : Tools to work with catkinized rosdistro files

dev-python / rospkg : Standalone Python library for the ROS package system

dev-python / setuptools : Collection of extensions to Distutils

845963
dev-util/rosinstall_generator: needs upgrade to Python 3.10 (PythonCompatUpdate)

6247
Michał Górny
These packages still lack support for Python 3.10. In general, they did not see any activity recently and either have no maintainer or their respective maintainers did not reply to the bug. Many of them do not have tests enabled or have unresolved test failures. Removal on 2022-12-18. Tracker bug #823185.
  • app-admin/ansible-cmdb
  • app-arch/bloscpack
  • app-backup/borgweb
  • app-i18n/fcitx-sunpinyin
  • app-i18n/ibus-kkc
  • app-i18n/ibus-sunpinyin
  • app-i18n/libkkc
  • app-i18n/libkkc-data
  • app-i18n/sunpinyin
  • app-i18n/sunpinyin-data
  • app-i18n/xsunpinyin
  • app-portage/distpatch
  • app-text/q-text-as-data
  • app-vim/pydiction
  • app-vim/vimoutliner
  • dev-libs/aws-sdk-cpp
  • dev-python/Rx
  • dev-python/bert
  • dev-python/flask-assets
  • dev-python/libpy_simdjson
  • dev-python/pytest-salt
  • dev-python/requests_pkcs12
  • dev-python/slackclient
  • dev-python/tvdb_api
  • dev-python/webassets
  • dev-python/ws4py
  • dev-util/comparator
  • dev-util/rosinstall_generator
  • games-util/pyfa
  • mate-extra/caja-hide
  • media-gfx/netpaint
  • media-plugins/mythplugins
  • media-sound/marrie
  • media-tv/tvnamer
  • net-analyzer/carl
  • net-im/skype-dbus-mock
  • sci-libs/bmrblib
  • sci-mathematics/relational
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
dev-util/rosinstall_generator: fix double KEYWORDS
Double KEYWORDS lines break tools like ekeyword and Nattka. As per PMS, blank/empty KEYWORDS is implied by not defining the variable. See: https://projects.gentoo.org/qa/policy-guide/ebuild-format.html#pg0105 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove obsolete values from PYTHON_COMPAT
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Alexis Ballier · gentoo
dev-util/rosinstall_generator: fix distutils dep
Add py39 Closes: https://bugs.gentoo.org/749945 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Alexis Ballier · gentoo
dev-util/rosinstall_generator: Remove old
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Alexis Ballier · gentoo
dev-util/rosinstall_generator: bump to 0.1.22
add py37/38 fix tests Closes: https://bugs.gentoo.org/683396 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Jakov Smolic · gentoo
dev-util/rosinstall_generator: update homepage link
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
dev-util/rosinstall_generator: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Clean PYTHON_COMPAT of obsolete impls
Closes: https://github.com/gentoo/gentoo/pull/14246 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Alexis Ballier · gentoo
dev-util/rosinstall_generator: bump to 0.1.14; add pypy support; add src_test
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Alexis Ballier · gentoo
dev-util/rosinstall_generator: Remove old
Package-Manager: Portage-2.3.24, Repoman-2.3.6
David Seifert · gentoo
dev-util/rosinstall_generator: [QA] Fix DESCRIPTION.toolong
Pacho Ramos · gentoo
dev-util/rosinstall_generator: Support newer python
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Alexis Ballier · gentoo
dev-util/rosinstall_generator: bump to 0.1.13
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Michał Górny · gentoo
global: Drop dead implementations from PYTHON_COMPAT
Alexis Ballier · gentoo
dev-util/rosinstall_generator: bump to 0.1.12
Package-Manager: portage-2.3.0
Alexis Ballier · gentoo
dev-util/rosinstall_generator: initial import. ebuild by me.
Package-Manager: portage-2.2.20.1