gnome-base / gnome-shell

Provides core UI functions for the GNOME 3 desktop

Official package sites : https://wiki.gnome.org/Projects/GnomeShell ·

GNOME Shell provides core user interface functions for the GNOME 3 desktop, like switching to windows and launching applications. GNOME Shell takes advantage of the capabilities of modern graphics hardware and introduces innovative user interface concepts to provide a visually attractive and easy to use experience.

v3.30.2-r2 :: 0 :: gentoo

Modified
License
GPL-2+ LGPL-2+
Keywords
amd64 x86 ~arm ~arm64 ~ppc ~ppc64
USE flags
bluetooth browser-extension elogind gtk-doc ibus networkmanager nsplugin systemd telepathy test

v3.26.2-r4 :: 0 :: gentoo

Modified
License
GPL-2+ LGPL-2+
Keywords
~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86
USE flags
bluetooth browser-extension elogind ibus networkmanager nsplugin systemd telepathy test

General

bluetooth
Enable Bluetooth Support
browser-extension
Ensure the presence of extensions.gnome.org native connector gnome-extra/chrome-gnome-shell
elogind
Use sys-auth/elogind for session tracking and suspend support.
gtk-doc
Build and install gtk-doc based developer documentation for dev-util/devhelp, IDE and offline use
ibus
Enable support for enhanced input methods through app-i18n/ibus
networkmanager
Enable net-misc/networkmanager support
nsplugin
Build plugin for browsers supporting the Netscape plugin architecture (that is almost any modern browser)
systemd
Enable use of systemd-specific libraries and features like socket activation or session tracking
telepathy
Ensure presence of telepathy chat integration
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

python_single_target

python3_5
Build for Python 3.5 only
python3_6
Build for Python 3.6 only
python3_7
Build for Python 3.7 only

python_targets

python3_5
Build with Python 3.5
python3_6
Build with Python 3.6
python3_7
Build with Python 3.7

app-accessibility / at-spi2-atk : Gtk module for bridging AT-SPI to Atk

app-arch / xz-utils : utils for managing LZMA compressed files

app-crypt / gcr : Libraries for cryptographic UIs and accessing PKCS#11 modules

app-crypt / libsecret : GObject library for accessing the freedesktop.org Secret Service API

app-i18n / ibus : Intelligent Input Bus for Linux / Unix OS

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-libs / atk : GTK+ & GNOME Accessibility Toolkit

dev-libs / dbus-glib : D-Bus bindings for glib

dev-libs / gjs : Javascript bindings for GNOME

dev-libs / glib : The GLib library of C routines

dev-libs / gobject-introspection : Introspection system for GObject-based libraries

dev-libs / json-glib : Library providing GLib serialization and deserialization for the JSON format

dev-libs / libcroco : Generic Cascading Style Sheet (CSS) parsing and manipulation toolkit

dev-libs / libical : An implementation of basic iCAL protocols

dev-libs / libxml2 : XML C parser and toolkit

dev-libs / libxslt : XSLT libraries and tools

dev-python / pygobject : Python bindings for GObject Introspection

dev-util / desktop-file-utils : Command line utilities to work with desktop menu entries

dev-util / gdbus-codegen : GDBus code and documentation generator

dev-util / glib-utils : Build utilities for GLib using projects

dev-util / meson : Open source build system

dev-util / ninja : A small build system similar to make

gnome-base / gnome-desktop : Library with common API for various GNOME modules

gnome-base / gsettings-desktop-schemas : Collection of GSettings schemas for GNOME desktop

gnome-extra / evolution-data-server : Evolution groupware backend

gnome-extra / nm-applet : GNOME applet for NetworkManager

media-libs / gstreamer : Open source multimedia framework

media-libs / libcanberra : Portable sound event library

media-libs / mesa : OpenGL-like graphic library for Linux

media-sound / pulseaudio : A networked sound server with an advanced plugin system

net-libs / libsoup : HTTP client/server library for GNOME

net-misc / networkmanager : A set of co-operative tools that make networking simple and straightforward

net-wireless / gnome-bluetooth : Bluetooth graphical utilities integrated with GNOME

sys-apps / systemd : System and service manager for Linux

sys-auth / elogind : The systemd project's logind, extracted to a standalone package

sys-auth / polkit : Policy framework for controlling privileges for system-wide services

sys-devel / gettext : GNU locale utilities

virtual / pkgconfig : Virtual for the pkg-config implementation

x11-apps / xhost : Controls host and/or user access to a running X server

x11-base / xorg-server : X.Org X servers

x11-libs / gdk-pixbuf : Image loading library for GTK+

x11-libs / gtk+ : Gimp ToolKit +

x11-libs / libX11 : X.Org X11 library

x11-libs / libXfixes : X.Org Xfixes library

x11-libs / startup-notification : Application startup notification and feedback library

x11-misc / shared-mime-info : The Shared MIME-info Database specification

x11-wm / mutter : GNOME 3 compositing window manager based on Clutter

app-accessibility / at-spi2-atk : Gtk module for bridging AT-SPI to Atk

app-accessibility / at-spi2-core : D-Bus accessibility specifications and registration daemon

app-accessibility / caribou : Input assistive technology intended for switch and pointer users

app-crypt / gcr : Libraries for cryptographic UIs and accessing PKCS#11 modules

app-crypt / libsecret : GObject library for accessing the freedesktop.org Secret Service API

app-i18n / ibus : Intelligent Input Bus for Linux / Unix OS

app-misc / geoclue : A location information D-Bus service

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-libs / atk : GTK+ & GNOME Accessibility Toolkit

dev-libs / dbus-glib : D-Bus bindings for glib

dev-libs / gjs : Javascript bindings for GNOME

dev-libs / glib : The GLib library of C routines

dev-libs / gobject-introspection : Introspection system for GObject-based libraries

dev-libs / json-glib : Library providing GLib serialization and deserialization for the JSON format

dev-libs / libcroco : Generic Cascading Style Sheet (CSS) parsing and manipulation toolkit

dev-libs / libgweather : Location and timezone database and weather-lookup library

dev-libs / libical : An implementation of basic iCAL protocols

dev-libs / libxml2 : XML C parser and toolkit

dev-python / pygobject : Python bindings for GObject Introspection

gnome-base / gnome-desktop : Library with common API for various GNOME modules

gnome-base / gnome-session : Gnome session manager

gnome-base / gnome-settings-daemon : Gnome Settings Daemon

gnome-base / gsettings-desktop-schemas : Collection of GSettings schemas for GNOME desktop

gnome-base / librsvg : Scalable Vector Graphics (SVG) rendering library

gnome-extra / evolution-data-server : Evolution groupware backend

gnome-extra / nm-applet : GNOME applet for NetworkManager

media-fonts / cantarell : Default fontset for GNOME Shell

media-libs / gstreamer : Open source multimedia framework

media-libs / libcanberra : Portable sound event library

media-libs / mesa : OpenGL-like graphic library for Linux

media-sound / pulseaudio : A networked sound server with an advanced plugin system

net-im / telepathy-logger : Daemon that centralizes the communication logging within the Telepathy framework

net-libs / libsoup : HTTP client/server library for GNOME

net-libs / telepathy-glib : GLib bindings for the Telepathy D-Bus protocol

net-misc / mobile-broadband-provider-info : Database of mobile broadband service providers

net-misc / networkmanager : A set of co-operative tools that make networking simple and straightforward

net-wireless / gnome-bluetooth : Bluetooth graphical utilities integrated with GNOME

sys-apps / accountsservice : D-Bus interfaces for querying and manipulating user account information

sys-apps / systemd : System and service manager for Linux

sys-auth / elogind : The systemd project's logind, extracted to a standalone package

sys-auth / polkit : Policy framework for controlling privileges for system-wide services

sys-libs / timezone-data : Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)

sys-power / upower : D-Bus abstraction for enumerating power devices, querying history and statistics

x11-libs / gdk-pixbuf : Image loading library for GTK+

x11-libs / gtk+ : Gimp ToolKit +

x11-libs / libX11 : X.Org X11 library

x11-libs / libXfixes : X.Org Xfixes library

x11-libs / pango : Internationalized text layout and rendering library

x11-libs / startup-notification : Application startup notification and feedback library

x11-misc / xdg-utils : Portland utils for cross-platform/cross-toolkit/cross-desktop interoperability

x11-themes / adwaita-icon-theme : GNOME default icon theme

x11-wm / mutter : GNOME 3 compositing window manager based on Clutter

app-eselect / eselect-gnome-shell-extensions : Manages system defaults for GNOME Shell extensions

app-misc / workrave : Helpful utility to attack Repetitive Strain Injury (RSI)

gnome-base / gdm : GNOME Display Manager for managing graphical display servers and user logins

gnome-base / gnome : Meta package for GNOME 3, merge this package to install

gnome-base / gnome-light : Meta package for GNOME-Light, merge this package to install

gnome-extra / chrome-gnome-shell : GNOME Shell integration for Chrome/Chromium, Firefox, Vivaldi, Opera browsers

gnome-extra / gnome-shell-extension-applications-overview-tooltip : Show tooltip with full name and description

gnome-extra / gnome-shell-extension-dash-to-panel : An icon taskbar for the Gnome Shell

gnome-extra / gnome-shell-extension-desktop-icons : A GNOME Shell extension for providing desktop icons

gnome-extra / gnome-shell-extension-gsconnect : KDE Connect implementation for Gnome Shell

gnome-extra / gnome-shell-extensions : JavaScript extensions for GNOME Shell

gnome-extra / gnome-shell-extensions-topicons-plus : Moves legacy tray icons to top panel

gnome-extra / gnome-shell-frippery : Unofficial extension pack providing GNOME 2-like features for GNOME 3

gnome-extra / gnome-tweaks : Customize advanced GNOME 3 options

gnome-extra / pch-session : Unofficial gnome based session with different default settings and extensions

net-misc / wicd : A lightweight wired and wireless network manager for Linux

virtual / notification-daemon : Virtual for notification daemon dbus service

x11-misc / gpaste : Clipboard management system

x11-terms / gnome-terminal : The Gnome Terminal

531294
[gnome-overlay] gnome-base/gnome-shell-3.14.2 should depend on dev-libs/libgsystem
568196
gnome-base/gnome-shell: Obey USE="eds" and make gnome-extra/evolution-data-server optional
671542
=gnome-base/gnome-shell-3.24.3 failed to upgrade to 3.26.2-r4 leading to broken GNOME desktop
673416
gnome-base/gnome-shell-3.26.2-r4 impossible to set non-native resolution
677176
dev-lang/sassc keywording for =gnome-base/gnome-shell-3.28.3
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
gnome-base/gnome-shell: arm64 keyworded
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.70, Repoman-2.3.16
Philipp Ammann · gentoo
*/*: Depend on media-libs/mesa[X(+)]
This changes any package that depends on media-libs/mesa (though not virtual/opengl) to depend on media-libs/mesa[X(+)] instead. Bug: https://bugs.gentoo.org/560096 Signed-off-by: Philipp Ammann <philipp.ammann@posteo.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
gnome-base/gnome-shell: remove old
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
gnome-base/gnome-shell: x86 stable wrt bug #685254
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="x86"
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
gnome-base/gnome-shell: amd64 stable wrt bug #685254
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
gnome-base/gnome-shell: remove old
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
gnome-base/gnome-shell: add a dialog ellipsizing fix
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: Remove python3_4 PYTHON_COMPAT correctly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
gnome-base/gnome-shell: fix crash, EAPI-7, python3.7
Refreshed patchset that contains (compared to previous): * a new commit from gnome-3-30 branch, which fixes some issues related to workspace finger gesture on wayland; * backport of a public API safeguard which downgrades a mysterious crasher (that may happen on suspend resume, or just trying to unlock) to an API misuse warning; * includes the bluetooth optionality patch in the patchset. Port to EAPI-7. Add python:3.7 support for the odd installed tools; not fully tested, as they are complicated to use and really only shell developers use them, but we install them for now still. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
gnome-base/gnome-shell: remove old
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Mart Raudsepp · gentoo
gnome-base/gnome-shell: raise gjs requirement
3.30 needs at least gjs-1.49.4 for Object.values() methods, probably more. Just bump the req to 1.54.0, released in the same cycle as gnome-shell-3.30, as there may be other runtime requirements. gnome-shell-3.32 has the req bumped to 1.54.0 already, so nothing to upstream. Closes: https://bugs.gentoo.org/681712 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
gnome-base/gnome-shell: bump to 3.30.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
gnome-base/gnome-shell: restrict to older gjs
3.28 and older crash without upstream commit e36ba874 "Stop using conditional catch statements It is a mozilla extension that is going away in SpiderMonkey 60." It trivially applies to 3.28, after which 3.28 appears to work fine with newer gjs, but we'll be bumping gnome-shell to 3.30 very soon anyways. Plus there seem to be non-crashing issues from using newer gjs with gnome-shell-3.28 (missing labels in GPG/SSH password dialogs for example). Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
gnome-base/gnome-shell: add explicit Cantarell font dep
gnome-shell uses Cantarell as its global font-family CSS setting, so pull it in explicitly. This is also the main font used by GNOME overall for its design looks, etc, and we removed the explicit dep from lower of the stack. Thus it's important to have it somewhere like gnome-shell for that reason as well. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sergei Trofimovich · gentoo
gnome-base/gnome-shell: keyworded 3.28.3 for ppc/ppc64, bug #677176
Package-Manager: Portage-2.3.62, Repoman-2.3.12 RepoMan-Options: --include-arches="ppc ppc64" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
gnome-base/gnome-shell: fix and re-enable USE=gtk-doc support
Turned out to be a meson-0.47 incompatibility, not gtk-doc Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
gnome-base/gnome-shell: bump to 3.28.3
Includes a huge patchset from upstream gnome-3-28 branch. Now provides its own onscreen keyboard instead of using caribou. Requires sassc at build time for CSS generation. Doesn't need deprecated networkmanager libraries from nm-applet anymore. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
gnome-base/gnome-shell-3.26.2-r4: propagate ~alpha keyword
~alpha was re-added to 3.24 by the time 3.26 was already introduced to main tree. Just propage the keyword, as it should have been done when the new deps got keyworded (but the lingering bug wasn't updated as it was months old). Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Mart Raudsepp · gentoo
gnome-base/gnome-shell: remove old
Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
gnome-base/gnome-shell: Add ~arm keyword wrt bug #583422
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
gnome-base/gnome-shell-3.24.3-r0: add ~alpha keyword
Gentoo-Bug: http://bugs.gentoo.org/583422 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
gnome-base/gnome-shell: bump to 3.26.2, support elogind, many tweaks
* Port ebuild to use meson (no autotools upstream anymore) * Support elogind and get rid of unnecessary openrc-force hacks; gnome-shell systemd code only handles journald integration - logging structured data to it itself, instead of plain g_prints and telling it about launched apps, so they get to log under their own identifier instead of gnome-session. The -Denable-systemd option only deals with that, so we can safely just not pass it on non-systemd systems. The suspend support is handled purely via logind dbus interfaces and is build unconditionally - at runtime it is conditional on /run/systemd/seats existing and being accessible, which should be the case with newer elogind (with relevant bugs fixed) by my quick research, but I have not tested personally. Don't make a big deal about lacking suspend and seat inhibition support and just pull in a logind interface provider (techically this is runtime only, but not bothering with a separate DEPEND-free RDEPEND block for elogind). The alternative (to require logind) would be to require one of the systemd or elogind USE flags instead of at-most-one-of, but this is runtime optional anyways, so don't block it - user could just build with systemd and boot with something else, for example, and similarly not have this work at runtime). Also remove some ewarns appropriately. * Build-time depend on systemd with USE=systemd for the aforementioned journald integration, which needs systemd present at build time already. * More appropriately use python-single-r1 instead of python-r1 for the two small python utilities. Hack meson to update to the correct shebang. * Make telepathy optional - it was made runtime optional in 3.24 already, and with empathy being in the state it's in, the chat integration is rather unused on a desktop system. * Remove questionable glib USE=dbus requirement - if dconf is required, it should be depended upon directly; but as this is just your typical GSettings memory vs dconf backend scenario, I don't see why that'd be. * Remove unnecessary libXtst depend - I can't find any usage of it in current version (only mentions of caribou using it, which has its own dep and is optional on-screen keyboard support, gone in newer versions). * Move dbus-glib depend inside USE=networkmanager, as this legacy thing is for some reason (instead of GDbus) still used only in a NM specific source file that doesn't get compiled with USE=-networkmanager afaics. * Require introspection on nm-applet with USE=networkmanager, as NMGtk GIR is used. * Remove bogus mesa-progs depend - no glxinfo/glxgears usages here. * Add glib-utils build depend. * Drop dejavu font depend - I don't think we should be pulling in a specific font these days for some glyphs; and if we should, then it probably should be cantarell. * Require USE=glib on pulseaudio, as libpulse-mainloop-glib is linked to in a subproject, not just libpulse. * Simplify the pax-mark logic, as we don't use so old spidermonkey for so long, and pax-mark stuff is not tested by us. But the old complicated conditionals don't apply in many cases, so simplify it to just the common case. Additionally newer spidermonkey (60) will lose jit USE flag and have that unconditional on arches where it's supported, so these conditionals will then result in wrong code paths being taken. Therefore just simplify it to the basics and hope it works and rely on any incoming bugs about it to modernize this. Closes: https://bugs.gentoo.org/655426 Closes: https://bugs.gentoo.org/553966 Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Mart Raudsepp · gentoo
gnome-base/gnome-shell: add python3.6 compat
gnome-shell-extension-tool works fine, gnome-shell-perf-tool was broken before already (reported as bug #652584) Package-Manager: Portage-2.3.28, Repoman-2.3.9
Mart Raudsepp · gentoo
gnome-base/gnome-shell: add missing librsvg[introspection] dependency
Bug: https://bugs.gentoo.org/649582 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Mart Raudsepp · gentoo
gnome-base/gnome-shell-3.22.3: remove further keywords as affected by CVE-2017-8288
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Mart Raudsepp · gentoo
gnome-base/gnome-shell: remove old
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Thomas Deutschmann · gentoo
gnome-base/gnome-shell: x86 stable (bug #631656)
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Mikle Kolyada · gentoo
gnome-base/gnome-shell: amd64 stable wrt bug #631656
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Sergei Trofimovich · gentoo
gnome-base/gnome-shell: keyworded 3.24.3 for ppc, bug #599574
Package-Manager: Portage-2.3.10, Repoman-2.3.3 RepoMan-Options: --include-arches="ppc"
Sergei Trofimovich · gentoo
gnome-base/gnome-shell: keyworded 3.24.3 for ppc64, bug #583422
Package-Manager: Portage-2.3.8, Repoman-2.3.3 RepoMan-Options: --include-arches="ppc64"
Mart Raudsepp · gentoo
gnome-base/gnome-shell: adjust USE depends on app-i18n/ibus
This fixes the breakage caused by commit fab5df2eef030ab7d815a82592a727fc78390710 which removed the dedicated gtk3 USE flag on ibus. Gentoo-bug: 626816 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Mart Raudsepp · gentoo
gnome-base/gnome-shell-3.24: clarify when media-libs/mesa[llvm] is needed in elog
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Mart Raudsepp · gentoo
gnome-base/gnome-shell: bump to 3.24.3
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Mart Raudsepp · gentoo
gnome-base/gnome-shell: Depend on required mutter API version subslot
Also fix mutter minimum depend while at it (was raised from 3.23.91 to 3.24.0 proper at some point release) Package-Manager: Portage-2.3.5, Repoman-2.3.2
Mart Raudsepp · gentoo
gnome-base/gnome-shell-3.24.2: Sync in changes done over time in the 3.22 series
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Sergei Trofimovich · gentoo
gnome-base/gnome-shell: ia64 keyworded, bug #583422
Package-Manager: Portage-2.3.6, Repoman-2.3.2 RepoMan-Options: --include-arches="ia64"
Mart Raudsepp · gentoo
gnome-base/gnome-shell: add missing autoconf-archive build dependency
Needed if eautoreconfing
Mart Raudsepp · gentoo
gnome-base/gnome-shell: security cleanup
Gentoo-bug: 616698 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Agostino Sarubbo · gentoo
gnome-base/gnome-shell: x86 stable wrt bug #616698
Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
gnome-base/gnome-shell: amd64 stable wrt bug #616698
Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Mart Raudsepp · gentoo
gnome-base/gnome-shell: fix bug triggered by version validation ignoring setting toggling
This has a CVE-2017-8288 assigned for some reason. Gentoo-bug: 616698
Timo Tambet · gentoo
gnome-base/gnome-shell: bump to 3.24.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Mart Raudsepp · gentoo
gnome-base/gnome-shell: remove double browser-plugin (nsplugin) arg passing to configure
There was a --enable-browser-plugin followed by $(use_enable nsplugin browser-plugin), making the first extraneous and not effective. No end result changes, just cosmetics to avoid confusion. Thanks-to: Matt Turner <mattst88@gentoo.org>
Mart Raudsepp · gentoo
gnome-base/gnome-shell: remove old
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Agostino Sarubbo · gentoo
gnome-base/gnome-shell: x86 stable wrt bug #611134
Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
gnome-base/gnome-shell: amd64 stable wrt bug #611134
Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Mart Raudsepp · gentoo
gnome-base/gnome-shell: pull in chrome-gnome-shell by default for extensions.g.o management, rename nls->ibus USE flag
gnome-control-center used to use USE=i18n for ibus stuff, which got changed to USE=ibus. Rename it here to USE=ibus as well, instead of yet another different USE=nls. Pull in chrome-gnome-shell via IUSE=+browser-extension in a revbump (as keywords need to be dropped)
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Rémi Cardona · gentoo
gnome-base/gnome-shell: bump to 3.22.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Pacho Ramos · gentoo
gnome-base/gnome-shell: Drop sparc (#599572)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Mart Raudsepp · gentoo
gnome-base/gnome-shell: Remove old
Package-Manager: portage-2.3.3
Gilles Dartiguelongue · gentoo
gnome-base/gnome-shell: version bump 3.22.1 → 3.22.2
Package-Manager: portage-2.3.2
Gilles Dartiguelongue · gentoo
gnome-base/gnome-shell: cleanup old revisions
Package-Manager: portage-2.3.2
Gilles Dartiguelongue · gentoo
gnome-base/gnome-shell: version bump 3.20.4 → 3.22.1
Cleanup unused dependencies. Add missing dependencies with introspection support. Make nsplugin optional as there is the chrome extension in tree too. Update comments. Package-Manager: portage-2.3.2
Michał Górny · gentoo
global: Drop dead implementations from PYTHON_COMPAT
Gilles Dartiguelongue · gentoo
gnome-base/gnome-shell: version bump 3.20.4 → 3.22.1
Package-Manager: portage-2.3.2 RepoMan-Options: --force
Pacho Ramos · gentoo
gnome-base/gnome-shell: x86 stable, bug 587010
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="x86"
Pacho Ramos · gentoo
gnome-base/gnome-shell: amd64 stable, bug 587010
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="amd64"
Gilles Dartiguelongue · gentoo
gnome-base/gnome-shell: version bump from 3.20.3 to 3.20.4
Package-Manager: portage-2.3.0
Pacho Ramos · gentoo
gnome-base/gnome-shell: Rebuilding with NM subslot bump will be needed when it's bumped (likely when we are ready to kill the obsolete dbus-glib support from NM)
Package-Manager: portage-2.3.0
Pacho Ramos · gentoo
gnome-base/gnome-shell: Version bump
Package-Manager: portage-2.3.0_rc1
Pacho Ramos · gentoo
gnome-base/gnome-shell: Drop old
Package-Manager: portage-2.3.0_rc1
Alexandre Rostovtsev · gentoo
gnome-base/gnome-shell: fix nvidia-drivers crash (bug #587110)
Thanks to Mark R. Pariente for reporting. Also, require adwaita-icon-theme-3.20 for new grid icon (bug #587130) Package-Manager: portage-2.3.0
Pacho Ramos · gentoo
gnome-base/gnome-shell: Version bump
Package-Manager: portage-2.3.0_rc1
Pacho Ramos · gentoo
gnome-base/gnome-shell: Drop old
Package-Manager: portage-2.3.0_rc1
Pacho Ramos · gentoo
gnome-base/gnome-shell: x86 stable, bug 584468
Package-Manager: portage-2.3.0_rc1 RepoMan-Options: --include-arches="x86"
Pacho Ramos · gentoo
gnome-base/gnome-shell: amd64 stable, bug 584468
Package-Manager: portage-2.3.0_rc1 RepoMan-Options: --include-arches="amd64"
Gilles Dartiguelongue · gentoo
gnome-base/gnome-shell: version bump to 3.18.5
Package-Manager: portage-2.2.28
Ole Reifschneider · gentoo
gnome-base/gnome-shell: Fix crash after enabling vpn
Upstream fixed it in 3.19.x but did did not push the fix to the stable branch so we need to patch it ourselves. Package-Manager: portage-2.2.27
Rémi Cardona · gentoo
gnome-base/gnome-shell: bump to 3.18.4
Package-Manager: portage-2.2.27
Ian Delaney · gentoo
Merge remote-tracking branch 'remotes/sbraz/syncthing'
Pull Request: https://github.com/gentoo/gentoo/pull/990
Mikle Kolyada · gentoo
gnome-base/gnome-shell: x86 stable wrt bug #566378
Package-Manager: portage-2.2.26
Pacho Ramos · gentoo
gnome-base/gnome-shell: amd64 stable, bug #566378
Package-Manager: portage-2.2.27
Pacho Ramos · gentoo
gnome-base/gnome-shell: Add a warning for people running nvidia-drivers[-kms], bug #563084
Package-Manager: portage-2.2.26
Pacho Ramos · gentoo
gnome-base/gnome-shell: Drop old
Package-Manager: portage-2.2.24
Pacho Ramos · gentoo
gnome-base/gnome-shell: Version bump
Package-Manager: portage-2.2.24
Pacho Ramos · gentoo
gnome-base/gnome-shell: Version bump
Package-Manager: portage-2.2.24
Agostino Sarubbo · gentoo
gnome-base/gnome-shell: x86 stable wrt bug #565086
Package-Manager: portage-2.2.20.1 RepoMan-Options: --include-arches="x86"
Agostino Sarubbo · gentoo
gnome-base/gnome-shell: amd64 stable wrt bug #565086
Package-Manager: portage-2.2.20.1 RepoMan-Options: --include-arches="amd64"
Pacho Ramos · gentoo
gnome-base/gnome-shell: Drop old
Package-Manager: portage-2.2.23
Pacho Ramos · gentoo
gnome-base/gnome-shell: Version bump
Package-Manager: portage-2.2.23
Agostino Sarubbo · gentoo
gnome-base/gnome-shell: x86 stable wrt bug #551826
Package-Manager: portage-2.2.20.1 RepoMan-Options: --include-arches="x86"
Mikle Kolyada · gentoo
gnome-base/gnome-shell: amd64 stable wrt bug #551826
Package-Manager: portage-2.2.20.1
Justin Lecher · gentoo
Use https by default
Convert all URLs for sites supporting encrypted connections from http to https Signed-off-by: Justin Lecher <jlec@gentoo.org>
Robin H. Johnson · gentoo
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed