media-libs / gst-plugins-bad

Less plugins for GStreamer

Official package sites : https://gstreamer.freedesktop.org/ ·

v1.22.11-r1 :: 1.0 :: gentoo

Modified
License
LGPL-2
Keywords
amd64 arm arm64 ppc ppc64 x86 ~alpha ~hppa ~ia64 ~loong ~mips ~riscv ~sparc
USE flags
X bzip2 introspection nls orc test udev vaapi vnc wayland

General

X
Add support for X11
bzip2
Enable bzip2 encoder/decoder plugin
introspection
Add support for GObject based introspection
nls
Add Native Language Support (using gettext - GNU locale utilities)
orc
Use dev-lang/orc for just-in-time optimization of array operations
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)
udev
Enable virtual/udev integration (device discovery, power and storage device support, etc)
vaapi
Enable Video Acceleration API for hardware decoding
vnc
Enable VNC (remote desktop viewer) support
wayland
Enable dev-libs/wayland backend

abi_mips

n32
64-bit (32-bit pointer) libraries
n64
64-bit libraries
o32
32-bit libraries

abi_s390

32
32-bit (s390) libraries
64
64-bit (s390x) libraries

abi_x86

32
32-bit (x86) libraries
64
64-bit (amd64) libraries
x32
x32 ABI libraries

app-arch / bzip2 : A high-quality data compressor used extensively by Gentoo Linux

dev-lang / orc : The Oil Runtime Compiler, a just-in-time compiler for array operations

dev-libs / glib : The GLib library of C routines

dev-libs / gobject-introspection : Introspection system for GObject-based libraries

dev-libs / libgudev : GObject bindings for libudev

dev-libs / wayland : Wayland protocol libraries

dev-libs / wayland-protocols : Wayland protocol files

media-libs / gst-plugins-base : Basepack of plugins for gstreamer

media-libs / gstreamer : Open source multimedia framework

media-libs / libva : Video Acceleration (VA) API for Linux

x11-libs / libX11 : X.Org X11 library

x11-libs / libdrm : X.Org libdrm library

app-arch / bzip2 : A high-quality data compressor used extensively by Gentoo Linux

dev-lang / orc : The Oil Runtime Compiler, a just-in-time compiler for array operations

dev-libs / glib : The GLib library of C routines

dev-libs / gobject-introspection : Introspection system for GObject-based libraries

dev-libs / libgudev : GObject bindings for libudev

dev-libs / wayland : Wayland protocol libraries

dev-libs / wayland-protocols : Wayland protocol files

media-libs / gst-plugins-base : Basepack of plugins for gstreamer

media-libs / gstreamer : Open source multimedia framework

media-libs / libva : Video Acceleration (VA) API for Linux

x11-libs / libX11 : X.Org X11 library

x11-libs / libdrm : X.Org libdrm library

dev-libs / kirigami-addons : Visual end user components for Kirigami-based applications

dev-qt / qtmultimedia : Multimedia (audio, video, radio, camera) library for the Qt6 framework

gui-libs / gtk : GTK is a multi-platform toolkit for creating graphical user interfaces

media-gfx / ahoviewer : A GTK image viewer, manga reader, and booru browser

media-libs / clutter-gst : GStreamer integration library for Clutter

media-libs / gstreamer-editing-services : SDK for making video editors and more

media-libs / nvidia-vaapi-driver : A VA-API implemention using NVIDIA's NVDEC

media-plugins / gst-plugins-aom : Alliance for Open Media AV1 plugin for GStreamer

media-plugins / gst-plugins-assrender : ASS/SSA rendering with effects support plugin for GStreamer

media-plugins / gst-plugins-bluez : AVDTP source/sink and A2DP sink plugin for GStreamer

media-plugins / gst-plugins-bs2b : bs2b elements for Gstreamer

media-plugins / gst-plugins-chromaprint : Calculate Chromaprint fingerprint from audio files for GStreamer

media-plugins / gst-plugins-colormanagement : Color management correction GStreamer plugins

media-plugins / gst-plugins-dash : MPEG-DASH plugin for GStreamer

media-plugins / gst-plugins-dtls : DTLS encoder/decoder with SRTP support plugin for GStreamer

media-plugins / gst-plugins-dts : DTS audio decoder plugin for Gstreamer

media-plugins / gst-plugins-dvb : plugin for gstreamer

media-plugins / gst-plugins-faac : AAC audio encoder plugin for GStreamer

media-plugins / gst-plugins-faad : AAC audio decoder plugin

media-plugins / gst-plugins-hls : HTTP live streaming plugin for GStreamer

media-plugins / gst-plugins-kate : Kate overlay codec suppport plugin for GStreamer

media-plugins / gst-plugins-ladspa : Ladspa elements for Gstreamer

media-plugins / gst-plugins-ldac : LDAC plugin for GStreamer

media-plugins / gst-plugins-libde265 : H.265 decoder plugin for GStreamer

media-plugins / gst-plugins-lv2 : Lv2 elements for Gstreamer

media-plugins / gst-plugins-meta : Meta ebuild to pull in gst plugins for apps

media-plugins / gst-plugins-modplug : MOD audio decoder plugin for GStreamer

media-plugins / gst-plugins-mpeg2enc : MPEG-1/2 video encoding plugin for GStreamer

media-plugins / gst-plugins-mplex : MPEG/DVD/SVCD/VCD video/audio multiplexing plugin for GStreamer

media-plugins / gst-plugins-neon : HTTP client source plugin for GStreamer

media-plugins / gst-plugins-openaptx : openaptx plugin for GStreamer

media-plugins / gst-plugins-opencv : OpenCV elements for GStreamer

media-plugins / gst-plugins-openh264 : H.264 encoder/decoder plugin for GStreamer

media-plugins / gst-plugins-resindvd : DVD playback support plugin for GStreamer

media-plugins / gst-plugins-rtmp : RTMP source/sink plugin for GStreamer

media-plugins / gst-plugins-sbc : SBC encoder and decoder plugin for GStreamer

media-plugins / gst-plugins-sctp : SCTP plugins for GStreamer

media-plugins / gst-plugins-smoothstreaming : Smooth Streaming plugin for GStreamer

media-plugins / gst-plugins-soundtouch : Beats-per-minute detection and pitch controlling plugin for GStreamer

media-plugins / gst-plugins-srt : Secure reliable transport (SRT) transfer plugin for GStreamer

media-plugins / gst-plugins-srtp : SRTP encoder/decoder plugin for GStreamer

media-plugins / gst-plugins-uvch264 : UVC compliant H264 encoding cameras plugin for GStreamer

media-plugins / gst-plugins-vaapi : Hardware accelerated video decoding through VA-API plugin for GStreamer

media-plugins / gst-plugins-voaacenc : AAC encoder plugin for GStreamer

media-plugins / gst-plugins-voamrwbenc : AMR-WB audio encoder plugin for GStreamer

media-plugins / gst-plugins-webp : WebP image format support for GStreamer

media-plugins / gst-plugins-webrtc : WebRTC plugins for GStreamer

media-plugins / gst-plugins-x265 : H.265 encoder plugin for GStreamer

media-plugins / gst-plugins-zbar : Bar codes detection in video streams for GStreamer

media-sound / gnome-sound-recorder : Simple sound recorder

media-sound / pulseeffects : Limiter, compressor, reverberation, equalizer auto volume effects for Pulseaudio

media-sound / soundconverter : A simple audiofile converter application for the GNOME environment

media-video / cheese : A cheesy program to take pictures and videos from your webcam

media-video / handbrake : Open-source, GPL-licensed, multiplatform, multithreaded video transcoder

media-video / pitivi : A non-linear video editor using the GStreamer multimedia framework

net-im / fractal : Matrix messaging app for GNOME written in Rust

net-libs / farstream : Audio/video conferencing framework specifically designed for instant messengers

net-libs / webkit-gtk : Open source web browser engine

net-misc / rygel : Rygel is an open source UPnP/DLNA MediaServer

x11-libs / wxGTK : GTK version of wxWidgets, a cross-platform C++ GUI toolkit

291165
media-libs/gst-plugins-bad ships a copy of rsvg plug-in, missing from tree
446251
media-plugins/gst-plugins-dts and others shouldn't depend on media-libs/gst-plugins-bad
591208
media-libs/gst-plugins-bad-1.8.2[opengl] - Test suite requires xorg-server[-minimal] - Error creating master context No GLX extension
618494
media-libs/gstreamer-1.14.1: app-emulation/spice configure blocks while "checking for the appsrc GStreamer element..." when old media-libs/gst-plugins-bad-1.12.4 is installed
670172
media-libs/gst-plugins-bad-1.14.1 should not provide HLS demuxer documentation.
845024
media-libs/gst-plugins-bad-1.20.2 fails to compile
907670
media-libs/gst-plugins-bad-1.22.3-r1 does not install Intel Quick Sync plugin
918095
<media-libs/gst-plugins-bad-1.22.11-r1: multiple vulnerabilities
928911
media-libs/gst-plugins-bad-1.22.11-r1 fails tests: 20 elements_mxfdemux FAIL 0.24s exit status 2
930562
media-libs/gst-plugins-bad-1.22.11-r1: missing bdepend on dev-util/wayland-scanner
930565
media-libs/gst-plugins-bad-1.22.11-r1: two tests fail without media-libs/gst-plugins-good
931737
media-libs/gst-plugins-bad-1.22.11-r1 fails test elements_netsim: Got data flow before stream-start event
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: drop 1.20.5-r1, 1.20.6
Bug: https://bugs.gentoo.org/918095 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.22.11-r1 amd64, #928779
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.22.11-r1 x86, #928779
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.22.11-r1 arm64, #928779
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.22.11-r1 arm, #928779
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.22.11-r1 ppc64, #928779
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.22.11-r1 ppc, #928779
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: fix missing libgudev multilib dep
Closes: https://bugs.gentoo.org/928973 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: fix bz2 build, drop msdk plugin, cleanups, touchups
* Fix USE=bzip2 not enabling bz2 plugin. * Drop msdk plugin for now; it'll get reintroduced later as gst-plugins-msdk, plus an alternative gst-plugins-qsv. Currently no consumers of these have been found, as they aren't getting used automatically by playbin/encodebin yet. * Drop transitional gtk, egl, gles2 and opengl USE flags; looks like everything has migrated to gst-plugins-gtk and gst-plugins-base[egl,gles2,opengl] deps. * Fix automagic dep on gudev for va plugin. * Fix automagic x11 dep for librfb plugin (USE=vnc). * Move vaapi handling to the common block, and add it to GST_PLUGINS_NOAUTO to make that work. * Drop leftover autotools era multilib_src_install_all - no libtool with meson. * Add missing subslot dep operator for media-libs/libva Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: add 1.22.11, EAPI-8, allow tests
With EAPI-8, python-any-r1 is handled by eclass, also adding py3.12 support. Prepare for addition of wayland into gstreamer-meson.eclass extra options list. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: default-enable gles2 instead of opengl
Upstream considers gles2 the better option and switches the default from opengl to gles2 (when both are enabled) in 1.24. As it works better with GL drivers in practive in 1.22 too, at least switch the default enabled over to it. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
media-libs/gst-plugins-bad: media-libs/oneVPL -> media-libs/libvpl
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Haelwenn (lanodan) Monnier · gentoo
media-libs/gstreamer: add 1.22.10, drop 1.22.3 (security)
- eclass / gst-plugins-good: Add "soup" option in the special cases - gst-plugins-good: Backport fix against tests being enabled on libsoup presence automagic-style <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/6058> Closes: https://bugs.gentoo.org/836163 Closes: https://bugs.gentoo.org/908978 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.6 ppc, #908277
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
media-libs/gst-plugins-bad: add missing deps for USE=qsv
Closes: https://bugs.gentoo.org/917001 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.6 ppc64, #908277
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: drop 1.20.3, 1.20.4-r1
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.6 arm, #908277
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.6 x86, #908277
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.6 arm64, #908277
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.6 amd64, #908277
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: fix whitespace
Thanks to sultan for pointing it out. Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: fix va
Thanks to kostadin for reporting. Add in a bunch of stashed changes (like commenting out RESTRICT="test" again for now as I need to recheck that). Bug: https://bugs.gentoo.org/907479 Fixes: d8fdc47378f4d53b5c1ebcc0f821d5b9f1e4753e Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: unsplit gst-plugins-va
It belongs better in gst-plugins-bad, given vaapi is a global USE flag, and it's not split upstream anyway. Closes: https://bugs.gentoo.org/907479 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.5-r1 ppc64, #907451
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.5-r1 ppc, #907451
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.5-r1 amd64, #907451
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.5-r1 x86, #907451
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.5-r1 arm64, #907451
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.5-r1 arm, #907451
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: avoid automagic dep on libva
As noted on the bug, I need to discuss properly with leio whether or not the split for -va makes sense, but -va is an orphan/leaf package right now so it's lower priority than just fixing -bad which many people have installed. So, for now, just backport the relevant upstream patches to fix the automagic for this side. Bug: https://bugs.gentoo.org/907481 Bug: https://bugs.gentoo.org/907479 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: add 1.20.6
Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
media-libs/gst-plugins-bad: add 1.22.3
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
media-libs/gst-plugins-bad: make dep on oneVPL multilib
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
brahmajit das · gentoo
media-libs/gst-plugins-bad: add 1.20.5
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: brahmajit das <listout@protonmail.com>
Repository mirror & CI · gentoo
Merge updates from master
David Seifert · gentoo
*/*: remove py3.8 from PYTHON_COMPAT
Signed-off-by: David Seifert <soap@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.4-r1 amd64, #884731
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.4-r1 ppc64, #884731
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.4-r1 ppc, #884731
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.4-r1 x86, #884731
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.4-r1 arm64, #884731
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.4-r1 arm, #884731
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andrew Ammerlaan · gentoo
media-libs/gst-plugins-bad: allow use of onevpl
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: drop 1.20.2
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
brahmajit das · gentoo
media-libs/gstreamer: Version bump to 1.20.4
Closes: https://bugs.gentoo.org/877325 Signed-off-by: brahmajit das <listout@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/28086 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Georgy Yakovlev · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.3 ppc64, #867784
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.3 ppc, #867784
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.3 arm64, #867784
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.3 arm, #867784
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.3 x86, #867784
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.3 amd64, #867784
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Igor V. Kovalenko · gentoo
media-libs/gst-plugins-bad: add 1.20.3
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
media-libs/gst-plugins-bad: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.2 ppc64, #839939
Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.2 ppc, #839939
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
WANG Xuerui · gentoo
media-libs/gst-plugins-bad: keyword 1.20.2 for ~loong
Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jakov Smolić · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.2 arm, #839939
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jakov Smolić · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.2 x86, #839939
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Jakov Smolić · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.2 arm64, #839939
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Jakov Smolić · gentoo
media-libs/gst-plugins-bad: Stabilize 1.20.2 amd64, #839939
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Igor V. Kovalenko · gentoo
media-libs/gstreamer: Version bump, 1.20.2
Bug: https://bugs.gentoo.org/843770 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.18.6 arm64, #835598
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jakov Smolić · gentoo
media-libs/gst-plugins-bad: Stabilize 1.18.6 x86, #835598
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.18.6 ppc, #835598
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.18.6 amd64, #835598
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.18.6 arm, #835598
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/gst-plugins-bad: Stabilize 1.18.6 ppc64, #835598
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Igor V. Kovalenko · gentoo
media-libs/gstreamer: Version bump, 1.18.6
Bug: https://bugs.gentoo.org/835368 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24625 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Igor V. Kovalenko · gentoo
media-libs/gstreamer: Version bump, 1.20.1
Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Igor V. Kovalenko · gentoo
media-libs/gstreamer: Clean up 1.20.0 unused dependency on gtk-doc-am
Since 1.17.1 gstreamer is disabling gtk_doc feature by default, therefore gtk-doc is not used. Drop gtk-doc-am dependency. Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Igor V. Kovalenko · gentoo
media-libs/gstreamer: Update dependencies from 1.20.0 build system
Update dependency versions changed since last 1.18 release. Every gstreamer package depends on media-libs/gstreamer and on dev-libs/glib, use this transitive dependency to keep dev-libs/glib requirement in single place. Move RDEPEND on dev-libs/glib from all packages to media-libs/gstreamer and bump version requirement there. Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Igor V. Kovalenko · gentoo
media-libs/gstreamer: Bump to 1.20.0
Gstreamer 1.20.0 version bump, includes - all existing 1.18.4 plugins except for two dropped upstream (gst-plugins-libmms and gst-plugins-ofa) - libnice-0.1.18 version bump required by gst-plugins-webrtc in 1.20.0 - required multilib change for libldac for new plugin gst-plugins-ldac - required multilib change for libopenaptx and libfreeaptx for new plugin gst-plugins-openaptx As discussed, this change adds a LICENSE to each of gstreamer modules which now require explicit opt-in for (A)GPL plugins for (A)GPL plugins we will not perform explicit license acceptance for affected gstreamer plugin, instead we will rely on a user accepting the license of dependency: - gstreamer change added explicit opt-in https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1084 - I looked at affected gstreamer plugins and looks like all are correctly license-compatible according to compatibility matrix https://www.gnu.org/licenses/gpl-faq.html#AllCompatibility - if a user is not willing to accept the license of corresponding (A)GPL dependency, such dependency will not be available and affected gstreamer plugin will not be built - Upstream gstreamer team will look into updating/fixing plugin license display available via gst-inspect-1.0 <plugin name> | grep License as currently it is just "GPL" which is not specific enough (should be GPL-2, GPL-2+, GPL-3 etc.) Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Igor V. Kovalenko · gentoo
media-libs/gstreamer: Improve 1.20.0 ebuild style and BDEPEND
Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: add python-any-r1 for build time dependency
Closes: https://bugs.gentoo.org/827022 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: fix glib/volatile build failure in consumers
Revbump required as this leaks into exposed headers and broke the build for e.g. gst-plugins-opencv. Bug: https://bugs.gentoo.org/826702 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.18.4-r1 arm64, #812836
Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.18.4-r1 x86, #812836
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.18.4-r1 amd64, #812836
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.18.4-r1 ppc64, #812836
Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.18.4-r1 ppc, #812836
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.18.4-r1 arm, #812836
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
media-libs/gst-plugins-bad: keyword 1.18.4-r1 for ~riscv
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: block media-plugins/gst-transcoder
Bug: https://bugs.gentoo.org/804603 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Haelwenn (lanodan) Monnier · gentoo
media-libs/gst-plugins-bad: Version bump, 1.18.4
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: remove old
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.16.3 arm, #766336
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.16.3 arm64, #766336
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.16.3 ppc, #766336
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.16.3 amd64, #766336
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.16.3 x86, #766336
Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.16.3 ppc64, #766336
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: bump to 1.16.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Fabian Groffen · gentoo
media-libs/gst-plugins-bad: drop Prefix keywords, bug #662458
Bug: https://bugs.gentoo.org/662458 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: ppc64 stable (bug #728940)
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
media-libs/gst-plugins-bad: ppc stable (bug #728940)
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
media-libs/gst-plugins-bad: Stabilize 1.16.2 arm, #728940
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
media-libs/gst-plugins-bad: amd64 stable wrt bug #728940
Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="amd64" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
media-libs/gst-plugins-bad: x86 stable (bug #728940)
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Sam James (sam_c) · gentoo
media-libs/gst-plugins-bad: arm64 stable (bug #728940)
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: drop now unnecessary IUSE="egl gles2 opengl"
All the remaining opengl plugin components (mixers) got moved into gst-plugins-base too with 1.16, and IUSE=egl was already only transitional in 1.14, and isn't used by anything anymore, so can go away as well. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
*/*: Drop stable ia64 keywords
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
David Seifert · gentoo
media-libs/gst-plugins-bad: Fix for >=make-4.3
Closes: https://bugs.gentoo.org/705974 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: David Seifert <soap@gentoo.org>
Haelwenn (lanodan) Monnier · gentoo
media-libs/gst-plugins-bad: Version bump, 1.16.2
leio: drop IUSE=gtk transitional IUSE, been there long enough Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
*/*: Drop stable alpha keywords
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: remove old
Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: arm stable wrt bug #702246
Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="arm" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
media-libs/gst-plugins-bad: alpha stable wrt bug #702246
Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="alpha" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
media-libs/gst-plugins-bad: arm64 stable (bug #702246)
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.81, Repoman-2.3.20
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: ppc stable wrt bug #702246
Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="ppc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: ppc64 stable wrt bug #702246
Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="ppc64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sergei Trofimovich · gentoo
media-libs/gst-plugins-bad: stable 1.14.5 for ia64, bug #702246
Package-Manager: Portage-2.3.81, Repoman-2.3.20 RepoMan-Options: --include-arches="ia64" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
media-libs/gst-plugins-bad: x86 stable wrt bug #702246
Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="x86" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Mikle Kolyada · gentoo
media-libs/gst-plugins-bad: amd64 stable wrt bug #702246
Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="amd64" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
media-libs: Remove *-fbsd KEYWORDS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: bump to 1.14.5 for upstream bug fixes
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: remove gstreamer 0.10
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
media-libs/gst-plugins-bad: arm64 stable
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: remove old
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
media-libs/gst-plugins-bad-1.14.3: alpha stable, bug 674854
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Matt Turner · gentoo
media-libs/gst-plugins-bad-1.14.3: ia64 stable, bug 674854
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
media-libs/gst-plugins-bad: arm stable wrt bug #674854
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: remove old
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
media-libs/gst-plugins-bad-1.14.3: ppc64 stable, bug 674854
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Matt Turner · gentoo
media-libs/gst-plugins-bad-1.14.3: ppc stable, bug 674854
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
media-libs/gst-plugins-bad-1.14.3: amd64 stable, bug 674854
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
media-libs/gst-plugins-bad: x86 stable (bug #674854)
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: remove old
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Sergei Trofimovich · gentoo
media-libs/gst-plugins-bad: stable 1.14.1-r1 for ia64, bug #661288
Package-Manager: Portage-2.3.49, Repoman-2.3.10 RepoMan-Options: --include-arches="ia64"
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: add glib-utils build dep
Uses glib-mkenums Package-Manager: Portage-2.3.49, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: bump to 1.14.3 for upstream bug fixes
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Matt Turner · gentoo
media-libs/gst-plugins-bad-1.14.1-r1: ppc64 stable, bug 661288
Matt Turner · gentoo
media-libs/gst-plugins-bad-1.14.1-r1: ppc stable, bug 661288
Repository mirror & CI · gentoo
Merge updates from master
Markus Meier · gentoo
media-libs/gst-plugins-bad: arm stable, bug #661288
Package-Manager: Portage-2.3.40, Repoman-2.3.9 RepoMan-Options: --include-arches="arm"
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: bump to 1.14.2 for upstream bug fixes
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
media-libs/gst-plugins-bad: x86 stable (bug #661288)
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
media-libs/gst-plugins-bad-1.14.1-r1: alpha stable
Gentoo-Bug: http://bugs.gentoo.org/661288
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
media-libs/gst-plugins-bad: amd64 stable wrt bug #661288
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: remove old
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: fix openglmixers plugin enabling
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad-1.14: USE=gtk transtion to gst-plugins-gtk
Some packages requiring gtksink are depending on gst-plugins-bad[gtk], so keep it working for now via proxying the dep towards new gst-plugins-gtk split package. This will likely be removed soon, after consumers (pitivi and corebird) have the dependency changed to gtk-plugins-gtk in revbumps. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: bump to 1.14.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Matt Turner · gentoo
media-libs/gst-plugins-bad-1.12.4: ppc64 stable, bug 650540
Matt Turner · gentoo
media-libs/gst-plugins-bad-1.12.4: ppc stable, bug 650540
Tobias Klausmann · gentoo
media-libs/gst-plugins-bad-1.12.4-r0: alpha stable
Gentoo-Bug: http://bugs.gentoo.org/650540
Matt Turner · gentoo
media-libs/gst-plugins-bad-1.12.4: added ~mips
Markus Meier · gentoo
media-libs/gst-plugins-bad: arm stable, bug #650540
Package-Manager: Portage-2.3.24, Repoman-2.3.6 RepoMan-Options: --include-arches="arm"
Sergei Trofimovich · gentoo
media-libs/gst-plugins-bad: stable 1.12.4 for ia64, bug #650540
Package-Manager: Portage-2.3.24, Repoman-2.3.6 RepoMan-Options: --include-arches="ia64"
Thomas Deutschmann · gentoo
media-libs/gst-plugins-bad: x86 stable (bug #650540)
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Mikle Kolyada · gentoo
media-libs/gst-plugins-bad: amd64 stable wrt bug #650540
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: bump to 1.12.4 for upstream bug fixes
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: remove old
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Markus Meier · gentoo
media-libs/gst-plugins-bad: arm stable, bug #635900
Package-Manager: Portage-2.3.13, Repoman-2.3.3 RepoMan-Options: --include-arches="arm"
Tobias Klausmann · gentoo
media-libs/gst-plugins-bad-1.12.3-r0: amd64 stable
Gentoo-Bug: http://bugs.gentoo.org/635900
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: remove old
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Thomas Deutschmann · gentoo
media-libs/gst-plugins-bad: x86 stable (bug #635900)
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Tobias Klausmann · gentoo
media-libs/gst-plugins-bad-1.12.3-r0: alpha stable
Gentoo-Bug: http://bugs.gentoo.org/635900
Sergei Trofimovich · gentoo
media-libs/gst-plugins-bad: stable 1.12.3 for hppa, bug #635900
Package-Manager: Portage-2.3.13, Repoman-2.3.4 RepoMan-Options: --include-arches="hppa"
Sergei Trofimovich · gentoo
media-libs/gst-plugins-bad: stable 1.12.3 for ppc64, bug #635900
Package-Manager: Portage-2.3.13, Repoman-2.3.4 RepoMan-Options: --include-arches="ppc64"
Sergei Trofimovich · gentoo
media-libs/gst-plugins-bad: stable 1.12.3 for ppc, bug #635900
Package-Manager: Portage-2.3.13, Repoman-2.3.4 RepoMan-Options: --include-arches="ppc"
Sergei Trofimovich · gentoo
media-libs/gst-plugins-bad: stable 1.12.3 for ia64, bug #635900
Package-Manager: Portage-2.3.13, Repoman-2.3.4 RepoMan-Options: --include-arches="ia64"
Sergei Trofimovich · gentoo
media-libs/gst-plugins-bad: stable 1.10.5 for ppc/ppc64, bug #624180
Package-Manager: Portage-2.3.12, Repoman-2.3.4 RepoMan-Options: --include-arches="ppc ppc64"
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: Default enable egl and opengl for webkit-gtk and 21st century, fix USE=egl to matter
webkit-gtk IUSE default enables egl and gstreamer, while now requiring gstreamer[egl] in that case as well. So try out default enabling egl here to work out of the box, plus opengl so we don't hit our own newly added constraint of wanting opengl or gles2 with USE=egl (otherwise USE=egl has no effect, because if neither is defined, the EGL code isn't built at all, as it's part of the gstgl library). Package-Manager: Portage-2.3.8, Repoman-2.3.2
Thomas Deutschmann · gentoo
media-libs/gst-plugins-bad: x86 stable (bug #624180)
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: remove old
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: bump to 1.12.3 for upstream bug fixes
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: bump to 1.12.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad and its splits: Remove old 1.8.3 and 1.10.4
Mart Raudsepp · gentoo
media-{libs,plugins}/gst-plugins-*: Drop sparc stable keywords
Gentoo-bug: 601354
Markus Meier · gentoo
media-libs/gst-plugins-bad: arm stable, bug #624180
Package-Manager: Portage-2.3.6, Repoman-2.3.1 RepoMan-Options: --include-arches="arm"
Tobias Klausmann · gentoo
media-libs/gst-plugins-bad-1.10.5-r0: alpha stable
Gentoo-Bug: 624180
Tobias Klausmann · gentoo
media-libs/gst-plugins-bad-1.10.5-r0: add amd64 keyword
Gentoo-Bug: 624180
Sergei Trofimovich · gentoo
media-libs/gst-plugins-bad: ia64 stable, bug #624180
Package-Manager: Portage-2.3.6, Repoman-2.3.2 RepoMan-Options: --include-arches="ia64"
Alexis Ballier · gentoo
media-libs/gst-plugins-bad: keyword ~arm64
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: bump to 1.10.5 for upstream bug fixes
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Sergei Trofimovich · gentoo
media-libs/gst-plugins-bad: ia64 stable, bug #601354
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Tobias Klausmann · gentoo
media-libs/gst-plugins-bad-1.10.3-r0: add alpha keyword
Gentoo-Bug: 601354
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: bump to 1.10.4 for upstream bug fixes
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: ppc stable wrt bug #601354
Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="ppc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: ppc64 stable wrt bug #601354
Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="ppc64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: remove old (security cleanup)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Michael Weber · gentoo
media-libs/gst-plugins-bad: ppc64 stable (bug 600142).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Jeroen Roovers · gentoo
media-libs/gst-plugins-bad: Stable for HPPA (bug #601354).
Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --ignore-arches
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: x86 stable wrt bug #601354
Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: amd64 stable wrt bug #601354
Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Markus Meier · gentoo
media-libs/gst-plugins-bad: arm stable, bug #601354
Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="arm"
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: bump to 1.10.3, add patch for CVE-2017-5848
Package-Manager: Portage-2.3.3, Repoman-2.3.1
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: ppc stable wrt bug #600142
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="ppc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: sparc stable wrt bug #600142
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="sparc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad and its splits: Remove old 1.6.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: ppc64 stable wrt bug #587010
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="ppc64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: ia64 stable wrt bug #600142
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="ia64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad and its splits: Remove old 1.4.5
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: ia64 stable wrt bug #587010
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="ia64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: sparc stable wrt bug #587010
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="sparc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: ppc stable wrt bug #587010
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="ppc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: Remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Jeroen Roovers · gentoo
media-libs/gst-plugins-bad: Stable for HPPA (bug #600142).
Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --ignore-arches
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad and its splits: Remove old 1.8.2
Package-Manager: portage-2.3.3
Markus Meier · gentoo
media-libs/gst-plugins-bad: arm stable, bug #600142
Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="arm"
Markus Meier · gentoo
media-libs/gst-plugins-bad: arm stable, bug #600142
Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="arm"
Pacho Ramos · gentoo
media-libs/gst-plugins-bad: Drop bogus REQUIRED_USE restraint (#525936, #602512)
Package-Manager: portage-2.3.2
Markus Meier · gentoo
media-libs/gst-plugins-bad: arm stable, bug #587010
Package-Manager: portage-2.3.2 RepoMan-Options: --include-arches="arm"
Tobias Klausmann · gentoo
media-libs/gst-plugins-bad-1.8.3-r1: stable on alpha
Gentoo-Bug: 600142
Tobias Klausmann · gentoo
media-libs/gst-plugins-bad-0.10.23-r4: stable on alpha
Gentoo-Bug: 600142
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: x86 stable wrt bug #600142
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: amd64 stable wrt bug #600142
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Michael Palimaka · gentoo
media-libs/gst-plugins-bad: disable vnmc and nsf plugins to resolve CVE-2016-9445, CVE-2016-9446 and CVE-2016-9447
Gentoo-bug: 600142 Acked-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: portage-2.3.2
Michael Palimaka · gentoo
media-libs/gst-plugins-bad: backport patch from upstream to resolve CVE-2016-9445
Gentoo-bug: 600142 Acked-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: portage-2.3.2
Jeroen Roovers · gentoo
media-libs/gst-plugins-bad: Stable for HPPA (bug #587010).
Package-Manager: portage-2.3.1 RepoMan-Options: --ignore-arches
Pacho Ramos · gentoo
media-libs/gst-plugins-bad: x86 stable, bug 587010
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="x86"
Pacho Ramos · gentoo
media-libs/gst-plugins-bad: amd64 stable, bug 587010
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="amd64"
Tobias Klausmann · gentoo
media-libs/gst-plugins-bad-1.8.3-r0: add alpha keyword
Gentoo-Bug: 587010
Tobias Klausmann · gentoo
media-libs/gst-plugins-bad-1.8.2-r0: add alpha keyword
Gentoo-Bug: 587010
Gilles Dartiguelongue · gentoo
media-libs/gst-plugins-bad: version bump 1.8.2 → 1.8.3
Package-Manager: portage-2.3.0
Gilles Dartiguelongue · gentoo
media-libs/gst-plugins-bad: fix a typo in glib dependency
Not a big problem since gstreamer and gst-plugins-base do depend on this version anyway but fixing for correctness. Package-Manager: portage-2.3.0
Andreas K. Hüttel · gentoo
media-libs/gst-plugins-bad: Pointless commit to enforce regeneration of the rsync Manifest, bug 577722
Package-Manager: portage-2.3.0
Pacho Ramos · gentoo
media-libs/gst-plugins-bad: ppc stable, bug 584468
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="ppc"
Pacho Ramos · gentoo
media-libs/gst-plugins-bad: Version bump
Package-Manager: portage-2.3.0
Pacho Ramos · gentoo
media-libs/gst-plugins-bad: alpha stable, bug 584468
Package-Manager: portage-2.3.0_rc1 RepoMan-Options: --include-arches="alpha"
Markus Meier · gentoo
media-libs/gst-plugins-bad: arm stable, bug #566378
Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="arm"
Justin Lecher · gentoo
Merge branch 'anthonyryan1-freedesktop'
* anthonyryan1-freedesktop: HTTPS for *.freedesktop.org
Anthony Ryan · gentoo
HTTPS for *.freedesktop.org
* Excluding xorg.freedesktop.org * Excluding tango.freedesktop.org The following modified ebuilds were found to have problems after modification but the problems were determined to not be a regression. Upstream tarball has a new hash: * app-misc/evtest-1.29 * app-misc/evtest-1.30 * dev-embedded/scratchbox2-2.0-r1 * dev-ml/cairo-ocaml-1.2.0 * net-libs/libqmi-1.0.0 * sys-auth/libfprint-0.4.0 * sys-auth/libfprint-0.5.0 * sys-auth/libfprint-0.5.1 Upstream tarball has been deleted: * dev-libs/liblazy-0.2 * dev-util/pkgconfig-openbsd-20130507-r1 * x11-libs/xvba-video-0.8.0-r3 * x11-misc/driconf-0.9.1-r1 * x11-misc/xdg-utils-1.1.0_rc2-r1
Jeroen Roovers · gentoo
media-libs/gst-plugins-bad: Stable for HPPA PPC64 (bug #566378).
Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches
Mart Raudsepp · gentoo
media-libs/gst-plugins-bad: remove old security vulnerable 0.10 revision
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: ia64 stable wrt bug #553742
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="ia64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: sparc stable wrt bug #553742
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="sparc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Ian Delaney · gentoo
Merge remote-tracking branch 'remotes/sbraz/syncthing'
Pull Request: https://github.com/gentoo/gentoo/pull/990
Mikle Kolyada · gentoo
media-libs/gst-plugins-bad: x86 stable wrt bug #566378
Package-Manager: portage-2.2.26
Pacho Ramos · gentoo
media-libs/gst-plugins-bad: Drop old
Package-Manager: portage-2.2.27
Pacho Ramos · gentoo
media-libs/gst-plugins-bad: gles2 <-> egl blocker wasn't really needed (#525936#c20)
Package-Manager: portage-2.2.27
Pacho Ramos · gentoo
media-libs/gst-plugins-bad: amd64 stable, bug 566378
Package-Manager: portage-2.2.27 RepoMan-Options: --include-arches="amd64"
Ian Delaney · gentoo
Merge remote-tracking branch 'remotes/sbraz/gaupol'
Pull request: https://github.com/gentoo/gentoo/pull/743
Gilles Dartiguelongue · gentoo
media-libs/gst-plugins-bad: version bump to 1.6.3
Package-Manager: portage-2.2.27
Patrice Clement · gentoo
Merge remote-tracking branch 'github/pr/697'.
Gentoo-Bug: 558182 PR-Number: https://github.com/gentoo/gentoo/pull/697
Andreas Schuerch · gentoo
media-libs/gst-plugins-bad: 0.10.23-r3 stable on x86, see bug 553742
Package-Manager: portage-2.2.26
Ian Delaney · gentoo
Merge remote-tracking branch 'remotes/Coacher/mpv-verbump-to-0.15.0'
Pull request: https://github.com/gentoo/gentoo/pull/675
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: ppc stable wrt bug #553742
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="ppc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Tobias Klausmann · gentoo
media-libs/gst-plugins-bad: add alpha keyword
Gentoo-Bug: 553742 Package-Manager: portage-2.2.26
Markus Meier · gentoo
media-libs/gst-plugins-bad: arm stable, bug #553742
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="arm"
Jeroen Roovers · gentoo
media-libs/gst-plugins-bad: Stable for HPPA (bug #553742).
Package-Manager: portage-2.2.26 RepoMan-Options: --ignore-arches
Jeroen Roovers · gentoo
media-libs/gst-plugins-bad: Stable for PPC64 (bug #553742).
Package-Manager: portage-2.2.26 RepoMan-Options: --ignore-arches
Agostino Sarubbo · gentoo
media-libs/gst-plugins-bad: amd64 stable wrt bug #553742
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Pacho Ramos · gentoo
media-libs/gst-plugins-bad: Drop old
Package-Manager: portage-2.2.26
Pacho Ramos · gentoo
media-libs/gst-plugins-bad: Fix CVE-2015-0797, bug #553742
Package-Manager: portage-2.2.26
Gilles Dartiguelongue · gentoo
media-libs/gst-plugins-bad: enable vcd and shm plugin bug #363631
Leave gsettings out as it is not ported yet. Package-Manager: portage-2.2.26
Gilles Dartiguelongue · gentoo
media-libs/gst-plugins-bad: version bump to 1.6.2
Package-Manager: portage-2.2.26
Gilles Dartiguelongue · gentoo
media-libs/gst-plugins-bad: drop old revisions
Package-Manager: portage-2.2.26
Gilles Dartiguelongue · gentoo
media-libs/gst-plugins-bad: add support for gtk element and fix gl element
gl element was not properly enabled when libs where already required to build gst libraries, bug #551712. gtk element might be useful for Gnome 3.18 and depends on wayland and GL context on gst-plugins-bad which is easier to manage in one place, refs: bug #555738. Package-Manager: portage-2.2.23
Gilles Dartiguelongue · gentoo
media-libs/gstreamer: version bump to 1.6.1
Merge branch 'gstreamer-1.6'
Gilles Dartiguelongue · gentoo
media-libs/gst-plugins-bad: version bump to 1.6.1
Drop libSM runtime dependency, checks have been changed upstream and it is not necessary anymore. Use ${PV} for gstreamer and gst-plugins-base dependency as all releases are coordinated for a while now. Package-Manager: portage-2.2.23
Gilles Dartiguelongue · gentoo
Merge branch 'gstreamer-1.6'
Gilles Dartiguelongue · gentoo
media-libs/gst-plugins-bad: add missing introspection USE dependencies
Package-Manager: portage-2.2.23
Gilles Dartiguelongue · gentoo
media-plugins/gst-plugins-smoothstreaming: version bump to 1.6.0
Package-Manager: portage-2.2.23
Gilles Dartiguelongue · gentoo
media-libs/gst-plugins-bad: install gtk-doc documentation
Gilles Dartiguelongue · gentoo
media-libs/gst-plugins-bad: remove unneeded flag filtering
Legacy from over 10 years ago, do not seem to cause problems now and we want to avoid over filtering. Package-Manager: portage-2.2.23
Gilles Dartiguelongue · gentoo
media-libs/gst-plugins-bad: version bump to 1.6.0
Package-Manager: portage-2.2.23
Zero_Chaos · gentoo
media-libs/gst-plugins-bad: fix dep properly
Package-Manager: portage-2.2.22
Zero_Chaos · gentoo
media-libs/gst-plugins-bad: build fix for bug #561944, feel free to fix in any way that works properly if this isn't desired
Package-Manager: portage-2.2.22
Justin Lecher · gentoo
Use https by default
Convert all URLs for sites supporting encrypted connections from http to https Signed-off-by: Justin Lecher <jlec@gentoo.org>
Robin H. Johnson · gentoo
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed