media-libs / libglvnd

The GL Vendor-Neutral Dispatch library

Official package sites : https://github.com/NVIDIA/libglvnd ·

v9999 :: 0 :: gentoo (Masked by set 3187)

Modified
License
MIT
USE flags
X

v1.1.1-r1 :: 0 :: gentoo (Masked by set 3187)

Modified
License
MIT
Keywords
~amd64

General

X
Add support for X11

abi_mips

n32
64-bit (32-bit pointer) libraries
n64
64-bit libraries
o32
32-bit libraries

abi_riscv

lp64
64-bit (rv64) soft-float libraries
lp64d
64-bit (rv64) double hard-float libraries

abi_s390

32
32-bit (s390) libraries
64
64-bit (s390x) libraries

abi_x86

32
32-bit (x86) libraries
64
64-bit (amd64) libraries
x32
x32 ABI libraries

dev-lang / python : An interpreted, interactive, object-oriented programming language

media-libs / mesa : OpenGL-like graphic library for Linux

x11-base / xorg-proto : X.Org combined protocol headers

x11-libs / libX11 : X.Org X11 library

x11-libs / libXext : X.Org Xext library

media-libs / mesa : OpenGL-like graphic library for Linux

x11-libs / libX11 : X.Org X11 library

x11-libs / libXext : X.Org Xext library

media-libs / mesa : OpenGL-like graphic library for Linux

x11-base / xorg-server : X.Org X servers

x11-drivers / nvidia-drivers : NVIDIA Accelerated Graphics Driver

692212
media-libs/cogl: Add support for media-libs/libglvnd
695026
File collision in media-libs/libglvnd-1.1.1-r1 and media-libs/mesa-19.2.0_rc3

3187
Matt Turner
New package. Needs to interact with media-libs/mesa and x11-drivers/nvidia-drivers. Work in progress.
  • media-libs/libglvnd
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
media-libs/libglvnd: Enable Python 3 support
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Matt Turner · gentoo
media-libs/libglvnd: Add blocker on <!media-libs/mesa-19.2.0_rc1
19.2.0_rc1 will not install its own pkg-config files if USE=libglvnd. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Matt Turner · gentoo
media-libs/libglvnd: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Matt Turner · gentoo
media-libs/libglvnd: Make X11 support optional
Closes: https://bugs.gentoo.org/693754 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Matt Turner · gentoo
media-libs/libglvnd: Install pkg-config files
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
media-libs/libglvnd: Version bump to 1.1.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Matt Turner · gentoo
media-libs/libglvnd: Prepare for a non-snapshot ebuild
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
media-libs/libglvnd: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Matt Turner · gentoo
media-libs/libglvnd: EAPI 7 and run tests
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Matt Turner · gentoo
media-libs/libglvnd: Version bump to 1.1.0.20190213
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Matt Turner · gentoo
media-libs/libglvnd: Add package
package.mask'd for now. Bug: https://bugs.gentoo.org/606924