media-libs / phonon

KDE multimedia abstraction library

Official package sites : https://community.kde.org/Phonon ·

v4.12.0-r2 :: 0 :: gentoo (Masked by set 7196)

Modified
License
|| ( LGPL-2.1 LGPL-3 ) !pulseaudio? ( || ( GPL-2 GPL-3 ) )
Keywords
~amd64
USE flags
debug designer pulseaudio qt5 qt6 vlc

v4.11.1-r2 :: 0 :: gentoo

Modified
License
|| ( LGPL-2.1 LGPL-3 ) !pulseaudio? ( || ( GPL-2 GPL-3 ) )
Keywords
amd64 arm64 ppc64 x86 ~arm ~loong ~ppc ~riscv
USE flags
debug designer gstreamer pulseaudio vlc

General

debug
Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
designer
Install plugin for dev-qt/designer
gstreamer
Add support for media-libs/gstreamer (Streaming media)
pulseaudio
Add sound server support via media-libs/libpulse (may be PulseAudio or PipeWire)
qt5
Add support for the Qt 5 application and UI framework
qt6
Add support for the Qt 6 application and UI framework
vlc
Install VLC Phonon backend

dev-libs / glib : The GLib library of C routines

dev-qt / designer : WYSIWYG tool for designing and building graphical user interfaces with QtWidgets

dev-qt / qt5compat : Qt module containing the unsupported Qt 5 APIs

dev-qt / qtbase : Cross-platform application development framework

dev-qt / qtcore : Cross-platform application development framework

dev-qt / qtgui : The GUI module and platform plugins for the Qt5 framework

dev-qt / qttools : Qt Tools Collection

dev-qt / qtwidgets : Set of components for creating classic desktop-style UIs for the Qt5 framework

media-libs / libpulse : Libraries for PulseAudio clients

dev-libs / glib : The GLib library of C routines

dev-qt / designer : WYSIWYG tool for designing and building graphical user interfaces with QtWidgets

dev-qt / qt5compat : Qt module containing the unsupported Qt 5 APIs

dev-qt / qtbase : Cross-platform application development framework

dev-qt / qtcore : Cross-platform application development framework

dev-qt / qtgui : The GUI module and platform plugins for the Qt5 framework

dev-qt / qttools : Qt Tools Collection

dev-qt / qtwidgets : Set of components for creating classic desktop-style UIs for the Qt5 framework

kde-frameworks / breeze-icons : Breeze SVG icon theme

kde-frameworks / kf-env : Environment setting required for all KDE Frameworks apps to run

kde-frameworks / oxygen-icons : Oxygen SVG icon theme

media-libs / libpulse : Libraries for PulseAudio clients

media-libs / phonon-gstreamer : GStreamer backend for the Phonon multimedia library

app-office / calligra : KDE Office Suite

app-office / texstudio : Free cross-platform LaTeX editor (fork from texmakerX)

kde-apps / blinken : Memory enhancement game based on KDE Frameworks

kde-apps / dolphin : Plasma filemanager focusing on usability

kde-apps / dragon : Simple video player

kde-apps / gwenview : Image viewer by KDE

kde-apps / juk : Jukebox and music manager by KDE

kde-apps / kalarm : Application to manage alarms and other timer based alerts for the desktop

kde-apps / kanagram : Game based on anagrams of words

kde-apps / khangman : Classical hangman game by KDE

kde-apps / kio-extras : KIO plugins present a filesystem-like view of arbitrary data

kde-apps / kio-extras-kf5 : KIO plugins present a filesystem-like view of arbitrary data

kde-apps / klettres : Alphabet learning application

kde-apps / kmousetool : KDE program that clicks the mouse for you

kde-apps / kopete : Multi-protocol IM client based on KDE Frameworks

kde-apps / ksirk : Port of the board game risk

kde-apps / ktuberling : Potato game for kids by KDE

kde-apps / kwordquiz : Powerful flashcard and vocabulary learning program

kde-apps / libkcompactdisc : Library for playing & ripping CDs

kde-apps / mailcommon : Common mail library

kde-apps / marble : Virtual Globe and World Atlas to learn more about Earth

kde-apps / okular : Universal document viewer based on KDE Frameworks

kde-frameworks / khtml : KHTML web rendering engine

kde-frameworks / knotifications : Framework for notifying the user of an event

kde-frameworks / knotifyconfig : Framework for configuring desktop notifications

kde-misc / basket : Multiple information organizer - a DropDrawers clone

kde-plasma / plasma-desktop : KDE Plasma desktop

kde-plasma / plasma-workspace : KDE Plasma workspace

media-gfx / kphotoalbum : Tool for indexing, searching, and viewing images

media-libs / phonon-gstreamer : GStreamer backend for the Phonon multimedia library

media-libs / phonon-vlc : VLC backend for the Phonon multimedia library

media-sound / musique : Qt music player

media-sound / soundkonverter : Frontend to various audio converters

media-sound / yarock : Qt-based music player

net-irc / kvirc : Advanced IRC Client

net-p2p / ktorrent : Powerful BitTorrent client based on KDE Frameworks


7196
Andreas Sturmlechner
KDE Plasma 6.0.5, Gear 24.05.0 and Frameworks 6.2.0 mask Don't do anything unless you're intentionally moving to Plasma 6, which is masked still for a reason. If you get this message just from conflicts where you're not trying to do that, please cleanup stale entries in /etc/portage and your world file. Plasma 6 replaces 5. For conflict resolution between KF5- and KF6-packages: - put '-kf6compat' into /etc/portage/profile/use.mask - enable USE=kf6compat globally - if you have the following packages installed, put the following into /etc/portage/package.use in order to avoid conflicts: dev-util/kdevelop:5 -gdbui -plasma If you encounter ... - build-time/packaging bugs: - file a bug after making sure none exists yet for your issue - runtime bugs: https://community.kde.org/Plasma/Plasma_6#How_to_use/test_it - work with upstream and help test patches using /etc/portage/patches
  • =kde-misc/kio-gdrive-23.08.5-r1
  • =kde-plasma/print-manager-23.08.5-r100
  • =media-libs/kquickimageeditor-0.3.0-r100
  • =net-libs/signond-8.61-r100
  • =net-misc/smb4k-3.2.5-r2
  • ~app-accessibility/kontrast-24.05.0
  • ~app-cdr/dolphin-plugins-mountiso-24.05.0
  • ~app-cdr/isoimagewriter-24.05.0
  • ~app-crypt/keysmith-24.05.0
  • ~app-editors/ghostwriter-24.05.0
  • ~app-editors/kile-2.9.94
  • ~app-office/libreoffice-24.2.3.2
  • ~app-office/libreoffice-l10n-24.2.3.2
  • ~app-office/merkuro-24.05.0
  • ~dev-db/futuresql-0.1.1
  • ~dev-libs/appstream-1.0.3
  • ~dev-libs/kdiagram-3.0.1
  • ~dev-libs/kirigami-addons-1.2.1
  • ~dev-libs/kopeninghours-24.05.0
  • ~dev-libs/kosmindoormap-24.05.0
  • ~dev-libs/kpublictransport-24.05.0
  • ~dev-libs/ktextaddons-1.5.4
  • ~dev-libs/kweathercore-0.8.0
  • ~dev-util/kio-perldoc-24.05.0
  • ~dev-util/massif-visualizer-0.8.0
  • ~games-puzzle/skladnik-0.5.2
  • ~games-puzzle/skladnik-24.05.0
  • ~gui-apps/xwaylandvideobridge-0.4.0
  • ~kde-apps/akonadi-24.05.0
  • ~kde-apps/akonadi-calendar-24.05.0
  • ~kde-apps/akonadi-contacts-24.05.0
  • ~kde-apps/akonadi-import-wizard-24.05.0
  • ~kde-apps/akonadi-mime-24.05.0
  • ~kde-apps/akonadi-notes-24.05.0
  • ~kde-apps/akonadi-search-24.05.0
  • ~kde-apps/akonadiconsole-24.05.0
  • ~kde-apps/akregator-24.05.0
  • ~kde-apps/analitza-24.05.0
  • ~kde-apps/ark-24.05.0
  • ~kde-apps/audiocd-kio-24.05.0
  • ~kde-apps/baloo-widgets-24.05.0
  • ~kde-apps/blinken-24.05.0
  • ~kde-apps/bomber-24.05.0
  • ~kde-apps/bovo-24.05.0
  • ~kde-apps/calendarjanitor-24.05.0
  • ~kde-apps/calendarsupport-24.05.0
  • ~kde-apps/dolphin-24.05.0
  • ~kde-apps/dolphin-plugins-dropbox-24.05.0
  • ~kde-apps/dolphin-plugins-git-24.05.0
  • ~kde-apps/dolphin-plugins-mercurial-24.05.0
  • ~kde-apps/dolphin-plugins-subversion-24.05.0
  • ~kde-apps/dragon-24.05.0
  • ~kde-apps/eventviews-24.05.0
  • ~kde-apps/ffmpegthumbs-24.05.0
  • ~kde-apps/filelight-24.05.0
  • ~kde-apps/granatier-24.05.0
  • ~kde-apps/grantlee-editor-24.05.0
  • ~kde-apps/grantleetheme-24.05.0
  • ~kde-apps/gwenview-24.05.0
  • ~kde-apps/incidenceeditor-24.05.0
  • ~kde-apps/juk-24.05.0
  • ~kde-apps/kaccounts-integration-24.05.0
  • ~kde-apps/kaccounts-providers-24.05.0
  • ~kde-apps/kaddressbook-24.05.0
  • ~kde-apps/kajongg-24.05.0
  • ~kde-apps/kalarm-24.05.0
  • ~kde-apps/kalgebra-24.05.0
  • ~kde-apps/kamera-24.05.0
  • ~kde-apps/kanagram-24.05.0
  • ~kde-apps/kapman-24.05.0
  • ~kde-apps/kapptemplate-24.05.0
  • ~kde-apps/kate-24.05.0
  • ~kde-apps/kate-addons-24.05.0
  • ~kde-apps/kate-lib-24.05.0
  • ~kde-apps/katomic-24.05.0
  • ~kde-apps/kbackup-24.05.0
  • ~kde-apps/kblackbox-24.05.0
  • ~kde-apps/kblocks-24.05.0
  • ~kde-apps/kbounce-24.05.0
  • ~kde-apps/kbreakout-24.05.0
  • ~kde-apps/kbruch-24.05.0
  • ~kde-apps/kcachegrind-24.05.0
  • ~kde-apps/kcalc-24.05.0
  • ~kde-apps/kcalutils-24.05.0
  • ~kde-apps/kcharselect-24.05.0
  • ~kde-apps/kcolorchooser-24.05.0
  • ~kde-apps/kcron-24.05.0
  • ~kde-apps/kde-apps-meta-24.05.0
  • ~kde-apps/kde-dev-utils-24.05.0
  • ~kde-apps/kdeaccessibility-meta-24.05.0
  • ~kde-apps/kdeadmin-meta-24.05.0
  • ~kde-apps/kdebugsettings-24.05.0
  • ~kde-apps/kdecore-meta-24.05.0
  • ~kde-apps/kdeedu-data-24.05.0
  • ~kde-apps/kdeedu-meta-24.05.0
  • ~kde-apps/kdegames-meta-24.05.0
  • ~kde-apps/kdegraphics-meta-24.05.0
  • ~kde-apps/kdegraphics-mobipocket-24.05.0
  • ~kde-apps/kdemultimedia-meta-24.05.0
  • ~kde-apps/kdenetwork-filesharing-24.05.0
  • ~kde-apps/kdenetwork-meta-24.05.0
  • ~kde-apps/kdenlive-24.05.0
  • ~kde-apps/kdepim-addons-24.05.0
  • ~kde-apps/kdepim-meta-24.05.0
  • ~kde-apps/kdepim-runtime-24.05.0
  • ~kde-apps/kdesdk-meta-24.05.0
  • ~kde-apps/kdeutils-meta-24.05.0
  • ~kde-apps/kdf-24.05.0
  • ~kde-apps/kdialog-24.05.0
  • ~kde-apps/kdiamond-24.05.0
  • ~kde-apps/keditbookmarks-24.05.0
  • ~kde-apps/kfind-24.05.0
  • ~kde-apps/kfourinline-24.05.0
  • ~kde-apps/kgeography-24.05.0
  • ~kde-apps/kget-24.05.0
  • ~kde-apps/kgoldrunner-24.05.0
  • ~kde-apps/kgpg-24.05.0
  • ~kde-apps/khangman-24.05.0
  • ~kde-apps/khelpcenter-24.05.0
  • ~kde-apps/kidentitymanagement-24.05.0
  • ~kde-apps/kigo-24.05.0
  • ~kde-apps/killbots-24.05.0
  • ~kde-apps/kimap-24.05.0
  • ~kde-apps/kio-extras-24.05.0
  • ~kde-apps/kiriki-24.05.0
  • ~kde-apps/kiten-24.05.0
  • ~kde-apps/kitinerary-24.05.0
  • ~kde-apps/kjumpingcube-24.05.0
  • ~kde-apps/kldap-24.05.0
  • ~kde-apps/kleopatra-24.05.0
  • ~kde-apps/klettres-24.05.0
  • ~kde-apps/klickety-24.05.0
  • ~kde-apps/klines-24.05.0
  • ~kde-apps/kmag-24.05.0
  • ~kde-apps/kmahjongg-24.05.0
  • ~kde-apps/kmail-24.05.0
  • ~kde-apps/kmail-account-wizard-24.05.0
  • ~kde-apps/kmailtransport-24.05.0
  • ~kde-apps/kmbox-24.05.0
  • ~kde-apps/kmime-24.05.0
  • ~kde-apps/kmines-24.05.0
  • ~kde-apps/kmousetool-24.05.0
  • ~kde-apps/kmouth-24.05.0
  • ~kde-apps/knavalbattle-24.05.0
  • ~kde-apps/knetwalk-24.05.0
  • ~kde-apps/knights-24.05.0
  • ~kde-apps/knotes-24.05.0
  • ~kde-apps/kolf-24.05.0
  • ~kde-apps/kollision-24.05.0
  • ~kde-apps/kolourpaint-24.05.0
  • ~kde-apps/konqueror-24.05.0
  • ~kde-apps/konquest-24.05.0
  • ~kde-apps/konsole-24.05.0
  • ~kde-apps/konsolekalendar-24.05.0
  • ~kde-apps/kontact-24.05.0
  • ~kde-apps/kontactinterface-24.05.0
  • ~kde-apps/korganizer-24.05.0
  • ~kde-apps/kpat-24.05.0
  • ~kde-apps/kpimtextedit-24.05.0
  • ~kde-apps/kpkpass-24.05.0
  • ~kde-apps/krdc-24.05.0
  • ~kde-apps/kreversi-24.05.0
  • ~kde-apps/krfb-24.05.0
  • ~kde-apps/kruler-24.05.0
  • ~kde-apps/kshisen-24.05.0
  • ~kde-apps/ksirk-24.05.0
  • ~kde-apps/ksmtp-24.05.0
  • ~kde-apps/ksnakeduel-24.05.0
  • ~kde-apps/kspaceduel-24.05.0
  • ~kde-apps/ksquares-24.05.0
  • ~kde-apps/ksudoku-24.05.0
  • ~kde-apps/ksystemlog-24.05.0
  • ~kde-apps/kteatime-24.05.0
  • ~kde-apps/ktimer-24.05.0
  • ~kde-apps/ktuberling-24.05.0
  • ~kde-apps/kturtle-24.05.0
  • ~kde-apps/kubrick-24.05.0
  • ~kde-apps/kwalletmanager-24.05.0
  • ~kde-apps/kwordquiz-24.05.0
  • ~kde-apps/kwrite-24.05.0
  • ~kde-apps/libgravatar-24.05.0
  • ~kde-apps/libkcddb-24.05.0
  • ~kde-apps/libkcompactdisc-24.05.0
  • ~kde-apps/libkdcraw-24.05.0
  • ~kde-apps/libkdegames-24.05.0
  • ~kde-apps/libkdepim-24.05.0
  • ~kde-apps/libkeduvocdocument-24.05.0
  • ~kde-apps/libkexiv2-24.05.0
  • ~kde-apps/libkgapi-24.05.0
  • ~kde-apps/libkleo-24.05.0
  • ~kde-apps/libkmahjongg-24.05.0
  • ~kde-apps/libksane-24.05.0
  • ~kde-apps/libksieve-24.05.0
  • ~kde-apps/libktnef-24.05.0
  • ~kde-apps/lskat-24.05.0
  • ~kde-apps/mailcommon-24.05.0
  • ~kde-apps/mailimporter-24.05.0
  • ~kde-apps/mbox-importer-24.05.0
  • ~kde-apps/messagelib-24.05.0
  • ~kde-apps/mimetreeparser-24.05.0
  • ~kde-apps/okular-24.05.0
  • ~kde-apps/palapeli-24.05.0
  • ~kde-apps/parley-24.05.0
  • ~kde-apps/picmi-24.05.0
  • ~kde-apps/pim-data-exporter-24.05.0
  • ~kde-apps/pim-sieve-editor-24.05.0
  • ~kde-apps/pimcommon-24.05.0
  • ~kde-apps/signon-kwallet-extension-24.05.0
  • ~kde-apps/spectacle-24.05.0
  • ~kde-apps/svgpart-24.05.0
  • ~kde-apps/sweeper-24.05.0
  • ~kde-apps/thumbnailers-24.05.0
  • ~kde-apps/yakuake-24.05.0
  • ~kde-frameworks/attica-6.2.0
  • ~kde-frameworks/baloo-6.2.0
  • ~kde-frameworks/bluez-qt-6.2.0
  • ~kde-frameworks/breeze-icons-6.2.0
  • ~kde-frameworks/extra-cmake-modules-6.2.0
  • ~kde-frameworks/frameworkintegration-6.2.0
  • ~kde-frameworks/karchive-6.2.0
  • ~kde-frameworks/kauth-6.2.0
  • ~kde-frameworks/kbookmarks-6.2.0
  • ~kde-frameworks/kcalendarcore-6.2.0
  • ~kde-frameworks/kcmutils-6.2.0
  • ~kde-frameworks/kcodecs-6.2.0
  • ~kde-frameworks/kcolorscheme-6.2.0
  • ~kde-frameworks/kcompletion-6.2.0
  • ~kde-frameworks/kconfig-6.2.0
  • ~kde-frameworks/kconfigwidgets-6.2.0
  • ~kde-frameworks/kcontacts-6.2.0
  • ~kde-frameworks/kcoreaddons-6.2.0
  • ~kde-frameworks/kcrash-6.2.0
  • ~kde-frameworks/kdav-6.2.0
  • ~kde-frameworks/kdbusaddons-6.2.0
  • ~kde-frameworks/kdeclarative-6.2.0
  • ~kde-frameworks/kded-6.2.0
  • ~kde-frameworks/kdesu-6.2.0
  • ~kde-frameworks/kdnssd-6.2.0
  • ~kde-frameworks/kdoctools-6.2.0
  • ~kde-frameworks/kfilemetadata-6.2.0
  • ~kde-frameworks/kglobalaccel-6.2.0
  • ~kde-frameworks/kguiaddons-6.2.0
  • ~kde-frameworks/kholidays-6.2.0
  • ~kde-frameworks/ki18n-6.2.0
  • ~kde-frameworks/kiconthemes-6.2.0
  • ~kde-frameworks/kidletime-6.2.0
  • ~kde-frameworks/kimageformats-6.2.0
  • ~kde-frameworks/kio-6.2.0
  • ~kde-frameworks/kirigami-6.2.1
  • ~kde-frameworks/kitemmodels-6.2.0
  • ~kde-frameworks/kitemviews-6.2.0
  • ~kde-frameworks/kjobwidgets-6.2.0
  • ~kde-frameworks/knewstuff-6.2.0
  • ~kde-frameworks/knotifications-6.2.0
  • ~kde-frameworks/knotifyconfig-6.2.0
  • ~kde-frameworks/kpackage-6.2.0
  • ~kde-frameworks/kparts-6.2.0
  • ~kde-frameworks/kpeople-6.2.0
  • ~kde-frameworks/kplotting-6.2.0
  • ~kde-frameworks/kpty-6.2.0
  • ~kde-frameworks/kquickcharts-6.2.0
  • ~kde-frameworks/krunner-6.2.0
  • ~kde-frameworks/kservice-6.2.0
  • ~kde-frameworks/kstatusnotifieritem-6.2.0
  • ~kde-frameworks/ksvg-6.2.0
  • ~kde-frameworks/ktexteditor-6.2.0
  • ~kde-frameworks/ktexttemplate-6.2.0
  • ~kde-frameworks/ktextwidgets-6.2.0
  • ~kde-frameworks/kunitconversion-6.2.0
  • ~kde-frameworks/kuserfeedback-6.2.0
  • ~kde-frameworks/kwallet-6.2.1
  • ~kde-frameworks/kwidgetsaddons-6.2.2
  • ~kde-frameworks/kwindowsystem-6.2.0
  • ~kde-frameworks/kxmlgui-6.2.0
  • ~kde-frameworks/modemmanager-qt-6.2.0
  • ~kde-frameworks/networkmanager-qt-6.2.0
  • ~kde-frameworks/oxygen-icons-6.0.0
  • ~kde-frameworks/prison-6.2.0
  • ~kde-frameworks/purpose-6.2.0
  • ~kde-frameworks/qqc2-desktop-style-6.2.0
  • ~kde-frameworks/solid-6.2.0
  • ~kde-frameworks/sonnet-6.2.0
  • ~kde-frameworks/syndication-6.2.0
  • ~kde-frameworks/syntax-highlighting-6.2.0
  • ~kde-frameworks/threadweaver-6.2.0
  • ~kde-misc/colord-kde-24.05.0
  • ~kde-misc/kclock-24.05.0
  • ~kde-misc/kdeconnect-24.05.0
  • ~kde-misc/kio-fuse-5.1.0
  • ~kde-misc/kio-gdrive-24.05.0
  • ~kde-misc/kweather-24.05.0
  • ~kde-misc/markdownpart-24.05.0
  • ~kde-misc/plasma-pass-1.2.2
  • ~kde-misc/zanshin-24.05.0
  • ~kde-plasma/bluedevil-6.0.5.1
  • ~kde-plasma/breeze-6.0.5
  • ~kde-plasma/breeze-grub-6.0.5
  • ~kde-plasma/breeze-gtk-6.0.5
  • ~kde-plasma/breeze-plymouth-6.0.5
  • ~kde-plasma/discover-6.0.5
  • ~kde-plasma/drkonqi-6.0.5
  • ~kde-plasma/flatpak-kcm-6.0.5
  • ~kde-plasma/kactivitymanagerd-6.0.5
  • ~kde-plasma/kde-cli-tools-6.0.5
  • ~kde-plasma/kde-gtk-config-6.0.5
  • ~kde-plasma/kdecoration-6.0.5
  • ~kde-plasma/kdeplasma-addons-6.0.5
  • ~kde-plasma/kgamma-6.0.5
  • ~kde-plasma/kglobalacceld-6.0.5
  • ~kde-plasma/kinfocenter-6.0.5
  • ~kde-plasma/kmenuedit-6.0.5
  • ~kde-plasma/kpipewire-6.0.5
  • ~kde-plasma/kscreen-6.0.5
  • ~kde-plasma/kscreenlocker-6.0.5
  • ~kde-plasma/ksshaskpass-6.0.5
  • ~kde-plasma/ksystemstats-6.0.5
  • ~kde-plasma/kwallet-pam-6.0.5
  • ~kde-plasma/kwayland-6.0.5
  • ~kde-plasma/kwayland-integration-6.0.5
  • ~kde-plasma/kwin-6.0.5
  • ~kde-plasma/kwrited-6.0.5
  • ~kde-plasma/layer-shell-qt-6.0.5
  • ~kde-plasma/libkscreen-6.0.5
  • ~kde-plasma/libksysguard-6.0.5
  • ~kde-plasma/libplasma-6.0.5
  • ~kde-plasma/milou-6.0.5
  • ~kde-plasma/ocean-sound-theme-6.0.5
  • ~kde-plasma/oxygen-6.0.5
  • ~kde-plasma/oxygen-sounds-6.0.5
  • ~kde-plasma/plasma-activities-6.0.5
  • ~kde-plasma/plasma-activities-stats-6.0.5
  • ~kde-plasma/plasma-browser-integration-6.0.5
  • ~kde-plasma/plasma-desktop-6.0.5
  • ~kde-plasma/plasma-disks-6.0.5
  • ~kde-plasma/plasma-firewall-6.0.5
  • ~kde-plasma/plasma-integration-6.0.5
  • ~kde-plasma/plasma-meta-6.0.5
  • ~kde-plasma/plasma-nm-6.0.5
  • ~kde-plasma/plasma-pa-6.0.5
  • ~kde-plasma/plasma-sdk-6.0.5
  • ~kde-plasma/plasma-systemmonitor-6.0.5
  • ~kde-plasma/plasma-thunderbolt-6.0.5
  • ~kde-plasma/plasma-vault-6.0.5
  • ~kde-plasma/plasma-welcome-6.0.5
  • ~kde-plasma/plasma-workspace-6.0.5
  • ~kde-plasma/plasma-workspace-wallpapers-6.0.5
  • ~kde-plasma/plasma5support-6.0.5
  • ~kde-plasma/plymouth-kcm-6.0.5
  • ~kde-plasma/polkit-kde-agent-6.0.5
  • ~kde-plasma/powerdevil-6.0.5
  • ~kde-plasma/print-manager-6.0.5
  • ~kde-plasma/qqc2-breeze-style-6.0.5
  • ~kde-plasma/sddm-kcm-6.0.5
  • ~kde-plasma/systemsettings-6.0.5
  • ~kde-plasma/wacomtablet-6.0.5
  • ~kde-plasma/xdg-desktop-portal-kde-6.0.5
  • ~media-gfx/kgraphviewer-2.5.0
  • ~media-gfx/skanpage-24.05.0
  • ~media-libs/ksanecore-24.05.0
  • ~media-libs/libqaccessibilityclient-0.6.0
  • ~media-libs/mpvqt-1.0.0
  • ~media-libs/phonon-4.12.0
  • ~media-libs/phonon-vlc-0.12.0
  • ~media-libs/pulseaudio-qt-1.5.0
  • ~media-sound/audex-24.05.0
  • ~media-sound/elisa-24.05.0
  • ~media-sound/kasts-24.05.0
  • ~media-sound/krecorder-24.05.0
  • ~net-im/neochat-24.05.0
  • ~net-im/tokodon-24.05.0
  • ~net-irc/konversation-24.05.0
  • ~net-libs/accounts-qml-0.7_p20231028
  • ~net-libs/accounts-qt-1.17
  • ~net-libs/kdsoap-2.2.0
  • ~net-libs/kdsoap-ws-discovery-client-0.4.0
  • ~net-libs/libktorrent-24.05.0
  • ~net-libs/signon-oauth2-0.25_p20210102
  • ~net-libs/signon-ui-0.15_p20231016
  • ~net-misc/kio-zeroconf-24.05.0
  • ~net-news/alligator-24.05.0
  • ~net-p2p/ktorrent-24.05.0
  • ~sys-auth/polkit-qt-0.200.0
  • ~sys-block/partitionmanager-24.05.0
  • ~sys-libs/kpmcore-24.05.0
  • ~www-client/falkon-24.05.0
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: media-libs/phonon-gstreamer is dead, block it
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: Use cmake.eclass and multibuild instead of ecm.eclass
Simultanous build of Qt5 and Qt6 is broken, installing Qt6 plugins in Qt5 paths and vice versa. ebuild was barely using ecm facilities anyway, this makes sure only those deps that are needed are also used. Closes: https://bugs.gentoo.org/923502 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Arthur Zamarin · gentoo
media-libs/phonon: Stabilize 4.11.1-r2 ppc64, #921319
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: Prepare for media-libs/phonon-vlc gaining IUSE qt5
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
media-libs/phonon: add 4.12.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: Fix build with clang-16
Closes: https://bugs.gentoo.org/894346 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
WANG Xuerui · gentoo
media-libs/phonon: keyword 4.11.1-r1 for ~loong
Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Andreas Sturmlechner · gentoo
media-libs/phonon: Switch IUSE pulseaudio to media-libs/libpulse
EAPI-8 too. Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Alex Fan · gentoo
media-libs/phonon: keyword 4.11.1-r1 for ~riscv
Signed-off-by: Alex Fan <alexfanqi@yahoo.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon*: Update HOMEPAGE
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
media-libs/phonon: arm64 stable (bug #700038)
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.80, Repoman-2.3.19
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop 4.10.2
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
media-libs/phonon: x86 stable wrt bug #700038
Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="x86" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
media-libs/phonon: amd64 stable wrt bug #700038
Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="amd64" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop 4.11.1 (r0)
Package-Manager: Portage-2.3.79, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
media-libs/phonon: Always build phononsettings
Package-Manager: Portage-2.3.79, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: Switch to ecm.eclass and kde.org.eclass
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
media-libs: Remove *-fbsd KEYWORDS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop 4.11.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
media-libs/phonon: 4.11.1 version bump
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop 4.10.3
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop 4.10.90
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
media-libs/phonon: 4.11.0 version bump
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: 4.10.90 version bump
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: Live ebuild moved to kde overlay
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop unused DEPEND, obsolete cmake option
Upstream commits: 41073dbb768106579a199a75f5b1d96a9f911af7 80991f330860a3f866defb589f6bbbb0003da4d3 Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: Pin down backend versions
Future updates break cmake compat. Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
media-libs/phonon: Switch to kde5.eclass, add USE=gui
This is now fully ported to ECM after upstream dropped Qt4 support. Update DESCRIPTION. Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: 4.10.3 version bump
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
media-libs/phonon: arm64 stable
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.12 RepoMan-Options: --include-arches="arm64"
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop 4.10.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
media-libs/phonon: x86 stable (bug #674860)
Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
media-libs/phonon: amd64 stable wrt bug #674860
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop 4.10.1-r1
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
media-libs/phonon: 4.10.2 version bump
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
media-libs/phonon: Fix PulseAudio support with Qt 5.12, EAPI-7 bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Thomas Deutschmann · gentoo
media-libs/phonon: x86 stable (bug #652942)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Agostino Sarubbo · gentoo
media-libs/phonon: amd64 stable wrt bug #652942
Package-Manager: Portage-2.3.24, Repoman-2.3.6 RepoMan-Options: --include-arches="amd64"
Andreas Sturmlechner · gentoo
media-libs/phonon*: Drop old versions with Qt4 support
Closes: https://bugs.gentoo.org/652942
Andreas Sturmlechner · gentoo
media-libs/phonon: Restore dropped ~amd64-fbsd keyword
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop 4.10.0
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Johannes Huber · gentoo
media-libs/phonon: Version bump 4.10.1
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Andreas Sturmlechner · gentoo
media-libs/phonon: Fix build with Qt 5.11_beta3
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Michał Górny · gentoo
media-libs/phonon: Keyword 4.10.0 ~amd64-fbsd
Andreas Sturmlechner · gentoo
media-libs/phonon: 4.10.0 version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop USE=qt4 and remove cmake-multilib
Qt5 does not support multilib. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Andreas Sturmlechner · gentoo
media-libs/phonon: Re-add pkg_setup
Closes: https://bugs.gentoo.org/641726 Package-Manager: Portage-2.3.13, Repoman-2.3.4
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop obsolete pkg_setup
Older GCC versions are masked now. Package-Manager: Portage-2.3.19, Repoman-2.3.6
Andreas Sturmlechner · gentoo
media-libs/phonon: Fix some cmake warnings
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Andreas Sturmlechner · gentoo
kde4*.eclass: Drop USE=aqua
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop USE=qt5
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop USE=zeitgeist
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Andreas Sturmlechner · gentoo
media-libs/phonon: Dekeyword hppa
Stabilisation timeout. No reverse-dependencies left. Gentoo-bug: 620368 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Andreas Sturmlechner · gentoo
media-libs/phonon: Dekeyword 4.9.0 all but hppa
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Tobias Klausmann · gentoo
media-libs/phonon-4.9.1-r1: add alpha keyword
Gentoo-Bug: 620368
Markus Meier · gentoo
media-libs/phonon: arm stable, bug #620368
Package-Manager: Portage-2.3.6, Repoman-2.3.1 RepoMan-Options: --include-arches="arm"
Alexis Ballier · gentoo
media-libs/phonon: keyword ~arm64
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Agostino Sarubbo · gentoo
media-libs/phonon: ppc stable wrt bug #620368
Package-Manager: Portage-2.3.6, Repoman-2.3.1 RepoMan-Options: --include-arches="ppc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
media-libs/phonon: ppc64 stable wrt bug #620368
Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="ppc64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
media-libs/phonon: x86 stable wrt bug #620368
Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
media-libs/phonon: amd64 stable wrt bug #620368
Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Andreas Sturmlechner · gentoo
media-libs/phonon: Drop old
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Andreas Sturmlechner · gentoo
media-libs/phonon: DEPEND on >=Qt-4.8.7, warn on <GCC-5
Sort DEPENDs, switch Qt default Gentoo-bug: 595618 Package-Manager: Portage-2.3.5, Repoman-2.3.1
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Johannes Huber · gentoo
media-libs/phonon: Version bump 4.9.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Johannes Huber · gentoo
media-libs/phonon: Remove 4.7.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Agostino Sarubbo · gentoo
media-libs/phonon: ppc64 stable wrt bug #587346
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="ppc64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Johannes Huber · gentoo
media-libs/phonon: Drop ia64/sparc to testing
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Markus Meier · gentoo
media-libs/phonon: arm stable, bug #587346
Package-Manager: portage-2.3.2 RepoMan-Options: --include-arches="arm"
Agostino Sarubbo · gentoo
media-libs/phonon: ppc stable wrt bug #587346
Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="ppc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Jeroen Roovers · gentoo
media-libs/phonon: Stable for HPPA (bug #587346).
Package-Manager: portage-2.3.1 RepoMan-Options: --ignore-arches
Tobias Klausmann · gentoo
media-libs/phonon-4.9.0-r0: stable on alpha
Gentoo-Bug: 587346
Michael Palimaka · gentoo
media-libs/phonon: remove old
Package-Manager: portage-2.3.0
Michael Palimaka · gentoo
media-libs/phonon: amd64/x86 stable
Gentoo-bug: 587346 Package-Manager: portage-2.3.0
Michael Palimaka · gentoo
media-libs/phonon: fix multilib build by explicitly specifying the path to qmake
Gentoo-bug: 580304 Package-Manager: portage-2.3.0
Michael Palimaka · gentoo
media-libs/phonon: ensure zeitgeist is always disabled on a foreign ABI
dev-libs/libqzeitgeist is not multilib-enabled, so if not explicitly disabled the native library may be detected during a foreign ABI build causing a build failure. Package-Manager: portage-2.3.0
Johannes Huber · gentoo
media-libs/phonon: Restore ppc64
Package-Manager: portage-2.3.0
Johannes Huber · gentoo
media-libs/phonon: Restore hppa
kde-frameworks/extra-cmake-modules is now keyworded. Package-Manager: portage-2.3.0_rc1
Johannes Huber · gentoo
media-libs/phonon: Add missing DEPEND
kde-frameworks/extra-cmake-modules is used when for USE qt5. Gentoo-bug: 581048 Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
media-libs/phonon: version bump
Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
media-libs/phonon: raise backend dependencies
Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
media-libs/phonon: port to EAPI 6
Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
media-libs/phonon: stop passing QT_QMAKE_EXECUTABLE
This is no longer necessary now that FindQt4.cmake has been fixed to always find the correct binary. Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
media-libs/phonon: update LICENSE to be more accurate
Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
media-libs/phonon: drop redundant KEYWORDS
Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
media-libs/phonon: cleanup inherits
Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
media-libs/phonon: update SRC_URI
Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
media-libs/phonon: update HOMEPAGE
Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
media-libs/phonon: remove unused dependency
CMake can now handle automoc directly. Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
media-libs/phonon: whitespace
Package-Manager: portage-2.2.28
Patrice Clement · gentoo
Merge remote-tracking branch 'github/pr/478'.
Michael Palimaka · gentoo
media-libs/phonon: add patch by Ryan Hill <rhill@gentoo.org> to fix build with GCC5.
Gentoo-bug: 555866 Package-Manager: portage-2.2.26
Robin H. Johnson · gentoo
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed