net-im / prosody

Prosody is a modern XMPP communication server

Official package sites : https://prosody.im/ ·

Prosody is a modern XMPP communication server. It aims to be easy to set up and configure, and efficient with system resources. Additionally, for developers it aims to be easy to extend and give a flexible system on which to rapidly develop added functionality, or prototype new protocols.

v0.11.10 :: 0 :: gentoo

Modified
License
MIT
Keywords
amd64 arm arm64 x86
USE flags
icu idn libevent mysql postgres selinux sqlite ssl test zlib

General

icu
Enable ICU (Internationalization Components for Unicode) support, using dev-libs/icu
idn
Enable support for Internationalized Domain Names
libevent
Use libevent for event handling
mysql
Add mySQL Database support
postgres
Add support for the postgresql database
selinux
!!internal use only!! Security Enhanced Linux support, this must be set by the selinux profile or breakage will occur
sqlite
Add support for sqlite - embedded sql database
ssl
Add support for SSL/TLS connections (Secure Socket Layer / Transport Layer Security)
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)
zlib
Add support for zlib (de)compression

lua_single_target

lua5-1
Build for Lua 5.1 only
lua5-3
Build for Lua 5.3 only
luajit
Build for LuaJIT only

dev-lang / lua : A powerful light-weight programming language designed for extending applications

dev-lang / luajit : Just-In-Time Compiler for the Lua programming language

dev-libs / icu : International Components for Unicode

dev-libs / openssl : Robust, full-featured Open Source Toolkit for the Transport Layer Security (TLS)

dev-lua / lua-bit32 : Backported Lua bit manipulation library

dev-lua / lua-zlib : Simple streaming interface to zlib for Lua

dev-lua / luadbi : A database interface library for Lua

dev-lua / luaevent : Binding of libevent for Lua

dev-lua / luaexpat : LuaExpat is a SAX XML parser based on the Expat library

dev-lua / luafilesystem : File System Library for the Lua programming language

dev-lua / luasec : Lua binding for OpenSSL library to provide TLS/SSL communication

dev-lua / luasocket : Networking support library for the Lua language

net-dns / libidn : Internationalized Domain Names (IDN) implementation

net-im / jabber-base : Base layout package for various jabber services

dev-lang / lua : A powerful light-weight programming language designed for extending applications

dev-lang / luajit : Just-In-Time Compiler for the Lua programming language

dev-libs / icu : International Components for Unicode

dev-libs / openssl : Robust, full-featured Open Source Toolkit for the Transport Layer Security (TLS)

dev-lua / lua-bit32 : Backported Lua bit manipulation library

dev-lua / lua-zlib : Simple streaming interface to zlib for Lua

dev-lua / luadbi : A database interface library for Lua

dev-lua / luaevent : Binding of libevent for Lua

dev-lua / luaexpat : LuaExpat is a SAX XML parser based on the Expat library

dev-lua / luafilesystem : File System Library for the Lua programming language

dev-lua / luasec : Lua binding for OpenSSL library to provide TLS/SSL communication

dev-lua / luasocket : Networking support library for the Lua language

net-dns / libidn : Internationalized Domain Names (IDN) implementation

net-im / jabber-base : Base layout package for various jabber services

sec-policy / selinux-jabber : SELinux policy for jabber

virtual / tmpfiles : Virtual to select between different tmpfiles.d handlers

net-im / prosody-modules : A collection of community-maintained modules for Prosody

803590
<net-im/prosody-0.11.10: remote information disclosure (CVE-2021-37601)
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: drop old version
Bug: https://bugs.gentoo.org/803590 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Sam James · gentoo
net-im/prosody: Stabilize 0.11.10 arm64, #803590
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-im/prosody: x86 stable wrt bug #803590
Package-Manager: Portage-3.0.20, Repoman-3.0.2 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
net-im/prosody: Stabilize 0.11.10 arm, #803590
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-im/prosody: amd64 stable wrt bug #803590
Package-Manager: Portage-3.0.20, Repoman-3.0.2 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: bump to version 0.11.10
Bug: https://bugs.gentoo.org/803590 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: drop old version
Bug: https://bugs.gentoo.org/789969 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
net-im/prosody: Stabilize 0.11.9 arm64, #789969
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
net-im/prosody: Stabilize 0.11.9 arm, #789969
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-im/prosody: x86 stable wrt bug #789969
Package-Manager: Portage-3.0.13, Repoman-3.0.2 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-im/prosody: amd64 stable wrt bug #789969
Package-Manager: Portage-3.0.13, Repoman-3.0.2 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: bump to version 0.11.9
Bug: https://bugs.gentoo.org/789969 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
net-im/prosody: remove libressl support
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: drop old version
Bug: https://bugs.gentoo.org/771144 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
net-im/prosody: Stabilize 0.11.8 arm64, #771144
Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
net-im/prosody: Stabilize 0.11.8 arm, #771144
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-im/prosody: amd64 stable wrt bug #771144
Package-Manager: Portage-3.0.13, Repoman-3.0.2 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-im/prosody: x86 stable wrt bug #771144
Package-Manager: Portage-3.0.13, Repoman-3.0.2 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: bump to version 0.11.8
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jonathan Davies · gentoo
net-im/prosody: Added selinux USE flag and dependency.
Closes: https://github.com/gentoo/gentoo/pull/19232 Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: drop old version
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Conrad Kostecki · gentoo
net-im/prosody: fix checkconfig on slotted lua
Closes: https://bugs.gentoo.org/767202 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
net-im/prosody: Stabilize 0.11.7-r100 arm64, #766528
Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
net-im/prosody: Stabilize 0.11.7-r100 arm, #766528
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
net-im/prosody: Stabilize 0.11.7-r100 x86, #766528
Signed-off-by: Sam James <sam@gentoo.org>
Sam James · gentoo
net-im/prosody: Stabilize 0.11.7-r100 amd64, #766528
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: drop old version
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Conrad Kostecki · gentoo
net-im/prosody: amd64 stable
Closes: https://bugs.gentoo.org/756025 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: fix luajit slot
Closes: https://bugs.gentoo.org/761592 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Marek Szuba · gentoo
*/*: limit pkgs not migrated to lua eclasses to dev-lang/lua:0
Only ebuilds which previously were happy with any slot (those which explicitly specify one of the 5.x slots are allowed to keep doing so until they have been migrated to the eclasses) and which do not require a version of Lua higher than 5.1 (to prevent CI from complaining about non-existent dependencies; all of these should have been masked or USE-masked by now anyway). Signed-off-by: Marek Szuba <marecki@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: add luajit (slotted)
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: migrate to tmpfiles eclass
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: enable lua5.3
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: migrate to single-lua eclass
Closes: https://bugs.gentoo.org/752966 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
net-im/prosody: Stabilize 0.11.7-r2 arm64, #756025
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
net-im/prosody: Stabilize 0.11.7-r2 arm, #756025
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-im/prosody: x86 stable (bug #756025)
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: drop old version
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Conrad Kostecki · gentoo
net-im/prosody: fix systemd unit
Closes: https://bugs.gentoo.org/750539 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: add ~arm64 keyword
Tested on packet-at. All tests pass. Closes: https://bugs.gentoo.org/747907 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: drop old version
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Conrad Kostecki · gentoo
net-im/prosody: switch to bit32, update init scripts
Since dev-lua/LuaBitOp is not supported on >=lua-5.2, switching to dev-lua/lua-bit32 as an alternative, since it's supported by upstream. Also updated the init scripts, since starting with prosodyctl is not recomended and current init scripts warns about not using it. Closes: https://bugs.gentoo.org/407079 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: add notice back
Also remove duplicate initd install. Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: drop old version
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Conrad Kostecki · gentoo
net-im/prosody: fix tests for 0.11.5
Closes: https://bugs.gentoo.org/740662 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Conrad Kostecki · gentoo
net-im/prosody: use proper patch name
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Conrad Kostecki · gentoo
net-im/prosody: bump to version 0.11.7
Changes: Dropped useflag ipv6, since old non ipv6 dependency does not exist anymore. Renamed lua to luajit to use gentoos default. Added optional postgresql dependency to init script. Overhauled ebuild. Dropped multilib inherit, as it's not being used. Updated deps for correct luaexpat. Closes: https://bugs.gentoo.org/564434 Closes: https://bugs.gentoo.org/674842 Closes: https://bugs.gentoo.org/740662 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
net-im/prosody: Clean up old versions
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-im/prosody: arm stable wrt bug #720928
Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="arm" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-im/prosody: x86 stable wrt bug #720928
Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-im/prosody: amd64 stable wrt bug #720928
Package-Manager: Portage-2.3.89, Repoman-2.3.20 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
net-im/prosody: Add v0.11.5 and remove old 0.9
Closes: https://bugs.gentoo.org/715066 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
David Seifert · gentoo
net-im/prosody: [QA] inherit toolchain-funcs.eclass directly
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michał Górny · gentoo
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
net-im/prosody: add v0.11.3 and clean up old versions
New build provided by xdch47 in GH PR 13507 Closes: https://bugs.gentoo.org/699070 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
net-im/prosody: arm stable wrt bug #678162
Package-Manager: Portage-2.3.69, Repoman-2.3.16 RepoMan-Options: --include-arches="arm" Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
net-im/prosody: amd64 stable wrt bug #678162
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --include-arches="amd64"
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-im/prosody: x86 stable (bug #678162)
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
net-im/prosody: Patch default config
This makes sure the default config uses the right user/group (jabber:jabber) and PID file. Fixes: https://bugs.gentoo.org/497104 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-im/prosody: x86 stable (bug #678162)
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
net-im/prosody-0.11.2-r0: amd64 stable
Bug: http://bugs.gentoo.org/678162 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
net-im/prosody: Add v0.11.2 and clean up older versions
Note that 0.9 will stay around for a while, due to Lua compatibility. Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-im/prosody: x86 stable (bug #673756)
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
net-im/prosody: arm stable wrt bug #673756
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
net-im/prosody: Add missing test dep
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
net-im/prosody-0.11.1-r0: amd64 stable
Bug: http://bugs.gentoo.org/673756 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
net-im/prosody: Add v0.11.1, cleanup v0.11.0-r0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
xdch47 · gentoo
net-im/prosody: use get_libdir
- fix libdir issue on 32 bit platforms - improve prefix support Closes: https://bugs.gentoo.org/672142 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Signed-off-by: Tobias Klausmann <klausman@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
net-im/prosody: Add v0.11 and bump to EAPI=7
Bug: https://bugs.gentoo.org/671750 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
net-im/prosody: Clean up old/vulnerable versions
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Markus Meier · gentoo
net-im/prosody: arm stable, bug #656998
Package-Manager: Portage-2.3.40, Repoman-2.3.9 RepoMan-Options: --include-arches="arm"
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-im/prosody: x86 stable (bug #656998)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-im/prosody: amd64 stable wrt bug #656998
Package-Manager: Portage-2.3.24, Repoman-2.3.6 RepoMan-Options: --include-arches="amd64"
Repository mirror & CI · gentoo
Merge updates from master
Tobias Klausmann · gentoo
net-im/prosody: Add bumped versions 0.9.14 and 0.10.2
These new versions fix security bugs. Gebtoo-Bug: https://bugs.gentoo.org/656998 Package-Manager: Portage-2.3.39, Repoman-2.3.9
Mikle Kolyada · gentoo
net-im/prosody: arm stable wrt bug #634232
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Thomas Deutschmann · gentoo
net-im/prosody: x86 stable (bug #634232)
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Manuel Rüger · gentoo
net-im/prosody: Stable on amd64
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Tobias Klausmann · gentoo
net-im/prosody: Fix broken bitops dep for v0.10.0
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Tobias Klausmann · gentoo
net-im/prosody: Add version v0.10.0
While upstream says it should work with Lua 5.2, they recommend not using it for production. Also, there are other Gentoo packages that don't like Lua 5.2, so let's keep prosody 5.1-only for now.
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Tobias Klausmann · gentoo
net-im/prosody: version bump to 0.9.12
Gentoo-Bug: 605528 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Markus Meier · gentoo
net-im/prosody: arm stable, bug #598998
Package-Manager: Portage-2.3.3, Repoman-2.3.1 RepoMan-Options: --include-arches="arm"
Tobias Klausmann · gentoo
net-im/prosody-0.9.11-r0: stable on x86
Gentoo-Bug: 598998
Tobias Klausmann · gentoo
net-im/prosody-0.9.11-r0: stable on amd64
Gentoo-Bug: 598998
Tobias Klausmann · gentoo
net-im/prosody-0.9.10: Restrict luasec to <0.6
Tobias Klausmann · gentoo
net-im/prosody: Add version 0.9.11 to the tree
Tobias Klausmann · gentoo
net-im/prosody: Remove old, vulnerable versions (0.9.{8,9})
Gentoo-Bug: 573158 Package-Manager: portage-2.3.0
Agostino Sarubbo · gentoo
net-im/prosody: x86 stable wrt bug #573158
Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Markus Meier · gentoo
net-im/prosody: arm stable, bug #573158
Package-Manager: portage-2.3.0_rc1 RepoMan-Options: --include-arches="arm"
Tobias Klausmann · gentoo
net-im/prosody-0.9.10-r0: add amd64 keyword
Gentoo-Bug: 573158 Package-Manager: portage-2.3.0_rc1
Jason A. Donenfeld · gentoo
Add libressl support to many packages
Package maintainers will likely want to cleanup various things for this experimental USE flag.
Tobias Klausmann · gentoo
net-im/prosody: Add v0.9.10 for sec bug 573158
Also remove one old version. Package-Manager: portage-2.2.27
Ian Delaney · gentoo
Merge remote-tracking branch 'remotes/Coacher/mpv-verbump-to-0.15.0'
Pull request: https://github.com/gentoo/gentoo/pull/675
Markus Meier · gentoo
net-im/prosody: arm stable, bug #571312
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="arm"
Andreas Schuerch · gentoo
net-im/prosody: 0.9.9 stable on x86, see bug 571312
Package-Manager: portage-2.2.26
Tobias Klausmann · gentoo
net-im/prosody: add amd64 keyword
Gentoo-Bug: 571764 Package-Manager: portage-2.2.26
Ian Delaney · gentoo
Merge remote-tracking branch 'remotes/Coacher/ffmpegsource-bug-564524'
Pull request: https://github.com/gentoo/gentoo/pull/629
Tobias Klausmann · gentoo
net-im/prosody: Add v0.9.9, including security fixes for CVE-2016-1231,CVE-2016-1232
Gentoo-Bug: 571312 Package-Manager: portage-2.2.26
Robin H. Johnson · gentoo
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed