net-libs / nodejs

A JavaScript runtime built on Chrome's V8 JavaScript engine

Official package sites : https://nodejs.org/ ·

v99999999 :: 0 :: gentoo

Modified
License
Apache-1.1 Apache-2.0 BSD BSD-2 MIT
USE flags
debug doc icu inspector npm snapshot ssl systemtap test

v12.6.0 :: 0 :: gentoo (Masked by set 3210)

Modified
License
Apache-1.1 Apache-2.0 BSD BSD-2 MIT
Keywords
~amd64 ~amd64-linux ~arm ~arm64 ~ppc ~ppc64 ~x64-macos ~x86
USE flags
debug doc icu inspector npm snapshot ssl systemtap test

v12.5.0 :: 0 :: gentoo (Masked by set 3210)

Modified
License
Apache-1.1 Apache-2.0 BSD BSD-2 MIT
Keywords
~amd64 ~amd64-linux ~arm ~arm64 ~ppc ~ppc64 ~x64-macos ~x86
USE flags
debug doc icu inspector npm snapshot ssl systemtap test

v11.15.0 :: 0 :: gentoo (Masked by set 3210)

Modified
License
Apache-1.1 Apache-2.0 BSD BSD-2 MIT
Keywords
~amd64 ~amd64-linux ~arm ~arm64 ~ppc ~ppc64 ~x64-macos ~x86
USE flags
debug doc icu inspector npm snapshot ssl systemtap test

v11.14.0 :: 0 :: gentoo

Modified
License
Apache-1.1 Apache-2.0 BSD BSD-2 MIT
Keywords
~amd64 ~amd64-linux ~arm ~arm64 ~ppc ~ppc64 ~x64-macos ~x86
USE flags
debug doc icu inspector npm snapshot ssl systemtap test

v10.16.0 :: 0 :: gentoo (Masked by set 3210)

Modified
License
Apache-1.1 Apache-2.0 BSD BSD-2 MIT
Keywords
~amd64 ~amd64-linux ~arm ~arm64 ~ppc ~ppc64 ~x64-macos ~x86
USE flags
debug doc icu inspector npm snapshot ssl systemtap test

v10.15.3 :: 0 :: gentoo

Modified
License
Apache-1.1 Apache-2.0 BSD BSD-2 MIT
Keywords
~amd64 ~amd64-linux ~arm ~arm64 ~ppc ~ppc64 ~x64-macos ~x86
USE flags
debug doc icu inspector npm snapshot ssl systemtap test

v8.16.0 :: 0 :: gentoo

Modified
License
Apache-1.1 Apache-2.0 BSD BSD-2 MIT
Keywords
~amd64 ~amd64-linux ~arm ~arm64 ~ppc ~ppc64 ~x64-macos ~x86
USE flags
debug doc icu inspector npm snapshot ssl systemtap test

v8.12.0 :: 0 :: gentoo

Modified
License
Apache-1.1 Apache-2.0 BSD BSD-2 MIT
Keywords
amd64 arm ppc ppc64 x86 ~amd64-linux ~arm64 ~x64-macos
USE flags
debug doc icu inspector npm snapshot ssl systemtap test

v6.17.1 :: 0 :: gentoo

Modified
License
Apache-1.1 Apache-2.0 BSD BSD-2 MIT
Keywords
~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86
USE flags
debug doc icu inspector npm snapshot ssl test

v6.14.4 :: 0 :: gentoo

Modified
License
Apache-1.1 Apache-2.0 BSD BSD-2 MIT
Keywords
amd64 arm x86 ~amd64-linux ~arm64 ~x64-macos
USE flags
debug doc icu inspector npm snapshot ssl test

v4.9.1 :: 0 :: gentoo

Modified
License
Apache-1.1 Apache-2.0 BSD BSD-2 MIT
Keywords
amd64 ~arm ~arm64 ~x64-macos ~x86
USE flags
debug icu npm snapshot ssl test

v0.12.18 :: 0 :: gentoo

Modified
License
Apache-1.1 Apache-2.0 BSD BSD-2 MIT
Keywords
amd64 x86 ~arm ~x64-macos
USE flags
debug icu npm snapshot ssl

General

debug
Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
icu
Enable ICU (Internationalization Components for Unicode) support, using dev-libs/icu
inspector
Enable V8 inspector
npm
Enable NPM package manager
snapshot
Enable snapshot creation for faster startup
snapshot
Enable snapshot creation for faster startup
ssl
Add support for SSL/TLS connections (Secure Socket Layer / Transport Layer Security)
systemtap
Enable SystemTAP/DTrace tracing
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

cpu_flags_x86

sse2
Use the SSE2 instruction set

python_targets

python2_7
Build with Python 2.7

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-libs / icu : International Components for Unicode

dev-libs / libuv : Cross-platform asychronous I/O

dev-libs / openssl : full-strength general purpose cryptography library (including SSL and TLS)

dev-util / systemtap : A linux trace/probe tool

net-dns / c-ares : C library that resolves names asynchronously

net-libs / http-parser : HTTP request/response parser for C

net-libs / nghttp2 : HTTP/2 C Library

net-misc / curl : A Client that groks URLs

sys-libs / zlib : Standard (de)compression library

dev-lang / python : An interpreted, interactive, object-oriented programming language

dev-lang / python-exec : Python script wrapper

dev-libs / icu : International Components for Unicode

dev-libs / libuv : Cross-platform asychronous I/O

dev-libs / openssl : full-strength general purpose cryptography library (including SSL and TLS)

net-dns / c-ares : C library that resolves names asynchronously

net-libs / http-parser : HTTP request/response parser for C

net-libs / nghttp2 : HTTP/2 C Library

sys-libs / zlib : Standard (de)compression library

dev-lang / coffee-script : A little language that compiles into javascript

dev-lang / nim : compiled, garbage-collected systems programming language

dev-python / bokeh : Statistical and interactive HTML plots for Python

dev-python / nbdime : Diff and merge of Jupyter Notebooks

dev-ruby / execjs : ExecJS lets you run JavaScript code from Ruby

dev-util / electron : Cross platform application development framework based on web technologies

dev-vcs / git-deps : git commit dependency analysis tool

net-analyzer / netdata : Linux real time system monitoring, done right!

sys-apps / yarn : Fast, reliable, and secure node dependency management

www-apps / kibana-bin : Analytics and search dashboard for Elasticsearch

www-client / firefox : Firefox Web Browser

575734
net-libs/nodejs-5.6.0-r1 src/stream_base.h:225:11: error: looser throw specifier for 'virtual node::StreamBase::~StreamBase() with gcc<4.8
580698
net-libs/nodejs major branches should be SLOTted
582712
net-libs/nodejs-0.12.6 should support USE=cpu_flags_x86_sse2
584252
net-libs/nodejs-4.4.1 installs scripts in /usr/share/doc/${PN}
603730
net-libs/nodejs-7.2.0 on PAX kernel fails tests - Can't determine the arch of: 'out/Release/node'
603744
net-libs/nodejs-7.2.0 fails tests - events.js:160 Error: Parse Error
604978
net-libs/nodejs-7.3.0 with dev-libs/openssl-1.1.0c - node_crypto.h:95:54: error: invalid application of 'sizeof' to incomplete type 'SSL_CTX {aka ssl_ctx_st}'
613314
net-libs/nodejs-6.9.4 merge error on PowerPC (G4): illegal instruction while running mksnapshot
613344
net-libs/nodejs: add libressl support
614772
net-libs/nodejs with net-libs/http-parser-version? breaks npm behind a proxy
625982
net-libs/nodejs-8.2.1 : sandbox issue (XDG_xxx_DIR related)
643556
net-libs/nodejs: Multiple vulnerabilities
649574
net-libs/nodejs-9.7.1 : [TEST] throw new errors.AssertionError({
649578
net-libs/nodejs: ignores -j1 in test phase
653870
net-libs/nodejs-9.10.1 shouldn't have been deleted
666114
net-libs/nodejs-6.14.4 fails tests
666730
net-libs/nodejs-6.14.4 fails to build with USE=-ssl
670574
net-libs/nodejs depends on =dev-libs/openssl-1.1.0*
671494
net-libs/nodejs-9.11.2-r2: The ebuild is installing to one or more unexpected paths
674020
net-libs/nodejs-11.6.0 fails tests
675812
net-libs/nodejs-10.15.0: yarn install for <package> does not see node-gyp in PATH
679590
>=net-libs/nodejs-11.7.0 bundles app-arch/brotli
682062
net-libs/nodejs-10.15.3: 'npm help' cannot find man pages
682348
net-libs/nodejs-11.13.0 : [TEST] Error: ENOENT: no such file or directory, mkdir /var/tmp/portage/net-libs/nodejs-11.13.0/work/node-v11.13.0/test/.tmp.9/test8/../test9/test10
682366
net-libs/nodejs/nodejs-10.15.3 prefix issue
682946
net-libs/nodejs USE="-snapshot" doesn't actually disable anything
683120
net-libs/nodejs-11.13.0 - In file included from ../deps/v8/src/api.cc:29: ../deps/v8/src/interface-descriptors.h: At global scope: ../deps/v8/src/interface-descriptors.h:354:18: error: expected identifier before ',' token
688282
>=net-libs/nodejs-8.16 should conditionally use bundled net-dns/c-ares
689902
net-libs/nodejs-11.14.0 requires net-libs/http-parser >= 2.9

3210
Jeroen Roovers
Depends on =dev-libs/openssl-1.1.1* due to newly introduced support for EVP_PKEY_ED25519 and EVP_PKEY_ED448 (bug #670574).
  • =net-libs/nodejs-10.16.0
  • =net-libs/nodejs-11.15.0
  • =net-libs/nodejs-12*
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Version 12.6.0
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Version 12.5.0
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Version 12.4.0
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.16.0
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Version 12.3.1
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Version 12.3.0
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Version 12.2.0
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 11.15.0
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 12.1.0
Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 12.0.0
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Bug: https://bugs.gentoo.org/670574 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Adjust dependencies, update live ebuild
* Fix various dependencies' minimum version * Fix sed script that removes -O3 * Set econf --openssl-use-def-ca-store as app-misc/ca-certificates is arguably more up to date than the included Mozilla certificate chain Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 8.16.0
Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 11.14.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 6.17.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Adjust dev-libs/openssl version
https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V11.md#notable-changes-5 Bug: https://bugs.gentoo.org/670574 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Old
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Version 11.13.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Update live ebuild
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Old
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Version 11.12.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 11.11.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.15.3
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Versions 6.17.0 8.15.1 10.15.2 11.10.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 11.10.0
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 11.9.0
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Bug: https://bugs.gentoo.org/show_bug.cgi?id=670574 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.15.1
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Version 11.8.0
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 11.7.0
Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Fabian Groffen · gentoo
net-libs/nodejs: fix install for Prefix, thanks Alan Pippin
Closes: https://bugs.gentoo.org/675120 Signed-off-by: Fabian Groffen <grobian@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Adjust net-libs/http-parser dependency
The previous dependency change did not account for revisions of 2.8.1, which should be unlikely but not impossible. While there, fix the live ebuild, too. Package-Manager: Portage-2.3.53, Repoman-2.3.12 Bug: https://bugs.gentoo.org/show_bug.cgi?id=673830 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Depend on >net-libs/http-parser-2.8.1:=
Bug: https://bugs.gentoo.org/673830 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Versions 6.16.0 8.15.0 10.15.0 11.6.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Versions 8.14.1 11.5.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Fix llhttp/http_parser in live ebuild
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Include stdarg.h
Bug: https://bugs.gentoo.org/673068 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.14.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 11.4.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 6.15.1
"This is a patch release to address a bad backport of the fix for "Slowloris HTTP Denial of Service" (CVE-2018-12122). Node.js 6.15.0 misapplies the headers timeout to an entire keep-alive HTTP session, resulting in prematurely disconnected sockets." https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V6.md#6.15.1 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Bug: https://bugs.gentoo.org/672136 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Bug: https://bugs.gentoo.org/672136 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Versions 6.15.0 8.14.0 10.14.0 11.3.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Bug: https://bugs.gentoo.org/672136 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Fix more dev-libs/openssl version dep specs
Fixes: https://bugs.gentoo.org/671658 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Revision bumps
1. The dev-libs/openssl change broke crypto functions, so everyone affected needs to recompile and record proper deps again. 2. The net-dns/c-ares dependency needs a revision bump, too. Bug: https://bugs.gentoo.org/670574 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Adjust patch for live ebuild
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Revert dev-libs/openssl-1.1* dep change
With openssl-1.1.1a I see lots and lots of test failures that I do not see with 1.1.0* -- these reflect actual errors in using crypto functions. While there, resolve an implicit dependency on net-dns/c-ares that was missed in the 8, 9, 10 and 11 branch version bumps. Fixes: 64bc534bf4412e0088839c628ff79fa456ae60bb Bug: https://bugs.gentoo.org/670574 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 8.13.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-libs/nodejs: adjust dev-lib/openssl requirement
- We are patching dev-libs/openssl to ship some EC curves even with dev-libs/openssl[bindist] so it is no longer required to enforce dev-libs/openssl[-bindist]. - NodeJS >=10 requires OpenSSL 1.1 or newer. Closes: https://bugs.gentoo.org/670574 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Thomas Deutschmann · gentoo
net-libs/nodejs: drop old
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-libs/nodejs: bump to v11.2.0
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Mikle Kolyada · gentoo
net-libs/nodejs: arm stable wrt bug #665656
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 11.1.0
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.13.0
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Fix dev-libs/libuv version
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Version 11.0.0
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.12.0
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Fix dev-libs/openssl dependency.
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.11.0.
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Matt Turner · gentoo
net-libs/nodejs: Drop ppc/ppc64 keywords on old versions, bug 665656
net-libs/nodejs-8.12.0 passes its test suite on ppc/ppc64 but version 6 doesn't. Since nothing requires older versions, let's just drop their keywords.
Matt Turner · gentoo
net-libs/nodejs-8.12.0: ppc64 stable, bug 665656
Matt Turner · gentoo
net-libs/nodejs-8.12.0: ppc stable, bug 665656
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-libs/nodejs: amd64 stable wrt bug #665656
Package-Manager: Portage-2.3.40, Repoman-2.3.9 RepoMan-Options: --include-arches="amd64"
Repository mirror & CI · gentoo
Merge updates from master
Thomas Deutschmann · gentoo
net-libs/nodejs: x86 stable (bug #665656)
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Jeroen Roovers · gentoo
net-libs/nodejs: Stable for AMD64 too.
Package-Manager: Portage-2.3.49, Repoman-2.3.10 RepoMan-Options: --ignore-arches
Jeroen Roovers · gentoo
net-libs/nodejs: Version 8.12.0.
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.10.0.
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Jeroen Roovers · gentoo
net-libs/nodejs: Versions 6.14.4 8.11.4 10.9.0.
Package-Manager: Portage-2.3.46, Repoman-2.3.10 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Set REQUIRED_USE for USE=npm (bug #662736).
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.8.0.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Jeroen Roovers · gentoo
net-libs/nodejs: Fix npm patch (bug #660450).
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.7.0.
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.6.0.
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.5.0.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Depend on net-libs/nghttp2-1.32.0.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Versions 6.14.3 9.11.2.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Versions 8.11.3 10.4.1.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.4.0.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Repository mirror & CI · gentoo
Merge updates from master
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.3.0.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Version 8.11.2.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Version 6.14.2.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.1.0.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Version 10.0.0.
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Stable for AMD64 too.
Package-Manager: Portage-2.3.28, Repoman-2.3.9 RepoMan-Options: --ignore-arches
Jeroen Roovers · gentoo
net-libs/nodejs: Stable for AMD64 too.
Package-Manager: Portage-2.3.28, Repoman-2.3.9 RepoMan-Options: --ignore-arches
Jeroen Roovers · gentoo
net-libs/nodejs: Raise net-libs/http-parser version requirement.
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Version 9.11.1.
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Versions 4.9.1 6.14.1 8.11.1 9.10.1.
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Versions 4.9.0 6.14.0 8.11.0 9.10.0.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version 9.9.0.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version 6.13.1.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Mikle Kolyada · gentoo
net-libs/nodejs: arm stable wrt bug #625562
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version 9.8.0.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Raise dev-libs/icu dependency.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version 8.10.0.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version 9.7.1.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Fix REQUIRED_USE.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Versions 6.13.0 9.6.1.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Stable for AMD64 x86 too.
Package-Manager: Portage-2.3.24, Repoman-2.3.6 RepoMan-Options: --ignore-arches
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version 9.5.0.
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Depend on >=net-libs.nghttp2-1.29.0.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version 9.4.0.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: EAPI=6.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version 0.12.18.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version 4.8.7 6.12.3 8.9.4.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Update dev-libs/icu dependency.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump (LTS).
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Update dependencies.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.17, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump.
Package-Manager: Portage-2.3.17, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Add live ebuild.
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump.
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Add USE=inspector (bug #638456 by Rodrigo Saboya).
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Remove -O3 injection in deps/v8 (bug #594638 by Jan Chren (rindeal)).
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Fix USE=-ssl (bug #615448 by Toralf Förster).
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Sergei Trofimovich · gentoo
net-libs/nodejs: stable 6.11.5 for ppc, bug #625562
Package-Manager: Portage-2.3.13, Repoman-2.3.4 RepoMan-Options: --include-arches="ppc"
Sergei Trofimovich · gentoo
net-libs/nodejs: stable 6.11.5 for ppc64, bug #625562
Package-Manager: Portage-2.3.13, Repoman-2.3.4 RepoMan-Options: --include-arches="ppc64"
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Manuel Rüger · gentoo
net-libs/nodejs: Stable on amd64
Package-Manager: Portage-2.3.12, Repoman-2.3.4
Manuel Rüger · gentoo
net-libs/nodejs: Stable on amd64
Package-Manager: Portage-2.3.12, Repoman-2.3.4
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Thomas Deutschmann · gentoo
net-libs/nodejs: x86 stable (bug #625562)
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump.
Package-Manager: Portage-2.3.12, Repoman-2.3.4
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump.
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump.
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump (more on this later).
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Patrick Lauer · gentoo
net-libs/nodejs: Bump, remove old
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Michael Weber · gentoo
net-libs/nodejs: add ~ppc keyword (bug 590274).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Michael Weber · gentoo
net-libs/nodejs: arm ppc ppc64 stable (bug 590274).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Agostino Sarubbo · gentoo
net-libs/nodejs: x86 stable wrt bug #600546
Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/nodejs: amd64 stable wrt bug #600546
Package-Manager: portage-2.3.3 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
T. Malfatti · gentoo
media-libs/portaudio: Version bump
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Patrice Clement · gentoo
net-libs/nodejs: remove vulnerable version.
Gentoo-Bug: https://bugs.gentoo.org/595256 Package-Manager: portage-2.3.0
Robin H. Johnson · gentoo
net-libs/nodejs: Fix http-parser dep.
Needed to compile stable 0.12.1[07]. X-Gentoo-Bug: 580700 Package-Manager: portage-2.3.2 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/nodejs: x86 stable wrt bug #595256
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/nodejs: amd64 stable wrt bug #595256
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Patrick Lauer · gentoo
net-libs/nodejs: Bump 0.12
Package-Manager: portage-2.3.2
Michał Górny · gentoo
net-libs/nodejs: Add a missing dep on systemtap, #601474
Patch-by: Marco Leogrande <dark.knight.ita@gmail.com>
Aaron Bauman · gentoo
net-libs/nodejs: clean vulnerable version wrt security bug #574418
Agostino Sarubbo · gentoo
net-libs/nodejs: x86 stable wrt bug #574418
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/nodejs: amd64 stable wrt bug #574418
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.3.2
Marco Leogrande · gentoo
net-libs/nodejs: add optional support for dtrace-based tracing
NodeJS supports dtrace-based tracing, that can be used by dev-util/systemtap and, more recently, dev-util/bcc. This support is forcibly disabled in nodejs ebuilds. This commit adds a systemtap USE flag to be able to turn on this support conditionally. The name of this flag matches the choice done for other ebuilds, like dev-db/mysql or app-emulation/qemu. Despite what has been done in those ebuilds, however, a dependency on dev-util/systemtap is not added: this is because, as of late, systemtap is not the only consumer of those traces anymore. Closes: https://github.com/gentoo/gentoo/pull/2803
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.3.2
Agostino Sarubbo · gentoo
net-libs/nodejs: x86 stable wrt bug #595256
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/nodejs: amd64 stable wrt bug #595256
Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Old.
Package-Manager: portage-2.3.2
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump.
Package-Manager: portage-2.3.2
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.3.2
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.3.2
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.3.0
Agostino Sarubbo · gentoo
net-libs/nodejs: x86 stable wrt bug #586084
Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.3.0
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.3.0
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.3.0
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.3.0
Agostino Sarubbo · gentoo
net-libs/nodejs: amd64 stable wrt bug #586084
Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Jeroen Roovers · gentoo
net-libs/nodejs: Mark ~ppc64 too.
Package-Manager: portage-2.3.0 RepoMan-Options: --ignore-arches
Jeroen Roovers · gentoo
net-libs/nodejs: Version bump.
Package-Manager: portage-2.3.0
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.3.0
Patrick Lauer · gentoo
net-libs/nodejs: Bump 4.4 #585456
Package-Manager: portage-2.3.0
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.3.0
Benda Xu · gentoo
net-libs/nodejs: fix for Prefix path.
Package-Manager: portage-2.2.28
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.3.0_rc1
Agostino Sarubbo · gentoo
net-libs/nodejs: x86 stable wrt bug #568900
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Agostino Sarubbo · gentoo
net-libs/nodejs: amd64 stable wrt bug #568900
Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Fabian Groffen · gentoo
net-libs/nodejs: marked ~amd64-linux
Package-Manager: portage-2.2.28
Fabian Groffen · gentoo
net-libs/nodejs: double prefix at install
Package-Manager: portage-2.2.28
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.2.28
Patrick Lauer · gentoo
net-libs/nodejs: Remove old
Package-Manager: portage-2.2.28
Patrick Lauer · gentoo
net-libs/nodejs: Bump #579016
Package-Manager: portage-2.2.28
Jeroen Roovers · gentoo
net-libs/nodejs: Mark ~ppc64 (bug #575322).
Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches
Patrick Lauer · gentoo
net-libs/nodejs: Bump, remove old
Package-Manager: portage-2.2.28
Steev Klimaszewski · gentoo
net-libs/nodejs: Add ~arm64 to 4.4.0
Since 4.x is an LTS release, keyword it as well after some minor testing. Package-Manager: portage-2.2.28
Steev Klimaszewski · gentoo
net-libs/nodejs: Add ~arm64 back
It would appear ~arm64 was dropped with the 5.7.0 bump, but I don't see why. Package-Manager: portage-2.2.28
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.2.28
Johan Bergström · gentoo
net-libs/nodejs: version bump to 0.12.10
Closes: https://github.com/gentoo/gentoo/pull/1021 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Johan Bergström · gentoo
net-libs/nodejs: version bump to 4.4.0
Backports a few build-related fixes from 5.8.0: - Require python built with threads (multiprocessing) - Update dependencies - cpu flag checks pre building - remove the test removal. file failed tests upstream please! Closes: https://github.com/gentoo/gentoo/pull/1021 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Johan Bergström · gentoo
net-libs/nodejs: version bump to 5.8.0
Closes: https://github.com/gentoo/gentoo/pull/1021 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.2.27
Patrice Clement · gentoo
Merge github#785: net-libs/nodejs: removal
Pull-Request: https://github.com/gentoo/gentoo/pull/785 Gentoo-Bug: https://bugs.gentoo.org/573870 Reporter: Johan Bergström <bugs@bergstroem.nu> Acked-by: Patrice Clement <monsieurp@gentoo.org> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Steev Klimaszewski · gentoo
net-libs/nodejs: Keyword 5.6.0-r1 for ~arm64
Tested on Cortex-A53 Package-Manager: portage-2.2.27
Patrick Lauer · gentoo
net-libs/nodejs: Unhardcode path #574460
Package-Manager: portage-2.2.27
Patrick Lauer · gentoo
net-libs/nodejs: Bump #574418, thanks to jbergstroem
Package-Manager: portage-2.2.27
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.2.27
Johan Bergström · gentoo
net-libs/nodejs: remove iojs references
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.2.27
Patrick Lauer · gentoo
net-libs/nodejs: Bump
Package-Manager: portage-2.2.26
Julian Ospald · gentoo
net-libs/nodejs: version bump to 5.0.0
Gentoo-Bug: 564594
Julian Ospald · gentoo
net-libs/nodejs: version bump to 4.2.2
Gentoo-Bug: 564594
Ian Delaney · gentoo
Revert "net-libs/nodejs: Keyword for ppc+ppc64. Disable tests on both platforms. Fixes bug 562984."
This reverts commit 98e09822dbca21a19966bbf533638205b6bb5fb5.
Patrice Clement · gentoo
net-libs/nodejs: Keyword for ppc+ppc64. Disable tests on both platforms. Fixes bug 562984.
Package-Manager: portage-2.2.20.1
Michał Górny · gentoo
net-libs/nodejs: Merge "respect system ld, binutils"
Pull-Request: https://github.com/gentoo/gentoo/pull/243 Approved-by: patrick
mschubert · gentoo
net-libs/nodejs: respect system ld, binutils
Jonathan Callen · gentoo
net-libs/nodejs: Fix build with USE=-npm
Gentoo-Bug: 562518 Package-Manager: portage-2.2.22
Zac Medico · gentoo
net-libs/nodejs: version bump to 4.1.1 (bug 560236)
Thanks to Wayne DePrince Jr. and Johan Bergström for their work on this ebuild. I have updated the ebuild to remove some failing unit tests, and also added slot-operator dependencies where appropriate. Package-Manager: portage-2.2.22
Patrice Clement · gentoo
net-libs/nodejs: Remove vulnerable versions. Fixes bug 554742.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Justin Lecher · gentoo
Enable https for all google URIs
Signed-off-by: Justin Lecher <jlec@gentoo.org>
Robin H. Johnson · gentoo
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed