net-libs / signond

Signon daemon for libaccounts-glib

Official package sites : https://gitlab.com/accounts-sso ·

v8.61-r100 :: 0 :: gentoo (Masked by set 7029)

Modified
License
LGPL-2.1
Keywords
~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86
USE flags
doc qt5 qt6 test

v8.61 :: 0 :: gentoo

Modified
License
LGPL-2.1
Keywords
amd64 arm64 x86 ~arm ~loong ~ppc64 ~riscv
USE flags
doc test

General

doc
Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
qt5
Add support for the Qt 5 application and UI framework
qt6
Add support for the Qt 6 application and UI framework
test
Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can be toggled independently)

dev-qt / qtbase : Cross-platform application development framework

dev-qt / qtcore : Cross-platform application development framework

dev-qt / qtdbus : Qt5 module for inter-process communication over the D-Bus protocol

dev-qt / qtgui : The GUI module and platform plugins for the Qt5 framework

dev-qt / qtnetwork : Network abstraction library for the Qt5 framework

dev-qt / qtsql : SQL abstraction library for the Qt5 framework

dev-qt / qttest : Unit testing library for the Qt5 framework

net-libs / libproxy : Library for automatic proxy configuration management

dev-qt / qtbase : Cross-platform application development framework

dev-qt / qtcore : Cross-platform application development framework

dev-qt / qtdbus : Qt5 module for inter-process communication over the D-Bus protocol

dev-qt / qtgui : The GUI module and platform plugins for the Qt5 framework

dev-qt / qtnetwork : Network abstraction library for the Qt5 framework

dev-qt / qtsql : SQL abstraction library for the Qt5 framework

net-libs / libproxy : Library for automatic proxy configuration management

kde-apps / kaccounts-integration : Administer web accounts for the sites and services across the Plasma desktop

kde-apps / ktp-accounts-kcm : KDE Telepathy account management kcm

kde-apps / ktp-auth-handler : KDE Telepathy authentication handler

kde-apps / signon-kwallet-extension : KWallet extension for signond

net-libs / accounts-qml : QML bindings for accounts-qt and signond

net-libs / libsignon-glib : GLib binding for the D-Bus API provided by signond

net-libs / signon-oauth2 : OAuth2 plugin for Signon daemon

net-libs / signon-ui : Online accounts signon UI

642420
net-libs/signond installs without SecretsStorage backend, falls back to unencrypted plain-text SQLite DB

7029
Andreas Sturmlechner
KDE Plasma 6.0.0, Gear 24.02.0 and Frameworks 6.0.0 mask Plasma 6 replaces 5. For conflict resolution between KF5- and KF6-packages: - put '-kf6compat' into /etc/portage/profile/use.mask - enable USE=kf6compat globally - if you have the following packages installed, put the following into /etc/portage/package.use in order to avoid conflicts: dev-util/kdevelop:5 -gdbui -plasma If you encounter ... - build-time/packaging bugs: - file a bug after making sure none exists yet for your issue - runtime bugs: https://community.kde.org/Plasma/Plasma_6#How_to_use/test_it - work with upstream and help test patches using /etc/portage/patches
  • =kde-apps/kio-extras-23.08.5-r100
  • =kde-apps/libkgapi-23.08.5-r100
  • =kde-misc/kio-gdrive-23.08.5-r1
  • =kde-plasma/print-manager-23.08.5-r100
  • =media-libs/kquickimageeditor-0.3.0-r100
  • =net-libs/signond-8.61-r100
  • =net-misc/smb4k-3.2.5-r2
  • >=sys-libs/snapd-glib-1.64-r100
  • ~app-accessibility/kontrast-24.02.0
  • ~app-cdr/dolphin-plugins-mountiso-24.02.0
  • ~app-cdr/isoimagewriter-24.02.0
  • ~app-crypt/keysmith-24.02.0
  • ~app-office/merkuro-24.02.0
  • ~dev-db/futuresql-0.1.1
  • ~dev-libs/appstream-1.0.2
  • ~dev-libs/kdiagram-3.0.1
  • ~dev-libs/kirigami-addons-1.0.1
  • ~dev-libs/kopeninghours-24.02.0
  • ~dev-libs/kosmindoormap-24.02.0
  • ~dev-libs/kpublictransport-24.02.0
  • ~dev-libs/ktextaddons-1.5.3
  • ~dev-libs/kweathercore-0.8.0
  • ~gui-apps/xwaylandvideobridge-0.4.0
  • ~kde-apps/akonadi-24.02.0
  • ~kde-apps/akonadi-calendar-24.02.0
  • ~kde-apps/akonadi-contacts-24.02.0
  • ~kde-apps/akonadi-import-wizard-24.02.0
  • ~kde-apps/akonadi-mime-24.02.0
  • ~kde-apps/akonadi-notes-24.02.0
  • ~kde-apps/akonadi-search-24.02.0
  • ~kde-apps/akonadiconsole-24.02.0
  • ~kde-apps/akregator-24.02.0
  • ~kde-apps/analitza-24.02.0
  • ~kde-apps/ark-24.02.0
  • ~kde-apps/audiocd-kio-24.02.0
  • ~kde-apps/baloo-widgets-24.02.0
  • ~kde-apps/blinken-24.02.0
  • ~kde-apps/bomber-24.02.0
  • ~kde-apps/bovo-24.02.0
  • ~kde-apps/calendarjanitor-24.02.0
  • ~kde-apps/calendarsupport-24.02.0
  • ~kde-apps/dolphin-24.02.0
  • ~kde-apps/dolphin-plugins-dropbox-24.02.0
  • ~kde-apps/dolphin-plugins-git-24.02.0
  • ~kde-apps/dolphin-plugins-mercurial-24.02.0
  • ~kde-apps/dolphin-plugins-subversion-24.02.0
  • ~kde-apps/dragon-24.02.0
  • ~kde-apps/eventviews-24.02.0
  • ~kde-apps/ffmpegthumbs-24.02.0
  • ~kde-apps/filelight-24.02.0
  • ~kde-apps/granatier-24.02.0
  • ~kde-apps/grantlee-editor-24.02.0
  • ~kde-apps/grantleetheme-24.02.0
  • ~kde-apps/gwenview-24.02.0
  • ~kde-apps/incidenceeditor-24.02.0
  • ~kde-apps/juk-24.02.0
  • ~kde-apps/kaccounts-integration-24.02.0
  • ~kde-apps/kaccounts-providers-24.02.0
  • ~kde-apps/kaddressbook-24.02.0
  • ~kde-apps/kajongg-24.02.0
  • ~kde-apps/kalarm-24.02.0
  • ~kde-apps/kalgebra-24.02.0
  • ~kde-apps/kamera-24.02.0
  • ~kde-apps/kanagram-24.02.0
  • ~kde-apps/kapman-24.02.0
  • ~kde-apps/kapptemplate-24.02.0
  • ~kde-apps/kate-24.02.0
  • ~kde-apps/kate-addons-24.02.0
  • ~kde-apps/kate-lib-24.02.0
  • ~kde-apps/katomic-24.02.0
  • ~kde-apps/kbackup-24.02.0
  • ~kde-apps/kblackbox-24.02.0
  • ~kde-apps/kblocks-24.02.0
  • ~kde-apps/kbounce-24.02.0
  • ~kde-apps/kbreakout-24.02.0
  • ~kde-apps/kbruch-24.02.0
  • ~kde-apps/kcachegrind-24.02.0
  • ~kde-apps/kcalc-24.02.0
  • ~kde-apps/kcalutils-24.02.0
  • ~kde-apps/kcharselect-24.02.0
  • ~kde-apps/kcolorchooser-24.02.0
  • ~kde-apps/kcron-24.02.0
  • ~kde-apps/kde-apps-meta-24.02.0
  • ~kde-apps/kde-dev-utils-24.02.0
  • ~kde-apps/kdeaccessibility-meta-24.02.0
  • ~kde-apps/kdeadmin-meta-24.02.0
  • ~kde-apps/kdebugsettings-24.02.0
  • ~kde-apps/kdecore-meta-24.02.0
  • ~kde-apps/kdeedu-meta-24.02.0
  • ~kde-apps/kdegames-meta-24.02.0
  • ~kde-apps/kdegraphics-meta-24.02.0
  • ~kde-apps/kdegraphics-mobipocket-24.02.0
  • ~kde-apps/kdemultimedia-meta-24.02.0
  • ~kde-apps/kdenetwork-filesharing-24.02.0
  • ~kde-apps/kdenetwork-meta-24.02.0
  • ~kde-apps/kdenlive-24.02.0
  • ~kde-apps/kdepim-addons-24.02.0
  • ~kde-apps/kdepim-meta-24.02.0
  • ~kde-apps/kdepim-runtime-24.02.0
  • ~kde-apps/kdesdk-meta-24.02.0
  • ~kde-apps/kdeutils-meta-24.02.0
  • ~kde-apps/kdf-24.02.0
  • ~kde-apps/kdialog-24.02.0
  • ~kde-apps/kdiamond-24.02.0
  • ~kde-apps/keditbookmarks-24.02.0
  • ~kde-apps/kfind-24.02.0
  • ~kde-apps/kfourinline-24.02.0
  • ~kde-apps/kgeography-24.02.0
  • ~kde-apps/kget-24.02.0
  • ~kde-apps/kgoldrunner-24.02.0
  • ~kde-apps/kgpg-24.02.0
  • ~kde-apps/khangman-24.02.0
  • ~kde-apps/khelpcenter-24.02.0
  • ~kde-apps/kidentitymanagement-24.02.0
  • ~kde-apps/kigo-24.02.0
  • ~kde-apps/killbots-24.02.0
  • ~kde-apps/kimap-24.02.0
  • ~kde-apps/kio-extras-24.02.0
  • ~kde-apps/kiriki-24.02.0
  • ~kde-apps/kiten-24.02.0
  • ~kde-apps/kitinerary-24.02.0
  • ~kde-apps/kjumpingcube-24.02.0
  • ~kde-apps/kldap-24.02.0
  • ~kde-apps/kleopatra-24.02.0
  • ~kde-apps/klettres-24.02.0
  • ~kde-apps/klickety-24.02.0
  • ~kde-apps/klines-24.02.0
  • ~kde-apps/kmag-24.02.0
  • ~kde-apps/kmahjongg-24.02.0
  • ~kde-apps/kmail-24.02.0
  • ~kde-apps/kmail-account-wizard-24.02.0
  • ~kde-apps/kmailtransport-24.02.0
  • ~kde-apps/kmbox-24.02.0
  • ~kde-apps/kmime-24.02.0
  • ~kde-apps/kmines-24.02.0
  • ~kde-apps/kmousetool-24.02.0
  • ~kde-apps/kmouth-24.02.0
  • ~kde-apps/knavalbattle-24.02.0
  • ~kde-apps/knetwalk-24.02.0
  • ~kde-apps/knights-24.02.0
  • ~kde-apps/knotes-24.02.0
  • ~kde-apps/kolf-24.02.0
  • ~kde-apps/kollision-24.02.0
  • ~kde-apps/konqueror-24.02.0
  • ~kde-apps/konquest-24.02.0
  • ~kde-apps/konsole-24.02.0
  • ~kde-apps/konsolekalendar-24.02.0
  • ~kde-apps/kontact-24.02.0
  • ~kde-apps/kontactinterface-24.02.0
  • ~kde-apps/korganizer-24.02.0
  • ~kde-apps/kpat-24.02.0
  • ~kde-apps/kpimtextedit-24.02.0
  • ~kde-apps/kpkpass-24.02.0
  • ~kde-apps/kreversi-24.02.0
  • ~kde-apps/krfb-24.02.0
  • ~kde-apps/kruler-24.02.0
  • ~kde-apps/kshisen-24.02.0
  • ~kde-apps/ksirk-24.02.0
  • ~kde-apps/ksmtp-24.02.0
  • ~kde-apps/ksnakeduel-24.02.0
  • ~kde-apps/kspaceduel-24.02.0
  • ~kde-apps/ksquares-24.02.0
  • ~kde-apps/ksudoku-24.02.0
  • ~kde-apps/ksystemlog-24.02.0
  • ~kde-apps/kteatime-24.02.0
  • ~kde-apps/ktimer-24.02.0
  • ~kde-apps/ktuberling-24.02.0
  • ~kde-apps/kturtle-24.02.0
  • ~kde-apps/kubrick-24.02.0
  • ~kde-apps/kwalletmanager-24.02.0
  • ~kde-apps/kwordquiz-24.02.0
  • ~kde-apps/kwrite-24.02.0
  • ~kde-apps/libgravatar-24.02.0
  • ~kde-apps/libkcddb-24.02.0
  • ~kde-apps/libkcompactdisc-24.02.0
  • ~kde-apps/libkdcraw-24.02.0
  • ~kde-apps/libkdegames-24.02.0
  • ~kde-apps/libkdepim-24.02.0
  • ~kde-apps/libkeduvocdocument-24.02.0
  • ~kde-apps/libkexiv2-24.02.0
  • ~kde-apps/libkgapi-24.02.0
  • ~kde-apps/libkleo-24.02.0
  • ~kde-apps/libkmahjongg-24.02.0
  • ~kde-apps/libksieve-24.02.0
  • ~kde-apps/libktnef-24.02.0
  • ~kde-apps/lskat-24.02.0
  • ~kde-apps/mailcommon-24.02.0
  • ~kde-apps/mailimporter-24.02.0
  • ~kde-apps/mbox-importer-24.02.0
  • ~kde-apps/messagelib-24.02.0
  • ~kde-apps/mimetreeparser-24.02.0
  • ~kde-apps/okular-24.02.0
  • ~kde-apps/palapeli-24.02.0
  • ~kde-apps/parley-24.02.0
  • ~kde-apps/picmi-24.02.0
  • ~kde-apps/pim-data-exporter-24.02.0
  • ~kde-apps/pim-sieve-editor-24.02.0
  • ~kde-apps/pimcommon-24.02.0
  • ~kde-apps/signon-kwallet-extension-24.02.0
  • ~kde-apps/spectacle-24.02.0
  • ~kde-apps/svgpart-24.02.0
  • ~kde-apps/sweeper-24.02.0
  • ~kde-apps/thumbnailers-24.02.0
  • ~kde-apps/yakuake-24.02.0
  • ~kde-frameworks/attica-6.0.0
  • ~kde-frameworks/baloo-6.0.0
  • ~kde-frameworks/bluez-qt-6.0.0
  • ~kde-frameworks/breeze-icons-6.0.0
  • ~kde-frameworks/extra-cmake-modules-6.0.0
  • ~kde-frameworks/frameworkintegration-6.0.0
  • ~kde-frameworks/karchive-6.0.0
  • ~kde-frameworks/kauth-6.0.0
  • ~kde-frameworks/kbookmarks-6.0.0
  • ~kde-frameworks/kcalendarcore-6.0.0
  • ~kde-frameworks/kcmutils-6.0.0
  • ~kde-frameworks/kcodecs-6.0.0
  • ~kde-frameworks/kcolorscheme-6.0.0
  • ~kde-frameworks/kcompletion-6.0.0
  • ~kde-frameworks/kconfig-6.0.0
  • ~kde-frameworks/kconfigwidgets-6.0.0
  • ~kde-frameworks/kcontacts-6.0.0
  • ~kde-frameworks/kcoreaddons-6.0.0
  • ~kde-frameworks/kcrash-6.0.0
  • ~kde-frameworks/kdav-6.0.0
  • ~kde-frameworks/kdbusaddons-6.0.0
  • ~kde-frameworks/kdeclarative-6.0.0
  • ~kde-frameworks/kded-6.0.0
  • ~kde-frameworks/kdesu-6.0.0
  • ~kde-frameworks/kdnssd-6.0.0
  • ~kde-frameworks/kdoctools-6.0.0
  • ~kde-frameworks/kfilemetadata-6.0.0
  • ~kde-frameworks/kglobalaccel-6.0.0
  • ~kde-frameworks/kguiaddons-6.0.0
  • ~kde-frameworks/kholidays-6.0.0
  • ~kde-frameworks/ki18n-6.0.0
  • ~kde-frameworks/kiconthemes-6.0.0
  • ~kde-frameworks/kidletime-6.0.0
  • ~kde-frameworks/kimageformats-6.0.0
  • ~kde-frameworks/kio-6.0.0
  • ~kde-frameworks/kirigami-6.0.0
  • ~kde-frameworks/kitemmodels-6.0.0
  • ~kde-frameworks/kitemviews-6.0.0
  • ~kde-frameworks/kjobwidgets-6.0.0
  • ~kde-frameworks/knewstuff-6.0.0
  • ~kde-frameworks/knotifications-6.0.0
  • ~kde-frameworks/knotifyconfig-6.0.0
  • ~kde-frameworks/kpackage-6.0.0
  • ~kde-frameworks/kparts-6.0.0
  • ~kde-frameworks/kpeople-6.0.0
  • ~kde-frameworks/kplotting-6.0.0
  • ~kde-frameworks/kpty-6.0.0
  • ~kde-frameworks/kquickcharts-6.0.0
  • ~kde-frameworks/krunner-6.0.0
  • ~kde-frameworks/kservice-6.0.0
  • ~kde-frameworks/kstatusnotifieritem-6.0.0
  • ~kde-frameworks/ksvg-6.0.0
  • ~kde-frameworks/ktexteditor-6.0.0
  • ~kde-frameworks/ktexttemplate-6.0.0
  • ~kde-frameworks/ktextwidgets-6.0.0
  • ~kde-frameworks/kunitconversion-6.0.0
  • ~kde-frameworks/kuserfeedback-6.0.0
  • ~kde-frameworks/kwallet-6.0.0
  • ~kde-frameworks/kwidgetsaddons-6.0.0
  • ~kde-frameworks/kwindowsystem-6.0.0
  • ~kde-frameworks/kxmlgui-6.0.0
  • ~kde-frameworks/modemmanager-qt-6.0.0
  • ~kde-frameworks/networkmanager-qt-6.0.0
  • ~kde-frameworks/oxygen-icons-6.0.0
  • ~kde-frameworks/prison-6.0.0
  • ~kde-frameworks/purpose-6.0.0
  • ~kde-frameworks/qqc2-desktop-style-6.0.0
  • ~kde-frameworks/solid-6.0.0
  • ~kde-frameworks/sonnet-6.0.0
  • ~kde-frameworks/syndication-6.0.0
  • ~kde-frameworks/syntax-highlighting-6.0.0
  • ~kde-frameworks/threadweaver-6.0.0
  • ~kde-misc/colord-kde-24.02.0
  • ~kde-misc/kclock-24.02.0
  • ~kde-misc/kdeconnect-24.02.0
  • ~kde-misc/kio-fuse-5.1.0
  • ~kde-misc/kio-gdrive-24.02.0
  • ~kde-misc/kweather-24.02.0
  • ~kde-misc/markdownpart-24.02.0
  • ~kde-misc/plasma-pass-1.2.2
  • ~kde-misc/zanshin-24.02.0
  • ~kde-plasma/bluedevil-6.0.0
  • ~kde-plasma/breeze-6.0.0
  • ~kde-plasma/breeze-grub-6.0.0
  • ~kde-plasma/breeze-gtk-6.0.0
  • ~kde-plasma/breeze-plymouth-6.0.0
  • ~kde-plasma/discover-6.0.0
  • ~kde-plasma/drkonqi-6.0.0
  • ~kde-plasma/flatpak-kcm-6.0.0
  • ~kde-plasma/kactivitymanagerd-6.0.0
  • ~kde-plasma/kde-cli-tools-6.0.0
  • ~kde-plasma/kde-gtk-config-6.0.0
  • ~kde-plasma/kdecoration-6.0.0
  • ~kde-plasma/kdeplasma-addons-6.0.0
  • ~kde-plasma/kgamma-6.0.0
  • ~kde-plasma/kglobalacceld-6.0.0
  • ~kde-plasma/kinfocenter-6.0.0
  • ~kde-plasma/kmenuedit-6.0.0
  • ~kde-plasma/kpipewire-6.0.0
  • ~kde-plasma/kscreen-6.0.0
  • ~kde-plasma/kscreenlocker-6.0.0
  • ~kde-plasma/ksshaskpass-6.0.0
  • ~kde-plasma/ksystemstats-6.0.0
  • ~kde-plasma/kwallet-pam-6.0.0
  • ~kde-plasma/kwayland-6.0.0
  • ~kde-plasma/kwayland-integration-6.0.0
  • ~kde-plasma/kwin-6.0.0
  • ~kde-plasma/kwrited-6.0.0
  • ~kde-plasma/layer-shell-qt-6.0.0
  • ~kde-plasma/libkscreen-6.0.0
  • ~kde-plasma/libksysguard-6.0.0
  • ~kde-plasma/libplasma-6.0.0
  • ~kde-plasma/milou-6.0.0
  • ~kde-plasma/ocean-sound-theme-6.0.0
  • ~kde-plasma/oxygen-6.0.0
  • ~kde-plasma/oxygen-sounds-6.0.0
  • ~kde-plasma/plasma-activities-6.0.0
  • ~kde-plasma/plasma-activities-stats-6.0.0
  • ~kde-plasma/plasma-browser-integration-6.0.0
  • ~kde-plasma/plasma-desktop-6.0.0
  • ~kde-plasma/plasma-disks-6.0.0
  • ~kde-plasma/plasma-firewall-6.0.0
  • ~kde-plasma/plasma-integration-6.0.0
  • ~kde-plasma/plasma-meta-6.0.0
  • ~kde-plasma/plasma-nm-6.0.0
  • ~kde-plasma/plasma-pa-6.0.0
  • ~kde-plasma/plasma-sdk-6.0.0
  • ~kde-plasma/plasma-systemmonitor-6.0.0
  • ~kde-plasma/plasma-thunderbolt-6.0.0
  • ~kde-plasma/plasma-vault-6.0.0
  • ~kde-plasma/plasma-welcome-6.0.0
  • ~kde-plasma/plasma-workspace-6.0.0
  • ~kde-plasma/plasma-workspace-wallpapers-6.0.0
  • ~kde-plasma/plasma5support-6.0.0
  • ~kde-plasma/plymouth-kcm-6.0.0
  • ~kde-plasma/polkit-kde-agent-6.0.0
  • ~kde-plasma/powerdevil-6.0.0
  • ~kde-plasma/print-manager-6.0.0
  • ~kde-plasma/sddm-kcm-6.0.0
  • ~kde-plasma/systemsettings-6.0.0
  • ~kde-plasma/wacomtablet-6.0.0
  • ~kde-plasma/xdg-desktop-portal-kde-6.0.0
  • ~media-gfx/skanpage-24.02.0
  • ~media-libs/ksanecore-24.02.0
  • ~media-libs/libqaccessibilityclient-0.6.0
  • ~media-libs/mpvqt-1.0.0
  • ~media-libs/phonon-4.12.0
  • ~media-libs/phonon-vlc-0.12.0
  • ~media-libs/pulseaudio-qt-1.4.0
  • ~media-sound/elisa-24.02.0
  • ~media-sound/kasts-24.02.0
  • ~media-sound/krecorder-24.02.0
  • ~net-im/neochat-24.02.0
  • ~net-im/tokodon-24.02.0
  • ~net-irc/konversation-24.02.0
  • ~net-libs/accounts-qml-0.7_p20231028
  • ~net-libs/accounts-qt-1.16_p20220803
  • ~net-libs/kdsoap-2.2.0
  • ~net-libs/kdsoap-ws-discovery-client-0.4.0
  • ~net-libs/libktorrent-24.02.0
  • ~net-libs/signon-oauth2-0.25_p20210102
  • ~net-libs/signon-ui-0.15_p20231016
  • ~net-misc/kio-zeroconf-24.02.0
  • ~net-news/alligator-24.02.0
  • ~net-p2p/ktorrent-24.02.0
  • ~sys-auth/polkit-qt-0.200.0
  • ~sys-block/partitionmanager-24.02.0
  • ~sys-libs/kpmcore-24.02.0
  • ~www-client/falkon-24.02.0
Repository mirror & CI · gentoo
Merge updates from master
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
net-libs/signond: add 8.61-r100 (with Qt 6 support)
Signed-off-by: Sam James <sam@gentoo.org>
Michał Górny · gentoo
Move {app-doc → app-text}/doxygen
Per the category metadata, app-doc/ is reserved for documentation *files* and not software. Move it to app-text/ where it seems a better fit. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: Fix path to qhelpgenerator
Closes: https://bugs.gentoo.org/891581 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: qhelpgenerator is in dev-qt/qthelp
Bug: https://bugs.gentoo.org/872167 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: Add missing IUSE doc BDEPEND
Closes: https://bugs.gentoo.org/872167 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
WANG Xuerui · gentoo
net-libs/signond: keyword 8.61 for ~loong
Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: Drop 8.60-r2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jakov Smolić · gentoo
net-libs/signond: Stabilize 8.61 arm64, #843362
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Jakov Smolić · gentoo
net-libs/signond: Stabilize 8.61 x86, #843362
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Jakov Smolić · gentoo
net-libs/signond: Stabilize 8.61 amd64, #843362
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: Add missing doxygen[dot] usedep
Closes: https://bugs.gentoo.org/835441 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: 8.61 version bump, EAPI-8 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Alex Fan · gentoo
net-libs/signond: keyword 8.60-r2 for ~riscv
Signed-off-by: Alex Fan <alexfanqi@yahoo.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James · gentoo
net-libs/signond: drop obsolete qt5 C++11 workaround
Signed-off-by: Sam James <sam@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: Drop 8.60-r1
Closes: https://bugs.gentoo.org/727228 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-libs/signond: amd64 stable wrt bug #727228
Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-libs/signond: x86 stable wrt bug #727228
Package-Manager: Portage-2.3.99, Repoman-2.3.22 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: Tests are really really brittle; but they can pass
...when they feel like it sometimes. Closes: https://bugs.gentoo.org/727666 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
net-libs/signond: Replace big sed with fix from pending upstream PR
See also: https://gitlab.com/accounts-sso/signond/-/merge_requests/27 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Sam James (sam_c) · gentoo
net-libs/signond: arm64 stable (bug #727228)
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: Drop bogus dependency
Closes: https://bugs.gentoo.org/727346 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: Fix runtime crashes
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Georgy Yakovlev · gentoo
net-libs/signond: keyword on ~ppc64
all tests pass Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: Drop 8.59-r1
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
net-libs/signond: arm64 stable (bug #702304)
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.81, Repoman-2.3.20
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-libs/signond: x86 stable wrt bug #702304
Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Agostino Sarubbo · gentoo
net-libs/signond: amd64 stable wrt bug #702304
Package-Manager: Portage-2.3.79, Repoman-2.3.16 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: RESTRICT="!test? ( test )"
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: Drop 8.60 (r0)
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Andreas Sturmlechner · gentoo
net-libs/signond: Fix pkgconfig libdir paths
Closes: https://bugs.gentoo.org/701142 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Michael Palimaka · gentoo
net-libs/signond: version bump 8.60
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Aaron Bauman · gentoo
net-libs/signond: arm64 stable
Signed-off-by: Aaron Bauman <bman@gentoo.org> Package-Manager: Portage-2.3.69, Repoman-2.3.16 RepoMan-Options: --include-arches="arm64"
Repository mirror & CI · gentoo
Merge updates from master
Roy Bamford · gentoo
net-libs/signond: added ~arm64
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Roy Bamford <neddyseagoon@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: Drop 8.59 (r0)
Closes: https://bugs.gentoo.org/668562 Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Repository mirror & CI · gentoo
Merge updates from master
Andreas Sturmlechner · gentoo
net-libs/signond: Override LIBDIR to avoid buildsystem assumption
Bug: https://bugs.gentoo.org/668562 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Michael Palimaka · gentoo
net-libs/signond: remove 8.58
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Michael Palimaka · gentoo
net-libs/signond: stabilse 8.59 for amd64/x86
Bug: https://bugs.gentoo.org/641974 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Andreas Sturmlechner · gentoo
net-libs/signond: 8.59 version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Robin H. Johnson · gentoo
Drop $Id$ per council decision in bug #611234.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Michael Palimaka · gentoo
net-libs/signond: improve net-libs/libproxy blocker
Newer versions of net-libs/libproxy do not link against kdelibs4 so do not risk a runtime symbol collision. Package-Manager: portage-2.3.0
Michael Palimaka · gentoo
net-libs/signond: x86 stable
Package-Manager: portage-2.3.0_rc1
Mikle Kolyada · gentoo
net-libs/signond: amd64 stable wrt bug #579992
Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
net-libs/signond: remove old
Package-Manager: portage-2.2.28
Michael Palimaka · gentoo
net-libs/signond: add ~arm keyword
Tested on Raspberry Pi 2. Package-Manager: portage-2.2.28
Patrice Clement · gentoo
Merge remote-tracking branch 'github/pr/503'.
Michael Palimaka · gentoo
net-libs/signond: remove unused dependency
Gentoo-bug: 569000 Package-Manager: portage-2.2.26
Ian Delaney · gentoo
Merge remote-tracking branch 'remotes/Coacher/fwknop-cleanup'
Pull request: https://github.com/gentoo/gentoo/pull/501
Michael Palimaka · gentoo
net-libs/signond: version bump
Package-Manager: portage-2.2.26
Johannes Huber · gentoo
net-libs/signond: New package
Needed for KDEs Telepathy client based on KF5. Import from kde overlay. Initial ebuild by Karol Herbst <git@karolherbst.de>. Improvements by several people. Package-Manager: portage-2.2.20.1